#openstack-nova: nova

Meeting started by bauzas at 16:00:11 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting (bauzas, 16:00:26)

  1. Bugs (stuck/critical) (bauzas, 16:02:04)
    1. Three Critical bugs (bauzas, 16:02:19)
    2. https://bugs.launchpad.net/nova/+bug/1988311 See https://lists.openstack.org/pipermail/openstack-discuss/2022-September/030325.html (bauzas, 16:02:41)
    3. https://lists.openstack.org/pipermail/openstack-discuss/2022-September/030352.html (gibi, 16:06:26)
    4. https://review.opendev.org/c/openstack/requirements/+/856044 (sean-k-mooney, 16:07:38)
    5. https://github.com/openstack/nova/blob/master/requirements.txt#L34 (bauzas, 16:08:27)
    6. https://github.com/openstack/nova/blob/stable/yoga/requirements.txt#L30 (bauzas, 16:09:12)
    7. https://bugs.launchpad.net/nova/+bug/1988316 Will be set to High now that the gate is skipping the test (bauzas, 16:10:09)
    8. https://bugs.launchpad.net/nova/+bug/1988482 Proposed patch on the fly https://review.opendev.org/c/openstack/nova/+/855658 (bauzas, 16:17:00)
    9. https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 9 new untriaged bugs (+2 since the last meeting) (bauzas, 16:25:12)
    10. https://storyboard.openstack.org/#!/project/openstack/placement 26 open stories (-1 since the last meeting) in Storyboard for Placement (bauzas, 16:25:18)
    11. Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster (bauzas, 16:25:24)
    12. bug baton is being passed to Uggla (bauzas, 16:25:29)

  2. Gate status (bauzas, 16:26:24)
    1. https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs (bauzas, 16:26:31)
    2. https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status (bauzas, 16:26:35)
    3. https://zuul.openstack.org/builds?job_name=tempest-integrated-compute-centos-9-stream&project=openstack%2Fnova&pipeline=periodic-weekly Centos 9 Stream periodic job status (bauzas, 16:26:40)
    4. https://zuul.opendev.org/t/openstack/builds?job_name=nova-emulation&pipeline=periodic-weekly&skip=0 Emulation periodic job runs (bauzas, 16:26:45)
    5. Please look at the gate failures and file a bug report with the gate-failure tag. (bauzas, 16:26:50)
    6. STOP DOING BLIND RECHECKS aka. 'recheck' https://docs.openstack.org/project-team-guide/testing.html#how-to-handle-test-failures (bauzas, 16:27:08)

  3. Release Planning (bauzas, 16:27:33)
    1. https://releases.openstack.org/zed/schedule.html (bauzas, 16:27:39)
    2. Zed-3 was last Thursday (bauzas, 16:27:45)
    3. FeatureFreeze officially declared today (bauzas, 16:27:55)
    4. ACTION: bauzas to -2 open changes that were having an accepted spec (bauzas, 16:28:05)
    5. ACTION: bauzas to run the script to move specs with merged implementation to 'implemented' (bauzas, 16:28:11)
    6. Zed tracking etherpad: https://etherpad.opendev.org/p/nova-zed-blueprint-status (bauzas, 16:28:21)
    7. https://releases.openstack.org/zed/schedule.html#z-final-clientlib (bauzas, 16:29:27)
    8. AGREED: Client patches are on Client libs freeze, please don't accept to merge new changes until RC1 happens (bauzas, 16:33:40)
    9. https://review.opendev.org/c/openstack/releases/+/855974 Nova Zed cycle highlights (bauzas, 16:41:19)

  4. PTG planning (bauzas, 16:43:25)
    1. https://etherpad.opendev.org/p/nova-antelope-ptg Antelope PTG etherpad (bauzas, 16:43:36)
    2. bauzas has asked for 4 hours per day for Tuesday to Friday (Bexar room) (bauzas, 16:44:38)
    3. https://ptg.opendev.org/ptg.html PTG schedule (bauzas, 16:47:24)
    4. https://lists.openstack.org/pipermail/openstack-discuss/2022-September/030301.html operator friendly timeslots, which ones for Nova ? (bauzas, 16:48:37)
    5. bauzas to propose Tuesday 13-15UTC for operator-friendly slots (bauzas, 16:53:16)
    6. bauzas to propose a tentative slot on Wed 16-17UTC for operators who aren't able to join on Tuesday (bauzas, 16:54:11)

  5. Review priorities (bauzas, 16:55:29)
  6. Stable Branches (bauzas, 16:55:42)
    1. stable/yoga is blocked due to py39 job is failing with prettytable 3.4.0; prettytable 3.4.1 fixes the issue so as soon as constraints are updated in requirements repository the gate will be OK (elodilles, 16:55:52)
    2. stable/stein (and older) are blocked: grenade and other devstack based jobs fail with the same timeout issue as stable/train was previously (elodilles, 16:56:07)
    3. stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci (elodilles, 16:56:15)

  7. Open discussion (bauzas, 16:59:03)


Meeting ended at 16:59:44 UTC (full logs).

Action items

  1. bauzas to -2 open changes that were having an accepted spec
  2. bauzas to run the script to move specs with merged implementation to 'implemented'


Action items, by person

  1. bauzas
    1. bauzas to -2 open changes that were having an accepted spec
    2. bauzas to run the script to move specs with merged implementation to 'implemented'


People present (lines said)

  1. bauzas (187)
  2. sean-k-mooney (52)
  3. gibi (33)
  4. dansmith (25)
  5. opendevreview (21)
  6. elodilles (13)
  7. opendevmeet (3)
  8. Uggla (3)


Generated by MeetBot 0.1.4.