16:00:04 <bauzas> #startmeeting nova
16:00:04 <opendevmeet> Meeting started Tue Nov  8 16:00:04 2022 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <opendevmeet> The meeting name has been set to 'nova'
16:00:17 <bauzas> hello folks, welcome in the nova meeting
16:00:40 <gibi> o/
16:00:43 <Kirill_> 0/
16:00:47 <elodilles> o/
16:00:50 * gibi is distracted
16:00:52 <gmann> o/
16:01:11 <bauzas> k, let's start
16:01:12 <auniyal> O/
16:01:18 <bauzas> #topic Bugs (stuck/critical)
16:01:22 <bauzas> #topic Bugs (stuck/critical)
16:01:34 <bauzas> #info No Critical bug
16:01:40 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 5 new untriaged bugs (-3 since the last meeting)
16:01:45 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:01:57 <bauzas> thanks gibi and others for having looked at the bugs
16:02:20 <bauzas> any bug to discuss ?
16:03:25 <bauzas> looks not
16:03:26 <Uggla> o/
16:03:37 <han-guangyu> o/
16:03:42 <bauzas> melwitt: could you be using the bug baton next week ?
16:04:05 <gibi> bauzas: yeah I did some triage last week
16:04:23 <gibi> not much this week thouh
16:04:26 <gibi> though
16:04:29 <bauzas> cool
16:05:05 <bauzas> ok, I'll ask again to melwitt to know if she can help for bug triage this week
16:05:08 <bauzas> moving on
16:05:22 <bauzas> #topic Gate status
16:05:28 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:05:39 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:05:47 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:05:52 <bauzas> #info STOP DOING BLIND RECHECKS aka. 'recheck' https://docs.openstack.org/project-team-guide/testing.html#how-to-handle-test-failures
16:06:25 <bauzas> as you can see, no issues for the CI periodic jobs (except for fips)
16:06:43 <bauzas> I need to modify the job to have more 30 mins
16:06:50 <bauzas> *deadline
16:07:17 <bauzas> any concern ?
16:07:44 <bauzas> looks not
16:07:48 <bauzas> moving on again
16:07:55 <bauzas> #topic Release Planning
16:08:03 <bauzas> #link https://releases.openstack.org/antelope/schedule.html
16:08:10 <bauzas> #info Antelope-1 is planned in 1 week
16:08:13 <bauzas> sl
16:08:14 <bauzas> so
16:08:33 <bauzas> when we should have a specs review day ?
16:08:41 <bauzas> next tuesday works ?
16:09:06 <sean-k-mooney> proably yes
16:09:29 <sean-k-mooney> ill be around and hopefully have more time to review next week
16:10:02 <bauzas> ok, anyone having an issue ?
16:10:07 <bauzas> for next tuesday
16:10:49 <gibi> works for me
16:11:02 <bauzas> ok
16:12:11 <bauzas> #agreed We will have have a spec review day on Nov 15th, please prepare your specs before this day and make sure you can be around on this day if you have reviews
16:12:43 <bauzas> #action bauzas to write an openstack-discuss email for this
16:12:59 <bauzas> #topic Review priorities
16:13:36 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+(label:Review-Priority%252B1+OR+label:Review-Priority%252B2)
16:14:07 <bauzas> as you can see, now we have more review-prio usage from contributors :)
16:14:09 <bauzas> <3
16:14:21 <bauzas> so, please, look at those when you review
16:14:36 <bauzas> #info As a reminder, cores eager to review changes can +1 to indicate their interest, +2 for committing to the review
16:14:49 <bauzas> any question here ?
16:15:19 <sean-k-mooney> its not qiute what i was suggestign for the usage but ok
16:15:38 <sean-k-mooney> +1 was commit to review +2 was asking for other cores to also review
16:15:42 <sean-k-mooney> but either woks
16:16:35 <bauzas> k
16:17:08 <bauzas> at least contributors can +1 if they want core reviews for some change they reviewed (not for their own changes of course)
16:18:22 <bauzas> moving on ?
16:18:31 <bauzas> #topic Stable Branches
16:18:40 <bauzas> elodilles : your time
16:18:47 <elodilles> #info wallaby transitioned to Extended Maintenance ( https://review.opendev.org/c/openstack/releases/+/862298 )
16:19:21 <elodilles> and we have released a final wallaby release
16:19:31 <elodilles> #info stable branches state should be OK (except stein and older)
16:19:41 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:19:47 <elodilles> and last but not least:
16:20:02 <elodilles> as said 2 weeks ago: stein, rocky and queens EOL'ing patch was proposed: https://review.opendev.org/862520 + mail was sent to ML https://lists.openstack.org/pipermail/openstack-discuss/2022-October/030980.html
16:20:26 <elodilles> as I see no mail replies arrived on the thread
16:20:39 <elodilles> so I propose to continue with the EOL'ing
16:20:49 <bauzas> yup, agreed
16:20:54 <bauzas> I just +1d the change
16:21:02 <elodilles> bauzas: thanks!
16:21:02 <bauzas> we agreed on it during the PTG
16:21:20 <bauzas> and given none has concerns by the email, that means we can EOL
16:21:43 <bauzas> elodilles: I guess you can now remove the -W
16:22:29 <elodilles> removed it now
16:22:53 <bauzas> thbanks
16:23:19 <bauzas> anything else to discuss about the stable branches ?
16:23:27 <elodilles> nothing from me
16:24:53 <bauzas> ok, last topic then
16:24:59 <bauzas> #topic Open discussion
16:25:05 <bauzas> we have an item today
16:25:21 <bauzas> Kirill_ : vnc console for baremetal. new spec: https://review.opendev.org/c/openstack/nova-specs/+/863773
16:25:30 <bauzas> I guess you want reviews ?
16:26:03 <Kirill_> hi! yes. also i've emplemented it)
16:27:14 <bauzas> Kirill_: OK, then no worries, we'll look at your spec at least on next Tuesday
16:27:17 <sean-k-mooney> so you used to be able to do this in the past
16:27:46 <bauzas> but if you can discuss about the design, sure, let us knwo
16:27:49 <sean-k-mooney> with the ipmi driver and vncinabox or something like that
16:27:51 <bauzas> if you *want
16:28:09 <sean-k-mooney> shellinabox
16:28:28 <sean-k-mooney> that was the ironic optional component
16:28:49 <sean-k-mooney> https://docs.openstack.org/ironic/latest/admin/console.html
16:29:11 <sean-k-mooney> if you use that you can enabel the console to work in horizong today
16:29:34 <Kirill_> i work on idrac servers+adding ilo console
16:29:51 <Kirill_> but the main gaul is
16:29:59 <Kirill_> new graphical console interface
16:30:33 <Kirill_> i also emplemented it. but will create mr after approve of this spec
16:31:09 <Kirill_> in my spec i added all links. also link to new graphical console interface approved spec
16:31:10 <sean-k-mooney> ok i would liek to see some context in the spec why the existing horizon integration which used to work with nova provisiond server no longer works
16:32:02 <sean-k-mooney> ok the reaons im asking this i si used ot have ironic deployed with the geniric ipmi driver and shellinabox at home a few years ago and it worked fine in horizon
16:32:16 <sean-k-mooney> useing a difffent ironic driver ideally shoudl not requrie changed to nova
16:32:31 <sean-k-mooney> so if we add this new feature i would hope it will work for all ironic drivers
16:32:42 <Kirill_> for vnc
16:32:50 <Kirill_> we need to create a handshake
16:33:02 <Kirill_> for this handshake we need a password from ironic
16:33:21 <sean-k-mooney> oh the old solution used the serial console proxy
16:33:28 <sean-k-mooney> not the novnc proxy
16:33:32 <sean-k-mooney> that the delta
16:33:35 <sean-k-mooney> ok makes sense
16:33:41 <Kirill_> we need a graphical console not serial
16:34:05 <sean-k-mooney> ack ya just was trying to figure out why this is fiddernt then https://docs.openstack.org/ironic/latest/admin/console.html
16:34:21 <sean-k-mooney> its the grapical console not serial
16:35:02 <Kirill_> it is not the same console as vnc
16:36:22 <bauzas> sean-k-mooney: Kirill_:  could you maybe discuss this in the spec then ?
16:36:30 <bauzas> or after the meeting ?
16:36:31 <Kirill_> ++
16:36:35 <bauzas> I'm about to end the meeting
16:36:45 <bauzas> so you can continue to discuss in the IRC channel after
16:37:02 <bauzas> ok, anyone else having an item to discuss ?
16:37:09 <Kirill_> just to sum up. on 15th November we will review all specs (and mine too)?)))
16:38:06 <bauzas> yes
16:38:41 <Kirill_> got it, thanks
16:39:30 <bauzas> ok, then let's close the meeting
16:39:41 <bauzas> thanks all
16:39:45 <bauzas> #endmeeting