#openstack-nova: nova

Meeting started by bauzas at 16:00:18 UTC (full logs).

Meeting summary

  1. Bugs (stuck/critical) (bauzas, 16:02:14)
    1. One Critical bug (bauzas, 16:02:24)
    2. https://bugs.launchpad.net/nova/+bug/2002951 (bauzas, 16:02:47)
    3. https://review.opendev.org/c/openstack/tempest/+/870974 skipping now the failing test (bauzas, 16:03:58)
    4. https://review.opendev.org/c/openstack/tempest/+/871000 proposal for fixing the test issue (bauzas, 16:04:32)
    5. https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 26 new untriaged bugs (-1 since the last meeting) (bauzas, 16:07:25)
    6. Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster (bauzas, 16:09:22)

  2. Gate status (bauzas, 16:10:27)
    1. https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs (bauzas, 16:10:33)
    2. https://bugs.launchpad.net/nova/+bug/2002782 needs help (bauzas, 16:11:05)
    3. https://zuul.openstack.org/builds?job_name=nova-tox-functional&job_name=nova-tox-functional-py310&project=openstack%2Fnova&skip=0 (bauzas, 16:14:06)
    4. https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly (bauzas, 16:16:50)
    5. https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status (bauzas, 16:17:00)
    6. Please look at the gate failures and file a bug report with the gate-failure tag. (bauzas, 16:17:15)
    7. STOP DOING BLIND RECHECKS aka. 'recheck' https://docs.openstack.org/project-team-guide/testing.html#how-to-handle-test-failures (bauzas, 16:17:28)

  3. Release Planning (bauzas, 16:19:39)
    1. https://releases.openstack.org/antelope/schedule.html (bauzas, 16:19:50)
    2. Antelope-3 is in 3 weeks (bauzas, 16:19:58)
    3. https://blueprints.launchpad.net/nova/antelope All accepted blueprints for 2023.1 (bauzas, 16:20:03)
    4. ACTION: bauzas to create an etherpad for tracking blueprints and their progress (bauzas, 16:27:08)
    5. As a reminder, Feature Freeze is in 3 weeks, be sure your patches are up to review sooner than later (bauzas, 16:27:49)

  4. Review priorities (bauzas, 16:28:18)
    1. https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+(label:Review-Priority%252B1+OR+label:Review-Priority%252B2) (bauzas, 16:28:25)
    2. As a reminder, cores eager to review changes can +1 to indicate their interest, +2 for committing to the review (bauzas, 16:28:30)

  5. Stable Branches (bauzas, 16:30:04)
    1. stable branches seem to be unblocked / OK back till wallaby (elodilles, 16:30:22)
    2. ussuri and train might be broken ('Could not build wheels for bcrypt, cryptography' errors) (elodilles, 16:30:30)
    3. stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci (elodilles, 16:34:07)

  6. Open discussion (bauzas, 16:36:00)
    1. https://review.opendev.org/c/openstack/nova/+/706897 (zigo, 16:37:15)
    2. https://review.opendev.org/c/openstack/nova/+/710239 (zigo, 16:37:28)
    3. https://review.opendev.org/c/openstack/nova/+/711679 (zigo, 16:37:39)
    4. https://review.opendev.org/c/openstack/oslo.utils/+/706880 is in ussuri and above (sean-k-mooney, 16:48:41)
    5. https://docs.python.org/3/tutorial/datastructures.html#more-on-lists (sean-k-mooney, 16:53:48)
    6. https://github.com/openstack/oslo.utils/commit/d49d5944824f15d00e04e1b9c7f8c3b03b440c95 (sean-k-mooney, 16:56:51)


Meeting ended at 16:57:58 UTC (full logs).

Action items

  1. bauzas to create an etherpad for tracking blueprints and their progress


Action items, by person

  1. bauzas
    1. bauzas to create an etherpad for tracking blueprints and their progress


People present (lines said)

  1. bauzas (146)
  2. sean-k-mooney (48)
  3. dansmith (30)
  4. zigo (26)
  5. gibi (19)
  6. elodilles (17)
  7. opendevreview (4)
  8. opendevmeet (3)
  9. Uggla (1)


Generated by MeetBot 0.1.4.