#openstack-nova: nova

Meeting started by bauzas at 16:00:11 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting (bauzas, 16:00:43)

  1. Bugs (stuck/critical) (bauzas, 16:01:32)
    1. No Critical bug (bauzas, 16:01:36)
    2. https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 14 new untriaged bugs (-3 since the last meeting) (bauzas, 16:01:50)
    3. https://etherpad.opendev.org/p/nova-bug-triage-20230301 (bauzas, 16:03:47)
    4. https://etherpad.opendev.org/p/nova-bug-triage-20230306 (bauzas, 16:03:53)
    5. https://bugs.launchpad.net/nova/+bug/2009280 im in two mind about how to fix (sean-k-mooney, 16:06:07)
    6. https://bugs.launchpad.net/nova/+bug/2009280 AMD-based computes may have a problem with Zed (bauzas, 16:06:13)
    7. Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster (bauzas, 16:11:33)
    8. bug baton is being passed to elodilles (bauzas, 16:12:54)

  2. Gate status (bauzas, 16:13:04)
    1. https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs (bauzas, 16:13:10)
    2. https://etherpad.opendev.org/p/nova-ci-failures (bauzas, 16:13:15)
    3. https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status (bauzas, 16:16:50)
    4. Please look at the gate failures and file a bug report with the gate-failure tag. (bauzas, 16:18:56)
    5. STOP DOING BLIND RECHECKS aka. 'recheck' https://docs.openstack.org/project-team-guide/testing.html#how-to-handle-test-failures (bauzas, 16:19:00)

  3. Release Planning (bauzas, 16:19:06)
    1. https://releases.openstack.org/antelope/schedule.html (bauzas, 16:19:13)
    2. Antelope-rc1 was this Monday (bauzas, 16:19:19)
    3. as a reminder, no backports are possible on the 2023.1 branch *unless* they are regression bugfixes (bauzas, 16:20:53)
    4. https://etherpad.opendev.org/p/nova-antelope-rc-potential (bauzas, 16:22:23)
    5. https://github.com/openstack/nova/blob/master/doc/requirements.txt#L13 (sean-k-mooney, 16:26:59)
    6. https://github.com/openstack/nova/blob/master/tox.ini#L238 (bauzas, 16:27:06)
    7. https://github.com/openstack/nova/blob/master/tox.ini#L238-L242 (sean-k-mooney, 16:27:36)
    8. https://blueprints.launchpad.net/nova/antelope now shows 'deferred' for approved but non-implemented Blueprints (bauzas, 16:35:05)
    9. ACTION: bauzas to clean-up the stories in Storyboard and tell their owners to recreate a Launchpad bug or blueprint if they wish to carry it on (bauzas, 16:38:38)
    10. Uggla and auniyal are the new release liaisons https://review.opendev.org/c/openstack/releases/+/876758 (bauzas, 16:39:17)

  4. vPTG Planning (bauzas, 16:42:24)
    1. https://www.eventbrite.com/e/project-teams-gathering-march-2023-tickets-483971570997 Register your free ticket (bauzas, 16:42:36)
    2. https://etherpad.opendev.org/p/nova-bobcat-ptg Draft PTG etherpad (bauzas, 16:43:21)
    3. we need to agree on the agenda and how many slots we book (bauzas, 16:43:29)
    4. https://ptg.opendev.org/ptg.html (bauzas, 16:44:04)
    5. ACTION: bauzas to notify the nova community by a ML thread of the proposed agenda for Nova sessions (bauzas, 16:51:56)

  5. Review priorities (bauzas, 16:52:42)
    1. https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+(label:Review-Priority%252B1+OR+label:Review-Priority%252B2) (bauzas, 16:52:49)
    2. As a reminder, cores eager to review changes can +1 to indicate their interest, +2 for committing to the review (bauzas, 16:53:00)

  6. Stable Branches (bauzas, 16:53:04)
    1. stable/2023.1 branches were cut (elodilles, 16:53:26)
    2. stable gates seem to be OK - though it's hard to merge patches due to intermittent failures (elodilles, 16:53:34)
    3. stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci (elodilles, 16:53:54)

  7. Open discussion (bauzas, 16:54:40)


Meeting ended at 17:01:10 UTC (full logs).

Action items

  1. bauzas to clean-up the stories in Storyboard and tell their owners to recreate a Launchpad bug or blueprint if they wish to carry it on
  2. bauzas to notify the nova community by a ML thread of the proposed agenda for Nova sessions


Action items, by person

  1. bauzas
    1. bauzas to clean-up the stories in Storyboard and tell their owners to recreate a Launchpad bug or blueprint if they wish to carry it on
    2. bauzas to notify the nova community by a ML thread of the proposed agenda for Nova sessions


People present (lines said)

  1. bauzas (183)
  2. sean-k-mooney (66)
  3. elodilles (21)
  4. astupnik (6)
  5. opendevmeet (3)
  6. gibi (2)
  7. auniyal (2)
  8. Uggla (1)


Generated by MeetBot 0.1.4.