16:00:04 <bauzas> #startmeeting nova
16:00:04 <opendevmeet> Meeting started Tue Apr  4 16:00:04 2023 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <opendevmeet> The meeting name has been set to 'nova'
16:00:14 <bauzas> hey folks
16:00:25 <bauzas> hope you had a good PTG
16:00:29 <Uggla> o/
16:00:37 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:45 <elodilles> o/
16:00:46 * bauzas again misses all of you
16:00:53 <TheJulia> sean-k-mooney: I looked at the query on the db, just looks like it is not there based upon the error. Only option I have is to attempt local reproduction most likely.
16:01:06 <auniyal> o/
16:01:12 <bauzas> TheJulia: sorry but we just started our weekly meeting
16:01:29 <TheJulia> I'm aware
16:01:37 * bauzas awaits for folks to be arriving
16:01:42 <dansmith> o/
16:02:23 <gibi> o/
16:03:02 <bauzas> ok, let's start then
16:03:08 <bauzas> #topic Bugs (stuck/critical)
16:03:13 <bauzas> #info No Critical bug
16:03:18 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 22 new untriaged bugs (+5 since the last meeting)
16:03:30 <bauzas> sorry I didn't had time to look at all the bugs
16:04:08 <bauzas> that said, I think we could quickly close some of them when I just opened ^
16:04:11 <bauzas> so,
16:04:26 <bauzas> I'll continue to have the bug baton for this weeek
16:04:32 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:04:37 <bauzas> #info bug baton is being passed to bauzas
16:04:56 <bauzas> any bug to discuss before we move ?
16:05:46 <bauzas> looks not
16:06:05 <bauzas> #topic Gate status
16:06:10 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:06:14 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures
16:06:21 <bauzas> I need to look again on the ci failures
16:06:27 <dansmith> I haven't had anything in the gate since before PTG, but it sounds like things are sucking a gain?
16:06:41 <bauzas> I saw some other issues so I'll try to verify whether they are a lot
16:07:17 <bauzas> dansmith: unfortunately yes, see for example https://review.opendev.org/c/openstack/nova/+/875621 and https://review.opendev.org/c/openstack/nova/+/878693
16:08:26 <bauzas> anyway, let's move on
16:08:40 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:09:06 <bauzas> all greens :)
16:09:21 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:09:28 <bauzas> #info STOP DOING BLIND RECHECKS aka. 'recheck' https://docs.openstack.org/project-team-guide/testing.html#how-to-handle-test-failures
16:09:31 <bauzas> that's it
16:09:45 <bauzas> moving on ?
16:11:06 <bauzas> looks so
16:11:16 <bauzas> #topic Release Planning
16:11:22 <bauzas> #link https://releases.openstack.org/bobcat/schedule.html
16:11:28 <bauzas> #link https://review.opendev.org/c/openstack/releases/+/877094 Proposed deadlines for Bobcat
16:11:42 <gmann> o/
16:11:44 <bauzas> as I said on Friday, I eventually provided a new revision
16:11:54 <bauzas> #link https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_2b8/877094/3/check/openstack-tox-docs/2b8febf/docs/bobcat/schedule.html Generated HTML for proposed deadlines
16:12:02 <bauzas> please review those dates
16:12:08 <bauzas> before tomorrow
16:12:16 <bauzas> #info Nova contributors should review this change before tomorrow 1600UTC.
16:12:21 <bauzas> I added one stable review day
16:12:30 <bauzas> and I added a second feature review day
16:13:03 <bauzas> on milestone-1 we could review the stable branches
16:13:27 <elodilles> ++
16:13:29 <bauzas> then we'll have one spec review day *before* the summit
16:13:54 <bauzas> and another one two weeks after the summit (one week before spec feature freeze)
16:14:04 <bauzas> spec approval freeze sorry
16:14:50 <bauzas> then, on the day after the spec approval freeze, we could review some series from accepted blueprints
16:15:21 <bauzas> and eventually, a second implementation review day the last week of July
16:15:45 <bauzas> (which would be 5 weeks before FF)
16:16:06 <bauzas> that's it.
16:16:46 <bauzas> we could review some series on the week before FF, but honestly, I think it's late (and also I'll just be back from PTO)
16:17:20 <bauzas> so I'd prefer to tell the blueprints owners to provide their series one month before (as we also discussed during the PTG)
16:17:56 <bauzas> anyway, as a reminder, please review https://review.opendev.org/c/openstack/releases/+/877094 before tomorrow 1600UTC
16:18:04 <bauzas> again, that's it on this topic for me
16:19:20 <bauzas> moving on, I guess
16:19:38 <bauzas> oh, last point
16:19:41 <bauzas> #info Bobcat-1 is in 5 weeks.
16:19:47 <opendevreview> Merged openstack/nova master: Update min support for Bobcat  https://review.opendev.org/c/openstack/nova/+/875621
16:19:52 <bauzas> woooohoooooooooooooooooooooooo
16:19:54 <bauzas> ^
16:20:08 <bauzas> so, next topic
16:20:15 <bauzas> #topic vPTG feedback
16:20:22 <bauzas> #link https://lists.openstack.org/pipermail/openstack-discuss/2023-April/033124.html
16:20:39 <bauzas> I provided an email summary ^
16:20:55 <bauzas> btw. heh, sorry about s/NFV/NFS :p
16:21:16 <bauzas> -ETOOMANYNETWORKINGDISCUSSIONS
16:21:26 <elodilles> :)
16:21:32 <bauzas> anyway, it was more a FYI
16:21:41 <bauzas> #topic Review priorities
16:21:50 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+(label:Review-Priority%252B1+OR+label:Review-Priority%252B2)
16:21:55 <bauzas> #info As a reminder, cores eager to review changes can +1 to indicate their interest, +2 for committing to the review
16:22:04 <bauzas> next topic
16:22:10 <bauzas> #topic Stable Branches
16:22:24 <bauzas> elodilles: before I'm asking you, let me first add something :)
16:22:31 <elodilles> sure :)
16:22:33 <bauzas> #link https://review.opendev.org/c/openstack/releases/+/878860 Xena stable branche EM proposal
16:22:39 <bauzas> so,
16:22:49 <bauzas> I said last week we should discuss the Xena EM approval this week
16:23:21 <bauzas> #link https://review.opendev.org/q/project:openstack/nova+branch:stable/xena+is:open
16:23:31 <bauzas> those are the open changes we have
16:23:33 <bauzas> so, question
16:23:35 <opendevreview> Rajesh Tailor proposed openstack/nova master: Fix trivial doc issues  https://review.opendev.org/c/openstack/nova/+/878779
16:24:27 <bauzas> does anyone want to have their series be merged in xena before we EM ?
16:24:42 <bauzas> as a reminder, we can continue to merge patches in that branch
16:25:10 <bauzas> this is just we won't have an upstream .z or .y release after EM tag
16:25:41 <bauzas> anyone ?
16:25:41 <auniyal> this is a clean backport for xena https://review.opendev.org/c/openstack/nova/+/874066
16:26:15 <elodilles> just an addition to what bauzas said: anyone see any patch that "would be good to get merged & released as final"?
16:26:27 <elodilles> in xena
16:26:44 <bauzas> elodilles: maybe we could wait for https://review.opendev.org/c/openstack/nova/+/866156 to be merged
16:26:55 <bauzas> since it's a bit of a regression
16:27:12 <bauzas> and yoga was merged
16:27:15 <elodilles> btw, we have a tracking pad if needed: https://etherpad.opendev.org/p/nova-stable-xena-em
16:27:26 <elodilles> so we can add these patches there ^^^
16:27:39 <sean-k-mooney> ill review that backport now
16:27:56 <bauzas> auniyal: the problem is that the patch you proposed needs to have its yoga backport approved before
16:27:57 <elodilles> and (stable) cores could review them when they have time
16:28:20 <elodilles> i can also help with some reviews hopefully
16:28:31 <bauzas> elodilles: remind me when the deadline for Xena EM is ?
16:28:33 <auniyal> yeah my bad its not merged in yoga
16:28:45 <elodilles> well, the transition date is April 20th
16:29:02 <elodilles> should be good to release earlier though
16:29:05 <bauzas> ok, then we'll track the progress every week
16:29:16 <bauzas> and every week, I'll ask the question
16:29:26 <elodilles> maybe we can see if next week we can cut a release
16:29:35 <bauzas> in the meantime, people can merge whatever they want
16:29:40 <bauzas> elodilles: yup
16:29:51 <bauzas> don't disagree
16:30:14 <elodilles> note also, that we had a xena release around end of january (24.2.0)
16:30:29 <bauzas> #link https://etherpad.opendev.org/p/nova-stable-xena-em Tracking etherpad for Xena
16:30:31 <elodilles> so really the open patches is mostly the ones that we need to consider
16:31:05 <sean-k-mooney> bauzas: i have approved the mdev patch
16:31:05 <bauzas> #info please tell the nova community which patches you want to have to be released before next week by pinging bauzas on IRC
16:31:11 <sean-k-mooney> just skimin gthe open ones now
16:31:18 <bauzas> cool thanks
16:31:29 <bauzas> anyway, elodilles, add your points now
16:31:30 <elodilles> ++
16:31:50 <elodilles> well, there is nothing left just the usual
16:31:53 <elodilles> #info stable gates seem to be OK - though it's hard to merge patches due to intermittent failures
16:31:58 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:33:23 <bauzas> cool
16:33:37 <bauzas> last topic then
16:33:42 <bauzas> #topic Open discussion
16:33:45 <bauzas> the agenda is empty
16:33:53 <auniyal> so I was looking for backports in 2023.1, zed and yoga
16:33:55 <bauzas> anyone wants to discuss about something that we missed at the PTG ?
16:34:51 <gibi> bauzas: the lower constraint job discussion was punted last week
16:35:31 <bauzas> gibi: yup, I haven't asked you if you wanted to discuss about it today
16:35:32 <gibi> bauzas: I have not much to add to what was in the current or in the previous PTG etherpad just that I have the intention to add a limited lower constraint job
16:35:36 <bauzas> gibi: do you want now ?
16:35:40 <gibi> we can
16:35:44 <bauzas> cool
16:36:05 <bauzas> (we also have other punted topics, but again, those were not prioritary for this week)
16:36:16 <bauzas> gibi: so, shoot
16:36:18 <gibi> yeah, this is not priority either
16:36:36 <bauzas> we discussed your topic briefly
16:36:50 <bauzas> concerns were coming from any potential transitive dependencies and the scope
16:37:01 <gibi> so I see that sean-k-mooney prefer not to have it
16:37:04 <bauzas> we said this was for unittests and functionaltests
16:37:11 <dansmith> gmann also had comments I think
16:37:11 <gibi> so the scope is intentionally limited
16:37:25 <bauzas> correct
16:37:30 <sean-k-mooney> i do not wnat nova to be the only ones to have it if we do i would prefer it to be a perodic
16:37:35 <gibi> so run unit and functional test, only with the some of our direct depds pinned to lowest
16:37:43 <bauzas> and if I'm not wrong, this wouldn't be having transitive deps in the filez
16:37:45 <bauzas> file
16:37:54 <gibi> no transitives yes
16:38:02 <sean-k-mooney> im more or less ok with that but limitation
16:38:04 <bauzas> ok, then I wasn't wrong
16:38:06 <dansmith> I didn't hear the pitch about why we should, but I too am a bit skeptical
16:38:23 <bauzas> dansmith: it was due to a regression we had with os-traits
16:38:33 <bauzas> we modified the code by using the new traits
16:38:33 <gibi> dansmith: in Zed we released nova code that depended on os-traits versions but we forgot to bump the version
16:38:38 <gmann> gibi: did you try how it will run with nova as lower bound and other deps's deps as upper bound ?
16:38:40 <bauzas> that yeah
16:38:59 <gibi> gmann: not yet, I had some local trials but mostly got sidetracked
16:39:07 <gmann> I am ok to run unit test lower bound job but just wondering how complex it will be to setup and keep green
16:39:11 <dansmith> traits is kinda weird though right? we sort of always need that to move in lockstep with our usage of it yeah/
16:39:16 <gmann> gibi: ack
16:39:29 <dansmith> so requirements and the lower constraint is always the same?
16:39:49 <dansmith> it's not like libvirt where we actually want to support a range of older and newer versions
16:40:14 <gibi> dansmith: yeah, in case of os-traits we have a fairly hard connection
16:40:15 <gmann> I think we need to keep lower constraint file as requirements.txt constraints might be higher than lowest supported versions
16:40:32 <dansmith> so was the miss that we always get the latest os-traits from other stuff and we didn't notice we needed a bump?
16:40:33 <sean-k-mooney> gmann: they should not be
16:40:36 <gmann> or gibi you want to test what we have in requirements.txt as lower bound and not actual lower bound ?
16:40:39 <gibi> gmann: I thought that the minimum in requiremenets.txt is the lowest we need to test with
16:40:44 <gmann> ok
16:40:48 <sean-k-mooney> requirements has our lower bound
16:41:11 <sean-k-mooney> while lower version might work if you dont use all features
16:41:27 <gmann> sean-k-mooney: yeah but they are no guaranteed to be lowest bound, we can have b>8 where it might work b==6 also
16:41:28 <gibi> dansmith: os-vif is a bit softer, i.e. lower != higher, but we can break the dep the same way
16:41:29 <dansmith> that's true of libvirt but probably less so os-traits
16:41:54 <sean-k-mooney> gmann: if you use somthing older then in in requiremtns i would say thats an unsupported config
16:42:03 <dansmith> so is the proposal to maintain a separate list, or to sed the >= out of requirements.txt?
16:42:14 <bauzas> do people say we shall pin our versions in reqs.txt ?
16:42:23 <gmann> that is why there are two things 1. test what we have lower bound in requirements.txt 2. test actual lower(st) bound work for nova
16:42:26 <gibi> dansmith: basically sedding the requirements.txt
16:42:50 <dansmith> gibi: okay if it's that, and periodic, then I'm okay with it.. what I don't want is a second list and pre-merge testing (just because of the load)
16:42:50 <sean-k-mooney> we dont want to do 2
16:42:52 <bauzas> hah
16:43:04 <bauzas> so, s/>=/== then ?
16:43:07 <sean-k-mooney> we could do 1
16:43:08 <gibi> dansmith: ack, I'm OK to make it periodic
16:43:10 <gmann> yeah, doing 2 is difficult
16:43:10 <bauzas> automatically from reqs.txt ?
16:43:20 <dansmith> bauzas: yeah, I think that's reasonable
16:43:20 <sean-k-mooney> i would say 2 is a non goal
16:43:22 <gibi> bauzas: that is the idea
16:43:28 <gmann> I am ok to doing 1 and even in check pipeline as unit test also ok
16:43:34 <gmann> sean-k-mooney: yes
16:43:41 <bauzas> so a specific tox target ?
16:43:55 <gibi> bauzas: yepp
16:43:59 <bauzas> to -epy38-min ?
16:44:00 <gmann> yeah, that will be helpful to check locally also
16:44:12 <bauzas> ok, then I don't disagree the idea
16:44:16 <dansmith> a specific tox target that runs both in a single go would be nice to avoid needing separate unit/functional jobs yeah
16:44:22 <bauzas> I see
16:44:38 <dansmith> and I'd prefer periodic until/unless we see it breaking more often
16:44:39 <gibi> sean-k-mooney, gmann : I agree to aim for 1. If somebody want to find the real lower bound (i.e 2) then that person can play with the requirements.txt and with the new job
16:44:42 <bauzas> so the tox target would call out a script that would copy/sed reqs.txt by pinning to the mins
16:45:09 <gmann> gibi: agree
16:45:17 <gibi> bauzas: yeah
16:45:36 <bauzas> and the gate would periodically run a job that would call this target
16:45:42 <bauzas> then I don't disagree
16:45:46 <gibi> cool
16:45:51 <gibi> I see an agreement forming :)
16:45:52 <bauzas> anyone having concerns ?
16:46:05 <gibi> (now I need to find the time to do the scripting)
16:46:17 <bauzas> say it now or forever hold your peace
16:46:34 <bauzas> crickets, all cool
16:46:38 <gibi> thanks
16:46:44 <gibi> and sorry again for missing the firday sessions
16:46:51 <gibi> Friday even
16:47:12 <bauzas> #agreed gibi to work on a new tox target that would run unittests with a pinned min version of reqs.txt, with a periodic job testing it weekly
16:47:53 <bauzas> gibi: I guess you may want to do it as well for functional tests but this doesn't harm to me
16:48:14 <gibi> bauzas: yeah, lets see the unit first, adding functional to it is easy then
16:48:24 <bauzas> cool
16:48:31 <bauzas> I think dust is settled now
16:48:43 <bauzas> anything else before I call it a wrap ?
16:48:47 <auniyal> bauzas, I dont have anything w.r.t PTG missing item, can we discuss few backports ?
16:48:55 <gibi> I've updated the etherpad with the link to this meeting log
16:49:10 <bauzas> gibi: excellent for tracking decisions
16:49:27 <bauzas> auniyal: are you asking for specific change reviews ?
16:49:36 <auniyal> I have few backports which can be merged mostly for zed and yoga, I have reviewed them from my end, I would like to request cores to review them
16:49:46 <bauzas> if so, I'd prefer if you could ping folks off the meeting
16:50:04 <bauzas> (we generally try to avoid review requests during the meeting, for obvious reasons)
16:50:09 <auniyal> okay
16:50:23 <bauzas> (the main one is brevity)
16:50:37 <bauzas> ok, so, last call ?
16:51:51 <bauzas> thanks all
16:51:56 <bauzas> #endmeeting