16:01:33 <bauzas> #startmeeting nova
16:01:33 <opendevmeet> Meeting started Tue May 23 16:01:33 2023 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:33 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:33 <opendevmeet> The meeting name has been set to 'nova'
16:01:39 <bauzas> good meeting folks
16:01:45 <dansmith> o/
16:01:55 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:02:05 <auniyal_> o/
16:03:39 <Uggla_> o/
16:04:24 <gibi> o/
16:04:41 <bauzas> ok, starting (sorry was reviewing some patch)
16:04:48 <bauzas> #topic Bugs (stuck/critical)
16:04:52 <bauzas> #info No Critical bug
16:04:57 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 15 new untriaged bugs (+0 since the last meeting)
16:05:01 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:05:09 <elodilles> o/
16:05:14 <bauzas> elodilles: anything to report ?
16:05:23 <elodilles> nothing
16:05:38 <elodilles> i was only able to triage one bug :/
16:06:35 <bauzas> no worries
16:06:46 <bauzas> moving on then
16:06:58 <bauzas> auniyal: can you do a bit of triage this week ?
16:07:07 <auniyal_> yes
16:07:10 <bauzas> cool thanks
16:07:16 <bauzas> #topic Gate status
16:07:19 <bauzas> oops
16:07:23 <bauzas> #undo
16:07:23 <opendevmeet> Removing item from minutes: #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:07:28 <bauzas> #info bug baton is being passed to auniyal
16:07:36 <bauzas> doh
16:07:41 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:08:02 <opendevreview> Balazs Gibizer proposed openstack/nova stable/train: Reproducer for bug 1983753  https://review.opendev.org/c/openstack/nova/+/883932
16:08:03 <opendevreview> Balazs Gibizer proposed openstack/nova stable/train: Update RequestSpec.pci_request for resize  https://review.opendev.org/c/openstack/nova/+/883933
16:08:04 <opendevreview> Balazs Gibizer proposed openstack/nova stable/train: Add reno for fixing bug 1941005  https://review.opendev.org/c/openstack/nova/+/883934
16:08:07 <bauzas> #topic Gate status
16:08:13 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:08:19 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures
16:08:48 <dansmith> I think CI has been pretty decent lately.. just yesterday we merged the mysql memory de-tune by default
16:08:54 <bauzas> gibi: dansmith: or others, do you want to discuss some failures ?
16:09:00 <opendevreview> Merged openstack/nova stable/ussuri: CI: fix backport validator for new branch naming  https://review.opendev.org/c/openstack/nova/+/882970
16:09:01 <bauzas> dansmith: excellent
16:09:02 <dansmith> also, I got an update on the powerkvm CI from the owners
16:09:17 <bauzas> cool, so ?
16:09:19 <dansmith> it's known to be totally broken right now, apparently due to libraries dropping ppc support
16:09:38 <dansmith> not sure what the outlook on that is, but I've suggested disabling it until it can possibly run successfully
16:09:55 <bauzas> ++
16:10:10 <gibi> bauzas: on my side I looked at https://bugs.launchpad.net/neutron/+bug/2015065/comments/8
16:10:13 <dansmith> also, not supported on rhel9, and I thought it was a dead product now, so I'm not sure why there's any reason to keep running it, but they do want to keep it running if/when they fix the library stuff
16:10:35 <bauzas> dansmith: yeah, that's not that it's holding our gate, it's just confusing
16:10:36 <dansmith> meaning it can only run on rhel8, nothing newer
16:10:46 <dansmith> bauzas: yep, and creating noise
16:11:01 <bauzas> we had some CI interface in the paste where we were gathering results of 3rd party CI
16:11:10 <bauzas> but afaics, this is dead horse noxw
16:11:51 <bauzas> ciwatch.mmedvede.net/project?project=nova is timing out for me
16:12:27 <bauzas> dansmith: on another point, I've seen good progress on bumping cirros
16:12:50 <dansmith> yeah I was going to ask gmann about that - I saw a test patch that seemed successful;
16:12:54 <bauzas> #link https://review.opendev.org/c/openstack/devstack/+/881437?usp=email Cirros is now bumped to 0.6.1
16:13:06 <bauzas> a revert of a revert
16:13:13 <bauzas> keep following, dudes :)
16:13:19 <dansmith> ah okay
16:13:35 <dansmith> so it'll be interesting to see if that improves our guest kernel crash issues
16:13:51 <bauzas> yup, related is https://bugs.launchpad.net/nova/+bug/2006467
16:14:14 <bauzas> and https://bugs.launchpad.net/nova/+bug/2018612
16:14:24 <dansmith> yeah
16:14:37 <bauzas> and some other IIRC
16:14:47 <bauzas> anyway, I'll try to look at it when I have time
16:15:14 <bauzas> gibi: want to discuss your recent findings on https://bugs.launchpad.net/neutron/+bug/2015065/comments/8 for the group ?
16:15:20 <gibi> you a summary
16:15:24 <gibi> ahh
16:15:25 <gibi> so
16:15:27 <gibi> just a summary
16:15:40 <gibi> https://bugs.launchpad.net/neutron/+bug/2015065/comments/8 feels like an eventlet issue
16:15:42 <bauzas> it was just a question, people can click :)
16:15:46 <gibi> so I opened https://github.com/eventlet/eventlet/issues/798
16:16:09 <gibi> waiting for the maintainer to say my reproduction is valid or not in pure eventlet
16:16:34 <bauzas> gibi: kudos for your detective skills
16:16:54 <gibi> kudos to ykarel for getting the stacktrace of the stuck thread
16:17:00 <bauzas> indeed
16:17:23 <bauzas> okay, anyting else to mention on failures before we brag too much ?
16:17:51 <bauzas> nah, ok
16:18:05 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:18:27 <bauzas> the centos9 job on fips had a blip
16:18:57 <bauzas> with a fun "/usr/bin/python3.9: No module named pip"
16:19:02 <bauzas> #link https://zuul.openstack.org/build/23afe450b9cc457bb094563b3f45aafd
16:19:19 <dansmith> blip? on the qa meeting just now it sounded unresolved
16:19:27 <bauzas> possibly
16:19:43 <bauzas> I just saw the blip, not the whole Thanos universe clap
16:21:01 <opendevreview> Merged openstack/nova stable/wallaby: fup: Print message logging uncaught nova-manage exceptions  https://review.opendev.org/c/openstack/nova/+/877334
16:21:39 <bauzas> doh, can't query https://zuul.openstack.org/builds?skip=0 with job=centos
16:21:49 <bauzas> and I don't know if it supports regexs
16:22:46 <bauzas> anyway
16:22:59 <bauzas> my Zuul query foo is rusty, so moving on
16:23:15 <bauzas> and I'll lurk #openstack-qa meanwhile
16:23:26 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:23:30 <bauzas> #info STOP DOING BLIND RECHECKS aka. 'recheck' https://docs.openstack.org/project-team-guide/testing.html#how-to-handle-test-failures
16:23:35 <bauzas> that's it for gate
16:23:40 <bauzas> #topic Release Planning
16:23:43 <bauzas> #link https://releases.openstack.org/bobcat/schedule.html
16:23:47 <bauzas> #info Nova deadlines are set in the above schedule
16:23:54 <bauzas> worth saying now :
16:23:58 <bauzas> #info Nova spec review day in two weeks
16:24:03 <bauzas> you're all noticed
16:24:29 <bauzas> take your pens and your paper, and write your best poetry
16:25:16 <bauzas> spec freeze will only be on the first week of July
16:25:32 <bauzas> noted ?
16:26:06 <bauzas> so,
16:26:15 <bauzas> #topic pPTG Planning
16:26:26 <gibi> pPTG?
16:26:33 <gibi> physical? partial?
16:26:33 <bauzas> I will be quick, I have two questions, one related to the other
16:26:44 <bauzas> gibi: hah, both :p
16:26:49 <gibi> ppPTG
16:26:59 <bauzas> Who will be at the pPTG in VancouverĀ ?
16:27:03 <bauzas> and related,
16:27:08 <bauzas> #link https://ptg.opendev.org/ptg.html Should we book some table for the PTGĀ ?
16:27:35 <bauzas> I've got one email from the Foundation asking to whether I would want to book a table
16:27:43 <bauzas> and honestly, I don't know what to do
16:27:56 <bauzas> the Forum will compete with the PTG
16:28:05 <gibi> book a table, then might be unused
16:28:37 <bauzas> the whole 2 days ? works for me
16:28:54 <bauzas> at least I'd have a spot to sit down
16:29:00 <gibi> :)
16:29:22 <gibi> I think that is the exact reason to publish where to find the PTL
16:29:47 <bauzas> that's a bit premature but I should start to gather information about topics that people wanna bring at the PTG and who could be present
16:30:26 <bauzas> and if some people that are NOT at the PTG wanna chime on such topics, that would give us some insight too
16:30:54 <bauzas> #action bauzas to prepare a PTG etherpad for calling about topics and attendace
16:31:13 <bauzas> that's it, I wanted to keep it short
16:31:21 <bauzas> #topic Review priorities
16:31:26 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+(label:Review-Priority%252B1+OR+label:Review-Priority%252B2)
16:31:30 <bauzas> #info As a reminder, cores eager to review changes can +1 to indicate their interest, +2 for committing to the review
16:32:06 <bauzas> #topic Stable Branches
16:32:10 <bauzas> elodilles: your turn !
16:32:14 <elodilles> o/
16:32:16 <elodilles> #info stable nova release patches merged on Wednesday: 2023.1 Antelope (27.1.0), Zed (26.2.0), Yoga (25.2.0)
16:32:22 <bauzas> huzzah
16:32:26 <elodilles> so these have been released ^^^ \o/
16:32:38 <elodilles> #info stable/wallaby is unblocked as gmann's nova-ceph-multistore job fix has merged (thanks!) -- https://review.opendev.org/871920
16:32:54 <bauzas> those include the CVE 2023-2088 fixes, I'm happy to have them now :)
16:33:07 <elodilles> bauzas: yepp
16:33:12 <bauzas> huzzah again
16:33:19 <elodilles> :]
16:33:19 <bauzas> about the ceph-multistore problem
16:33:32 <elodilles> yepp-yepp
16:33:36 <elodilles> #info stable/train is blocked by failing openstacksdk-functional-devstack job
16:33:42 <bauzas> doh
16:33:54 <elodilles> this is probably because of heat's stable/train eol
16:34:18 <elodilles> i'm looking at multiple ways of possibilities to unblock the gate
16:34:33 <elodilles> will see which is the best / working :P
16:34:47 <elodilles> and the general info:
16:34:53 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:35:01 <elodilles> EOM
16:35:41 <bauzas> about Train, given some parts of the universe started to EOL it
16:35:51 <bauzas> then, my question is, should we copy them ?
16:36:05 <elodilles> heat EOL'd their ussuri as well
16:36:08 <bauzas> I know that my paycheck comes partly from Train, but that's still a question to me
16:36:33 <elodilles> bauzas: i still say that until we can merge patches (hehh) we can keep it open o:)
16:37:42 <bauzas> stable/train also doesn't include the previous CVE fix you know ;)
16:38:08 <elodilles> hmmm, i forgot that
16:38:23 <elodilles> though there are some who still wanted rocky to accept patches ;)
16:38:48 <bauzas> I'm not only talking of the brick CVE
16:38:57 <bauzas> I'm also taking of the VMDK CVE
16:39:24 <bauzas> if people want to risk their lifes, I'm OK
16:39:37 <elodilles> good point
16:39:44 <bauzas> but that is still two serious security flaws that haven't been fixed
16:39:45 <elodilles> i cannot ague with that
16:39:57 <sean-k-mooney> i would may keep it alive for a few more months and ask operators at the summit
16:40:15 <sean-k-mooney> but i could see use retiring it after bobcat in either case
16:40:30 <dansmith> I'm fine (and prefer) to keep branches available, but if we're maintaining part of it but not backporting critical CVEs it really sends a mixed message
16:40:45 <bauzas> dansmith: that's my whole point
16:40:46 <dansmith> mixed and confusing I would say
16:40:57 <elodilles> dansmith: true
16:41:57 <sean-k-mooney> the vmdk cve however makes me more inclided to say we should be keeping train
16:41:59 <bauzas> dansmith: we can't reasonably say we're open to keep a branch open and accept backports if the most critical ones aren't done
16:42:35 <sean-k-mooney> we fixed it downstream in our train based product but it causes a lot fo pain because it had a bug that would have been caught if we fixed it upstream instead
16:42:40 <dansmith> bauzas: I just like the branches to be open over tags personally, but if people see "last commit X days ago" they're likely to assume that some of those commits are critical fixes
16:42:42 <bauzas> sean-k-mooney: train doesn't include the vmdk fix
16:42:48 <sean-k-mooney> i know
16:42:55 <bauzas> ah, missed your poiint
16:43:18 <bauzas> sean-k-mooney: truly, we missed something downstream because we lacked some upstream backport
16:43:23 <sean-k-mooney> if we had fixed the cve via the upstream backport process it would have caught the missing patch we had downstream
16:43:57 <bauzas> but the upstream branch isn't really arguably in a good shape if the two most major CVEs that I know since a decade aren't fixed
16:44:11 <sean-k-mooney> well they could be fixed
16:44:26 <sean-k-mooney> we just dont have peopel volentering to fix it
16:44:32 <bauzas> sean-k-mooney: true, and this hadn't been done because of the way we manage our dependencies upstream is tough
16:44:50 <dansmith> right the point is that we're not meant to be maintaining these.. so we either need to do it, or stop *signaling* that we're doing it
16:45:05 <bauzas> +1
16:45:06 <sean-k-mooney> yep
16:45:30 <bauzas> the brick CVE isn't AFAIK proposed against train now
16:45:31 <dansmith> so I guess I'll say I'm +1 for EOLing train
16:46:08 <bauzas> so, honestly, if we want to keep train, let's do the efforts to backport both CVE fixes to train
16:46:13 <dansmith> are we even sync/importing from train downstream anymore?
16:46:21 <bauzas> don't look at me, I'm not rushing to do it
16:46:35 <sean-k-mooney> we are
16:46:51 <sean-k-mooney> but our last release that will do that is planed for q3
16:47:00 <sean-k-mooney> so after bobcat is release we wont be
16:47:09 <bauzas> don't speak redhat greek in this channel please :)
16:47:49 <sean-k-mooney> well the point being that we will stop consuming form the stable branch anyway in the next few months
16:47:56 <dansmith> right
16:47:56 <sean-k-mooney> for our downstream uses
16:48:24 <bauzas> yeah, but we still don't provide the CVE fixes to it ? :)
16:48:53 <sean-k-mooney> you know i orgianly wanted use to fix both of those on upstream train right
16:49:08 <dansmith> sean-k-mooney: so then why didn't you?
16:49:33 <sean-k-mooney> i asked the peopel that did the backprot to do it
16:49:35 <bauzas> we all have priorities and I don't blame anyone
16:50:03 <bauzas> particularly me, since I was owning the backports for the VMDK one and I intentionally skipped the train one
16:50:35 <bauzas> because it would have required some oslo.utils release number belly dance
16:51:16 <bauzas> and as a reminder, Extended Maintenance is clear on its intents
16:51:26 <dansmith> bauzas: exactly
16:51:31 <bauzas> https://docs.openstack.org/project-team-guide/stable-branches.html#extended-maintenance
16:52:40 <bauzas> anyway, seems we won't reach a consensus, but I can propose to send an email to openstack-discuss
16:52:52 <bauzas> we'll see if people argue
16:53:18 * bauzas just hopes that operators read our mailing lists
16:53:57 <bauzas> #action bauzas to send an email to -discuss to gauge the freakiness of EOLing stable/train now
16:54:33 <bauzas> I guess we're done with this hot topic
16:54:54 <bauzas> #topic Open Discussion
16:54:58 <bauzas> nothing on the agenda
16:55:16 <bauzas> is anyone having a thought to share with the team ?
16:56:47 <bauzas> looks not
16:56:55 <bauzas> sorry this week I won't save too much of your time
16:56:59 <bauzas> thanks all
16:57:03 <bauzas> #endmeeting