16:00:29 <bauzas> #startmeeting nova
16:00:29 <opendevmeet> Meeting started Tue Jul 11 16:00:29 2023 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:29 <opendevmeet> The meeting name has been set to 'nova'
16:00:36 <bauzas> howdy
16:00:46 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:01:03 <bauzas> hopefully will be short, I need to go off early
16:01:09 <bauzas> who's around ?
16:01:12 <gibi> o/
16:01:19 <auniyal> o/
16:01:20 <sean-k-mooney> o/ ish
16:01:27 <sean-k-mooney> im here but a littel distracted
16:01:29 <dansmith> o/ kinda
16:01:37 <elodilles> o/
16:02:06 <bauzas> okay, let's start
16:02:14 <bauzas> happy to see quorum here
16:02:20 <bauzas> #topic Bugs (stuck/critical)
16:02:24 <bauzas> #info One Critical bug
16:02:28 <bauzas> #link https://bugs.launchpad.net/nova/+bug/2025813
16:02:30 <bauzas> so
16:02:56 <bauzas> afaict, https://review.opendev.org/c/openstack/nova/+/887632 is merged
16:03:19 <bauzas> so we should modify the bug importance to High, fair enough ?
16:03:33 <bauzas> (at least for the master branch)
16:03:36 <elodilles> it's only affecting now stable branches
16:03:51 <bauzas> yup
16:04:02 <elodilles> and of course nova/virt/libvirt/* patches
16:04:03 <bauzas> we're tracking the stable branches correctly in the bug report
16:04:11 <elodilles> ++
16:04:31 <bauzas> so, let's keep the bug importance to Critical for all the stable series
16:04:40 <bauzas> but changing to High for the main one
16:04:40 <elodilles> +1
16:04:45 <bauzas> cool, doing it now
16:05:25 <sean-k-mooney> bauzas: its still blocking the sable branches
16:05:32 <bauzas> done.
16:05:36 <sean-k-mooney> but im not really sure what the point of modifying it is
16:05:57 <sean-k-mooney> the status shoudl jsut go to fix-released instead
16:06:08 <bauzas> I can do it
16:06:19 <bauzas> done too.
16:06:25 <bauzas> anyway, moving on
16:06:33 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 35 new untriaged bugs (+1 since the last meeting)
16:06:37 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:06:44 <bauzas> melwitt is the next in the queue
16:06:56 <bauzas> not sure she's around, I can try to ping her
16:07:04 <bauzas> moving on
16:07:08 <bauzas> #topic Gate status
16:07:12 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:07:16 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures
16:07:44 * gibi had no time to do bug triage
16:07:48 <bauzas> anything to discuss apart of the already one we had ?
16:07:53 <bauzas> gibi: no worries
16:08:29 <bauzas> looks the gate is stable-ish, but since I'll review most of implementation patches this week, I'll see :)
16:08:41 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:08:45 <bauzas> all greens
16:08:50 <bauzas> nothing to report
16:08:55 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:09:03 <bauzas> anything about CI failures ?
16:09:15 <bauzas> if not, let's move on
16:09:25 <bauzas> #topic Release Planning
16:09:29 <bauzas> #link https://releases.openstack.org/bobcat/schedule.html
16:09:32 <bauzas> #info Nova deadlines are set in the above schedule
16:09:57 <bauzas> last week, we had our spec deadline
16:10:10 <bauzas> so, now, we know about all the accepted blueprints :
16:10:14 <bauzas> #link https://blueprints.launchpad.net/nova/bobcat
16:10:32 <bauzas> I just accepted all the blueprints with a merged spec
16:10:53 <bauzas> as you see, 17 bps are accepted, 4 of them being specless
16:11:04 <bauzas> iirc, this was like Antelope
16:11:20 <bauzas> I started to review a few patches already
16:11:40 <bauzas> but, I'll create an blueprints etherpad like we do every cycle
16:12:06 <bauzas> so, reviewers could use this etherpad for knowing about the existing gerrit series, without needing to look at the blueprint
16:12:12 <bauzas> and they'll see what needs reviews
16:12:24 <bauzas> #action bauzas to create an blueprints etherpad for next week
16:13:05 <bauzas> #info as a reminder, Feature Freeze is Aug 31.
16:14:00 <bauzas> oh and the week before, there is a non-client libs freeze
16:14:45 <bauzas> so, if you work on a feature and you need to modify either os-vif or say os-traits, you need your library patch to be merged before Aug 24.
16:15:10 <bauzas> I'll try to mark in the etherpad if some series requires a library modification
16:15:18 <sean-k-mooney> ack
16:15:26 <bauzas> that's it for me, anything people wanting to discuss ?
16:15:42 <sean-k-mooney> jsut wanted to highlight
16:15:53 <sean-k-mooney> the thread on EM and the governace patches
16:16:02 <sean-k-mooney> if you have not read them then you proably should
16:16:16 <elodilles> ++
16:16:29 <sean-k-mooney> "[all][tc] Proposals for reforming extended maintenance" is the subject line
16:16:47 <bauzas> good poinr
16:17:01 <gmann> and this is etherpad we will use to brainstrom #link https://etherpad.opendev.org/p/openstack-exteneded-maintenance
16:17:03 <bauzas> the TC will discuss this topic today during their meeting
16:17:07 <gmann> yeah
16:17:22 <bauzas> but unfortunately, can't longer attend the TC meetings due to personal time conflicts :(
16:17:28 <sean-k-mooney> ack im interested but progbaly wont have time to attend
16:17:41 <sean-k-mooney> but i will try and read over the outcome/summery
16:17:48 <bauzas> like everyone :)
16:18:12 <bauzas> I mean, this meeting time isn't convenient for both Asian and European folks, but I'm done saying it :)
16:18:37 <bauzas> moving on ?
16:18:55 <bauzas> looks so
16:19:02 <bauzas> #topic Review priorities
16:19:08 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+(label:Review-Priority%252B1+OR+label:Review-Priority%252B2)
16:19:12 <bauzas> #info As a reminder, cores eager to review changes can +1 to indicate their interest, +2 for committing to the review
16:19:17 <bauzas> #topic Stable Branches
16:19:27 <bauzas> elodilles: showtime !
16:19:34 <elodilles> yepp
16:19:39 <elodilles> so, my part:
16:19:45 <elodilles> #info stable gates should be OK from stable/xena to stable/train
16:19:56 <elodilles> #info stable gate of stable/2023.1 -> stable/yoga mostly broken due to nova-lvm (https://bugs.launchpad.net/nova/+bug/2025813) + nova-ceph-multistore job issue
16:20:03 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:20:24 <elodilles> that's all from me
16:21:00 <bauzas> ok, let me continue
16:21:08 <bauzas> #info train-eol patch proposed https://review.opendev.org/c/openstack/releases/+/885365
16:21:15 <bauzas> reviews welcome
16:21:35 <bauzas> we said that the EM discussion shouldn't impact our train EOL :)
16:22:59 <bauzas> at least I'd appreciate if some cores could +1 again
16:23:13 <bauzas> auniyal: you had other items I presume ?
16:23:24 <auniyal> yes bauzas, there are hardly any new reviews for stable branches
16:23:24 <sean-k-mooney> ack, for what its worth i noticed os-vifs train gate is failing due to devestack-gate issues
16:23:39 <auniyal> #info Please review these backport patches of stable 2023.1, zed and yoga for next minor release
16:23:48 <auniyal> #info most of these already have one +2.
16:23:50 <bauzas> ack
16:23:52 <sean-k-mooney> works fine on ussuri but i dont have any interest in actully fix devstack-gate issue/zull v2 legacy jobs
16:24:19 <auniyal> #link https://etherpad.opendev.org/p/release-liaison-PatchesToReview
16:24:29 <auniyal> thats all from my side, thanks
16:24:54 <elodilles> sean-k-mooney: if we are EOL'ing train, then it not even worth fixing os-vifs train i guess
16:24:58 <bauzas> cool and thanks
16:25:14 <bauzas> elodilles: I'm EOLing os-vif in my own patch
16:25:30 <elodilles> exactly why i say this :)
16:25:54 <bauzas> okay, I guess we're done with discussing stable branches
16:26:05 <sean-k-mooney> yep i know i was just rebasing https://review.opendev.org/c/openstack/os-vif/+/841780
16:26:06 <bauzas> #topic Open discussion
16:26:16 <sean-k-mooney> yesterday and notice it broken on train but not ussuri
16:26:22 <bauzas> #undo
16:26:22 <opendevmeet> Removing item from minutes: #topic Open discussion
16:26:23 <sean-k-mooney> but if we old train i dont need to care
16:26:29 <sean-k-mooney> so we can move on
16:26:48 <bauzas> sean-k-mooney: if you want some patch to be merged in train before we eol, please -1 my releases patch
16:27:04 <sean-k-mooney> its not merged on seve newer branches
16:27:11 <sean-k-mooney> so i dont wnat to hold it up
16:27:14 <bauzas> I just provided the existing master SHA1s for each of the projects
16:27:31 <bauzas> that means that any new merged patch wouldn't be in the eol tag
16:27:47 <sean-k-mooney> thats ok we have not merged anything since then
16:27:50 <sean-k-mooney> and i dont expect too
16:28:10 <bauzas> elodilles: btw. do we have a CI job that tests this and say "eh, look, you want to tag with this sha1, but I see some other patch above, so -1"
16:28:10 <elodilles> (sean-k-mooney: i propsed a gate fix patch 2 yrs ago: https://review.opendev.org/c/openstack/os-vif/+/807839 :D )
16:28:22 <sean-k-mooney> ...
16:28:35 <sean-k-mooney> ok well then we coudl fix it or just not
16:29:10 <elodilles> bauzas: no, there's no such check, but i ussually check it myself
16:29:31 <elodilles> bauzas: though it could be added to relmgmt tools, yes
16:29:34 <sean-k-mooney> i dont really want to delay the eol process but we can discuss this after the meeting
16:29:37 <bauzas> okay
16:30:02 <bauzas> sean-k-mooney: I need to drop quickly after the meeting, but sure I let you to discuss this with elodilles
16:30:08 <sean-k-mooney> ack
16:30:14 <elodilles> bauzas: and the branch removal script checks if we have patches on top of the EOL tag (but anyway, we cannot modify the tag)
16:30:45 <bauzas> elodilles: okay, so I'll probably double-check the train branches before we eventually +W
16:30:47 <elodilles> bauzas: no need, we can continue after the meeting with sean-k-mooney
16:30:52 <bauzas> cool
16:30:54 <bauzas> moving on
16:30:57 <bauzas> #topic Open discussion
16:31:04 <bauzas> (agenda empty)
16:31:16 <bauzas> oh, actually, there is one
16:31:47 <bauzas> I'll be off between Tues Aug 1 and Friday Aug 25
16:32:15 <bauzas> so someone needs to be leading the nova meeting in between Aug 1 and Aug 22
16:32:23 <bauzas> who wants to do it ? :)
16:32:35 <gibi> I can do the meeting on 15 and 22
16:32:47 <bauzas> gibi: appreciated
16:32:53 <gibi> I'm also off on 1 and 8
16:33:27 <bauzas> ack so we'll see next week
16:33:37 <bauzas> either someone proposes or we drop Aug 1 and 8 meetings
16:33:48 <gibi> ack
16:33:50 <bauzas> that was it for me
16:34:12 <bauzas> as every week, anything anyone ?
16:34:17 <gibi> -
16:34:35 <elodilles> -
16:35:13 <bauzas> cool
16:35:20 <bauzas> I give you all 25 mins back of your time !
16:35:24 <gibi> thanks!
16:35:25 <bauzas> thanks all
16:35:28 <bauzas> #endmeeting