16:00:09 <bauzas> #startmeeting nova
16:00:09 <opendevmeet> Meeting started Tue Oct  3 16:00:09 2023 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:09 <opendevmeet> The meeting name has been set to 'nova'
16:00:19 <bauzas> sorry guys, meeting by now
16:00:31 <elodilles> o/
16:00:35 <bauzas> atmark: I can also help you once we're done with the meeting, shall be quick
16:00:35 <dansmith> o/
16:00:50 <bauzas> heya folks
16:00:59 <opendevreview> Merged openstack/nova master: Add job to test with SQLAlchemy master (2.x)  https://review.opendev.org/c/openstack/nova/+/886230
16:01:08 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:01:38 <gibi> o/
16:01:42 <bauzas> ok, I guess we can start
16:01:50 <bauzas> #topic Bugs (stuck/critical)
16:01:58 <Uggla> o/
16:02:04 <bauzas> #info No Critical bug
16:02:04 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 44 new untriaged bugs (-1 since the last meeting)
16:02:04 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:02:10 <bauzas> gibi: happy with triaging some bugs ?
16:02:29 <bauzas> or do you want to skip it given your other prios ?
16:03:27 <gibi> bauzas: I can try
16:03:47 <bauzas> gibi: no worries, as I always say, it's a stretch goal, best-effort
16:04:12 <bauzas> and fwiw, in general when it's me, the number of bugs is raising :blushes: :facepalm:
16:04:31 <bauzas> but thanks, appreciated given the known situation
16:04:39 <bauzas> #info bug baton is gibi
16:04:43 <bauzas> moving on
16:04:47 <bauzas> #topic Gate status
16:04:52 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:04:56 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:05:02 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:05:04 <bauzas> all greens
16:05:08 <bauzas> nothing I spotted
16:05:26 <bauzas> that's a silent week and I appreciate it :)
16:05:41 <bauzas> any CI failures you guys spotted N?
16:06:03 <bauzas> (doh about the N?, thanks french keyboard layout)
16:06:23 <bauzas> looks nothing ditto
16:06:28 <bauzas> that's cool \o/
16:06:38 <bauzas> #topic Release Planning
16:06:45 <bauzas> #link https://releases.openstack.org/caracal/schedule.html
16:07:03 <bauzas> #info Nova deadlines aren't set yet until we agree on them at the PTG
16:07:11 <bauzas> #info Bobcat GA planned tomorrow
16:07:18 <bauzas> mostly a FYI
16:07:40 <bauzas> #info Specs can be reproposed for 2024.1 Caracal timeframe
16:07:55 <bauzas> I've been a round of reviews but I still need to do my homework on some
16:08:05 <bauzas> I've been doing*
16:08:13 <bauzas> (with the verb, it's better)
16:08:35 <bauzas> #info Caracal-1 milestone in 6 weeks
16:08:42 <bauzas> I don't expect any deadline around caracal-1 so hold my beer
16:09:24 <sean-k-mooney> well
16:09:47 <sean-k-mooney> the only "deadlien" we really had around m1 ins the past was a gentil
16:09:56 <sean-k-mooney> encurrament to please have your specs ready for review
16:10:10 <bauzas> yeah, for sure, good point
16:10:16 <sean-k-mooney> because many are on PTO for a lot of the time between m2 and m1
16:10:28 <sean-k-mooney> so prehaps not a deadline
16:10:34 <sean-k-mooney> but i do want to do a spec review day
16:10:35 <bauzas> once we agree on the deadlines, be sure I'll probably tell this
16:10:44 <bauzas> yeah, sure too
16:10:46 <sean-k-mooney> somewhere between m1 and decemeber 13th ish
16:10:50 <bauzas> fwiw, I started looking at some specs
16:11:03 <bauzas> but we can align ourselves on a review day, this is helpful
16:11:12 <bauzas> and yeah about the calendar
16:11:22 <sean-k-mooney> when is m1 this release
16:11:27 <bauzas> for some unexpected reason, people leave around Christmas period, doh.
16:11:31 * sean-k-mooney has not looked at the schedule yet
16:11:52 <bauzas> C-1 is mid-Nov
16:11:58 <sean-k-mooney> ack
16:12:11 <bauzas> C-2 is the second week of January
16:12:32 <sean-k-mooney> so like m-1 + 4 weeks is when we should try to get most specs reviewd and landed by
16:12:43 <bauzas> so yeah, basically, it would be appreciated if specs could be written in advance of the XMas period
16:12:46 <sean-k-mooney> m-2 is very early in jan ya
16:13:00 <bauzas> sure, and that's one of the topics we already have in the PTG etherpad :)
16:13:09 <sean-k-mooney> cool
16:13:38 <bauzas> anyway, yeah, people can propose anytime they want, the sooner the better
16:13:55 <bauzas> but we'll clarify that after PTG
16:14:13 <bauzas> this actually goes well as a good transition
16:14:16 <bauzas> #topic Caracal vPTG planning
16:14:23 <bauzas> #info Sessions will be held virtually October 23-27
16:14:30 <bauzas> #info Register yourselves on https://ptg2023.openinfra.dev/ even if the event is free
16:14:41 <bauzas> (I stupidly did it twice, heh)
16:14:55 <bauzas> #link https://etherpad.opendev.org/p/nova-caracal-ptg PTG etherpad
16:15:01 <bauzas> #info add your own topics into the above etherpad if you want them to be discussed at the PTG
16:15:07 <bauzas> time for collecting your inputs !
16:15:21 <bauzas> again, the sooner the better
16:15:43 <bauzas> the sooner we know the topics, the easiest it would be for us to organize our sessions and plan in advance the schedule
16:16:21 <bauzas> tl;dr: don't hold your thoughts, provided you care about something for Caracal
16:16:43 <bauzas> moving on
16:16:49 <bauzas> #topic Review priorities
16:16:56 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+(label:Review-Priority%252B1+OR+label:Review-Priority%252B2)
16:17:00 <bauzas> #info As a reminder, people eager to review changes can +1 to indicate their interest, +2 for asking cores to also review
16:17:16 <bauzas> I shall actually regenerate a new Gerrit dashboard with review prios
16:17:25 <bauzas> that's easy
16:18:06 <bauzas> #action bauzas to propose a Gerrit dashboard for review priorities
16:18:20 <bauzas> #topic Stable Branches
16:18:30 <bauzas> elodilles: WAAAZUUUP ?
16:18:34 <elodilles> :)
16:18:51 <elodilles> as you said, we are in a calm period, even for stable branches
16:19:01 <elodilles> i'm not aware of any broken stable gates
16:19:06 <bauzas> \o/
16:19:06 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:19:24 <elodilles> please add here issues if you find one ^^^
16:19:36 <elodilles> that's all from me
16:19:51 <auniyal> #info request to review https://review.opendev.org/q/topic:bug%252F1996732
16:19:53 <bauzas> elodilles: bobcat will become our stable branch tomorrow
16:20:16 <bauzas> elodilles: I assume with the new TC resolution that nothing happens with the other branches in terms of maintenance ?
16:20:26 <elodilles> well, 2023.2 is already open for all our repositories
16:20:48 <elodilles> and yoga was next to transition to EM in early november,
16:20:54 <bauzas> oh right, we did cut the last rc
16:21:08 <elodilles> i don't know yet what will be the new process around yoga
16:21:26 <bauzas> I need to read something at bedtime
16:21:35 <bauzas> which is the new TC resolution about EM
16:21:43 <elodilles> anyway, i suggest to release any needed yoga patches, if you have one :)
16:21:52 <bauzas> (should hopefully find sleep after that :D)
16:21:55 <bauzas> (naaah, kidding)
16:22:00 <elodilles> because in a month yoga will transition to somehwere :)
16:22:22 <gibi> :)
16:22:26 <bauzas> fwiw, I have no personal interest into yoga, in whether form it can be :)
16:23:01 <bauzas> including the real strecthing thing
16:23:28 <bauzas> except it will be our first SLURP-ish release to disappear
16:23:48 <dansmith> SLURPy?
16:23:56 <elodilles> :)
16:24:20 <bauzas> hah
16:24:45 <bauzas> anyway, that questions me about the future of non-SLURP releases if the precedent SLURP release goes EOL
16:24:51 <auniyal> bauzas  few from my end ... \o
16:25:06 <bauzas> surely people can non-skip releases, so it can exist
16:25:19 <bauzas> but its interest reduces
16:25:21 <sean-k-mooney> well each reasle is supported for 18 months
16:25:27 <bauzas> auniyal: you're next in the pipe
16:25:28 <sean-k-mooney> and non slurps are drop after that
16:25:38 <auniyal> ack thakns
16:25:43 <auniyal> sean-k-mooney there is a backport patch for stable/zed https://review.opendev.org/c/openstack/nova/+/885344 created by gibi
16:25:46 <sean-k-mooney> only slurps can move form stable/x to unmained/x
16:25:56 <auniyal> its for anti-affinity check count,  can you please review this .
16:26:02 <bauzas> anyway, not a question we shall discuss here, mostly a TC-wide question
16:26:03 <sean-k-mooney> so the current stables got granfatherd in
16:26:06 <auniyal> I am asking you because you had reviewed it for master and its merged in master.
16:26:14 <sean-k-mooney> there is a section in the tc doc for that
16:26:15 <auniyal> it's created till ussuri, if its alright can you please approve them as well. thanks  :)
16:26:24 <sean-k-mooney> so zed is still ok to have patches merged
16:26:35 <bauzas> ok, anuyal, I guess it's your turn now
16:26:35 <JayF> sean-k-mooney: ++ that matches my understanding
16:26:49 <auniyal> :(
16:26:57 <sean-k-mooney> we should however do a review of the old stable branches and determin if they are healty
16:27:02 <sean-k-mooney> liek we are ment to do for unstable
16:27:27 <bauzas> sean-k-mooney: yeah, sounds an idea
16:27:36 <auniyal> bauzas added already thats all from me
16:27:36 <sean-k-mooney> that specific patch seams to have passed ci so i hope that means zed is healty
16:27:37 <bauzas> because we EOLd Train with pain
16:28:01 <bauzas> and I would want us to be a little more aggresive in terms of cleanup :)
16:28:22 <sean-k-mooney> i would have to check the resolution but i think everyting pre Wallaby should be removed under the propsal
16:28:31 <sean-k-mooney> but i dont recall off the top of my head
16:29:03 <sean-k-mooney> https://github.com/openstack/governance/blob/master/resolutions/20230724-unmaintained-branches.rst#transition
16:29:13 <sean-k-mooney> he last 3 active Extended Maintenance branches are automatically transitioned to Unmaintained branches.
16:29:49 <elodilles> ++
16:29:56 <sean-k-mooney> so thats W,X,Y
16:30:08 <sean-k-mooney> unless im off by one which i could be
16:30:14 <elodilles> (this is the merged resolution: https://governance.openstack.org/tc/resolutions/20230724-unmaintained-branches.html )
16:30:49 <sean-k-mooney> so we dont need to fully figure this out now
16:31:09 <bauzas> as I said, I need to do bedtime readings
16:31:20 <bauzas> nothing urges
16:31:22 <sean-k-mooney> but we can prepare to EOL Ussuri and victoria and asses Wallaby
16:31:41 <elodilles> sean-k-mooney: i remember, X,W,V, hence, i'm not sure about Y :)
16:31:46 <bauzas> but yeah, EOLing up to Victoria is honestly a goal for me :)
16:32:08 <sean-k-mooney> eoling Victoria allows us to drop 18.04
16:32:12 <sean-k-mooney> form all our ci
16:32:45 <elodilles> yeah, ussuri is the last 18.04 based series
16:33:00 <sean-k-mooney> so that i think has a lot of value
16:33:12 <bauzas> yeah
16:33:18 <dansmith> why?
16:33:25 <bauzas> in terms of CI
16:33:45 <dansmith> I mean I'm fine with EOLing V but is 18.04 adding a lot of pain I'm unaware of?
16:33:56 <bauzas> if nova stops supporting ussuri, that would pull the other projects to do the same
16:34:04 <sean-k-mooney> dansmith: 18.04 is EOL form a canonical point of view
16:34:10 <sean-k-mooney> so its not entirly unsecurity patched
16:34:38 <sean-k-mooney> it went out of supprot in march this year
16:35:03 <bauzas> worth adding it into a PTG topic then
16:35:08 <dansmith> okay just for that reason, fine, I just am not aware of any actual problems
16:35:10 <bauzas> I take the action
16:35:43 <sean-k-mooney> we dont get any similar benifts again until zed
16:36:14 <dansmith> bauzas: you said this meeting would be quick
16:36:18 <bauzas> ok, moving on
16:36:20 <bauzas> and yeah
16:36:26 <sean-k-mooney> zed droped centos 8 and python 3.6
16:36:30 <bauzas> my bad, I opened a can
16:36:37 <elodilles> :D
16:36:45 <bauzas> #topic Open discussion
16:36:55 <bauzas> (nothing)
16:37:09 <bauzas> so, anything else or can I return you 23 mins of your time ?
16:37:20 <sean-k-mooney> not form me
16:37:25 <bauzas> thanks all
16:37:29 <bauzas> #endmeeting