16:00:13 <bauzas> #startmeeting nova
16:00:13 <opendevmeet> Meeting started Tue Oct 10 16:00:13 2023 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:13 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:13 <opendevmeet> The meeting name has been set to 'nova'
16:00:24 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:37 <bauzas> hello everyone, a bit busy today but let's run it quickly
16:00:40 <elodilles> o/
16:00:43 <han-guangyu> o/
16:01:03 <gmann> o/
16:01:51 <bauzas> ok, I guess we can softly start
16:02:09 <bauzas> #topic Bugs (stuck/critical)
16:02:17 <bauzas> #info No Critical bug
16:02:23 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 46 new untriaged bugs (+2 since the last meeting)
16:02:38 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:02:45 <bauzas> melwitt: around ?
16:03:23 <Uggla> o/
16:04:11 <gibi> o~
16:04:31 <gibi> I did not manage to look at bugs. Sorry
16:05:46 <bauzas> np
16:07:16 <bauzas> okay let's continue
16:08:24 <bauzas> #info bug baton is melwitt
16:08:29 <bauzas> #info https://bugs.launchpad.net/nova/+bug/2026345 failed for nova few times.
16:09:46 <bauzas> #topic Gate status
16:10:24 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:10:31 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:11:01 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:11:53 <bauzas> anything to discuss ?
16:12:19 <bauzas> looks not
16:12:24 <bauzas> #topic Release Planning
16:12:29 <bauzas> #link https://releases.openstack.org/caracal/schedule.html
16:12:34 <bauzas> #info Nova deadlines are not yet defined and will be once the PTG happens
16:12:37 <bauzas> #info Caracal-1 milestone in 5 weeks
16:12:49 <bauzas> again, any questions so far ,
16:12:51 <bauzas> ?
16:13:12 <sean-k-mooney> nope
16:13:32 <bauzas> continuing so
16:13:37 <bauzas> #topic Caracal vPTG planning
16:13:40 <bauzas> #info Sessions will be held virtually October 23-27
16:13:44 <bauzas> #info Register yourselves on https://ptg2023.openinfra.dev/ even if the event is free
16:13:47 <bauzas> #link https://etherpad.opendev.org/p/nova-caracal-ptg PTG etherpad
16:13:51 <bauzas> #info add your own topics into the above etherpad if you want them to be discussed at the PTG
16:13:55 <bauzas> that's it
16:14:12 <bauzas> we already have a few topics, thanks folks who added them
16:14:20 <bauzas> but please continue to add some if you want
16:14:27 <bauzas> #topic Review priorities
16:14:35 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+(label:Review-Priority%252B1+OR+label:Review-Priority%252B2)
16:14:38 <bauzas> #info As a reminder, people eager to review changes can +1 to indicate their interest, +2 for asking cores to also review
16:15:00 <bauzas> I said I was about to propose a Gerrit dashboard for those, I had no time yet to do it
16:15:08 <bauzas> #action bauzas to propose a Gerrit dash
16:15:15 <bauzas> #topic Stable Branches
16:15:20 <bauzas> elodilles: ?
16:15:24 <elodilles> yepp
16:15:32 <elodilles> i'm not aware of any gate issue
16:15:41 <elodilles> otherwise nothing else to report
16:15:48 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:16:09 <elodilles> please add stable gate issues if you see any ^^^
16:16:14 <bauzas> ++
16:16:22 <elodilles> that's all from me
16:17:19 <bauzas> cool
16:19:19 <bauzas> #topic Open discussion
16:19:24 <bauzas> (bauzas) Specless blueprint approval for https://blueprints.launchpad.net/nova/+spec/aggregatemultitenancyisolation-to-support-unlimited-tenant
16:20:23 <sean-k-mooney> hum
16:20:42 <bauzas> wdyt about that ?
16:21:06 <sean-k-mooney> dont we support having multiple keys
16:21:18 <sean-k-mooney> so i didnt think there was an effective limit today
16:22:46 <sean-k-mooney> or parhaps we require one aggreate per tenatnt today i would have to review the code
16:23:10 <sean-k-mooney> the patch is basiclly enabling what i orgianlly tought already worked
16:23:22 <sean-k-mooney> instead of looking for filter_tenant_id explictly
16:23:28 <sean-k-mooney> just making that a prefix
16:24:00 <sean-k-mooney> so you can have filter_tenant_id=<tenant-0> filter_tenant_id_1=<tenant-1>
16:24:30 <sean-k-mooney> thats proably an ok change to make
16:24:58 * dansmith stumbles in late
16:25:35 <sean-k-mooney> tenant isolation shoudl be done via placement
16:25:45 <sean-k-mooney> and we shoudl really be removing the filter based approch so im not sure
16:27:16 <bauzas> sahid wanted to still use the filters
16:27:53 <sean-k-mooney> i would be in favor of deprecateding it for removal in D if  the current fucntionlaiy is supproted by the placment approch
16:28:41 <sean-k-mooney> https://docs.openstack.org/nova/latest/admin/aggregates.html#tenant-isolation-with-placement
16:28:47 <dansmith> tenant isolation can't be done entirely in placement right?
16:28:55 <bauzas> I think sahid actually wanted to backport this
16:28:57 <sean-k-mooney> i belive it can
16:29:02 <dansmith> all we can do is select an aggregate and then get placement to limit for us
16:29:14 <bauzas> you know what ? we can punt this until he can be around
16:29:33 <sean-k-mooney> so given this dicussion i would say not a specless blueprint
16:29:40 <sean-k-mooney> spec or ptg discussion
16:29:41 <dansmith> right
16:30:48 <sean-k-mooney> i think the fucntionaliyt is possible today withthe placement approch so i would question why we dont remove the filter
16:30:59 <sean-k-mooney> so i would like to capture the answer to  that
16:31:51 <bauzas> okay, let's say this
16:31:57 <bauzas> I'll tell this to sahid tomorrow
16:32:12 <bauzas> and he could explain why he still wants to use filters
16:32:20 <bauzas> (IMHO like I said, backports)
16:32:39 <bauzas> do all agree ?
16:32:44 <sean-k-mooney> backports are a downstream problem
16:33:01 <bauzas> sure, but this is easier with a python module like a filter, right?.
16:33:03 <sean-k-mooney> that is not a good reason to extend it upstream unless its useful upstream
16:33:21 <bauzas> sure, we need to discuss the usecases
16:33:33 <bauzas> but I'm not in favor of removing every single filter we have
16:33:44 <dansmith> agree
16:33:44 <bauzas> some operators still run filters on their choices
16:34:17 <bauzas> anyway, let's punt this until PTG or when sahid can join us
16:34:26 <dansmith> we have the prefilter for isolation, which uses placement's aggregates to do some isolation, but I'll have to revisit my understanding of the differences
16:34:31 <bauzas> #agreed defer this agreement to the next PTG
16:34:49 <bauzas> I'll add a topic in the PTG etherpad
16:34:55 <sean-k-mooney> dansmith: we deveoped that prefilter to eventurlly remove this one
16:36:07 <sean-k-mooney> https://specs.openstack.org/openstack/nova-specs/specs/rocky/implemented/placement-req-filter.html#proposed-change
16:36:43 <bauzas> sean-k-mooney: well, for CPUFilter, I totally agree with removing it
16:36:47 <sean-k-mooney> this was the first prefilter that you wote many moons ago
16:37:24 <bauzas> I'm just saying that for non-allocatable filters (placing things) we may leave those if those are cheap to maintain
16:37:41 <sean-k-mooney> right but this filter is know to be problematic
16:37:42 <bauzas> because this is a python module and not another SQL query
16:37:54 <sean-k-mooney> so i realy dont think this is a good example ot extned
16:37:55 <dansmith> sean-k-mooney: I know, but I think there were limitations
16:38:18 <bauzas> anyway, we punted the potential agreement to the next PTG
16:38:21 <dansmith> I thought we agreed to punt until PTG ?
16:38:22 <dansmith> yeah
16:38:30 <bauzas> so let's stop for now
16:38:40 <sean-k-mooney> sure
16:38:40 <bauzas> and I'll give you all extra 20 mins of your time
16:38:42 <bauzas> thanks all
16:38:52 <bauzas> any other item before we close ?
16:39:07 <sean-k-mooney> i just wanted to highlight i reporposed the healtcheck spec https://review.opendev.org/c/openstack/nova-specs/+/897225
16:39:16 <bauzas> oh right, I've seen it
16:39:20 <sean-k-mooney> so if we can reappove that it would be good
16:39:22 <bauzas> I just need to look at it
16:39:25 <sean-k-mooney> ack
16:39:41 <sean-k-mooney> thats all from me
16:39:43 <bauzas> tuesdays are usually upstream days for me, but I was vamped into some crazy internal thing
16:39:57 <bauzas> anyway, ending now
16:40:00 <bauzas> thanks all
16:40:04 <bauzas> #endmeeting