16:01:18 <bauzas> #startmeeting nova
16:01:18 <opendevmeet> Meeting started Tue Oct 17 16:01:18 2023 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:18 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:18 <opendevmeet> The meeting name has been set to 'nova'
16:01:22 <bauzas> hey folsk
16:01:24 <dansmith> o/
16:01:27 <elodilles> o/
16:01:31 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:02:01 * bauzas is currently hit by a big bus, so I'm sorry to not be around like I should
16:02:38 <auniyal> 0/\
16:02:52 <auniyal> o/
16:02:57 <bauzas> okay, let's start
16:03:02 <bauzas> #topic Bugs (stuck/critical)
16:03:04 <bauzas> #info No Critical bug
16:03:09 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 47 new untriaged bugs (+1 since the last meeting)
16:03:15 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:03:34 <Uggla> o/
16:03:38 <bauzas> artom: you're next in the roster list, fancy trying to look at some upstream bugs ?
16:04:33 <bauzas> artom seems to be offline, let's move on and we'll see
16:04:38 <bauzas> #info bug baton is artom
16:04:40 <bauzas> #undo
16:04:41 <opendevmeet> Removing item from minutes: #info bug baton is artom
16:04:49 <artom> Eh? No I'm here
16:04:50 <bauzas> #info bug baton is tentatively artom
16:05:19 <bauzas> artom: I was just asking you whether you were happy to go looking at Launchpad
16:05:22 <artom> (to my own surprise, I should say - I've been trying a new wayland-native IRC client, and it got lost somewhere on my 9 workspaces)
16:05:47 <bauzas> trust me, this is a happy place compared to some other bug reporting tools I know
16:05:52 <artom> Yep, I'll launch all the triage pads
16:06:09 <artom> And pad all the triage launches
16:06:29 <bauzas> I give you my pad, bro
16:06:48 <bauzas> anyway, moving on
16:06:48 <artom> Pad accepted, brah
16:06:52 <bauzas> #topic Gate status
16:06:59 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:07:09 <bauzas> this was a funny week
16:07:22 <sean-k-mooney> dansmith: have you seen that grenade failure more then once
16:07:26 <bauzas> but afaict, the gate postfailure is now fixed ?
16:07:30 <dansmith> sean-k-mooney: yeah
16:07:49 <dansmith> looks like failure to ssh to the test instance though
16:07:55 <dansmith> I haven't dug in deep yet
16:08:01 <sean-k-mooney> ok so that might be another gate blocker
16:08:16 <bauzas> shit
16:08:25 <sean-k-mooney> ya it looks like an ssh issue but im not sure if its consitent or intermitant
16:08:26 <dansmith> idk, but it's blocking the fix for another blocker :)
16:08:57 <bauzas> I don't you for you folks, but I have the impression that the universe is after me
16:09:01 <sean-k-mooney> for context https://github.com/openstack/grenade/blob/master/projects/70_cinder/resources.sh#L240 is failing
16:09:40 <sean-k-mooney> but have not looked at it properly either
16:09:46 <bauzas> ack
16:10:04 <bauzas> I guess the cinder team is fully aware of the situation ?
16:10:31 <dansmith> I doubt it's a cinder problem
16:10:34 <bauzas> but since we ssh to the guest, this is our mud, right ?
16:10:43 <sean-k-mooney> if they run grenade maybe but i just saw it this morning
16:11:02 <sean-k-mooney> im logging in to opensarch to see how common it is now
16:11:08 <bauzas> and no guest console saying anything ?
16:11:35 <sean-k-mooney> again i havent debug it so im not sure
16:11:38 <dansmith> no guest console dump in grenade
16:11:41 <dansmith> that's a tempest thing
16:11:45 <dansmith> lets not debug here
16:12:27 <bauzas> I quite agree with the fact that we shouldn't debug now
16:12:31 <bauzas> moving on so
16:12:44 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:12:45 <sean-k-mooney> looks like 100 failures in the last 30 days
16:12:50 <sean-k-mooney> but ya lets move on
16:13:05 <bauzas> some reds, but the gate isn't happy those days, we'll see next week
16:13:10 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:13:58 <bauzas> #topic Release Planning
16:14:03 <bauzas> #link https://releases.openstack.org/caracal/schedule.html
16:14:07 <bauzas> #info Nova deadlines are not yet defined and will be once the PTG happens
16:14:12 <bauzas> #info Caracal-1 milestone in 4 weeks
16:14:27 <bauzas> we'll discuss about spec review days next week at the PTG
16:14:53 <bauzas> but this is a good idea to propose your specs this week or the week after, since we'll be around at the same time
16:15:11 <bauzas> message is sent, moving on
16:15:15 <bauzas> #topic Caracal vPTG planning
16:15:19 <bauzas> #info Sessions will be held virtually October 23-27
16:15:25 <bauzas> which is next week, basically
16:15:44 <bauzas> let's be honest, I'm late in terms of preparing this PTG
16:15:57 <opendevreview> Takashi Kajinami proposed openstack/nova master: Drop remaining deprecated upgrade_levels option for nova-cert  https://review.opendev.org/c/openstack/nova/+/898613
16:16:00 <bauzas> but we will already have a nova-cinder x-p session
16:16:04 <bauzas> FYI
16:16:46 <bauzas> feel free to add any cinder-related topics in the nova ptg etherpad, I'll move them to the right place in order for them to be discussed
16:16:55 <bauzas> no other PTLs came to me until now
16:17:06 <bauzas> but I guess this will come soon
16:17:38 <bauzas> I also haven't seen yet any cross-project-ish topic in the nova ptg etherpad, but if so, I'll do the liaison
16:17:51 <bauzas> #info Register yourselves on https://ptg2023.openinfra.dev/ even if the event is free
16:17:58 <bauzas> this is free, tbc.
16:18:04 <bauzas> #link https://etherpad.opendev.org/p/nova-caracal-ptg PTG etherpad
16:18:17 <bauzas> that's the etherpad I was referring to, seconds ago
16:18:22 <sean-k-mooney> we can proably just join there room if they have one or two topics
16:18:26 <bauzas> and yet the reminder
16:18:28 <bauzas> #info add your own topics into the above etherpad if you want them to be discussed at the PTG
16:18:54 <bauzas> sean-k-mooney: yeah that's the plan, the nova-cinder x-p session will be in their room
16:19:28 <bauzas> the exact timing of the nova-cinder session is already written in the etherpad (wed 5pm IIRC)
16:19:53 <bauzas> or maybe thur, my brain is playing with me
16:20:18 <bauzas> that reminds me, we shall cancel next team meeting
16:20:23 <bauzas> anybody disagrees ?
16:20:59 <bauzas> I take your silence as no
16:21:07 * sean-k-mooney nods
16:21:23 <dansmith> obvious :)
16:21:35 <bauzas> #agreed next Nova weekly meeting on Oct 24 is CANCELLED, go join the PTG instead, you'll have fun
16:21:58 * bauzas doesn't know what to do in order to incentize operators to join
16:22:12 <bauzas> I should try to joggle with balls, maybe
16:22:27 <bauzas> oh, last point
16:22:44 <bauzas> shall we run again this marvelous and succesful experience that is the operator-hour ?
16:23:23 <bauzas> I mean, I can just unbook some nova slot and officially pretend this is an operator hour
16:23:32 <dansmith> I think we should try yeah
16:23:57 <bauzas> and if nobody steps up, which would be sad and unfortunately expected, we could just consume the regular nova etherpad
16:24:20 <bauzas> okay, then I'll do the flip for tuesday 4pm
16:24:45 <bauzas> 4pm UTC allows us to get EU and US east-coast ops
16:25:15 <bauzas> and we could continue to discuss at 5pm if we really have audience and hot topics
16:25:53 <bauzas> #action bauzas to set up some operator hour, preferably Tuesday around 4pm UTC
16:26:09 <bauzas> #topic Review priorities
16:26:14 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+(label:Review-Priority%252B1+OR+label:Review-Priority%252B2)
16:26:19 <bauzas> #info As a reminder, people eager to review changes can +1 to indicate their interest, +2 for asking cores to also review
16:26:43 <bauzas> yet again, taking the action to propose a Gerrit dash, once I'll have 5 mins of my time for doing this easy peasy
16:26:53 <bauzas> #topic Stable Branches
16:26:58 <bauzas> elodilles: ?
16:27:01 <elodilles> yepp
16:27:15 <elodilles> i'm not aware of any stable gate issues
16:27:31 <bauzas> the universe is smiling at me then
16:27:40 <elodilles> though nova-ceph-multistore is suspicious on stable/victoria
16:27:55 <elodilles> but need more check
16:28:02 <elodilles> otherwise gates should be OK
16:28:50 <elodilles> also, some bug fixes landed already on stable/2023.1 (antelope), so i'll propose a release patch, if that's OK for people
16:28:57 <bauzas> elodilles: thanks
16:29:10 <bauzas> elodilles: and yeah, sounds cool to me
16:29:16 <elodilles> ++
16:29:18 <elodilles> and the usual:
16:29:21 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:29:35 <elodilles> add stable gate issues there ^^^
16:29:38 <bauzas> fwiw, we'll discuss the State of Wallaby and Ussuri
16:29:41 <elodilles> if you encounter any
16:29:42 <bauzas> at the PTG*
16:29:51 <elodilles> bauzas: ACK
16:30:14 <elodilles> (wallaby, victoria, ussuri, you mean?)
16:30:38 <elodilles> anyway, we'll discuss at PTG :)
16:30:41 * bauzas doesn't know why but I always skip victoria
16:30:49 <bauzas> this is like the thanos blip
16:31:04 <bauzas> I pretend victoria never existed
16:31:34 <bauzas> elodilles: heard any other projects besides Cinder pursuing the idea to drop those releases ?
16:32:10 <elodilles> bauzas: well, some projects have eol'd their xena already
16:32:19 <elodilles> bauzas: let me check quickly
16:32:25 <bauzas> see, the ship has sailed then
16:32:35 <bauzas> should be a very quick discussion at the PTG then
16:32:55 <elodilles> kolla & magnum, otherwise i think projects are quiet about it yet
16:33:36 <elodilles> so no other projects yet
16:33:59 <bauzas> okay, we'll see at the PTG
16:34:03 <elodilles> +1
16:34:09 <bauzas> thanks
16:34:19 <elodilles> ++
16:34:20 <bauzas> #topic Open discussion
16:34:33 <bauzas> I have nothing in the wikipage
16:34:39 <bauzas> anything anyone ?
16:35:06 <bauzas> looks not
16:35:18 <bauzas> have a good day everyone and thanks all
16:35:22 <bauzas> #endmeeting