16:00:26 <bauzas> #startmeeting nova
16:00:26 <opendevmeet> Meeting started Tue Nov 14 16:00:26 2023 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:26 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:26 <opendevmeet> The meeting name has been set to 'nova'
16:00:39 <elodilles> o/
16:00:42 <bauzas> I was about to write 'startmeeting nvidia'
16:00:48 <elodilles> :S
16:00:52 <bauzas> ETOOMANYTHINGS
16:00:53 <dvo-plv> o/
16:01:05 <elodilles> someone spend too much time with nvidia things? :-o
16:01:07 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:01:18 <bauzas> elodilles: probably me, but who guesses ?
16:01:22 <elodilles> :)
16:02:03 <gibi> o/
16:02:11 <dansmith> o/
16:02:12 <bauzas> let's start
16:02:19 <bauzas> and let's be quick
16:02:26 <bauzas> #topic Bugs (stuck/critical)
16:02:30 <bauzas> #info No Critical bug
16:02:34 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 32 new untriaged bugs (+0 since the last meeting)
16:02:37 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:02:55 <bauzas> elodilles: anything you want to tell about bugs ?
16:03:00 <elodilles> (damn, it was 31 one hr ago..)
16:03:06 <elodilles> nothing to tell
16:03:12 <bauzas> cool
16:03:16 <elodilles> had little time to deal with bugs :/
16:03:33 <bauzas> auniyal6: want to be the next for triaging ?
16:04:45 <bauzas> okay, given his TZ, he's probably off
16:04:57 <bauzas> no worries at all, will discuss with him later tomorrow
16:05:42 <bauzas> #info bug baton may be auniyal
16:05:48 <bauzas> #topic Gate status
16:05:53 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:05:57 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:06:02 <bauzas> periodics are green
16:06:06 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:06:19 <bauzas> dansmith: what's up with the grenade vnc failure ?
16:06:27 <dansmith> long since fixed?
16:06:31 <dansmith> because melwitt
16:06:33 <bauzas> \o/
16:06:57 <bauzas> okay, so, no other gate issues we just discovered this week ?
16:07:09 <tkajinam> o/
16:07:30 <tkajinam> this is not new... but as you may now the earlier issue with sqlalchemy 2.0 job has been fixed and it should be green now
16:07:40 <tkajinam> so we can merge https://review.opendev.org/c/openstack/nova/+/900538 to make the job voting again
16:08:06 <bauzas> tkajinam: ahah, good time for telling this, we're on a meeting and we discuss about CI failures :)
16:08:07 <tkajinam> (which is waiting for 2nd +2
16:08:25 <tkajinam> yeah I saw it and that's why I jumped in here ;-)
16:08:32 <bauzas> tkajinam: sent to the gate
16:08:50 <tkajinam> thanks !
16:09:21 <bauzas> tkajinam: perfect timing ! ;-)
16:09:21 <bauzas> anyway, anything else to say about failures ?
16:09:34 <bauzas> looks not
16:09:36 <bauzas> #topic Release Planning
16:09:40 <bauzas> #link https://releases.openstack.org/caracal/schedule.html
16:09:44 <bauzas> #info Nova deadlines will be proposed in the schedule above
16:09:50 <bauzas> ... once I have time :)
16:09:54 <bauzas> #info Caracal-1 milestone this week
16:10:04 <bauzas> I also need to look at my gerrit emails :)
16:10:22 <bauzas> elodilles: have we already a release change for it ?
16:10:32 * bauzas goes looking at Gmail
16:10:32 <elodilles> changes were generated yes
16:10:36 <elodilles> let me look
16:11:15 <bauzas> os-vif is proposed https://review.opendev.org/c/openstack/releases/+/900762?usp=email
16:11:17 <elodilles> and as i see there's no nova related caracal-1 release
16:11:21 <bauzas> but I don't see nova in my mailbox
16:11:58 <bauzas> elodilles: cool, will check emails later
16:12:07 <bauzas> so, something else
16:12:26 <bauzas> I wrote 2 weeks before that today is an implementation review day
16:12:30 <bauzas> of course, I forgot about it
16:12:39 <elodilles> bauzas: btw, you told some time ago that we could release beta/milestone releases off nova. do you want me to propose a patch for that?
16:12:52 <bauzas> so, would people agree with us having an implementation review day tomorrow ?
16:13:44 <dansmith> bauzas: ++
16:13:49 <bauzas> elodilles: what have I said ?
16:13:54 <elodilles> :)
16:14:12 <bauzas> I mean, I can surely propose a m-1 release change if nobody does this
16:14:39 <elodilles> for cycle-with-rc (like nova) release team does not generate release patches
16:14:40 <bauzas> that said, I don't know how many people use that tag tbh
16:14:49 <bauzas> doh my bad
16:14:53 <bauzas> then I'll do my duty
16:15:25 <elodilles> bauzas: i'm just asking :) maybe i misheard something :)
16:15:54 <bauzas> I honestly can't remember anything, apart the fact I think noone is using milestone-1 tag
16:15:59 <bauzas> milestone-3 for sure
16:16:17 <bauzas> but the first two ones are just there for nothing :)
16:16:22 <elodilles> OK, then i'll wait for Caracal-3 :)
16:16:33 <elodilles> ACK :)
16:16:51 <elodilles> sorry for the noise :X
16:16:58 <bauzas> nah, I'll create caracal-1 and caracal-2 because creating a tag named "caracal-3" alone would be super bizarre, right ? :D
16:17:25 <bauzas> we're not Microsot
16:17:31 <bauzas> Microsoft*
16:17:36 <bauzas> anyway
16:17:42 <bauzas> #action bauzas to propose caracal-1 tag
16:17:51 <bauzas> #undo
16:17:51 <opendevmeet> Removing item from minutes: #action bauzas to propose caracal-1 tag
16:17:57 <bauzas> #action bauzas to propose caracal-1 tag for nova and placement
16:17:57 <elodilles> (it won't be caracal-3, it'll be 29.0.0.0b1 ;))
16:18:28 <bauzas> I'm lost and don't have a lot of time, but I trust you
16:18:37 <bauzas> anyway, thanks for asking
16:18:50 <elodilles> np
16:18:51 <bauzas> so, back on track
16:19:09 <bauzas> I heard dansmith saying yay for tomorrow being implementation review day
16:19:15 <bauzas> who else nays ?
16:19:59 <gibi> yay from me
16:20:10 <gibi> at least I can add implementation to review :)
16:20:18 <bauzas> cool
16:20:21 <dansmith> heh
16:20:27 <gibi> https://review.opendev.org/q/topic:bp%252Flibvirt-migrate-with-hostname-instead-of-ip
16:20:33 <dansmith> I admit I'm biased since I just pushed an implementation _to_ review :P
16:20:40 <bauzas> #agreed Tomorrow (Nov 15) will be implementation review day
16:20:42 <gibi> same here :)
16:21:21 <bauzas> #action bauzas to create an etherpad for tracking features and bugs like we agreed at PTG, so it would be used tomorrow
16:21:25 <sean-k-mooney> well any review that are rety can be reviewd including they ones you just pushed so
16:21:39 <bauzas> I too much punted that action item
16:22:07 <bauzas> #action bauzas to notify by email about both the implementation review day and the etherpad to use
16:22:18 <bauzas> the email will be late today for sure
16:23:22 <bauzas> #topic Review priorities
16:23:32 <bauzas> #action bauzas need to create the etherpad he just said above
16:23:41 <bauzas> #topic Stable Branches
16:23:46 <bauzas> elodilles: I'm all ears
16:23:53 <elodilles> o7
16:24:02 <elodilles> #info stable gates don't seem blocked
16:24:20 <elodilles> i've seen some failing jobs but nothing constantly failing...
16:24:34 <elodilles> (or I'm not aware of it)
16:24:41 <elodilles> #info stable release patches still open for review: https://review.opendev.org/q/project:openstack/releases+is:open+intopic:nova
16:24:53 <elodilles> +1: yoga is going to be unmaintained, so final stable/yoga release should happen ASAP - https://etherpad.opendev.org/p/nova-stable-yoga-eom
16:25:34 <elodilles> if we want to do a final release at all
16:26:01 <bauzas> that's a need
16:26:08 <elodilles> otherwise we can just live with the last release from summer(?)
16:26:20 <bauzas> elodilles: nah, I'd prefer we do some release
16:26:31 <bauzas> elodilles: bug me this week or next week
16:26:37 <elodilles> now we have 1 merged patch as can be seen in the etherpad
16:26:50 <bauzas> I guess you know that I'm busy, so I'll forget if nobody harasses me
16:27:11 <elodilles> bauzas: i'll ping you then some time
16:27:18 <bauzas> thanks
16:27:31 <elodilles> the open patches are also listed on the etherpad
16:27:40 <bauzas> I'm unfortunately not very good at doing multiple things at the same time
16:27:42 <elodilles> feel free to use the pad, edit it if you want
16:27:50 <bauzas> like, my mind is not good for concurrency
16:28:46 <elodilles> i'll try to add details to the pad so that will be easier to reviewers to look at 'things-to-be-reviewed'
16:28:54 <bauzas> ack
16:29:01 <elodilles> anyway, last but not least:
16:29:04 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:29:25 <elodilles> add stable gate issues here if you find one ^^^
16:29:36 <elodilles> and that was all from me
16:30:08 <bauzas> cool
16:30:13 <bauzas> last topic
16:30:19 <bauzas> #topic open discussion
16:30:22 <bauzas> anything anyone ?
16:30:26 <dvo-plv> o/ In the open discussion topic I would like to remind about ability to reviwe this cool spec file:) https://review.opendev.org/c/openstack/nova-specs/+/895924/8
16:30:35 <dvo-plv> Sorry, I forgot to fill agenda with this
16:30:43 <sean-k-mooney> i have two related things we we can talk about after ^
16:31:40 <sean-k-mooney> dvo-plv: if dansmith and bauzas feel stronly that the tait is not required and want to use a min compute service check instead i can relent on that
16:32:00 <sean-k-mooney> but you will need to modify the spec to say that the feature will only work when its fully upgraded
16:32:20 <sean-k-mooney> bauzas: dansmith ^ is that still your prefernce
16:32:39 <dansmith> I have never been super opinionated about it.. I'm pretty meh all around
16:32:50 <dvo-plv> i beleive that we alreadt agreed with trait usage
16:32:52 <dansmith> I still feel like a trait is just too much work for such a thing
16:33:13 <dvo-plv> I added upgrade impact https://review.opendev.org/c/openstack/nova-specs/+/895924/8/specs/2024.1/approved/virtio_packedring_configuration_support.rst#126
16:33:33 <sean-k-mooney> dvo-plv: is this what you wanted to discuss by the way
16:33:43 <sean-k-mooney> i want to make sure we have a path to unblocking you
16:34:27 <dvo-plv> yes, I also want a path to unblock this feature and i thought that nova core already agreed with that
16:34:41 <dvo-plv> so I've updated spec and nova code
16:34:46 <sean-k-mooney> im fine with the trait i assuemd that was the only open
16:34:54 <sean-k-mooney> i can re review the new version of the spec
16:35:02 <bauzas> I think I said loudly a couple of times that I eventually give up
16:35:18 <bauzas> so, I let other cores accept using traits
16:36:04 <bauzas> my only concern is that I just want to make sure nobody would use that trait in a flavor so we could eventually remove it if we want, but given I won't review the spec, I leave others to say what they want
16:36:47 <dvo-plv> I suggest to add thi item somewhere regarding trait usage
16:37:09 <dvo-plv> but it does not required as far as it will assigned automatically
16:37:45 <dvo-plv> https://review.opendev.org/c/openstack/nova/+/876075/27/nova/scheduler/request_filter.py#275 here for instance
16:38:08 <dvo-plv> https://review.opendev.org/c/openstack/nova/+/876075/27/nova/virt/libvirt/driver.py#12429 here for node
16:40:33 <sean-k-mooney> so can i suggest we take a look at this (the spec and the implematnion) tomorrow n the implemation review day
16:40:37 <sean-k-mooney> for those that are interested
16:40:58 <bauzas> I am not but that's a good idea
16:41:24 <bauzas> anyway, can we end the meeting now ?
16:41:34 <sean-k-mooney> i would like to add 2 thigns quickly
16:41:42 <sean-k-mooney> https://blueprints.launchpad.net/nova/+spec/remove-hyperv-driver and https://blueprints.launchpad.net/nova/+spec/remove-vmware-support
16:42:00 <sean-k-mooney> are we ok to appove those or would you like use to expeand the description with more details
16:42:35 <bauzas> I think gmann wrote specs
16:42:45 <sean-k-mooney> yes which they abandoned
16:42:51 <bauzas> okay
16:42:55 <sean-k-mooney> because multiple of us said it was not requried
16:42:58 <bauzas> so we need to review both blueprints in a meeting
16:43:04 <bauzas> yeah, including me
16:43:11 <dvo-plv> Thank you
16:43:17 <sean-k-mooney> so i just want to decied on a path forward for the paper work
16:43:21 <bauzas> but I don't wanna force someone to not write a spec if he/she really wants to :)
16:43:22 <sean-k-mooney> if we want to review them next week we can
16:43:37 <sean-k-mooney> but i would like to merge the first patches for the removal sooner rather then later
16:43:38 <bauzas> sure
16:43:44 <bauzas> and sure
16:43:58 <sean-k-mooney> bauzas: i was orgianlly hoping ot merge the vmware removal patch tomorrow in the implemation day
16:44:02 <sean-k-mooney> but it can wait
16:44:12 <bauzas> then, we can approve those today
16:44:15 <bauzas> folks,
16:44:32 <bauzas> anyone having concerns with https://blueprints.launchpad.net/nova/+spec/remove-hyperv-driver as a specless BP for one ?
16:46:26 <sean-k-mooney> im fine with that. for the vmware one i do have more patches ill need to write to complete the removal but the inital patch https://review.opendev.org/c/openstack/nova/+/897017 is the entirty of the driver removal. i need to remove the console and objects in follow up patches
16:46:38 <bauzas> okay, so
16:46:52 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/remove-hyperv-driver to be accepted as a specless bp
16:46:57 <bauzas> next one
16:47:22 <bauzas> anyone having concerns with https://blueprints.launchpad.net/nova/+spec/remove-vmware-support as a specless BP ?
16:47:59 <bauzas> sean-k-mooney: the fact that you have left things to implement is just some implementation nit
16:48:03 <bauzas> we can still approve the bp
16:48:09 <sean-k-mooney> yep
16:48:14 <bauzas> like we did with nova-net
16:48:21 <sean-k-mooney> just wanted to clarify that since we expanded the scope at the ptg
16:48:23 <bauzas> anyone having concerns again ?
16:48:33 <bauzas> okay so
16:48:50 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/remove-vmware-support to be accepted as a specless BP
16:48:54 <bauzas> there we go
16:49:11 <bauzas> sean-k-mooney: I'll just set the LP fields right after the meeting
16:49:15 <sean-k-mooney> thanks
16:49:18 <sean-k-mooney> thats all from me
16:49:23 <bauzas> and we can start to review your patches tomorrow
16:49:26 <bauzas> cool
16:49:35 <bauzas> so, let me call it a wrap
16:49:42 <bauzas> thanks all
16:49:45 <bauzas> #endmeeting