16:00:06 <bauzas> #startmeeting nova
16:00:06 <opendevmeet> Meeting started Tue Dec 19 16:00:06 2023 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:06 <opendevmeet> The meeting name has been set to 'nova'
16:00:12 <bauzas> howdy folks
16:00:21 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:49 <bauzas> who's around ?
16:01:18 <elodilles> o/
16:02:07 <bauzas> anybody else ?
16:02:29 <elodilles> looks like holiday season :)
16:02:42 <bauzas> well, yes and no :)
16:02:49 <bauzas> not for all of us yet :)
16:03:00 <gibi> o/
16:03:31 <bauzas> let's start, we'll see
16:03:38 <bauzas> #topic Bugs (stuck/critical)
16:03:44 <bauzas> #info No Critical bug
16:03:55 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 44 new untriaged bugs (+3 since the last meeting)
16:04:07 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:04:39 <bauzas> artom: could you look at some bug reports this week ?
16:05:30 <bauzas> anyway, moving on
16:05:39 <bauzas> #topic Gate status
16:05:46 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:05:52 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:06:26 <bauzas> fwiw, I haven't seen any CI failure this week
16:06:51 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:06:55 <bauzas> all greens \o/
16:07:00 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:07:06 <JayF> I've seen a couple unrelated failures this week on patches I've pushed, but the frequency I've seen on my limited sample size has been significantly reduced.
16:07:08 <bauzas> any CI failure you would want to discuss ?
16:07:13 <JayF> Thank you for the improvement \o/
16:07:30 <bauzas> JayF: cool
16:07:33 * fwiesel joins late
16:07:49 <bauzas> shall we move ?
16:08:03 <bauzas> #topic Release Planning
16:08:09 <bauzas> #link https://releases.openstack.org/caracal/schedule.html#nova
16:08:13 <sean-k-mooney> o/
16:08:15 <bauzas> #info Caracal-2 (and spec freeze) milestone in 3 weeks
16:08:21 <bauzas> we still have some open specs
16:09:24 <bauzas> so if you could review them, it would be nice : https://review.opendev.org/q/project:openstack/nova-specs+is:open+file:%5Especs/2024.1/.*
16:10:17 <bauzas> (at least mine, it would be nice :p )
16:10:56 <bauzas> as a reminder, the specs freeze deadline is on January 11 (eob)
16:11:20 <sean-k-mooney> ill do some spec reviews before i finsih up fo rthe year
16:11:26 <bauzas> ditto
16:11:34 <sean-k-mooney> ill then be back on the 8th
16:11:35 <bauzas> #topic Review priorities
16:11:49 <grandchild> o/
16:11:54 <bauzas> sean-k-mooney: as well, but let's discuss about when we're off by the last topic
16:12:04 <bauzas> I added an item about that
16:12:18 <bauzas> so, about review prios
16:12:23 <bauzas> #link https://etherpad.opendev.org/p/nova-caracal-status
16:12:32 <bauzas> I checked every item in the etherpad before the meeting
16:12:52 <bauzas> as a reminder, you can use this etherpad to know which features or bug reports to review
16:13:27 <bauzas> each of the approved bps has one item in the etherpad with the related change
16:13:43 <bauzas> and we have a few accepted prioritied bug reports
16:14:04 <bauzas> moving on
16:14:07 <bauzas> #topic Stable Branches
16:14:21 <Uggla> o/
16:14:21 <bauzas> elodilles: passing you
16:14:32 <elodilles> #info stable gates don't seem blocked
16:14:52 <elodilles> at least I'm not aware of any *constantly* failing job
16:14:59 <elodilles> #info nova stable releases are out: 2023.2 Bobcat (28.0.1), 2023.1 Antelope (27.2.0), Yoga (25.3.0)
16:15:08 <elodilles> note that there won't be more release out of stable/yoga as that branch will transition to Unmaintained
16:15:15 <elodilles> #info Zed stable release is not yet approved: https://review.opendev.org/899604
16:15:28 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:15:47 <elodilles> and that's all from me regarding stable branches
16:15:48 <bauzas> elodilles: so about yoga
16:16:04 <bauzas> I guess we would have another change for EM ?
16:16:10 <bauzas> I mean the tag
16:16:15 <elodilles> nope
16:16:21 <elodilles> it will be a different tag,
16:16:34 <elodilles> then unmaintained/yoga will be cut from that tag
16:16:45 <elodilles> (and stable/yoga branch will be deleted)
16:16:51 <bauzas> okayt
16:16:52 <elodilles> that's the plan
16:18:12 <bauzas> JayF: I can't remember, does the TC eventually accepted the unmaintained resolution ?
16:18:19 * bauzas looks at https://governance.openstack.org/tc/
16:18:31 <opendevreview> Merged openstack/nova-specs master: Re-submit Ironic-shards for Caracal  https://review.opendev.org/c/openstack/nova-specs/+/902698
16:19:09 <bauzas> I mean, what do we miss for starting to use unmaintained/yoga ?
16:19:22 * bauzas reads now https://governance.openstack.org/tc/resolutions/20230724-unmaintained-branches.html
16:19:51 <elodilles> bauzas: the automation tools are missing from release tooling :)
16:20:03 <elodilles> bauzas: i'm working on it ;)
16:20:10 <bauzas> okay
16:20:37 <bauzas> so, basically, people can backport some changes to stable/yoga but we shouldn't be merging them ?
16:21:00 <elodilles> also this is a good reading for people who are interested in the topic: https://governance.openstack.org/tc/resolutions/20231114-amend-unmaintained-status.html
16:21:00 <bauzas> now we released yoga with the last number?
16:21:28 <sean-k-mooney> the stable/yoga branch will be deleted after the tag is created adn unmaintained/yoga is created
16:21:40 <sean-k-mooney> one thing we need to do is update the .gitreview file
16:21:46 <elodilles> bauzas: we can merge, the tag will be applied at the HEAD of stable/yoga (like the *-eol tag)
16:21:46 <sean-k-mooney> once we cut the new branch
16:22:04 <bauzas> elodilles: okay
16:22:13 <bauzas> good to know
16:22:58 <bauzas> so, basically, we can still backport some changes if we need (like some important fixes), but it would be better to wait until yoga is unmaintained
16:23:49 <elodilles> +1
16:23:49 <bauzas> people interested in maintaining yoga would tho still want to backport changes to the stable branch, but we shouldn't be releasing it
16:24:06 <bauzas> I'm cool with the plan then
16:24:17 <bauzas> moving on
16:24:19 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:24:28 <fwiesel> #Info Script installs functional devstack, starting from a blank vm snapshot in ca. 500s
16:24:29 <bauzas> fwiesel: grandchild: if you want to tell us
16:24:44 <bauzas> fwiesel: bravo !
16:24:57 <fwiesel> So, we should be able to hook now things up, but...
16:25:04 <fwiesel> #Info Need to lock down network before hooking up CI (ETA: Roughly Mid-January due to holidays)
16:25:34 <fwiesel> For the curious ones, the stack.log I've put here: http://sap-openstack-ci.s3-website.us-east-2.amazonaws.com/logs-stack.tar.gz
16:25:39 <bauzas> heh, sure :)
16:25:57 * bauzas clicks
16:25:58 <fwiesel> We will probably dump there also then the output of the test-runs, so they are publically visible
16:26:13 <bauzas> fwiesel: I got a 403 from the link
16:26:15 <elodilles> (fwiesel: it says 403 forbidden)
16:27:07 <fwiesel> Hmm, I'll have to check with the colleague then. Just five minutes I we fixed the permissions. And I do not have the means to change them myself
16:27:19 <bauzas> fwiesel: no rush
16:27:33 <sean-k-mooney> for what its worht  this https://www.ovhcloud.com/en-ie/web-hosting/performance-offer/ used to be what we used to host the logs publicly in teh past
16:27:54 <sean-k-mooney> it is much cheaper then aws
16:28:19 <bauzas> I didn't wanted to play the French card :D
16:28:25 <fwiesel> Not if you factor in the bureaucracy to get that through in a big company
16:28:57 <sean-k-mooney> so its 120 euro a year so it genrelly does not require appoveal and can be expensed in most companies :)
16:29:00 <sean-k-mooney> but sue
16:29:07 <sean-k-mooney> *sure
16:29:17 <bauzas> we're publicly logged here so I won't speak that much, but yeah AWS is good as being the primer
16:29:21 <sean-k-mooney> anyway good to know
16:29:43 <fwiesel> We probably put it behind a dns redirect, so we can switch it whenever we want.
16:30:08 <bauzas> fwiesel: that's a good idea and you shouldn't publiclize what you use for your environment IMHO )
16:30:10 <bauzas> :)
16:30:31 <bauzas> even if people can see the dns redirect :)
16:30:50 <bauzas> anyway
16:31:04 <bauzas> thanks for the report, and that's very good to hear that your lab is running :)
16:31:11 <bauzas> kudos again
16:31:38 <fwiesel> bauzas: You're welcome. Thanks for giving us the opportunity to pitch in.
16:31:46 <bauzas> shall we move on ?
16:31:55 <bauzas> I have an item
16:31:56 <fwiesel> #Info Next update on 9th January
16:32:03 <bauzas> noted.
16:32:13 <bauzas> and it will transition to my own item actually :)
16:32:18 <bauzas> #topic Open discussion
16:32:24 <bauzas> (bauzas) Skip next two nova meetingsĀ ?
16:32:35 <sean-k-mooney> i think yes
16:32:56 <bauzas> so, I'm off from Christmas to Jan 8
16:33:10 <bauzas> (Jan 8 not included, tbc)
16:33:25 <gibi> +1 on skipping
16:33:29 <gibi> I'm back on the 15th
16:33:31 <elodilles> +1 from me, too
16:33:48 <bauzas> anyone having concerns and wanting to discuss the next day after Jan 1 ? :D
16:34:17 <bauzas> looks not
16:34:42 <bauzas> #agreed Next two nova meetings (Dec 26 and Jan 2) will be SKIPPED. Next meeting will be Jan 9
16:34:55 <bauzas> #action bauzas to communicate this over ML
16:35:05 <bauzas> okay
16:35:11 <bauzas> so, we have another item
16:35:18 <bauzas> that we already discussed last week
16:35:24 <bauzas> (JayF/johnthetubaguy) Specless blueprint for ironic guest metadata
16:35:28 <bauzas> https://blueprints.launchpad.net/nova/+spec/ironic-guest-metadata
16:35:33 <JayF> I've put a significant amount of detail in this since last week
16:35:39 <bauzas> JayF: fancy taking the baton again ?
16:35:42 <bauzas> cool
16:35:43 <JayF> I'm happy to discuss here, or async in the blueprint/mailing list/etc
16:35:58 * bauzas reads the whiteboard
16:36:11 <JayF> This is mostly based on conversations with sean-k-mooney, especially the part about generalizing the libvirt code
16:36:55 <sean-k-mooney> just readign it now
16:37:10 <bauzas> JayF: I just have one question
16:37:43 <JayF> I either have an answer or a clever deflection technique ;)
16:37:46 <bauzas> with a SLURP environment consisted of Caracal controllers, Caracal computes but also Antelope computes, how Ironic could use this ?
16:38:07 <JayF> Ironic is going to just look for the metadata provided by Nova in instnace_info
16:38:16 <sean-k-mooney> im not sure that will matter given this will be entrily in the driver
16:38:18 <JayF> if it's there; Ironic will add the lessee; if not, it won't
16:38:39 <JayF> if someone is migrating, they'll migrate *after* the upgrade is complete and because the migration script is additive only, it'll make the environment consistent
16:39:00 <sean-k-mooney> if the ironic compute are running antelope code it just wotn set that data
16:39:03 <bauzas> JayF: here, I just want to hear that you understand that the metadata will be optional, at least until we upgrade to 2024.2
16:39:11 <sean-k-mooney> if its upgraded it can check the ironic api version if needed
16:39:22 <JayF> Absolutely; 100%, ironic will opportunistically use that metadata if it exists, we will not make a hard dependency on it
16:39:54 <JayF> it'd be an API break for us to do anything else
16:40:03 <sean-k-mooney> the ironic script that will be created for backfilling can also be used to reconsile everythign after the upgrade is fully done
16:40:22 <opendevreview> Stephen Finucane proposed openstack/nova master: Resolve mypy error  https://review.opendev.org/c/openstack/nova/+/903530
16:40:23 <opendevreview> Stephen Finucane proposed openstack/nova master: tox: Use pre-commit for pep8 target  https://review.opendev.org/c/openstack/nova/+/896227
16:40:23 <opendevreview> Stephen Finucane proposed openstack/nova master: pre-commit: Add mypy  https://review.opendev.org/c/openstack/nova/+/896228
16:40:24 <opendevreview> Stephen Finucane proposed openstack/nova master: pre-commit: Bump linter versions  https://review.opendev.org/c/openstack/nova/+/903749
16:40:36 <bauzas> JayF: then I'm cool
16:40:41 <JayF> woo
16:40:49 <sean-k-mooney> i think im oke with moving forward with this as a specless bluepint and movign the dicussion to the implementaion
16:40:51 <bauzas> from a nova pov, this is just a small thing
16:41:12 <JayF> That's sorta how I feel about it too, but it's hard for me to tell :)
16:41:18 <bauzas> but again, I don't want Ironic to have a bug because we continue to support Antelope computes, that's it :)
16:41:40 <bauzas> if the plan is already sorted, then yay, sounds specless
16:41:53 <bauzas> anyone concerned by any design problem ?
16:42:10 <bauzas> anyone thinking of some nit that would need to be discussed ?
16:42:29 <bauzas> apparently no
16:42:36 <bauzas> so,
16:42:53 <JayF> I'll note Ironic team discussed this at PTG; this reflects that discussion. I'll run it by our cores as well, don't expect any contention but I'll make another round trip here if there's any change.
16:43:07 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/ironic-guest-metadata to be approved as a specless blueprint for 2024.1 timeframe
16:43:54 <JayF> Thank you o/
16:44:22 <bauzas> I already did the paperwork stamping
16:44:41 <bauzas> I guess we're done with the meeting
16:44:51 <bauzas> I don't see anything else in the agenda
16:44:55 <fwiesel> Thanks everyone and happy holidays
16:44:56 <bauzas> so, anything anyone ?
16:45:03 <gibi> have a nice time off folks!
16:45:26 <elodilles> happy holidays o/
16:45:28 <bauzas> yeah, happy holidays to all of you and for those who take time off, have a good one :)
16:45:40 <bauzas> see you all next year
16:45:50 <bauzas> #endmeeting