16:01:17 <bauzas> #startmeeting nova
16:01:17 <opendevmeet> Meeting started Tue May 14 16:01:17 2024 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:17 <opendevmeet> The meeting name has been set to 'nova'
16:01:21 <bauzas> hey folks
16:01:44 <tkajinam> o/
16:01:46 <elodilles> o/
16:02:04 <fwiesel> o/
16:02:04 <gibi> o/
16:02:42 <Uggla_> o/
16:02:50 <bauzas> okay, let's softly start
16:02:58 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:03:07 <bauzas> #topic Bugs (stuck/critical)
16:03:11 <bauzas> #info No Critical bug
16:03:16 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:03:21 <bauzas> anything important to tell about bugs ?
16:03:58 <bauzas> looks not
16:04:03 <bauzas> #topic Gate status
16:04:07 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:04:10 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:04:15 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:04:20 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:04:25 <bauzas> #info Please try to provide meaningful comment when you recheck
16:05:06 <tkajinam> just fyi. global u-c was updated and sqlalchemy was bumped to 2.0. I don't expect any problems with core services since sqlahcmely 2.0 has been tested for some time, but we may need to pay some attention to gate.
16:05:32 * bauzas still awaits Zull to provide me the peridic jobs
16:05:50 <bauzas> okay, all of the perodics are green, even the nova-emulation one
16:05:57 <dansmith> o/
16:06:08 <sean-k-mooney> the emultaion one was just being OMM killed
16:06:30 <sean-k-mooney> so it can pass currently i have a patch to correct that
16:06:32 <bauzas> oh, for the moment, the latest master job for nova-emulation was still failing
16:06:43 <bauzas> we'll see it next week then
16:07:05 <bauzas> do people want to discuss about the guest kernel issues now or not  ?
16:08:05 <sean-k-mooney> just an fyi https://review.opendev.org/c/openstack/nova/+/918464 is the fix for the emulator job
16:08:14 <sean-k-mooney> regarding panics
16:08:40 <sean-k-mooney> im not sure i have seen them get any worse but i know dansmith wants to try reverting the way we define the glance images
16:08:48 <sean-k-mooney> dansmith: did you have time to push a patch for that
16:08:50 <bauzas> okay
16:09:16 <dansmith> no, I need to do that still
16:09:37 <sean-k-mooney> ack if you dont get around to it by the next meeting ill push a patch to do it
16:10:21 <bauzas> kk
16:11:55 <bauzas> moving on then
16:12:03 <bauzas> #topic Release Planning
16:12:08 <bauzas> #link https://releases.openstack.org/dalmatian/schedule.html
16:12:13 <bauzas> #link https://review.opendev.org/c/openstack/releases/+/918422 nova specific schedule is proposed
16:12:25 <bauzas> I saw sean-k-mooney's comment, I'll provide a new revision
16:12:38 <bauzas> (but fwiw, we discussed it on the PTG)
16:12:51 <bauzas> #info Dalmatian-1 this week
16:12:56 <bauzas> #info Spec review day is today
16:13:11 <bauzas> I started to review some specs and I saw also some other comments
16:13:30 <bauzas> thanks to the folks that already started to review <3
16:13:49 <bauzas> #topic Review priorities
16:13:53 <bauzas> #link https://etherpad.opendev.org/p/nova-dalmatian-status
16:14:25 <bauzas> tomorrow, I'll modify the etherpad by adding the new series related to the specs that will be merged today
16:15:52 <bauzas> #topic Stable Branches
16:15:57 <bauzas> elodilles: hehe
16:16:00 <bauzas> \o
16:16:05 <elodilles> ~o~
16:16:09 <elodilles> #info all stable gates are OK (stable/2024.1, stable/2023.2, stable/2023.1) as grenade jobs are fixed and passing
16:16:31 <elodilles> #info stable nova versions released: nova 28.1.0 (2023.2 Bobcat), nova 27.3.0 (2023.1 Antelope)
16:16:49 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:16:58 <elodilles> that's all for today :)
16:19:14 <bauzas> cool
16:19:21 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:19:21 <elodilles> cool indeed
16:19:29 <bauzas> fwiesel: anything to tell ?
16:19:52 <fwiesel> Not much...
16:20:06 <fwiesel> #info Sync script in place. CI working through the backlog.
16:20:13 <sean-k-mooney> is https://review.opendev.org/c/openstack/nova/+/910627 the next patch on your review list
16:20:22 <fwiesel> So, if you do not see any messages, it is because of that.
16:20:51 <fwiesel> sean-k-mooney: Yes, that would be the next one. That should cut down the errors to one, IRC.
16:21:05 <bauzas> ok
16:21:37 <fwiesel> That would be from my side, unless there are more questions.
16:21:55 <bauzas> not from me
16:21:57 <bauzas> cool
16:21:59 <bauzas> and thanks
16:22:07 <bauzas> #topic Open discussion
16:22:12 <bauzas> I have one item
16:22:21 <sean-k-mooney> i also have one but i can wait
16:22:24 <bauzas> next Tuesday, I'll be on a train when the meeting starts
16:22:35 <bauzas> (going to the OpenInfra Day in Paris)
16:22:46 <bauzas> so anyone happy to lead the meeting ?
16:23:00 <bauzas> if not, we'll just punt it to the next week
16:23:15 <JayF> Hey, can
16:23:19 <JayF> whoops, one thing
16:23:40 <JayF> Can https://blueprints.launchpad.net/nova/+spec/ironic-guest-metadata be re-approved for Dalmation?
16:23:56 <bauzas> JayF: you're next in queue after sean-k-mooney's point :)
16:24:00 <bauzas> we're on meeting now :)
16:24:20 <bauzas> so, anyone volunteering for running the meeting next week ?
16:24:20 <sean-k-mooney> bauzas: if we dont have anything urgent i think we can skip next week
16:24:27 <bauzas> no worries, then we'll skip it
16:24:42 <sean-k-mooney> lets do JayF point first
16:24:47 <sean-k-mooney> im fine with reappoving that
16:24:48 <bauzas> #agreed next nova meeting on May 21 is CANCELLED
16:25:02 <bauzas> #action bauzas to communicate about the cancellation
16:25:10 <bauzas> okay, done for my item
16:25:15 <bauzas> next one then, Jay
16:25:17 <andrewbonney> One query on bugs if I could too after others
16:25:40 <sean-k-mooney> andrewbonney: sure. JayF  do you want to summerise
16:25:51 <bauzas> JayF: I don't see anything controversial with reapproving https://blueprints.launchpad.net/nova/+spec/ironic-guest-metadata as specless
16:26:17 <JayF> thank!
16:26:20 <JayF> *thanks
16:26:21 <bauzas> most of my concerns come with testing this, but this is not related to the blueprint itself
16:26:50 <bauzas> anyone having concerns with reapproving ^ as specless ?
16:27:16 <bauzas> speak now or forever hold your peace
16:27:35 <bauzas> okay, I'll do the paperwork stamp
16:27:50 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/ironic-guest-metadata reapproved as specless for Dalmatian
16:28:15 <bauzas> next one, who's this ? sean-k-mooney I think ?
16:28:18 <sean-k-mooney> so hopefully my item will be jsut as quick
16:28:20 <sean-k-mooney> https://blueprints.launchpad.net/nova/+spec/eventlet-removal-part-1
16:28:25 <sean-k-mooney> can we appove that as specless
16:28:47 <sean-k-mooney> i mostly have it implmeneted
16:29:05 <dansmith> the critical bits are the implementation details,
16:29:07 <sean-k-mooney> there is some feedback form stephen on the implmentaion but i think it will be ready for review next week
16:29:22 <dansmith> so I think it's reasonable to call this cleanup/maintenance and focus on the actual code, IMHO
16:29:35 <dansmith> i.e. no API or RPC or DB changes, just internals
16:29:37 <bauzas> yeah I think we said it's just for tracking
16:29:50 <bauzas> tracking progress and adding it to our review eyes
16:29:56 <sean-k-mooney> cool well the patches are avaiable for review here https://review.opendev.org/q/topic:%22eventlet-removal-part-1%22
16:30:12 <bauzas> I'm fine with approving it then as specless and I think we even agreed on that at the PTG
16:30:21 <sean-k-mooney> yep
16:30:27 <bauzas> okay,
16:30:44 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/eventlet-removal-part-1 accepted as specless blueprint as agreed during the PTG
16:30:53 <sean-k-mooney> i belive andrewbonney had a question around a bug?
16:31:26 <sean-k-mooney> assuming there was nothign else on the adgenda
16:31:40 <andrewbonney> Thanks. Just a procedure thing really. I have a few reports since March and just wanted to check if I should be following up here generally or in meetings for feedback?
16:31:53 <andrewbonney> I appreciate you get a lot so just trying to do the right thing
16:32:36 <sean-k-mooney> as in you filed a number of bug reporst since march?
16:32:47 <andrewbonney> Yeah that's right, https://bugs.launchpad.net/nova/+bugs?field.bug_reporter=andrewbonney
16:32:49 <sean-k-mooney> and you want to knwo if they have been looked at or how to progress them
16:33:38 <andrewbonney> Sure. For maybe one I could propose a patch, but generally they need review from those more familiar with the codebase
16:33:44 <bauzas> andrewbonney: we agreed on previous PTG that we can't really triage the new bugs every week as we lack volunteers and time for that
16:33:52 <andrewbonney> Sure
16:34:09 <sean-k-mooney> looking at the first one https://bugs.launchpad.net/nova/+bug/2058725 sound familar and im trying to recall if it was intentional
16:34:18 <bauzas> unfortunately, we then let the reporters to communicate to us any bug in particular they could consider as critical
16:34:55 <bauzas> andrewbonney: for the other bugs that are less important, our channel is always open for discussion and you shouldn't be afraid of pinging ourselves
16:35:00 <gibi> andrewbonney: if you could try to push a test case that reproduces the issue in unit or functional test env would greatly increas the chance that we get to it
16:35:25 <bauzas> some people usually bug ourselves in this chat, asking either for reviews, help or categorisation
16:35:33 <opendevreview> Stephen Finucane proposed openstack/nova-specs master: Follow-up for openapi spec  https://review.opendev.org/c/openstack/nova-specs/+/919603
16:36:10 <andrewbonney> Thanks, just don't want to annoy
16:37:05 <sean-k-mooney> its fine. https://bugs.launchpad.net/nova/+bug/2065403 sound like you are not running it in a loop until completion
16:37:44 <sean-k-mooney> although the interaction with -max-count problmeatic
16:37:57 <andrewbonney> I think the default behaviour does run in a loop, that's where the problem lies. With max-count it doesn't run in a loop as far as I can see
16:38:42 <bauzas> if people agree, we can close the meeting now and let people to discuss about andrewbonney's bug reports just after
16:38:49 <sean-k-mooney> sure
16:39:30 <bauzas> cool
16:39:32 <bauzas> thanks all then
16:39:38 <bauzas> #endmeeting