16:00:22 <bauzas> #startmeeting nova
16:00:22 <opendevmeet> Meeting started Tue Jun 11 16:00:22 2024 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:22 <opendevmeet> The meeting name has been set to 'nova'
16:00:35 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:35 <gibi> o/
16:00:56 <elodilles> o/
16:01:00 <fwiesel> \o
16:01:11 <dansmith> o/
16:01:27 <auniyal> o/
16:01:34 <bauzas> my current time :
16:01:37 <bauzas> 64 bytes from par21s19-in-f4.1e100.net (142.250.179.68): icmp_seq=27972 ttl=112 time=193 ms
16:01:49 <bauzas> anyway, let's start
16:02:05 <bauzas> #topic Bugs (stuck/critical)
16:02:10 <bauzas> #info No Critical bug
16:02:15 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:02:22 <bauzas> anything to discuss ?
16:03:09 <bauzas> looks not
16:03:19 <bauzas> #topic Gate status
16:03:25 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:03:30 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:03:36 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:03:56 <bauzas> we had a nova-emulation master job failure https://zuul.openstack.org/build/2f26196745fe4cc8a93b5453317710ee
16:04:09 <sean-k-mooney> the fix for that job is still not merged
16:04:23 <sean-k-mooney> it keeps hitting job timeout or unrelated failures in other jobs
16:04:36 <bauzas> because of when deleting some instance, it was not found
16:04:53 <sean-k-mooney> i have started to look in to how to gather some data to deteimn if we should bump the timeouts in the integrated-compute jobs and its decendent jobs
16:05:00 <bauzas> ok
16:05:56 <sean-k-mooney> the simple solution woudl be to temporally add 30mins to the integrated comptue job while i try and figure out what a more reasonable value would be
16:06:20 <bauzas> but it was not a timeout issue
16:06:28 <sean-k-mooney> not in this case
16:06:36 <sean-k-mooney> but the patch that fixes the OOM issue in that job
16:06:44 <sean-k-mooney> is being blocked by timouts in other jobs
16:06:56 <bauzas> ah ok
16:07:23 <sean-k-mooney> anyway i think we can move on for now
16:07:27 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:07:31 <bauzas> #info Please try to provide meaningful comment when you recheck
16:07:36 <bauzas> #topic Release Planning
16:07:40 <bauzas> #link https://releases.openstack.org/dalmatian/schedule.html
16:07:45 <bauzas> #info Dalmatian-2 in 3 weeks
16:08:25 <bauzas> #info we'll have a spec review day on July 3rd
16:08:34 <bauzas> (which is a Wednesday)
16:08:55 <bauzas> #action bauzas to tell this in the mailing-list
16:09:08 <bauzas> (on July 2nd I'll be off)
16:09:50 <bauzas> would people prefer to have this day on Monday, as July 4th is some US holiday
16:09:55 <bauzas> ?
16:11:31 <bauzas> is it me lagging or nobody replied ?
16:11:51 <dansmith> nobody replied
16:11:57 <bauzas> thoughts then ?
16:12:10 <dansmith> it's right around the american holiday
16:12:20 <dansmith> most of us will be plotting to blow up our neighbors on the following day
16:13:00 <sean-k-mooney> i have no real prefernce os i think tis also fine if we do it semi async
16:13:26 <sean-k-mooney> i.e. if us folks wont be around that day and feel like doing reviews on monday then the rest of us will already have that feedback
16:13:33 <sean-k-mooney> on wednesday
16:15:37 <bauzas> ok, let's do this on monday and I'll explain that it can be async for the week
16:15:44 <bauzas> moving on
16:15:49 <bauzas> #topic Review priorities
16:15:55 <bauzas> #link https://etherpad.opendev.org/p/nova-dalmatian-status
16:16:15 <bauzas> nothing to report, I'm planning to review specs but my lag doesn't help much today
16:16:26 <bauzas> hopefully my connection will come back tomorrow
16:16:49 * bauzas won't tell how his fiber is good
16:17:02 <bauzas> moving on
16:17:04 <bauzas> #topic Stable Branches
16:17:13 <bauzas> elodilles: please
16:17:24 <elodilles> #info stable gates should be OK
16:17:37 <elodilles> #info nova 29.0.2 released for 2024.1 Caracal stable series
16:17:48 <elodilles> thanks for the review o/
16:17:57 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:18:09 <elodilles> and that's all from me about stable
16:20:05 <bauzas> cool
16:20:09 <bauzas> thanks
16:20:15 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:20:22 <bauzas> fwiesel: anything to tell ?
16:20:28 <fwiesel> #info Fixed bug in resolving the right branch in case of renaming from "stable/" to "unsupported/"
16:21:01 <fwiesel> Not much, but a small change... I query now the gerrit api to find out how the actual branch name is for each project.
16:21:37 <fwiesel> Any questions or feedback?
16:21:42 <elodilles> (* "unmaintained" o:))
16:22:00 <bauzas> yeah, unmaintained is the right wording
16:22:16 <bauzas> thanks fwiesel for that
16:22:16 <fwiesel> Ah, sorry. Yeah, in the code it is correct :)
16:22:27 <elodilles> :)
16:23:31 <fwiesel> That's then from my side wrt the 3rd-party CI
16:24:03 <bauzas> cool
16:24:08 <bauzas> #topic Open discussion
16:24:11 <bauzas> anything anyone ?
16:24:33 <fwiesel> Hopefully a quick question: I have a draft for a blueprint in etherpad: https://etherpad.opendev.org/p/nova-lazy-metadata-loading
16:24:38 <fwiesel> How do I continue from there on?
16:25:10 <fwiesel> Register it right away and put that in the url?
16:25:32 <fwiesel> Or ask here for feedback? (as I have done then implicitly)
16:26:27 <bauzas> well, usually, we discuss specless blueprints in our meetings
16:26:40 <bauzas> if you want to have it accepted, it's the right time
16:26:47 <bauzas> or do you want to discuss the design ?
16:26:53 * bauzas clicks but it will take a bit of time
16:27:16 <bauzas> oh, that's a spec template, nevermind
16:27:44 <bauzas> I think you can now create the blueprint, link it in the spec and upload that spec
16:28:05 <fwiesel> in nova-specs then?
16:28:22 <bauzas> you need to register a blueprint with https://blueprints.launchpad.net/nova/+spec/lazy-metadata-loading
16:28:45 <bauzas> then you need to upload the file you created in the nova-specs/2024.2/approved repor
16:28:53 <bauzas> s/repor/directory
16:29:00 <bauzas> and then push that commit to gerrit
16:30:01 <fwiesel> Okay, thanks. Will do
16:32:08 <bauzas> fwiesel: pro-tip, in the commit msg (in the nova-specs repo), add a specific "blueprint lazy-metadata-loading" tag in the text
16:32:19 <bauzas> something like "Proposes blueprint lazy-metadata-loading"
16:32:30 <bauzas> it will automatically link the spec in the blueprint whiteboard
16:33:18 <bauzas> ideally, create local branch from that name, so gerrit will have this topic
16:33:53 <fwiesel> Great, I'll do that.
16:36:44 <bauzas> okay, anything else ?
16:40:45 <bauzas> ok, I think we can close the meeting
16:40:48 <bauzas> thanks guys
16:40:52 <bauzas> #endmeeting