16:00:02 <bauzas> #startmeeting nova
16:00:02 <opendevmeet> Meeting started Tue Jul 16 16:00:02 2024 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:02 <opendevmeet> The meeting name has been set to 'nova'
16:00:12 <fwiesel> o/
16:00:14 <tkajinam> o/
16:00:19 <bauzas> hey everyone, welcome back, it was long overdue
16:00:39 <elodilles> o/
16:01:21 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:01:42 <auniyal> o/
16:02:24 <bauzas> I guess we can softly start
16:02:42 <bauzas> #topic Bugs (stuck/critical)
16:02:49 <bauzas> #info No Critical bug
16:02:59 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:03:14 <bauzas> do people want to discuss about some specific bugs, like some now public ones :)
16:04:04 <sean-k-mooney> i think you can take that as a no
16:04:51 <bauzas> thanks btw. dansmith and sean-k-mooney for https://bugs.launchpad.net/nova/+bug/2059809
16:05:27 <bauzas> moving on
16:05:28 <gibi> o./
16:05:30 <sean-k-mooney> *for fixing https://bugs.launchpad.net/nova/+bug/2059809 :) elodilles did a lot fo the hevay lifting on the backports as did gibi
16:05:45 <bauzas> :)
16:05:46 <elodilles> o:)
16:06:04 <bauzas> sorry, I was on PTO so I wasn't able to help :)
16:06:13 <bauzas> anyway, moving on
16:06:15 <bauzas> #topic Gate status
16:06:15 <sean-k-mooney> its fine it got done in the end
16:06:22 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:06:28 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:06:34 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:06:41 <bauzas> all greens
16:06:49 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:06:56 <bauzas> #info Please try to provide meaningful comment when you recheck
16:07:08 <bauzas> so, how is the current CI ?
16:07:38 <sean-k-mooney> better then it was. we merged the zswap changes and that seams to help stablise things
16:07:57 <sean-k-mooney> i have a patch up for review to slightly increase the ram of the default falvor
16:08:07 <sean-k-mooney> im hoping that will reduce or remove the kernel panics
16:08:11 <bauzas> ok
16:08:20 <sean-k-mooney> so we will want to monitor those once that merges
16:09:09 <bauzas> I could look at opensearch
16:10:04 <sean-k-mooney> we could do that yes alhtough im hopign it will become obvious or not if its enouch
16:10:10 <sean-k-mooney> https://review.opendev.org/c/openstack/devstack/+/924094 is the patch in question
16:10:46 <sean-k-mooney> downstream we obseved a crash that we have not seen since we changed form 128 to 256 mb upstream i only went to 192
16:11:42 <sean-k-mooney> so lets see how thing go for the next week
16:12:03 <tkajinam> that makes very clear sense
16:12:19 <bauzas> okay, I see that it's close to be merged
16:13:10 <sean-k-mooney> yep i also did a DNM to nova https://review.opendev.org/c/openstack/nova/+/924142
16:13:20 <sean-k-mooney> just to run our full set of jobs and it was green
16:14:48 <bauzas> for the guest panics, I'll ask opensearch about something like " ---[ end Kernel panic "
16:15:11 <bauzas> anyway, we'll see
16:15:21 <bauzas> moving on ?
16:15:42 <bauzas> looks so
16:15:48 <bauzas> #topic Release Planning
16:15:55 <bauzas> #link https://releases.openstack.org/dalmatian/schedule.html
16:16:00 <bauzas> #info Dalmatian-3 in 6 weeks
16:16:05 <bauzas> #info Spec approval freeze planned on Thursday
16:16:17 <bauzas> so that will be my review priority until Thursday
16:17:28 <bauzas> after Thursday EOD, we won't accept any other specs for Dalmatian, but you can then ask them for Epoxy once we merge https://review.opendev.org/c/openstack/nova-specs/+/924227
16:17:53 <bauzas> anything about the spec freeze ?
16:18:27 <tkajinam> I'm willing to move SEV-ES support forward this cycle so am looking for further feedback to https://review.opendev.org/c/openstack/nova-specs/+/907702 :-)
16:19:28 <fwiesel> I'd like raise attention then to my lazy-metadata-loading spec: https://review.opendev.org/c/openstack/nova-specs/+/922201
16:19:30 <sean-k-mooney> i can try and review that before thrusday
16:19:32 <bauzas> tkajinam: ack, I'll review
16:19:45 <bauzas> ditto for fwiesel
16:20:09 <bauzas> moving on so
16:20:18 <bauzas> #topic Review priorities
16:20:24 <bauzas> #link https://etherpad.opendev.org/p/nova-dalmatian-status
16:20:45 <bauzas> #action bauzas to update the above etherpad and Launchpad by tomorrow morning
16:20:55 <bauzas> I need to exactly look at what we already accepted
16:21:17 <bauzas> #topic Stable Branches
16:21:22 <bauzas> elodilles: heya
16:21:26 <elodilles> o7
16:21:27 <elodilles> #info stable gates should be in OK state
16:21:30 <elodilles> #info nova stable versions were released a week ago: 29.1.0 (2024.1 Caracal), 28.2.0 (2023.2 Bobcat), 27.4.0 (Antelope)
16:21:40 <elodilles> but i guess we will need new releases after some time as new fixes landed after the release
16:22:02 <elodilles> either feel free to propose the release patch or ping me
16:22:26 <elodilles> and that's all from me for stable for now
16:22:33 <bauzas> okay, we'll see
16:22:48 <bauzas> and indeed we will need to create new releases due to the cve fixes
16:23:05 <sean-k-mooney> does already shipped btu the regression fixes are pending
16:23:12 <bauzas> we'll just see when it's needed
16:23:23 <bauzas> yeah that
16:23:57 <tkajinam> once a new release with follow-up fixes is created then we can start the discussion to oslo'nize the implementation
16:24:14 <sean-k-mooney> release are fortunetly relitively cheap
16:24:25 <elodilles> sean-k-mooney: yepp
16:24:27 <sean-k-mooney> also yes that
16:24:32 <bauzas> given all the distros already fixed their cves, this is not that urgent, but I'd still want to get those stable versions quickly
16:24:44 <sean-k-mooney> bauzas: i mean it semi urgent
16:24:51 <sean-k-mooney> we broke all useage of isos in nova
16:24:54 <bauzas> semi-urgent indeeed
16:25:08 <bauzas> I'm not telling about the backports
16:25:18 <bauzas> but about the stable releases
16:25:33 <sean-k-mooney> yep we broke all useage of iso on the sable branches too
16:25:43 <sean-k-mooney> they are now fixed but not released
16:25:47 <gibi> :)
16:26:04 <sean-k-mooney> but we can likely od that in the next weeek or so
16:26:25 <sean-k-mooney> i think the last patch to stable/2023.1 landed friday
16:26:36 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:26:43 <fwiesel> #info No updates
16:26:44 <bauzas> fwiesel: want to say anything ?
16:26:49 <bauzas> cool with me
16:26:55 <bauzas> #topic Open discussion
16:27:02 <bauzas> anything from me, anything anyone ?
16:27:16 <tkajinam> I have one thing
16:27:51 <tkajinam> I have a few items pending on os-traits change. I wonder if I can ask for an early release (probably right after spec freeze) so that I can start pushing patches early
16:28:04 <tkajinam> See https://review.opendev.org/q/project:openstack/os-traits+status:open
16:28:39 <elodilles> +1 for early release o:)
16:28:58 <bauzas> that's always a good idea (to release os-traits release way earlier than milestone-3)
16:29:06 <bauzas> ditto with os-vif if required
16:29:41 <tkajinam> ok, that's nice. :-)
16:30:08 <bauzas> once the spec is approved, I don't see any reason to hold a os-traits patch
16:30:36 <bauzas> tkajinam: accordingly, please ping me if you want once your both specs are validated
16:30:47 <sean-k-mooney> i dont see why not
16:31:10 <bauzas> I just can't remember the state of both specs :)
16:31:22 <bauzas> so I'll first look whether they're accepted or not
16:31:54 <tkajinam> the SEV-ES work still needs spec approval but the other two have specs approved
16:32:14 <tkajinam> I'll update the status after the meeting
16:32:46 <bauzas> thanks
16:32:59 <bauzas> (yeah I remembered about the firmware one)
16:33:15 <sean-k-mooney> im not sure if we need the es trait
16:33:27 <opendevreview> Takashi Kajinami proposed openstack/os-traits master: Add a new trait for stateless firmware support  https://review.opendev.org/c/openstack/os-traits/+/908885
16:33:32 <sean-k-mooney> didnt we say we would use a seperate resouce class for that
16:33:45 <bauzas> for SEV-ES ?
16:33:50 <sean-k-mooney> yep
16:34:03 <sean-k-mooney> oh no we didnt
16:34:10 <sean-k-mooney> its the same resouce class
16:34:12 <tkajinam> sean-k-mooney, we agreed using trait, not resource class to distinguish SEV and SEV-ES, IIUC
16:34:13 <sean-k-mooney> just with a triat
16:34:18 <sean-k-mooney> it been a while since i looked
16:34:19 <tkajinam> yes
16:34:25 <sean-k-mooney> ya ok
16:34:54 <bauzas> yeah https://etherpad.opendev.org/p/nova-dalmatian-ptg#L498
16:35:04 <bauzas> (I was looking at the etherpad)
16:35:24 <bauzas> we didn't wanted to differentiate all the SEV supports
16:35:37 <bauzas> s/supports/types
16:35:46 <bauzas> anything else to discuss ?
16:36:07 <sean-k-mooney> not on this topic at least not form me
16:36:39 <tkajinam> nothing else from me
16:41:13 <bauzas> sorry, I looked at other stuff
16:41:19 <bauzas> thanks folks
16:41:23 <bauzas> #endmeeting