16:01:36 <bauzas> #startmeeting nova
16:01:36 <opendevmeet> Meeting started Tue Aug 27 16:01:36 2024 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:36 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:36 <opendevmeet> The meeting name has been set to 'nova'
16:01:40 <bauzas> hey folks
16:01:59 <bauzas> sorry, that's been so long, maybe you forgot about it
16:02:14 <gibi> never!
16:02:25 <fwiesel> o/
16:02:46 <elodilles> o/
16:03:03 <sean-k-mooney> o/
16:03:12 <auniyal> o/
16:03:34 <bauzas> cool folks
16:03:42 <bauzas> let's start then :)
16:03:56 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:04:05 <bauzas> #topic Bugs (stuck/critical)
16:04:12 <bauzas> #info No Critical bug
16:04:18 <bauzas> (glad to hear it)
16:04:26 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:04:45 <bauzas> any important bug people would want to discuss ?
16:04:59 <bauzas> I was off for 3 weeks so I don't really know
16:06:01 <bauzas> looks no
16:06:08 <bauzas> moving on
16:06:33 <sean-k-mooney> novaclint is blokced but we will talk about that later
16:06:37 <bauzas> okay
16:06:43 <bauzas> #topic Gate status
16:06:49 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:06:54 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:07:01 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:07:06 <bauzas> all greens
16:07:24 <bauzas> (well, we have a stable/zed job done, but meh)
16:07:33 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:07:38 <bauzas> #info Please try to provide meaningful comment when you recheck
16:08:25 <bauzas> moving on ?
16:08:52 <bauzas> #topic Release Planning
16:08:57 <bauzas> #link https://releases.openstack.org/dalmatian/schedule.html
16:09:04 <bauzas> #info Dalmatian-3 in 1 week
16:09:10 <bauzas> #info non-client library freeze happened last week
16:09:15 <bauzas> #info client library freeze this week
16:09:23 <bauzas> sean-k-mooney: want to discss the novaclient issue ?
16:10:13 <dansmith> I kinda have something for release planning
16:10:20 <sean-k-mooney> we have 2 issues
16:10:30 <sean-k-mooney> the first one is just a ci job issue
16:10:45 <bauzas> okay, tell me both
16:10:45 <sean-k-mooney> the functioanl job is exepcting there to only be one network
16:10:54 <sean-k-mooney> there are now 2
16:10:58 <sean-k-mooney> so 2 tests fail
16:11:10 <sean-k-mooney> we can update them to skip or modify them to use the first network
16:11:18 <sean-k-mooney> stephenfin: has a patch for the latter
16:11:48 <sean-k-mooney> the second issue is the cli does not work on python 3.11
16:11:59 <bauzas> this is a priority before we release novaclient IMHO
16:11:59 <sean-k-mooney> it was deprecated when the newest veriohn we supproted was 3.9
16:12:41 <sean-k-mooney> so i think we need to look at removing the nova client cli in 2025.1 and the python bidnign by 2026.1
16:12:58 <sean-k-mooney> that is a ptg discussion that im hopign melwitt and stephenfin can partake in
16:13:26 <sean-k-mooney> to actully do that we need to dicsuss with neutron and heat to get them to swap to the sdk
16:13:31 <bauzas> https://github.com/openstack/python-novaclient/blob/master/setup.cfg#L22-L24
16:13:43 <bauzas> are you saying that we don't have any job testing 3.11 ?
16:13:49 <sean-k-mooney> we do and it fails
16:13:59 <sean-k-mooney> but we deprecated the cli before that
16:14:16 <sean-k-mooney> so the cli has not been updated to supprot py311
16:14:16 <bauzas> oh, you're saying the deprecation of the CLI
16:14:22 <bauzas> I see
16:14:40 <sean-k-mooney> the 3.11 issue is a change in argparse behavior
16:14:44 <sean-k-mooney> so only affect the cli
16:14:55 <bauzas> this is deprecated, but we could provide some exception telling "sorry, we only support up to 3.9 for the CLI"
16:14:57 <sean-k-mooney> anyway there are two patches to fix the 3.11 issue
16:15:31 <sean-k-mooney> so the main question is do we quickly fix this for 2024.2
16:15:32 <bauzas> we could backport such patches then
16:15:51 <sean-k-mooney> and then look at removing the shell in 2025.1/2
16:16:04 <bauzas> I think we should rather just fix the 3.11 issues
16:16:12 <sean-k-mooney> actully we can dicussss post 2024.1 at the ptg
16:16:37 <bauzas> we can write some relnote before we release explaning the status of the CLI if you wan
16:16:39 <bauzas> want*
16:16:53 <sean-k-mooney> well the cil is deprecated for removal
16:17:01 <sean-k-mooney> so unless we are going to set a release there is no point
16:17:15 <sean-k-mooney> im hoping to deprecate the entire project in 2025.1
16:17:18 <bauzas> at a previous PTG, we said we preferred to defer the removal
16:17:19 <elodilles> with the relmgt hat on, i like the idea of landing the two patch that fixes the gate o:) (thanks sean-k-mooney for bringing this topic up :))
16:17:46 <bauzas> there are people continuing to run scrips with the CLI
16:17:47 <sean-k-mooney> ok then all we need to do is see if we are happy with stephenfin patch for functional
16:17:55 <sean-k-mooney> and then we can merge one of the two patches for 3.11
16:18:05 <sean-k-mooney> and backport those to stable branches
16:18:07 <sean-k-mooney> if needed
16:18:17 <bauzas> could you please add all the patches in the release etherpad if they're not there yet ?
16:18:27 <bauzas> for tracking
16:18:28 <sean-k-mooney> yep
16:18:32 <bauzas> thanks
16:18:40 <bauzas> do both of the problems have bug reports against them ?
16:18:50 <sean-k-mooney> yes i think so
16:18:53 <bauzas> cool
16:18:59 <bauzas> sean-k-mooney: thanks for helping
16:19:06 <bauzas> dansmith: you had a comment
16:19:07 <elodilles> yepp, thanks sean-k-mooney \o/
16:19:28 <dansmith> bauzas: release-wise, i think it's critical that we get this into 2024.2: https://review.opendev.org/c/openstack/nova/+/925025
16:19:39 <dansmith> it will reduce the number of releases where we carry the format_inspector stuff,
16:19:54 <dansmith> and the sooner we get that in the more coverage we'll get before the release
16:20:02 <bauzas> good point
16:20:08 <bauzas> I'll add it to the tracker
16:20:12 <dansmith> just made the oslo release, so we should take advantage of it
16:20:14 <gibi> I can start my tomorrow on that commit
16:20:17 <bauzas> ++
16:20:24 <dansmith> gibi: thanks
16:20:29 <bauzas> I can review that patch
16:20:44 <bauzas> (I actually reviewed the first patch that added the module :) )
16:21:01 <dansmith> -1741 +55
16:21:04 <dansmith> pretty good stats :)
16:21:13 <gibi> dansmith: nice work!
16:21:32 <bauzas> yeah, thanks for having worked on it from the last semester :)
16:21:40 <dansmith> yeah, I'm sick of it :)
16:21:57 <bauzas> I don't guess the reason why :-P
16:22:01 <bauzas> (jk)
16:22:18 <bauzas> anyway, moving on, I'll review that patch and gibi too
16:22:52 <bauzas> release-wise too, I'll start adding the procedural patches we usually merge before RC1
16:23:06 <bauzas> the rpcapi pins, etc.
16:23:55 <bauzas> #topic Review priorities
16:24:01 <bauzas> #link https://etherpad.opendev.org/p/nova-dalmatian-status
16:24:24 <bauzas> I'll start scrubbing that list and identify the series that are impacted by the client freeze and need to be punted
16:24:25 * sean-k-mooney added the nova clinet patches https://etherpad.opendev.org/p/nova-dalmatian-status#L32
16:24:29 <bauzas> ++
16:24:48 <bauzas> I'll provide comments in the etherpad about what can be reviewed
16:24:55 <bauzas> classic paperwork
16:25:08 <bauzas> next topic
16:25:11 <bauzas> #topic Stable Branches
16:25:23 <bauzas> elodilles: happy to listen to you
16:25:28 <elodilles> #info stable/202*.* gates seem to be OK
16:25:38 <bauzas> I like that
16:25:39 <elodilles> and that's all from me about stable :)
16:26:59 <bauzas> short and nice
16:27:03 <bauzas> I love that
16:27:12 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:27:14 <fwiesel> #info Fixed regression in neutron driver used in CI.
16:27:18 <bauzas> \o/
16:27:29 <fwiesel> sean-k-mooney: We are back to the two known failures
16:28:10 <sean-k-mooney> yep
16:28:18 <sean-k-mooney> i asked a question on the patch about rebuild
16:28:23 <sean-k-mooney> is that expected to fail
16:28:28 <sean-k-mooney> i see normal bfv works
16:28:38 <fwiesel> Yeah, that is its own bug an discussion
16:28:40 <sean-k-mooney> if there is a followup for the rebuild case i can upgrade to +2
16:29:07 <sean-k-mooney> ok upgraded to +2 based on the latest ci results
16:29:09 <sean-k-mooney> https://review.opendev.org/c/openstack/nova/+/910627
16:29:14 <fwiesel> \o/
16:29:27 <fwiesel> That would be then from my side for this week, unless there are questions.
16:29:34 <sean-k-mooney> im tempeted to +w since other have not reviewd in 6 months
16:29:36 <bauzas> not from me
16:29:53 <bauzas> I can review the patch
16:30:03 <bauzas> CI is green
16:30:27 <bauzas> and we have some kind of gentlemen's agreement on 'other virt drivers' patches we may not know by heart
16:30:30 <sean-k-mooney> ok, but general question since cores are not really maintianing the vmware stuff do we want ot require 2 +2s if ci is green and fwiesel's team are the autors of the patch?
16:30:49 <sean-k-mooney> im stictly talking about chagne that only impact vmware like this
16:30:51 <bauzas> that's the whole point of running a stable CI
16:31:03 <dansmith> I still want good review (i.e. two +2s)
16:31:19 <bauzas> if we can trust the vmware job, then we can get some good regressing insight
16:31:33 <bauzas> but I second dansmith on not release our two cores approval
16:31:56 <sean-k-mooney> ok then unless i see more people reviewin this i think we need to reopen the deprecation pathces
16:31:58 <bauzas> previously, we had the same concerns when other drivers were asking for reviews and we had that agreement
16:32:22 <bauzas> I don't see the need of threatening the driver
16:32:26 <sean-k-mooney> im not seeing other actully take the time to review but bauzas if your happy too review then cool
16:32:31 <gibi> I would be OK to drop down to 1x +2 for a driver only code with a good CI
16:32:48 <dansmith> I'm mostly concerned about drivers doing things they shouldn't and not so much the review of the actual vmware-specific bits
16:32:49 <bauzas> fwiesel makes a solid effort of keeping the job paceful, so we just need reviews
16:32:59 <dansmith> and I think if we drop down the review requirement we're just asking for rubber stamps
16:33:16 <bauzas> yeah, exactly why I think we need to continue the agreement we had
16:33:43 <sean-k-mooney> bauzas: that agreement goes too ways assuming more cores then just me look at the patch :)
16:33:49 <bauzas> two cores need to lookup the patches and somehow be "enlighted" by the result of the CI job
16:34:00 <sean-k-mooney> im happy for the work fwiesel has been doing
16:34:13 <bauzas> sean-k-mooney: correct and that's why I'm saying this is a normal situation
16:34:26 <bauzas> I got the signal and I'll do my homework
16:34:53 <bauzas> anything else about vmware ?
16:35:39 <fwiesel> Not from me.
16:35:41 <bauzas> #topic Open discussion
16:35:48 <bauzas> I have two procedural items
16:35:52 <bauzas> (bauzas) Sep 3 meeting
16:36:05 <bauzas> I'll be traveling to the OIF Asia Summit
16:36:19 <bauzas> only that week
16:36:27 <bauzas> so I won't be able to run the meeting
16:36:35 <bauzas> so either we skip or someone runs it
16:37:17 <bauzas> the most critical thing is to say next week that FeatureFreeze is coming in 2 days
16:37:36 <bauzas> so, anyone fancy runnning it ?
16:37:50 <bauzas> I can notify the deadline async using the ML
16:38:26 <bauzas> okay, I don't see any head popping up
16:38:29 <bauzas> so,
16:38:37 <bauzas> #info Sep 3 meeting is CANCELLED
16:38:45 <bauzas> #action bauzas to notify by email
16:38:51 <bauzas> second poit
16:38:53 <bauzas> point*
16:39:00 <bauzas> (bauzas) Epoxy PTL seat
16:39:19 <bauzas> if you contributed to nova recently, you received some email
16:39:38 <bauzas> maybe you don't know but I'm running for a TC seat this cycle
16:40:11 <bauzas> I think I can both sit on two chairs (TC and PTL) but I wanted to let people consider the PTL position
16:41:05 <bauzas> either way, my personal take is that IMHO nova is that important to me that I'd rather stick on that seat than leave the project to be leaderless (procedurarely)
16:41:26 <bauzas> but if you consider running for that position, my DM is open
16:41:45 <bauzas> that's it from me
16:42:02 <bauzas> I don't see any other item in the agenda
16:42:43 <bauzas> so unless someone disagrees loudly, let's end this meeting earlier and lemme give you 15 mins back of your time
16:43:35 <bauzas> okay, thanks folks
16:43:44 <bauzas> #endmeeting