16:01:19 <bauzas> #startmeeting nova
16:01:19 <opendevmeet> Meeting started Tue Sep 17 16:01:19 2024 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:19 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:19 <opendevmeet> The meeting name has been set to 'nova'
16:01:24 <bauzas> hey everyone
16:01:29 <fwiesel> o/
16:01:31 <bauzas> the agenda isn't written yet, lemme do it
16:01:35 <elodilles> o/
16:01:50 <dansmith> o/
16:02:44 <bauzas> okay, I'm done with the agenda
16:02:51 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:02:57 <bauzas> #topic Bugs (stuck/critical)
16:03:14 <bauzas> #info One critical bug
16:03:25 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.importance=Critical&field.status=New&field.status=Incomplete&field.status=Confirmed&field.status=Triaged&field.status=In+Progress
16:03:36 <bauzas> #link https://bugs.launchpad.net/nova/+bug/2079850
16:03:41 <gibi> o/
16:03:47 <bauzas> so we know about it, we just need to merge the bugfix
16:04:04 <bauzas> but, we'll discuss why we weren't able to do it previously in a second
16:04:11 <bauzas> anything else about bugs ?
16:04:20 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:05:00 <bauzas> looks not
16:05:04 <bauzas> #topic Gate status
16:05:10 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:05:17 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:05:26 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:05:36 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:05:42 <bauzas> #info Please try to provide meaningful comment when you recheck
16:05:56 <bauzas> so, you probably saw but the gate is blocked
16:06:16 <Uggla> o/
16:06:36 <bauzas> #info Gate is currently blocked due to a bug in OpenStackClient 7.1.0
16:07:19 <gibi> bauzas: https://review.opendev.org/c/openstack/requirements/+/929504 is merged 7.1.1 is in uc now
16:07:24 <bauzas> elodilles just told me that u-c now supports 7.1.1 where the bug is fixed (due to a parameter modification)
16:07:34 <bauzas> gibi: yup, was writing it :)
16:07:45 <bauzas> so, now, we can recheck, which I willk
16:07:51 <gibi> I already did
16:07:56 <bauzas> cool
16:08:03 <gibi> rechecked the bottom of the 3 RC bug we track in the etherpad
16:08:15 <bauzas> cool
16:08:39 <bauzas> we need to recheck the prelude and another Dalmatian change
16:08:48 <bauzas> but we'll discuss that in the next topic
16:09:16 <gibi> the prelude is already merged :)
16:09:24 <bauzas> #info Gate should now be unblocked as upper-constraints now supports OSC 7.1.1 which fixes the cause
16:09:30 <bauzas> oh cool
16:09:41 * bauzas was in meetings for the last 2 hours
16:09:48 <bauzas> that's how you can be productive, right?
16:10:08 <bauzas> gibi: thanks then
16:10:08 <gibi> I think the dalmatian service version patch is still open, I rechecked it now
16:10:15 <bauzas> ack
16:10:28 <bauzas> I can basically now take a beer then :)
16:10:43 <bauzas> 'hold my beer' literally
16:10:51 <gibi> sure, but keep your fingres crossed :)
16:11:03 <bauzas> my toes are even crossed
16:11:20 <bauzas> we're super late and I feel bad about it
16:11:28 <bauzas> but we shouldn't need another RC2
16:11:41 <bauzas> #topic Release Planning
16:11:47 <bauzas> #link https://releases.openstack.org/dalmatian/schedule.html
16:11:52 <gibi> so we just name this RC2 and say we have an early  :)
16:12:05 <bauzas> #info Dalmatian RC1 not yet tagged, hopefully tomorrow
16:12:28 <bauzas> #link https://etherpad.opendev.org/p/nova-dalmatian-rc-potential Tracking etherpad for RC candidates
16:12:48 <bauzas> okay, I think we discussed that enough, unless someone has any question ?
16:13:44 <bauzas> #topic Review priorities
16:14:23 <bauzas> #link https://etherpad.opendev.org/p/nova-2025.1-status
16:14:35 <bauzas> please add the series you'd want us to look at
16:14:48 <bauzas> I already see two proposals
16:15:55 <bauzas> moving on
16:15:59 <bauzas> #topic PTG planning
16:16:26 <bauzas> #info as a reminder, we'll meet (virtually) at the PTG on Oct 21-25 2024
16:16:46 <bauzas> I'm starting to draft an etherpad where you could add your topics of interest
16:16:50 <bauzas> #link https://etherpad.opendev.org/p/nova-2025.1-ptg
16:17:27 <bauzas> I'll send an email to openstack-discuss soon to tell about it
16:18:01 <bauzas> I think I'm done
16:18:05 <bauzas> next topic
16:18:16 <bauzas> #topic Stable Branches
16:18:20 <bauzas> elodilles: floor is yours
16:18:26 <elodilles> o7
16:18:29 <elodilles> #info stable/202*.* gates seem to be OK
16:18:42 <elodilles> #info stable/2024.2 branch is not yet cut for nova, but all the other repos the new branch exist
16:18:56 <elodilles> and that's all from me about stable branches for now
16:19:11 <bauzas> cool
16:20:12 <bauzas> last topic
16:20:24 <bauzas> well
16:20:33 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:20:38 <bauzas> fwiesel: anything to report ?
16:20:43 <fwiesel> #info No updates
16:21:00 <fwiesel> Not really... patch still stuck in ci... I'll recheck it soon
16:21:13 <bauzas> cool
16:21:17 <bauzas> last topic then
16:21:26 <bauzas> #topic Open discussion
16:21:33 <bauzas> (noonedeadpunk) Enable serving NoVNC under subpath (not only via port/subdomain)
16:21:38 <bauzas> noonedeadpunk: around ?
16:21:48 <bauzas> #link https://review.opendev.org/c/openstack/nova/+/928839
16:22:50 <sean-k-mooney> so its tecnnically possible ot do ^ externally with the correct revers proxy config but its a bit of a pain
16:23:11 <sean-k-mooney> im generally supportive of this as a minor feature (specless blueprint)
16:23:16 <sean-k-mooney> tl;dr
16:23:40 <sean-k-mooney> if you want to deploy all services on port 443 including novnc
16:23:49 <gibi> I only skimmed it, is this only support a single new query param "path"?
16:24:05 <sean-k-mooney> (either beacuse of yoru isp or firewall issues) you can do it with subdomains but its tricky to do with subfolders
16:24:25 <sean-k-mooney> yep path is the subpath to append ot the websocket
16:24:43 <sean-k-mooney> so in there case they wanted to deply openstac.my.domain/vnc
16:24:50 <bauzas> I'm having a few concerns by the implementation but I don't have any concenr about the design
16:25:01 <sean-k-mooney> without setting path it will connect ot /
16:25:02 <noonedeadpunk> yeah, around jsut a bit busy
16:25:27 <bauzas> like, I don't want nova to just sub the path and see whether there is path
16:25:33 <sean-k-mooney> so this is just exposing a way to pass path to novnc
16:25:44 <bauzas> maybe a config option, maybe something like a relnote
16:26:08 <noonedeadpunk> nova does not sub the path - but it jsut respects whatever user defiens in config
16:26:09 <bauzas> but I don't want us to not expose that
16:26:25 <noonedeadpunk> by not respecting query, and not just fqdn
16:26:33 <bauzas> well your change will parse the qs
16:26:43 <noonedeadpunk> and append to it
16:27:09 <sean-k-mooney> so we brifly dicussed having a config option like the exisitng port option for the query sting
16:27:24 <noonedeadpunk> vs currnet behaviour where  query is hardcoded basically
16:28:08 <sean-k-mooney> for libvirt we decieded that just passing a uri for the connection was better
16:28:17 <bauzas> well, here you're hard parsing the query with only 'path'
16:28:17 <noonedeadpunk> well, I'm not sure about config option ,as there could be more usecases whre you wnat to pass smth as admin to novnc
16:28:24 <sean-k-mooney> so that why i was mostly ok with noonedeadpunk  approch as its consitent with that
16:28:54 <sean-k-mooney> bauzas: there may be other query arges that novnc uses tha tcould be reasoanable to pass
16:29:02 <noonedeadpunk> bauzas: yeah, but current code will jsut add `?path=?token=<uuid>`
16:29:04 <sean-k-mooney> so i woudl prefer not to limit it to path
16:29:37 <bauzas> anyway, as I said, this is a technical detail
16:29:43 <noonedeadpunk> so if you try to add like anything to the `novncproxy_base_url` - you will end up with invalid token
16:29:54 <bauzas> I don't oppose to the usecase and I think keeping an URI is important
16:30:13 <noonedeadpunk> probably I jsut don't get what you're proposing isntead...
16:30:35 <bauzas> as I said, I only have implementation concerns
16:30:51 <bauzas> your current patch only accepts 'path' as a qs param
16:30:59 <noonedeadpunk> but like unit tests shows it should be quite consistent... I can add more test cases if I'll get what these concerns are
16:31:35 <bauzas> if we restrict to 'path' then we need to document it better than "oh and now you can pass *any* qs"
16:31:42 <sean-k-mooney> noonedeadpunk: bauzas  is askign to make sure it will work with any arg
16:31:51 <noonedeadpunk> it's not restricted with path?
16:32:14 <noonedeadpunk> l133 of https://review.opendev.org/c/openstack/nova/+/928839/3/nova/tests/unit/objects/test_console_auth_token.py
16:32:21 <bauzas> "@item(hotlist):button2
16:32:24 <bauzas> doh
16:32:46 <bauzas> the documentation says "You can also supply extra request arguments"
16:33:25 <bauzas> anyway, can we just (for the sake of my beer) accept that blueprint as specless and nitpick over the change as much as we want over the Epoxy timeframe ? :)
16:33:34 <noonedeadpunk> ++
16:33:43 <sean-k-mooney> +1 form me also
16:34:04 <bauzas> any objection ?
16:34:48 <bauzas> looks not
16:35:10 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/novnc-base-url-respect-extra-params accepted as specless for the Epoxy release
16:35:17 <bauzas> I'll file the paperwork
16:35:22 <gibi> OK for me
16:35:24 <bauzas> that's it for the agenda
16:35:39 <bauzas> any other bit you'd like to raise ?
16:35:56 <bauzas> looks not
16:36:06 <bauzas> my beer won't heat, cool
16:36:10 <bauzas> thanks all
16:36:13 <bauzas> #endmeeting