16:00:09 <bauzas> #startmeeting nova
16:00:09 <opendevmeet> Meeting started Tue Nov  5 16:00:09 2024 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:09 <opendevmeet> The meeting name has been set to 'nova'
16:00:23 <bauzas> hey folks, I'm in a meeting but I can do two things at the same time :)
16:00:31 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:01:02 <tkajinam> o/
16:01:31 <elodilles> o/
16:03:08 <bauzas> #topic Bugs (stuck/critical)
16:03:14 <bauzas> #info No Critical bug
16:03:21 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:03:25 <bauzas> any bugs to raise ?
16:04:26 <gibi> o/
16:04:43 <tkajinam> nothing I'm aware of
16:04:49 <sean-k-mooney> not anytin cirtical
16:04:57 <sean-k-mooney> there are a few i need to loop back too
16:05:24 <sean-k-mooney> but nothing to call out sepcifically
16:06:00 <sean-k-mooney> actully gibi was workign on https://review.opendev.org/q/topic:%22bug/2085975%22
16:06:18 <sean-k-mooney> so reviews welcom but we can likely move on
16:06:24 <bauzas> ok
16:06:33 <bauzas> #topic Gate status
16:06:39 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:06:46 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:06:51 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:06:58 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:07:11 <bauzas> #info Please try to provide meaningful comment when you recheck
16:07:36 <bauzas> all the zed perodic jobs got failures but fine enough
16:07:39 <elodilles> (i've removed the placement periodic jobs for unmaintained branches)
16:07:59 <elodilles> zed? :-o
16:08:36 <sean-k-mooney> we are not currently filtering only to stable branches
16:08:41 <sean-k-mooney> we probaly should update the query
16:09:13 <elodilles> hmm, i see, the zed jobs are for nova. i'll remove that too then
16:09:18 <bauzas> why ? we just look at all periodics this way
16:09:50 <sean-k-mooney> becasue we dont maintian the unmained branches
16:09:57 <sean-k-mooney> so we shoudl not be looking at them
16:10:30 <sean-k-mooney> we suhould just look at https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&branch=stable%2F*&branch=master&pipeline=periodic-weekly&skip=0
16:11:47 <sean-k-mooney> elodilles: i assume you would still like use to keep the older unmained/* branches for a bit longer
16:11:50 <bauzas> okay, then I'll amend that
16:12:03 <elodilles> sean-k-mooney: yepp
16:12:25 <sean-k-mooney> thats fine we can keep them while you still get value from them
16:12:28 <elodilles> though i guess the periodic-weekly jobs are not relevant for unmaintained branches
16:12:44 <bauzas> updated
16:12:55 <bauzas> anyway, let's move on
16:13:28 <elodilles> ACK
16:15:31 <Uggla> o/
16:15:32 <bauzas> #topic Release Planning
16:15:40 <bauzas> #link https://releases.openstack.org/epoxy/schedule.html
16:15:46 <bauzas> #action bauzas to add Epoxy nova deadlines in the schedule
16:15:50 <bauzas> (I forgot about that)
16:19:53 <opendevmeet> qwebirc88614: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:20:32 <sean-k-mooney> :) i assume that was a copy past error
16:20:38 <qwebirc88614> How to enter the meeting ?
16:20:48 <sean-k-mooney> its on irc so your already in it
16:20:58 <sean-k-mooney> we jsut hold it in the channel
16:21:13 <qwebirc88614> is the meeting in progress ?
16:21:26 <sean-k-mooney> yep although i dont kno if we lost bauzas?
16:21:51 <bauzas> sorry
16:22:03 <bauzas> moving one
16:22:05 <bauzas> on: )
16:22:48 <qwebirc88614> Let me introduce myself, I  am Ishan, I am a software engineer at Webex, Cisco. I wanted to know how I can start contributing to the nova project
16:23:35 <bauzas> qwebirc88614: sorry we're currently on a meeting, you could discuss that in the last topic if you want
16:23:40 <bauzas> I'll ping you
16:24:36 <qwebirc88614> Can you give me the IRC command to join the meeting ? Sorry this is my first time using IRC, Im finding it a bit confusing.
16:24:59 <sean-k-mooney> the confution is because no one is talkign in the meeting currently
16:25:12 <sean-k-mooney> bauzas: is being distrated by a internal call right now
16:25:57 <sean-k-mooney> we shoudl perhaps move on to  #topic Stable Branches
16:26:10 <sean-k-mooney> qwebirc88614: this is the adgenda https://wiki.openstack.org/wiki/Meetings/Nova#Weekly_Nova_team_meeting
16:26:23 <bauzas> #topic Review priorities
16:26:31 <bauzas> #link https://etherpad.opendev.org/p/nova-2025.1-status
16:26:49 <bauzas> nothing to say more, moving on to stable branches
16:28:37 <bauzas> #topic Stable Branches
16:28:41 <bauzas> elodilles: your time
16:28:45 <elodilles> o7
16:28:52 <elodilles> i'm not aware of any gate issue on stable branches
16:29:25 <elodilles> #info final 2023.1 Antelope nova (27.5.1) was released before transitioning stable/2023.1 to unmaintained/2023.1
16:29:36 <elodilles> and that's all from me this time
16:30:24 <elodilles> (sorry, forgot about the daylight saving time change, hence not updated yet the agenda)
16:30:41 <elodilles> s/forgot/i forgot/
16:31:01 <elodilles> so that's all from me about stable
16:32:24 <tkajinam> it reminds me of the need to create bunch of final antelope releases (not for nova but for a few other projects)
16:34:39 <bauzas> can we move on ?
16:34:43 <elodilles> yes
16:35:26 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:35:34 <bauzas> fwiesel: around ?
16:36:38 <fwiesel> So, I found a race-conditon in the setup. The network agent was not always yet up, when the tests started. I delay now the tests for that.
16:37:25 <fwiesel> There is still occasionally a "random" error, which leads me to suspect that the agent is still not yet 100% there, even when registered in neutron. I'll dig into that.
16:37:47 <fwiesel> But we are now back to 2-4 failing tests, and two of them are real errors.
16:38:05 <fwiesel> bauzas: Back to you.
16:38:10 <bauzas> thanks
16:38:20 <bauzas> #topic Open discussion
16:38:33 <bauzas> we don't have any open item for now
16:38:38 <bauzas> qwebirc88614: want to dicuss ?
16:39:04 <qwebirc88614> sure
16:40:35 <qwebirc88614> Hi Everyone, I am new to community. I am part of the engineering team at Webex, and we use openstack heavily for our IaaS layer. I am seeking mentorship to contribute to nova project. Things are very new to me and I dont know where to get started.
16:41:33 <gibi> qwebirc88614: I think this is the starting point of our contributor doc https://docs.openstack.org/nova/latest/contributor/index.html
16:42:24 <sean-k-mooney> qwebirc88614: are there paticallar topic or quetions you had?
16:43:26 <qwebirc88614> gibi: Thanks for the resource. In particular, I would like to know how we setup a development environment specifically for the Nova project
16:44:06 <sean-k-mooney> qwebirc88614: for unit/functional/style check we use a tool called tox. for general developemnt we use a tool called devstack
16:44:24 <tkajinam> devstack => https://docs.openstack.org/devstack/latest/
16:44:51 <sean-k-mooney> in general we recommend using a dedicated vm or machine for devstack
16:45:09 <sean-k-mooney> 8Gram 6-8 cpus 25-80G of disk space
16:45:58 <sean-k-mooney> most of us use ubuntu for devleopemtn but you can use rocky/centos/fedora too
16:47:04 <qwebirc88614> sean-k-mooney: thanks I will start using a dedicated VM for the same. are there a set of good first issue to get started ? and can I post my questions and doubts in the same IRC channel ?
16:47:40 <sean-k-mooney> outside of the meeting feel free to disucss on the irc channel or mailing list
16:48:20 <sean-k-mooney> the irc channel is here to supprot peopel developing nova which woudl now include you :)
16:48:50 <sean-k-mooney> we have some bugs tagged as low haning fuit
16:49:08 <sean-k-mooney> but if you tell us what your insterested in we can proably find something for you
16:49:27 <sean-k-mooney> qwebirc88614: i assume you have some specific areas of interest?
16:50:08 <sean-k-mooney> qwebirc88614: bauzas  is the nova PTL (project team lead) im sure they can help you find a good first task
16:50:51 <bauzas> sure, I'll try
16:51:28 <bauzas> can we close the meeting ?
16:51:45 <sean-k-mooney> i think so?
16:51:59 <qwebirc88614> Sean-k-mooney: Apologies if my questions are a bit broad at the moment – I’m just getting started and finding my way. In particular, I dont have an area of interest currently.
16:52:42 <qwebirc88614> bauzas: will connect with you to know more.
16:52:53 <qwebirc88614> thanks team.
16:52:57 <bauzas> thanks
16:53:02 <bauzas> so, thanks all
16:53:05 <bauzas> #endmeeting