16:00:13 <bauzas> #startmeeting nova
16:00:13 <opendevmeet> Meeting started Tue Nov 19 16:00:13 2024 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:13 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:13 <opendevmeet> The meeting name has been set to 'nova'
16:00:21 <bauzas> hello everyone
16:00:34 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:01:19 <bauzas> who's around ?
16:01:26 <elodilles> o/
16:01:33 <bauzas> let's wait for a few more
16:01:42 <bauzas> if we don't have quorum, I'll skip the meeting
16:01:52 <s3rj1k> hi all
16:02:25 <tkajinam> o/
16:02:34 <gibi> o/
16:03:39 <sean-k-mooney> o/
16:03:57 <bauzas> okay we can start
16:04:09 <sean-k-mooney> i have one quick topic for the end of the meetign but i could also ask on the list. just an fyi
16:04:16 <bauzas> ack
16:04:25 <bauzas> let's have this meeting being quick
16:04:36 <bauzas> my whole day was already packed with meetings
16:04:43 <bauzas> #topic Bugs (stuck/critical)
16:04:48 <bauzas> #info No Critical bug
16:04:53 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:05:04 <bauzas> nothing about bugs ?
16:05:42 <bauzas> okay, let's move on
16:05:48 <tkajinam> sean-k-mooney has proposed the fix for os-vif issue I raised last week
16:05:53 <tkajinam> https://review.opendev.org/c/openstack/os-vif/+/935653
16:05:55 <bauzas> ah cool
16:06:02 <tkajinam> if we can merge this quickly that would be nice
16:06:02 <bauzas> sean-k-mooney++
16:06:22 <bauzas> I'm not sure I can review that patch but I'll try
16:06:23 <tkajinam> I'll propose a new release of os-vif once that is merged to unblock bump of oslo.utils
16:06:57 <sean-k-mooney> i just bumpt the timeout for the retry loop
16:07:01 <sean-k-mooney> and made it configurable
16:07:12 <sean-k-mooney> the test only fails under high load
16:07:26 <sean-k-mooney> so the ohter way to fix itw as reduce concurancy but this seamed ok
16:07:41 <sean-k-mooney> if we have issues in the future ill reduce the concurancy instead
16:07:52 <bauzas> noted
16:09:12 <bauzas> ok moving on then
16:09:19 <bauzas> #topic Gate status
16:09:24 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:09:30 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:09:35 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&branch=stable%2F*&branch=master&pipeline=periodic-weekly&skip=0 Nova&Placement periodic jobs status
16:09:40 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:09:42 <Uggla> o/
16:09:45 <bauzas> #info Please try to provide meaningful comment when you recheck
16:09:47 <opendevreview> Takashi Kajinami proposed openstack/nova master: Detect AMD SEV-ES support  https://review.opendev.org/c/openstack/nova/+/925685
16:09:55 <bauzas> all periodics are green
16:10:24 <bauzas> and fwiw, the CI seems in good shape, I was recently reviewing a lot of patches and I found no massive CI failures
16:10:29 <bauzas> anything else to mention ?
16:10:58 <opendevreview> Takashi Kajinami proposed openstack/nova master: Add hw_mem_encryption_model image property  https://review.opendev.org/c/openstack/nova/+/927706
16:11:08 <opendevreview> Takashi Kajinami proposed openstack/nova master: libvirt: Launch instances with SEV-ES memory encryption  https://review.opendev.org/c/openstack/nova/+/926106
16:12:20 <bauzas> looks not
16:12:28 <bauzas> #topic Release Planning
16:12:33 <bauzas> #link https://releases.openstack.org/epoxy/schedule.html
16:12:38 <bauzas> #action bauzas to add Epoxy nova deadlines in the schedule
16:13:18 <sean-k-mooney> i have a minor request related to that
16:13:35 <bauzas> shoot
16:13:35 <sean-k-mooney> bauzas: can we put the etherpad back in the topic?
16:13:47 <sean-k-mooney> i.e. https://etherpad.opendev.org/p/nova-2025.1-status
16:13:49 <bauzas> in the channel topic ?
16:13:54 <sean-k-mooney> yes
16:13:58 <bauzas> I can try but I don't have op rights AFAIK
16:14:13 <sean-k-mooney> ok i tought we had it there before but its fine
16:14:40 <sean-k-mooney> its in my browser history anyway but it can be nice for visiablity since we are using that as part of our release plannign/tracking
16:15:23 <sean-k-mooney> we can move on
16:15:26 <bauzas> cool
16:15:56 <bauzas> I really need to provide the release patch to add the deadlines, as we told about a review round by mid-Dec
16:16:15 <bauzas> #topic Review priorities
16:16:22 <bauzas> #link https://etherpad.opendev.org/p/nova-2025.1-status
16:16:34 <bauzas> I updated it with a few blueprints that got approved
16:16:40 <bauzas> but I still need to curate it
16:17:11 <tkajinam> gibi, looks like all patches for igb vif model have been merged ?
16:17:50 <gibi> tkajinam: yes indeed
16:17:56 <gibi> tkajinam: I marked the bp implemented
16:17:57 <tkajinam> (then we can move it to the upper section, just fyi)
16:17:58 <tkajinam> :-)
16:18:00 <bauzas> I'll curate that list
16:18:10 <bauzas> tkajinam: ack, will do
16:18:11 <gibi> I will update the etherpad...
16:18:40 <bauzas> done :)
16:18:42 <gibi> thanks bauzas
16:18:43 <bauzas> moving on
16:18:51 <bauzas> #topic Stable Branches
16:18:52 <gibi> you were like 0.5 sec faster to cuting it :)
16:18:59 <bauzas> elodilles: welcome back: )
16:19:04 <elodilles> o/
16:19:08 <elodilles> #info stable/202*.* gates seem to be OK
16:19:11 <bauzas> gibi: I'm closer to my keyboard than you :p
16:19:16 <elodilles> unmaintained/2023.1 was cut already and now stable/2023.1 is deleted, too
16:19:24 <gibi> :)
16:19:29 <elodilles> #info stable/2024.2, stable/2024.1 and stable/2023.2 are the maintained branches from now on
16:19:45 <elodilles> for nova :)
16:19:57 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:20:10 <elodilles> and that's all from me about stable branches
16:21:25 <bauzas> thanks
16:21:41 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:21:47 <bauzas> fwiesel: available ?
16:21:48 <fwiesel> o/
16:21:55 <fwiesel> Hi, no update from my side.
16:22:00 <bauzas> thanks
16:22:07 <bauzas> #topic Open discussion
16:22:13 <bauzas> there was one item in the agenda
16:22:21 <bauzas> https://blueprints.launchpad.net/nova/+spec/allow-scp-ip-operations (s3rj1k)
16:22:26 <bauzas> s3rj1k: around ?
16:22:34 <s3rj1k> here
16:23:04 <s3rj1k> I think this one is obsolete, as revert mentioned in comments works fine
16:23:17 <sean-k-mooney> s3rj1k: so that should not be needed after our testing last week correct if we land https://review.opendev.org/c/openstack/nova/+/909122
16:23:35 <s3rj1k> sean-k-mooney: yes
16:23:52 <sean-k-mooney> then i would like to ask for another core to review ^
16:24:01 <bauzas> ah cok
16:24:03 <bauzas> ok
16:24:08 <bauzas> then moving on
16:24:08 <s3rj1k> I think we did not update agenda page from last week :)
16:24:11 <sean-k-mooney> and elodilles  it would be nice if you could weigh in on if you think that is backportable
16:24:26 <elodilles> sean-k-mooney: ACK, will check that
16:24:31 <bauzas> sean-k-mooney: you had one thing to discuss
16:24:54 <sean-k-mooney> bauzas: yes. i would like to add ralonsoh to the os-vif core team
16:25:38 * bauzas opens gerrit to see the list of os-vif cores :)
16:25:39 <sean-k-mooney> rodolfo has helpped maintained that repo on and off over the years and as a neuton core they have an invested interest in keeping it helaty as they also consume it
16:26:07 <bauzas> https://review.opendev.org/admin/groups/c113c882e5906f1b4ec806509ae59f0d363375c0,members
16:26:27 <sean-k-mooney> with watcher takeing some of my time ill have a little less time to look at issue in os-vif and i thikn they choudl be a good addtion to that team
16:26:39 <gibi> having a neutron core on the os-vif core team is not a bad idea
16:26:44 <bauzas> yeah
16:26:50 <bauzas> procedure-wise, it's a lib
16:27:08 <bauzas> and looking at the existing cores of os-vif, that's basically sean and the nova team
16:27:39 <sean-k-mooney> more or less jan moshe and sahid are mostly inative
16:27:46 <gibi> yeah
16:27:50 <sean-k-mooney> although sahid has beeen around a little more lately
16:27:52 <bauzas> the usual process would to request os-vif cores to accept this nomination
16:28:01 <bauzas> thru openstack-discuss
16:28:10 <sean-k-mooney> correct i ment ot send the mail to the list last week
16:28:24 <sean-k-mooney> and then bring it up today but i didnt get arond ot sending the mail
16:28:24 <bauzas> if you did and had no argument, then I'm cool
16:28:32 <bauzas> ah
16:28:44 <sean-k-mooney> so i can send it this week
16:28:49 <sean-k-mooney> and we can loop back next week
16:28:56 <bauzas> sean-k-mooney: please do so we respect the current policy
16:29:00 <sean-k-mooney> i just said i would ask ot see if there  was any objection
16:29:22 <bauzas> I don't expect  any controversy but I'd like to continue doing things the normal way
16:29:39 <sean-k-mooney> ok thats all form me then
16:29:55 <bauzas> cool then we can end this meeting
16:30:01 <bauzas> thanks all !
16:30:06 <bauzas> #endmeeting