#openstack-nova: nova

Meeting started by bauzas at 16:00:34 UTC (full logs).

Meeting summary

  1. Bugs (stuck/critical) (bauzas, 16:02:46)
    1. No Critical bug (bauzas, 16:02:55)
    2. Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster (bauzas, 16:03:00)

  2. Gate status (bauzas, 16:03:56)
    1. https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs (bauzas, 16:04:02)
    2. https://etherpad.opendev.org/p/nova-ci-failures-minimal (bauzas, 16:04:07)
    3. https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&branch=stable%2F*&branch=master&pipeline=periodic-weekly&skip=0 Nova&Placement periodic jobs status (bauzas, 16:04:14)
    4. Please look at the gate failures and file a bug report with the gate-failure tag. (bauzas, 16:04:20)
    5. Please try to provide meaningful comment when you recheck (bauzas, 16:04:26)

  3. Release Planning (bauzas, 16:07:06)
    1. https://releases.openstack.org/epoxy/schedule.html (bauzas, 16:07:11)
    2. Nova deadlines are set in the above schedule (bauzas, 16:07:17)
    3. 5 weeks before Feature Freeze (bauzas, 16:07:25)
    4. we'll try to create as os-traits release next week, please provide your os-traits patches sooner than later. (bauzas, 16:08:49)

  4. Review priorities (bauzas, 16:10:31)
    1. https://etherpad.opendev.org/p/nova-2025.1-status (bauzas, 16:10:39)

  5. Stable Branches (bauzas, 16:13:23)
    1. nothing to report, stable gates seem to be healthy (elodilles, 16:13:48)
    2. stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci (elodilles, 16:13:54)

  6. vmwareapi 3rd-party CI efforts Highlights (bauzas, 16:14:55)
  7. Open discussion (bauzas, 16:15:33)
    1. https://governance.openstack.org/tc/reference/runtimes/2025.1.html (bauzas, 16:19:00)
    2. https://github.com/openstack/nova/blob/master/nova/virt/libvirt/driver.py#L215-L224 (bauzas, 16:21:58)
    3. AGREED: Uggla will propose the QEMU/libvirt versions bump this cycle so people may review the proposal (bauzas, 16:24:44)
    4. AGREED: sean-k-mooney will notify openstack-discuss about disabling by default the instance info cache and give a 2-week notice for disagreements (bauzas, 16:42:42)
    5. https://docs.openstack.org/nova/latest/contributor/policies.html#metrics-gathering (sean-k-mooney, 16:45:52)
    6. AGREED: as the current design policy explicitely avoiding new monitors, this feature requires a quorum and a long discussion to evaluate a policy revision, hence the Nova community proposing to revisit that topic at the PTG (bauzas, 16:55:46)


Meeting ended at 16:57:46 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. bauzas (136)
  2. sean-k-mooney (41)
  3. gibi (16)
  4. elodilles (11)
  5. Uggla (11)
  6. opendevmeet (4)
  7. fwiesel (3)
  8. masahito (2)
  9. opendevreview (2)


Generated by MeetBot 0.1.4.