16:00:27 <bauzas> #startmeeting nova
16:00:27 <opendevmeet> Meeting started Tue Jan 28 16:00:27 2025 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:27 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:27 <opendevmeet> The meeting name has been set to 'nova'
16:01:16 <fwiesel> o/
16:01:22 <masahito> o/
16:01:23 <r-taketn> o/
16:01:25 <sean-k-mooney> o/
16:01:45 <gibi> o/
16:03:06 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:03:46 <bauzas> I guess we can softly start
16:04:20 <bauzas> #topic Bugs (stuck/critical)
16:04:33 <bauzas> #info No Critical bug
16:05:25 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:05:47 <masahito> hi, question for the bug roster activity.
16:05:53 <bauzas> any othre sure
16:06:10 <masahito> Is it bug triage activity newly reported?
16:07:08 <bauzas> we stopped looking at the non triaged bugs, as unfortunately there were no longer any volunteers :(
16:07:39 <bauzas> and it takes a large hit to triage those new bugs, given 2 of 3 are more configuration problems than real bugs :(
16:08:18 <Uggla> o/
16:08:30 <sean-k-mooney> ocationally we will still look and triage some
16:08:50 <sean-k-mooney> but its now mostly async or based on pings form folks on irc or teh mailign list
16:09:05 <bauzas> this indeed
16:09:09 <masahito> I got the situation.
16:09:21 <sean-k-mooney> we still use the bug tracker but we are not doing tirage weekly in thei meeting
16:09:30 <sean-k-mooney> if you have issue you can however bring them up here
16:10:30 <masahito> we hit some bugs in the v2.96 API and started to report and to fix it. Let me bring it up here or the bug triage roaster.
16:11:11 <masahito> I try to check other bugs as well for the triage if possible.
16:12:04 <masahito> ping on irc is sometime difficult for us because of time difference. The bug roster activity sounds nice :)
16:12:07 <masahito> thank you.
16:12:57 <bauzas> masahito: what you can do is to add your patches in the tracking etherpad, we'll look over them
16:13:45 <bauzas> can we move on ?
16:14:23 <masahito> Got it. Looks last update is the last September. We could refresh the etherpad, too.
16:14:27 <masahito> yes. Thank you.
16:15:18 <bauzas> #topic Gate status
16:15:24 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:15:30 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:15:38 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&branch=stable%2F*&branch=master&pipeline=periodic-weekly&skip=0 Nova&Placement periodic jobs status
16:15:44 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:15:50 <bauzas> #info Please try to provide meaningful comment when you recheck
16:16:01 <bauzas> the periodics are in a good shape
16:16:10 <bauzas> any gate failure you wanna talk ?
16:16:55 <sean-k-mooney> i havent really been looking at the gate in a while but the only fialures i notices were the usual volume or kernel panic issues
16:17:08 <bauzas> ditto here
16:17:09 <sean-k-mooney> with that said tehree was a fix for some of the volume tests in tempest
16:17:17 <sean-k-mooney> so that may help
16:17:19 <bauzas> and I definitely need to do a round of reviews
16:17:50 <sean-k-mooney> https://review.opendev.org/c/openstack/tempest/+/939663/2 and https://review.opendev.org/c/openstack/tempest/+/939633/11 for context
16:18:09 <sean-k-mooney> that shoudl help with some of the volume failures in test_instances_with_cinder_volumes
16:18:57 <sean-k-mooney> tl;dr those tests were not waiting for the vm to be sshabel ebfore trying to attach the voluems
16:18:59 <bauzas> good call, we can give them a shot
16:19:29 <sean-k-mooney> we can move on unless anyone else what to raise something
16:19:32 <bauzas> yup
16:19:36 <bauzas> #topic Release Planning
16:19:42 <bauzas> #link https://releases.openstack.org/epoxy/schedule.html
16:19:48 <bauzas> #info Nova deadlines are set in the above schedule
16:19:54 <bauzas> #info 4 weeks before Feature Freeze
16:19:57 <bauzas> the clock is ticking
16:20:29 <bauzas> as I said, I'll try to do a round of reviews as soon as my availability raises once I'm done with implementing a few things
16:20:49 <bauzas> as a reminder:
16:20:52 <bauzas> #info we'll try to create as os-traits release by this week, please provide your os-traits patches sooner than later.
16:21:00 <bauzas> Uggla: still volunteering for the release ?
16:21:08 <Uggla> sure
16:21:19 <sean-k-mooney> are there pending patches
16:21:24 <sean-k-mooney> that need review
16:21:48 <gibi> I think we need the vtpm one
16:22:05 <gibi> https://review.opendev.org/c/openstack/os-traits/+/940191
16:22:05 <sean-k-mooney> https://review.opendev.org/c/openstack/os-traits/+/940191
16:22:21 <sean-k-mooney> ok ill try and do a pass on the open patcher after the meeting
16:22:36 <Uggla> yes you were faster than me.
16:22:53 <sean-k-mooney> actully that look like the only relevent one
16:23:00 <sean-k-mooney> https://review.opendev.org/q/project:openstack/os-traits+status:open
16:23:11 <sean-k-mooney> the rest are not requried
16:23:22 <Uggla> btw I'm waiting this patch to be merged, then I'll go ahead with the release.
16:23:47 <sean-k-mooney> i have +2'd it
16:24:06 <sean-k-mooney> the traits alinght to what we dicussed in the spec and follow our naming convention
16:24:12 <sean-k-mooney> so looks good to me
16:24:17 <bauzas> I just +wd it, I was just reading the spec
16:24:20 <Uggla> \o/
16:24:37 <bauzas> so yeah, it was a nobrainer
16:24:49 <gibi> awesome
16:24:59 <Uggla> yep reviewing that one was not difficult. ;)
16:25:40 <bauzas> #action Uggla to release os-traits this week
16:25:47 <bauzas> moving on
16:25:57 <bauzas> #topic Review priorities
16:26:05 <bauzas> #link https://etherpad.opendev.org/p/nova-2025.1-status
16:26:22 <bauzas> I'll be honest, I have some cleanup to do on that etherpad
16:29:00 <bauzas> I guess we can move on
16:29:09 <bauzas> #topic Stable Branches
16:29:38 <gibi> elodilles is out
16:29:42 <bauzas> ah ok
16:29:53 <bauzas> I guess we can discuss that next week then
16:29:56 <gibi> sure
16:30:06 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:30:10 <bauzas> fwiesel: around ?
16:30:37 <fwiesel> Hi, I discovered another regression in the networking driver and investigating that.
16:30:47 <fwiesel> So, any failures are due to that.
16:30:52 <fwiesel> (In master that is)
16:30:59 <fwiesel> That's from my side.
16:31:16 <bauzas> oh sad newds
16:31:33 <bauzas> good luck then and thanks for your report
16:31:39 <fwiesel> Thanks.
16:31:42 <bauzas> #topic Open discussion
16:31:53 <bauzas> we have one item for today
16:31:58 <bauzas> (r-taketn) Request for comments on the following - Discussion of ArmCCA feature merge
16:32:01 <bauzas> r-taketn: around ?
16:32:04 <r-taketn> Hi, thanks for adding this to the agenda.
16:32:09 <bauzas> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/244U52T3HINVWUFSMPMA45A67BUPAQGK/
16:32:24 <r-taketn> Please review the above mailing list about an Arm CCA new feature.
16:32:33 <r-taketn> In particular, We would like to discuss the feature merging timeline mentioned at the beginning with nova core developers.
16:32:57 <opendevreview> Merged openstack/os-traits master: Add vTPM secret policy traits  https://review.opendev.org/c/openstack/os-traits/+/940191
16:32:57 <r-taketn> We are proposing development for a feature (ArmCCA) targeting hardware not yet released to the market.
16:33:21 <r-taketn> We would appreciate your comments on the feasibility of merging a feature for unreleased hardware.
16:33:24 * bauzas reads the mailing thread
16:33:43 <sean-k-mooney> r-taketn: we do not allow meging enabling code for unreleased hardware
16:33:54 <sean-k-mooney> wwe are also passed the spec approveal deadline for this cycle
16:34:14 <sean-k-mooney> but it can be proposed for next cycle if the hardware is aviable
16:34:47 <sean-k-mooney> we only merge hardware enabling code after the hardware is generally aviabel in teh market not before
16:34:51 <bauzas> yes indeed, there are a few limitations that you should be aware
16:35:17 <r-taketn> To our knowledge, no products currently support Arm CCA. FUJITSU-MONAKA [1], scheduled for release by Fujitsu in 2027, may be the first such product.
16:35:20 <bauzas> usually, we would want to make sure that our upstream CI can test specific hardware
16:35:46 <bauzas> if specific hardware can't be tested on upstream CI, then there are two possibilities :
16:36:35 <bauzas> 1/ either you're able to test nova against fake hardware that reproduces the hardware behaviour
16:36:49 <bauzas> 2/ or you have to provide third-party CI
16:38:37 <sean-k-mooney> while 2 is preferd it much more overhead btu actull tests that the feature works end to end
16:38:46 <r-taketn> Does this mean that if we submit third-party CI and comprehensive test results, there is a possibility that they will be merged before the hardware release?
16:38:55 <sean-k-mooney> no
16:39:28 <sean-k-mooney> we have strictly applied the requriemetn that hardware is released before its enabeld in the past. we coudl change that
16:39:34 <sean-k-mooney> but it would eb a break with precedent
16:39:52 <sean-k-mooney> we also require that any kernel/qemu/libivrt supprot is in a public offcial release
16:40:02 <sean-k-mooney> so if this requires qemu changes
16:40:08 <sean-k-mooney> or libvirt
16:40:23 <sean-k-mooney> those must be in a public offical release formr that upstream proejct before we can enabel it in nova
16:41:07 <r-taketn> ok, i understood.
16:41:08 <sean-k-mooney> is arm CCA supported in the kernel, qemu and libvirt today
16:41:56 <r-taketn> no. LinuxKernel, qemu and libvirt are being developed now.
16:42:22 <sean-k-mooney> if you want to propose poc patches and prepare them that is fine
16:42:41 <sean-k-mooney> but we cant merge them until the deps are resolved
16:42:56 <bauzas> indeed, nothing blocks you to create a feature branch that you could use for your own testing
16:44:17 <bauzas> what I could suggest you is to come back to us as soon as kernel, QEMU and libvirt versions are released upstream so then we can discuss the alternatives
16:44:49 <sean-k-mooney> just looking at https://patchwork.kernel.org/project/qemu-devel/cover/20240419155709.318866-2-jean-philippe@linaro.org/
16:44:54 <bauzas> but I strongly suggest you to invest a bit of your time into providing a testing kernel framework that could mock any specific hardware
16:44:56 <sean-k-mooney> it nodes that
16:45:02 <sean-k-mooney> Enabled support for guest memfd by Xiaoyao Li and Chao Peng [3].
16:45:04 <sean-k-mooney> Guest memfd is mandatory for CCA.
16:45:14 <sean-k-mooney> nova does not supprot memfd currently
16:45:36 <sean-k-mooney> so there may be other work that is required and we wont knwo that until the qemu/libvirt work is complete
16:46:26 <r-taketn> I got it. I understood that merging of  LinuxKernel, qemu and libvirt  are prerequisite.
16:46:30 <bauzas> which I assume is the reason why r-taketn wants to work on nova
16:46:57 <sean-k-mooney> well adressing thing like supprotign memfd which is pretty simiple coudl be done independetly
16:47:29 <sean-k-mooney> we considered addign supprot for it to enabel the manial share attachment feature without hugepages or file backed memory
16:47:48 <sean-k-mooney> so there may be some work that can be doen without wiating for the hardware.
16:48:15 <sean-k-mooney> perhaps we can discss this after the meeting if needed
16:49:07 <opendevreview> Artom Lifshitz proposed openstack/nova master: WIP: Add hw_tpm_secret_security image property  https://review.opendev.org/c/openstack/nova/+/940196
16:49:07 <opendevreview> Artom Lifshitz proposed openstack/nova master: WIP: Add hw:tpm_secret_security extra spec validation  https://review.opendev.org/c/openstack/nova/+/940197
16:49:08 <opendevreview> Artom Lifshitz proposed openstack/nova master: WIP: Allow vTPM live migrations for admins  https://review.opendev.org/c/openstack/nova/+/925771
16:49:50 <r-taketn> ok. I'll rethink the strategy. It would be helpful if you could let us discuss it on the mailing list, etc.
16:50:34 <sean-k-mooney> you are definetly free too
16:50:37 <bauzas> sure, r-taketn are you familiar with our release cadence ?
16:51:10 <sean-k-mooney> this could also be a good topic for a future PTG
16:51:30 <sean-k-mooney> i know other are also interested in confindcial computing in general
16:51:53 <r-taketn> I have read and understand the Eproxy Release Schedule.
16:53:21 <bauzas> r-taketn: the PTG dates for the next release were recently announced
16:53:47 <bauzas> PTG is a virtual event occuring a couple of days where we usually chat about feature requests
16:54:13 <bauzas> as sean-k-mooney said, it could be one item worth speaking about
16:54:41 <bauzas> anyway, we're almost at time, so we need to wrap
16:54:45 <r-taketn> I would like to attend PTG and discuss it.
16:55:28 <fwiesel> ls
16:57:30 <bauzas> r-taketn: then please continue to look at the mailing-list, you'll see some emails about the next steps
16:58:22 <bauzas> our agenda is pretty free-form, as soon as we draft some ptg etherpad you should be able to add your topic
16:58:32 <bauzas> ok, that's it for now
16:58:34 <r-taketn> Ok. Thank you for discussing.
16:58:41 <bauzas> any other item to cover ?
16:59:08 <gibi> -
16:59:21 <bauzas> okay then thanks all
16:59:26 <bauzas> #endmeeting