00:01:15 <cyeoh> #startmeeting nova-api
00:01:16 <openstack> Meeting started Fri Apr 11 00:01:15 2014 UTC and is due to finish in 60 minutes. The chair is cyeoh. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:01:19 <openstack> The meeting name has been set to 'nova_api'
00:01:23 <cyeoh> Hi - so who's here today?
00:01:39 <oomichi> Hi!
00:02:01 <alex_xu> Hi!
00:02:34 <cyeoh> ok, let's get started
00:02:40 <cyeoh> #topic v2 on v3 API POC
00:03:13 <cyeoh> so I added a couple of patches to the v2 on v3 API POC patch series
00:03:26 <cyeoh> #link https://review.openstack.org/#/c/85879/
00:03:40 <cyeoh> #link https://review.openstack.org/#/c/85927/
00:03:49 <oomichi> cyeoh: good work:)
00:03:56 <cyeoh> those two combined delay the generation of API error messages until the wsgi point
00:04:12 <cyeoh> so we can translate field names.
00:04:17 <cyeoh> oomichi: thx :-)
00:04:38 <cyeoh> in practice it might need a bit more work eventually if we end up with deeply hierarchal translations required
00:04:53 <cyeoh> but from what I saw of the translation dicts we have so far, its not needed yet, and it demonstrates we can do it.
00:05:16 <cyeoh> I'd appreciate a review of them if you have time
00:05:17 <manslaughter> sorry I'm late (I'm mrda not on Fridays)
00:05:31 <cyeoh> manslaughter: hah, excellent nick :-)
00:06:00 <c_yoyo> so the other one I added was Add logging capability to API input validation
00:06:08 <c_yoyo> #link https://review.openstack.org/#/c/85644/
00:06:18 <c_yoyo> which puts the input validation into a log rather than reject mode.
00:06:41 <c_yoyo> so I think we might have all the major features we want know for the POC?
00:06:55 <c_yoyo> oomichi, alex_xu: did you guys want to add anything re: POC?
00:07:28 <oomichi> cyeoh: now I dont have anything else.
00:07:43 <alex_xu> that's all for me. only one thing I found it is v2.1 and v3 request body can both pass the input validation
00:08:07 <alex_xu> not sure it's need for POC
00:08:31 <c_yoyo> alex_xu: sorry I'm not sure I quite understand which scenario you are talking about there?
00:08:46 <c_yoyo> do you mean cases where the input validation is exactly the same for V2.1 and v3?
00:09:06 <alex_xu> c_yoyo, sorry, I mean if I submit a v2.1 request with v3's style request body, it also can pass the input validation
00:09:32 <c_yoyo> alex_xu: hrm, oh yes.
00:09:38 <oomichi> alex_xu: yes right.
00:09:59 * c_yoyo is not sure how big an issue that is
00:10:04 <oomichi> alex_xu: current v2.1 API allows v3 request format.
00:10:17 <alex_xu> maybe it's is ok for POC, but I think I should warn you guys
00:10:18 <oomichi> c_yoyo: agree
00:10:19 <c_yoyo> that would technically be a backwards compatible change
00:11:08 <oomichi> c_yoyo: +1
00:11:13 <c_yoyo> I can't immediately think of a way of stopping that from happening either.
00:12:15 <c_yoyo> it perhaps allows for an easier transition for clients, some we might be able to reclassify it as a feature rather than a bug :-)
00:12:27 <c_yoyo> s/some/so
00:12:40 <alex_xu> :)
00:12:40 <c_yoyo> #topic api response validation in tempest
00:13:00 <c_yoyo> hrm meetbot seems to have disappeared
00:13:07 <c_yoyo> #topic api response validation in tempest
00:13:25 <c_yoyo> oomichi: do you have anything you want to talk about here?
00:13:33 <oomichi> yes: https://docs.google.com/spreadsheet/ccc?key=0AmYuZ6T4IJETdEVNTWlYVUVOWURmOERSZ0VGc1BBQWc#gid=3
00:13:51 <c_yoyo> #link https://docs.google.com/spreadsheet/ccc?key=0AmYuZ6T4IJETdEVNTWlYVUVOWURmOERSZ0VGc1BBQWc#gid=3
00:13:56 <oomichi> now 22.13% has been done for this work.
00:14:15 <oomichi> 92API's patches are in review.
00:14:26 <oomichi> https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/nova-api-attribute-test,n,z
00:14:36 <c_yoyo> oomichi, excellent :-)
00:14:42 <oomichi> thanks
00:14:55 <c_yoyo> #action everyone review https://review.openstack.org/#/q/status:open+project:openstack/tempest+branch:master+topic:bp/nova-api-attribute-test,n,z patches as much as possible!
00:14:56 <oomichi> and needs more reviews again;-)
00:15:15 * manslaughter will try
00:15:17 <c_yoyo> oomichi: agreed
00:15:19 <alex_xu> maybe I can try some
00:15:35 <oomichi> manslaughter, c_yoyo: thanks!
00:15:47 <oomichi> alex_xu: thanks
00:16:00 <c_yoyo> oomichi: so I don't think we have any technical blocking issues for the api attribute testing do we? It's just a matter of doing them and getting them merged?
00:16:26 <oomichi> c_yoyo: that's right. we can just review them
00:16:34 <c_yoyo> oomichi: cool
00:17:05 <c_yoyo> #topic progress on sdk port for V3 API
00:17:12 <c_yoyo> manslaughter: you're up :-)
00:17:33 <manslaughter> thanks cyeoh
00:17:52 <manslaughter> I've been looking at libcloud and implementing v3 on top
00:18:36 <manslaughter> I haven't made the progress I would have liked (had a few distractions this week) but should have something up early next week to show
00:19:11 <c_yoyo> cool - anything about the v2->v3 changes that make the transition particularly difficult?
00:19:13 <manslaughter> The good news is there's not a lot of API calls in play
00:19:24 <c_yoyo> oh interesting.
00:19:42 <c_yoyo> is that because things like libcloud only support functionality that is available across all the clouds it supports?
00:19:46 <oomichi> manslaughter: good news:)
00:19:53 <manslaughter> correct - lowest common denominator
00:20:08 <c_yoyo> hrm I wonder how common that is amongst cloud sdks
00:20:16 <manslaughter> so right now I'm untangling authentication from the compute api calls
00:20:30 <c_yoyo> which makes me wonder just how many of our api extensions are actually *used*
00:20:39 <manslaughter> i.e. /v2/ for authn and api calls is common
00:20:56 <manslaughter> and trying to do it in a semi-nice way
00:21:03 <c_yoyo> manslaughter: ah, hard coding instead of using the keystone registry I guess
00:21:16 <c_yoyo> I guess its not too surprising that people went that way
00:21:39 <manslaughter> still uncovering - but yes, it appears there's some hard-coding going on
00:21:52 <c_yoyo> #topic API related nova-specs
00:22:13 <c_yoyo> are there any API related nova-specs patches that people really want some review bandwidth on?
00:23:50 <oomichi> c_yoyo and john have already reviewed my nova-specs patch, thanks:)
00:24:02 <c_yoyo> oomichi: cool.
00:24:25 <c_yoyo> I haven't managed to get the nova v3 API nova-specs patches submitted yet. But hopefully very soon now (I keep saying that I know)
00:24:40 <c_yoyo> #topic V3 API related work
00:24:54 <c_yoyo> I'm not sure we have much to talk about here
00:25:01 <c_yoyo> I haven't had time to do much on it yet.
00:25:16 <c_yoyo> alex_xu, oomichi: anything you wanted to mention here?
00:25:34 <c_yoyo> I saw some schema stuff get unabandoned but I think we're still waiting for bp approval?
00:25:35 <oomichi> now we should wait for the summit?
00:25:57 <c_yoyo> oomichi: so I think the stuff left over from icehouse is ok to merge assuming we can bp approval
00:26:02 <oomichi> I guess we need a lot of patches again for v3 API but time is gooing
00:26:14 <c_yoyo> oomichi: yea I'm concerned about waiting a month
00:26:26 <oomichi> c_yoyo: agree.
00:26:42 <c_yoyo> so I think it would be nice to merge what we can and at least have patches up.
00:26:52 <c_yoyo> nova-network support is a big chunk of work
00:26:56 <alex_xu> c_yoyo, v3 related spec can begin for now, all it's also need waiting for summit?
00:27:24 <alex_xu> s/all/or
00:27:29 <manslaughter> c_yoyo: the way forward is to add nova-network into v3 f'sure?
00:27:32 <c_yoyo> alex_xu: so doing the work now comes at the risk that will get ripped out if v3 api gets blocked at summit
00:27:46 <c_yoyo> manslaughter: so there's an interesting discussion there
00:27:48 <alex_xu> c_yoyo, ok, got it
00:28:21 <c_yoyo> johnthetubaguy sort of suggested that we consider not supporting nova network in V3, but if we go the V2.1 route support it there
00:28:29 <manslaughter> or is it tied to v3 as a whole being accepted/abandoned?
00:29:04 <c_yoyo> and supporting it for 2.1 makes supporting it in v3 very easy (and there's not much difference in work)
00:29:15 <c_yoyo> manslaughter: so there's a couple of separate issues there
00:29:20 <c_yoyo> there's v2.1 and v3
00:29:30 <c_yoyo> I honestly don't know how the v3 discussions are going to turn out
00:29:56 <c_yoyo> but re: v2.1 - if we want the V2 API on the new framework I think the v2.1 route is actually the best way to get to V2 on the new framework
00:30:24 <c_yoyo> eg rather than trying to backport the framework to V2, moving V2 capabilities onto V3.
00:30:28 <c_yoyo> even if V3 is not "enabled"
00:30:57 <c_yoyo> one of the big reasons being if we backport the framework and input validation features to V2 codebase it means changing things in place
00:31:10 <c_yoyo> and so those doing CD get the changes (and mistakes) straight away
00:31:21 <c_yoyo> and there is no opportunity for people to test V2.1 first
00:31:35 <c_yoyo> so a V2.1 seems to me to be lower risk
00:31:54 <manslaughter> right
00:32:04 <c_yoyo> manslaughter: anyway this will all have to be argued out at summit ultimately....
00:32:26 <c_yoyo> #topic open discussion
00:33:11 <c_yoyo> PTL voting is still running for a few more hours I think. If you can vote, please do so!
00:33:42 <c_yoyo> anything else people wanted to talk about?
00:34:12 <manslaughter> all sounds good - sounds like I need to get back to reviewing :)
00:34:51 <c_yoyo> manslaughter: heh, me too.
00:35:00 <c_yoyo> ok if there's nothing else we might as well finish early :-)
00:35:08 <c_yoyo> thanks everyone!
00:35:15 <oomichi> thanks!
00:35:20 <alex_xu> thanks!
00:35:23 <c_yoyo> #endmeeting
00:35:24 <manslaughter> thanks!
00:35:24 <GMann> Thanks
00:35:37 <oomichi> and bot could not work:(
00:36:00 <alex_xu> is it related to your name changed c_yoyo ?
00:36:18 <cyeoh> #endmeeting