12:00:28 <alex_xu> #startmeeting nova api
12:00:29 <openstack> Meeting started Fri Jul 10 12:00:28 2015 UTC and is due to finish in 60 minutes.  The chair is alex_xu. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:32 <openstack> The meeting name has been set to 'nova_api'
12:00:44 <alex_xu> hello~ who is here today!
12:00:57 <gmann> hi
12:01:00 <Jeffrey4l> alex_xu, hi
12:01:09 <alex_xu> gmann: Jeffrey4l hi!
12:01:39 <alex_xu> wait one more minute if there are more people join in
12:02:01 <johnthetubaguy> hi
12:02:12 <alex_xu> johnthetubaguy: hi
12:02:25 <johnthetubaguy> I should really run off and get some lunch, soon ish, but just want to make sure you are not being blocked by anything
12:02:33 <johnthetubaguy> there are pending specs I guess
12:02:48 <alex_xu> johnthetubaguy: thanks a lot!
12:03:03 <alex_xu> so let me quick go through all the items
12:03:10 <alex_xu> s/me/us/
12:03:12 <alex_xu> #topic Liberty priority items
12:03:24 <alex_xu> Good news is we merged most of items' spec in L1 except the only one https://review.openstack.org/#/c/173243/
12:03:41 <alex_xu> But I think it won't have too much change. Maybe I should ping Anne to see if she can remove the -1
12:04:19 <alex_xu> #action alex_xu catch Anne to see if she can remove the -1
12:04:36 <alex_xu> For other thing we can focus on code. They are Microversion client, remove v3, policy cleanup.
12:04:45 <alex_xu> Microversion client is ready review for a while~.
12:04:52 <alex_xu> #link https://review.openstack.org/#/c/152569/39
12:05:02 <alex_xu> I reviewed it today, I found it still have some problem. I think it still coding the pattern as API will do version negotiation. That isn't what we discussed before, right?
12:05:18 <alex_xu> johnthetubaguy: sdague ^
12:05:26 <johnthetubaguy> yeah, that doesn't sound correct
12:05:38 <johnthetubaguy> I mean it could be an option, but it certainly shouldn't be the default
12:05:51 <alex_xu> I guess there is something misunderstand what is 'API bit' and 'CLI bit'
12:06:01 <johnthetubaguy> quite possibly
12:06:32 <sdague> yeh, I feel like that whole back and forth has been a lot of communication issues
12:06:46 <sdague> I had thought we got to the bottom of that in the spec
12:07:36 <alex_xu> sdague: do we still need update spec? or just focus on the code now?
12:07:53 <sdague> I think just the code, the spec was obviously not clarifying anything
12:08:06 <alex_xu> sdague: yea...
12:08:25 <johnthetubaguy> +1
12:08:28 <alex_xu> let me see if I can catch the author, try to explain some to him
12:08:30 <johnthetubaguy> (sadly)
12:08:48 <johnthetubaguy> so if a google hangout helps for these things, lets try set that up
12:08:58 <johnthetubaguy> I think we are spread between enough timezones something could work
12:09:42 <johnthetubaguy> (thats me "giving permission", rather than requesting that)
12:10:05 <alex_xu> johnthetubaguy: the author isn't English guys I guess, then +me too...maybe text for me better
12:10:20 <sdague> johnthetubaguy: yeh, or at least get a dedicated chunk of irc time
12:11:33 * nightanne waves over coffee
12:12:20 <johnthetubaguy> yeah, either of those could work
12:12:45 <johnthetubaguy> anyways, sounds like there is more communication needed, but thats cool
12:12:57 <alex_xu> yea, agree
12:13:46 <alex_xu> I can send email to contact the author, then find out a time. or maybe next api meeting
12:14:38 <alex_xu> #action alex_xu send email to contact microversio client author to setup a meeting
12:14:49 <alex_xu> For policy cleanup, I submited more patches~ The final goal is remove the hard-code permission checks decorator.
12:14:51 <johnthetubaguy> cool
12:14:53 <johnthetubaguy> thank you
12:14:55 <alex_xu> #link https://review.openstack.org/200382
12:14:57 <alex_xu> johnthetubaguy: np
12:15:09 <alex_xu> There are some useless db call still using hard-code permission, I want to cleanup the useless db call directly.
12:15:14 <alex_xu> I guess no more question for this
12:15:25 <alex_xu> For removing v3, the patch looks like still under coding, not ready for review yet.
12:15:35 <johnthetubaguy> if a blueprint helps to track those things, we can add one, but its not a requirement
12:16:12 <alex_xu> johnthetubaguy: for removing v3 or policy?, those have bluepring too
12:17:21 <johnthetubaguy> sorry, I was meaning the db calls, although yeah, I guess thats already covered
12:17:35 <alex_xu> johnthetubaguy: yea
12:17:51 <alex_xu> welcome anyone review for priority items~
12:17:54 <alex_xu> let's moving on
12:17:59 <alex_xu> #topic What is next for nova api policy
12:18:21 <alex_xu> After catching a lot of discussion about dynamic policy, I see the thing as sdague said we need waiting for dynamic policy's big picture before we continue policy improvement in nova.
12:18:34 <alex_xu> The propose from sdague about 'default in code', and '/policy' didn't get agreement with keystone guys yet from yet. And from previous meeting, we said we should workout what we want to in the future first. So let us work out the devref first?
12:18:57 <sdague> yeh, I need to circle around with morganfainberg on the oslo.policy changes
12:19:03 <sdague> he seemed pretty ammenable to it
12:19:27 <sdague> but, vacation last week, and working through some other issues this week (like multinode)
12:19:52 <johnthetubaguy> so this was a post summit action I think, don't totally remember who got that one
12:20:01 <johnthetubaguy> I think its good to stop and write down the problems we want to solve
12:20:14 <johnthetubaguy> we do have a lot of policy, all over the place
12:20:36 <johnthetubaguy> I mean we have a big API, thats the root cause
12:20:49 <alex_xu> johnthetubaguy: yea
12:20:59 <johnthetubaguy> anyways, all good, we just need more time in the day
12:21:09 <alex_xu> sdague: actually the propose and idea is from you. Would you like to draft devref?, or you want to others help?
12:21:37 <sdague> it is unlikely that I'll get to it before the midcycle
12:21:48 <johnthetubaguy> so its one of the thing I might draft if I get there first, but i looks unlikely for me too
12:21:49 <sdague> maybe we can allocate a bit of time to talk it through at the midcycle
12:22:06 <johnthetubaguy> I think we already did that at the summit though
12:22:15 <johnthetubaguy> well, maybe not the dynamic bit I supose
12:23:15 <sdague> yeh, I feel like we have end game, but there are details to talk through
12:23:20 <sdague> if there isn't time, that's fine as well
12:24:17 <johnthetubaguy> cool, its probably worth talking through then
12:24:46 <johnthetubaguy> I assigned time on Monday for all the priorities, it could go in there
12:25:20 <alex_xu> ok, cool.
12:26:01 <alex_xu> so waiting for the result from mid-cycle. let's moving on
12:26:10 <alex_xu> #topic What is next for Liberty-2
12:26:26 <alex_xu> We still have few items I think need to do, like remove extension, and api reference doc.
12:26:44 <alex_xu> anything more?
12:27:24 <alex_xu> if no more other thing is more prioirty, I will work on remove extension, probably an nova-specs
12:27:43 <alex_xu> and welcome anyone interesting in it to help on ^
12:28:07 <Jeffrey4l> I can help ;P
12:28:17 <alex_xu> Jeffrey4l: cool, thanks :)
12:28:19 <johnthetubaguy> it would be good to the the docs moving too
12:28:39 <Jeffrey4l> np~
12:28:42 <johnthetubaguy> we really need all the specs in ASAP, if possible
12:28:57 <alex_xu> johnthetubaguy: actually remove extesion is a little related to api reference doc.
12:29:10 <morninganne> alex_xu: can you help with the api ref doc? I have ideas
12:29:19 <alex_xu> because our api ref doc still talk about extension
12:29:28 <alex_xu> morninganne: yea, sure
12:29:40 <alex_xu> #link http://developer.openstack.org/api-ref-compute-v2.1.html#os-extended-availability-zone-v2.1
12:29:48 <alex_xu> ^ it still talk about extesion for v2.1
12:30:01 <morninganne> alex_xu: ideas here http://lists.openstack.org/pipermail/openstack-docs/2015-June/007041.html
12:30:03 <morninganne> #link http://lists.openstack.org/pipermail/openstack-docs/2015-June/007041.html
12:30:27 <morninganne> alex_xu: do you have a doc bug in https://bugs.launchpad.net/openstack-api-site
12:30:33 <alex_xu> morninganne: cool~ this is what I want~
12:30:35 <johnthetubaguy> yeah, we did say the docs should be the main aim for liberty
12:31:02 <alex_xu> morninganne: not yet
12:31:12 <morninganne> johnthetubaguy: +1
12:31:26 <alex_xu> morninganne: so we can switch to swagger now, or we still need maintaince existed api ref doc?
12:31:32 <morninganne> alex_xu: please jump in. I haven't had a chance to tackle the JSON schema work for /actions
12:31:43 <gmann> #link https://review.openstack.org/#/c/177934
12:31:47 <morninganne> alex_xu: we have to maintain while we get the generated swagger solution working
12:31:49 <alex_xu> morninganne: yea /actions is a problem, it isn't discoverable
12:32:01 <gmann> about API ref doc site new idea
12:32:04 <morninganne> read the spec and posts carefully, it's "Swagger-ish" :)
12:32:06 <gmann> FYI
12:32:13 <morninganne> gmann: thanks yes that's the spec
12:32:18 <morninganne> gmann: the list post is the latest progress
12:32:26 <morninganne> I should just merge that spec :)
12:32:56 <gmann> yea
12:33:33 <alex_xu> morninganne: the current api doc ref for v2.1 looks like mess, and it didn't support microversion, I'm not sure maintance it whether is waste, if we can have swagger in no long time
12:33:36 <morninganne> alex_xu: we'll send PRs to https://github.com/russell/fairy-slipper
12:33:45 <morninganne> alex_xu: it's a waste, please work on https://github.com/russell/fairy-slipper
12:33:57 <morninganne> alex_xu: accelerating Swagger is preferred
12:34:14 <alex_xu> morninganne: ok, cool
12:34:18 <morninganne> alex_xu: and microversion for swagger is what we want
12:34:21 <morninganne> to the future! :)
12:34:31 <johnthetubaguy> I think testing the new micro versions in the new thing would be fun
12:34:35 <johnthetubaguy> maybe just do keypairs
12:34:37 <alex_xu> morninganne: yes, agree, and hope we get that for liberty release
12:34:39 <johnthetubaguy> and see how it works?
12:34:41 <morninganne> only 3 months til release right
12:35:07 <alex_xu> morninganne: yea, it's tight
12:35:29 <alex_xu> johnthetubaguy: you mean doc?
12:35:49 <johnthetubaguy> yeah
12:35:58 <morninganne> keypairs where? (tell me more)
12:35:59 <johnthetubaguy> use the new doc system on two microversions
12:36:02 <johnthetubaguy> see how it looks
12:36:23 <morninganne> ah, we'll need more than that though eventually?
12:36:27 <morninganne> (more than pairs?)
12:36:33 <johnthetubaguy> agreed
12:36:39 * russellb is amused he got an irc notification about something called fairy-slipper
12:36:51 <morninganne> russellb: ha ha hah
12:36:54 <johnthetubaguy> just its somewhere we have added a version already
12:36:59 <johnthetubaguy> russellb: hehe
12:37:08 <gmann> :)
12:37:20 <morninganne> never thought about the attention aspect. I have a new lease on life.
12:37:48 <alex_xu> ok, cool
12:37:59 <johnthetubaguy> so its this bit: https://github.com/openstack/nova/blob/master/nova/api/openstack/compute/plugins/v3/keypairs.py#L54
12:38:03 <johnthetubaguy> it has one microversion
12:38:06 <johnthetubaguy> another is in review
12:38:13 <johnthetubaguy> its just an interesting test case
12:38:57 <johnthetubaguy> something tells me that we kinda want v2.0 and v2.1 in the same set of docs really, rather than separate
12:39:09 <alex_xu> johnthetubaguy: yea
12:39:12 <johnthetubaguy> in the same way v2.1 and v2.2 should be in the same docs I guess
12:39:24 <johnthetubaguy> but anyways, keypairs is a small place we could start with I think
12:39:32 <alex_xu> johnthetubaguy: do we still need talk about extension in v2.0?
12:39:49 <morninganne> alex_xu: hm, good question. it's already out there and what people think of at Rackspace
12:40:01 <johnthetubaguy> alex_xu: well consider it removed in v2.1 I guess
12:40:01 <morninganne> but yes, we consider it removed in 2.1
12:40:06 <morninganne> (it being all extensions)
12:40:23 <alex_xu> if v2.0 still consider extensions, then we may not put v2.1 and v2.0 in one doc
12:40:39 <johnthetubaguy> I think we just need to look at it differently
12:40:55 <johnthetubaguy> in v2.0 the extension returns 404 if not listed in that /extensions
12:41:10 <johnthetubaguy> thats gets dropped at some version, once we get that sorted
12:41:36 <johnthetubaguy> I mean when you use v2.1 code, it will not be possible to turn any of those off, but its still technically an API concept
12:41:39 <johnthetubaguy> does that make sense?
12:41:46 <johnthetubaguy> basically call the whole thing the Nova API
12:42:06 <morninganne> johnthetubaguy: not to end users, never use extension for end users
12:42:08 <johnthetubaguy> just note that some bits might be missing, based on the extension list, where as later its a version
12:42:25 <morninganne> johnthetubaguy: we'll use microversions in end user doc though I think
12:42:31 <johnthetubaguy> morninganne: well that is the end user API we have right /extensions
12:42:47 <morninganne> johnthetubaguy: only to people grepping nova code if we can make the docs nice
12:43:02 <morninganne> johnthetubaguy: capabilities/rights not extensions
12:43:12 <johnthetubaguy> thats quite different actually
12:43:12 <morninganne> johnthetubaguy: I'd like to ban the word extensions except for in the nova code
12:43:18 <johnthetubaguy> so its in the API
12:43:25 <morninganne> johnthetubaguy: nooo...
12:43:33 * morninganne is sad panda
12:43:37 <johnthetubaguy> we are trying to remove it
12:43:46 <johnthetubaguy> but its been there since almost the beginning
12:43:50 <johnthetubaguy> and agreed that sucks
12:44:06 <alex_xu> we call it as plugin
12:44:18 <alex_xu> if that sounds better~
12:44:35 <johnthetubaguy> so we don't have to do any of that right
12:44:52 <johnthetubaguy> its simply that an API can be disabled and return 404
12:45:02 <johnthetubaguy> you can see if its disabled by looking in the extension list
12:45:11 <johnthetubaguy> (well see if its enabled, I guess)
12:45:25 <johnthetubaguy> now as of some version, thats no longer there, as its always enabled
12:45:29 <johnthetubaguy> and its pure policy
12:45:34 <johnthetubaguy> I don't think we can hide that
12:45:59 <johnthetubaguy> at no time should we say v2.0 vs extensions any more
12:46:01 <johnthetubaguy> its just a single v2.0 API
12:46:15 <johnthetubaguy> just you can discover if its missing in a particular way
12:46:22 <johnthetubaguy> at least thats what I was thinking
12:46:27 <johnthetubaguy> .... seems like I should write that down
12:47:26 <morninganne> does the policy file say extensions johnthetubaguy?
12:47:30 <morninganne> heh
12:47:40 <morninganne> yes please so I can ban the word extensions (I kid, really)
12:48:20 <johnthetubaguy> morninganne: so the API says extensions
12:48:43 <morninganne> johnthetubaguy: where
12:48:55 <morninganne> docs or code?
12:48:59 <johnthetubaguy> / extenions
12:49:09 <johnthetubaguy> https://github.com/openstack/nova/blob/master/nova/api/openstack/compute/plugins/v3/extension_info.py.
12:49:26 <johnthetubaguy> thats the v2.1 version
12:49:28 <morninganne> oh in the API resource, got it. did y'all have a name debate about /capabilities or anything like that?
12:49:43 <johnthetubaguy> it was added years ago right
12:49:46 <morninganne> (might be too late, just trying to fill in my history knowledge)
12:49:52 <morninganne> johnthetubaguy: to 2.0, sure :)
12:49:52 <johnthetubaguy> thats just keeping compatibility with the old API
12:50:01 <morninganne> johnthetubaguy: oh ok, I get it. yeah
12:50:13 * alex_xu lose the context...
12:50:15 <morninganne> johnthetubaguy: could add a 2nd resource called /capabilities some day
12:50:17 <johnthetubaguy> we didn't want to add it, but yeah, its required
12:50:26 <johnthetubaguy> we are talking about dropping it
12:50:31 <morninganne> alex_xu: oh I'm just trying to eliminate the word extensions but it's a resource in the API
12:50:32 <johnthetubaguy> it doesn't mean anything much any more
12:50:38 <morninganne> johnthetubaguy: cool, that's what I'm looking for
12:50:50 <johnthetubaguy> but yeah, thats the spec we discussed about
12:50:54 <johnthetubaguy> above^
12:51:03 <johnthetubaguy> basically add a microversion to drop /extensions
12:51:06 <alex_xu> morninganne: yea, it just for v2.0 user switch to v2.1 smooth, will drop in the future
12:51:12 <morninganne> ok
12:51:18 <morninganne> :thumbsup"
12:51:22 <morninganne> heh I can't type
12:51:29 <johnthetubaguy> I thought we were basically agreeing
12:51:36 <morninganne> ayup
12:51:45 <morninganne> I mostly just seek understanding when I question :)
12:51:54 <morninganne> not arguing :)
12:52:04 <johnthetubaguy> morninganne: me too, generally
12:52:06 <johnthetubaguy> :)
12:52:30 <alex_xu> ok, cool, so for l2, two items: remove v3 and api doc, any question?
12:52:39 <alex_xu> sorry, remove extension
12:52:42 <johnthetubaguy> anyways, I think we can have a single doc that covers both v2.0 and v2.1 and v2.2, in theory
12:53:03 <johnthetubaguy> but that can be the new doc for v2.1 I guess
12:53:09 <alex_xu> johnthetubaguy: yea, that is the goal
12:53:24 <johnthetubaguy> once the doc covers v2.0 well enough, it replaces the old one, just like the code :)
12:53:45 <johnthetubaguy> alex_xu: cool, just making sure we all thinking the same thing there
12:54:01 <alex_xu> johnthetubaguy: yea
12:55:03 <alex_xu> do we still have question for Liberty-2 works items?
12:56:18 <johnthetubaguy> nothing from me
12:56:29 <alex_xu> ok, cool, no question
12:56:51 <alex_xu> #action alex_xu Jeffrey4l works on remove extensions
12:57:04 <alex_xu> #action alex_xu help morninganne on nova api doc
12:57:14 <morninganne> sweet thanks alex_xu
12:57:24 <alex_xu> morninganne: np :)
12:57:33 <alex_xu> let's moving on
12:57:37 <johnthetubaguy> awesomeness
12:57:39 <alex_xu> #topic open
12:58:12 <alex_xu> two items I listed, hope api team help non-priority feature review, for the api impact feature
12:58:35 <alex_xu> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/068815.html
12:58:40 <alex_xu> I checked just few items
12:58:50 <alex_xu> and some of them is not ready for review
12:59:32 <alex_xu> and there are some api-wg guideline is closed to merge, it worth to review
12:59:34 <alex_xu> #link API-WG guideline review http://lists.openstack.org/pipermail/openstack-dev/2015-July/068682.html
12:59:51 * alex_xu just reivew part of those guideline~
13:00:08 <alex_xu> any more open? if no, then we can let johnthetubaguy go to lunch~
13:00:44 <alex_xu> 3...
13:00:49 <alex_xu> 2..
13:00:55 <alex_xu> 1.
13:01:11 <alex_xu> thanks all!
13:01:17 <alex_xu> #endmeeting