12:01:18 <johnthetubaguy> #startmeeting nova_api
12:01:19 <openstack> Meeting started Fri Aug 7 12:01:18 2015 UTC and is due to finish in 60 minutes. The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:01:23 <openstack> The meeting name has been set to 'nova_api'
12:01:31 <edleafe> o/
12:01:46 <johnthetubaguy> #link https://wiki.openstack.org/wiki/Meetings/NovaAPI
12:01:56 <eliqiao1> O/
12:02:19 <johnthetubaguy> hi, so alex_xu is stuck in water, I think, or something like that
12:02:33 <johnthetubaguy> #topic Liberty Stuff
12:02:39 <johnthetubaguy> #link https://etherpad.openstack.org/p/YVR-nova-liberty-summit-action-items
12:02:47 <johnthetubaguy> anyone got anything to raise for the work items?
12:03:02 <eliqiao1> yeah, alex_xu is swimming in beijing's street :)
12:03:41 <johnthetubaguy> so sdague raised a good point, in that we need to make more progress with API docs
12:03:50 <edleafe> ugh, I didn't hear about that
12:04:20 <johnthetubaguy> I also noticed that the remove extensions spec is not merged for liberty, but we should sure make progress on that too, ideally
12:04:29 <johnthetubaguy> edleafe: how are your patches doing?
12:04:33 <johnthetubaguy> for the rename
12:04:40 <edleafe> I need some fresh eyes
12:04:47 <johnthetubaguy> you got the link handy?
12:04:50 <edleafe> I posted the second phase yesterday
12:04:54 <edleafe> one sec
12:05:08 <edleafe> https://review.openstack.org/#/c/210131/
12:05:15 <johnthetubaguy> #link https://review.openstack.org/#/c/210131/
12:05:33 <edleafe> The failing tests all follow the same pattern, and I can't see how to fix it
12:05:47 <edleafe> seems like something in the wsgi fakes
12:06:39 <johnthetubaguy> oh nasty
12:06:44 <johnthetubaguy> I was just looking at the first one
12:06:52 <johnthetubaguy> https://review.openstack.org/#/c/193725/28
12:06:58 <johnthetubaguy> that has failing tests now I guess
12:07:21 <edleafe> yeah, I saw that one of my junior devs pushed something last night
12:07:41 <edleafe> I think PS 27 only had some spurious failures
12:07:50 <edleafe> haven't looked to see what he changed
12:07:51 <edleafe> yet
12:08:12 * edleafe needs more coffee to think at 7am
12:08:59 <johnthetubaguy> yeah, its early
12:09:00 <johnthetubaguy> https://review.openstack.org/#/c/193725/28/nova/tests/functional/api_samples/legacy_v2/all_extensions/server-get-resp.json.tpl,cm
12:09:06 <johnthetubaguy> thats the bit that seems odd I guess
12:09:25 <johnthetubaguy> wasn't sure why that stuff had changed
12:11:01 <edleafe> me neither
12:11:12 <edleafe> I don't remember touching that myself
12:11:14 <johnthetubaguy> hmm, OK
12:11:27 <johnthetubaguy> so I have a feeling there are a few little gremlins in there
12:11:46 <johnthetubaguy> so this one:
12:11:47 <johnthetubaguy> https://review.openstack.org/#/c/193725/28/nova/api/openstack/compute/legacy_v2/contrib/__init__.py,cm
12:11:49 <sdague> edleafe: well, if you think a smaller series helps get to the bottom of test failures, so be it
12:11:55 <johnthetubaguy> seems like the config changed
12:11:58 <edleafe> not having done any of the v3 stuff, I find myself guessing as to what was supposed to be temporary
12:12:14 <johnthetubaguy> temporary, in what sense?
12:12:23 <johnthetubaguy> you mean which stuff will eventually get removed?
12:12:38 <edleafe> going away once microversions was the law of the land
12:12:55 <johnthetubaguy> right, its the stuff in legacy_v2, as I understand it
12:13:15 <johnthetubaguy> (although there are other things)
12:13:19 <edleafe> johnthetubaguy: well, I meant what in v3 is v21, and what is vestigial
12:13:43 <edleafe> lots of test code has both V21 and V3 test cases
12:13:51 <johnthetubaguy> right, v3 is the v2.1 stuff, the legacy_v2 stuff will get removed after a deprecation sycle
12:13:59 <johnthetubaguy> yeah, thats crazy
12:14:10 <johnthetubaguy> v3 = v2.1 now
12:14:41 <sdague> edleafe: I don't think it really has both, I think not all of it has gotten converted
12:14:55 <johnthetubaguy> ah, that makes sense
12:15:07 <johnthetubaguy> so the unit tests, I see you are moving those, is that a good idea?
12:15:34 <johnthetubaguy> I am thinking we should maybe move those second? given they are slowly converging into a single set of tests anyways?
12:15:39 <edleafe> if the goal is to make things less confusing to newcomers to the code base, yes, they have to be moved too
12:16:12 <edleafe> johnthetubaguy: oh, you mean break things into smaller steps?
12:16:15 <johnthetubaguy> edleafe: I just think it will be simpler to see whats correct once we have moved the API code
12:16:16 <johnthetubaguy> yeah
12:16:41 <edleafe> sdague: yeah, that could be. It's hard to tell with some of it, though
12:17:21 <sdague> johnthetubaguy: yeh, well, I'm a little concerned that we're going to half merge things and make it worse. As long as we are up for late merge with this maybe that's ok
12:17:24 <johnthetubaguy> I mean, once those test imports are updated, I recon life will be easier
12:18:02 <edleafe> sdague: I agree. We should hold off merging these until they are all ready, and then push them at once
12:18:28 <edleafe> sdague: that should achieve the 'pull the band-aid quickly' pain we were hoping for
12:18:30 <johnthetubaguy> so I have a feeling we have a week at the most to get this all in, but thats just my gut feeling
12:19:36 <edleafe> I don't mind doing all the grunt work (pep8 is a huge pain), but if I could get some insight on what I'm doing wrong with the test failures, that would be a big help
12:20:25 <johnthetubaguy> OK, who would you say knows those inside out, I am not sure any more?
12:21:04 <edleafe> In the past alex_xu was pretty helpful, but he's not been around much lately
12:21:24 * edleafe really wishes he could ping Chris Yeoh
12:21:55 <johnthetubaguy> yeah, so I am tempted to have a look, in the spirit of a new pair of eyes
12:22:08 <sdague> sure, it's just going to kind of suck to end this cycle without this bit done
12:22:10 <johnthetubaguy> honestly it looks like we have stuff testing the wrong code bade
12:22:19 <edleafe> that would be greatly appreciated
12:22:56 <edleafe> johnthetubaguy: that's why breaking this up is critical
12:22:56 <johnthetubaguy> OK, I will get some lunch and take a look at this, we need this moving foward
12:22:57 <sdague> so - https://etherpad.openstack.org/p/liberty-nova-api - is an etherpad with the what I think is the required work for 2.1
12:23:01 <sdague> sorry for liberty
12:23:03 <johnthetubaguy> edleafe: yeah, I think you are right
12:23:12 <edleafe> when it was one big patch, you had things pointing to the same file path
12:23:13 <sdague> this is 8. on there
12:23:39 <johnthetubaguy> we are a little ways away from a lot of those right now :'(
12:23:41 <edleafe> it was impossible to distinguish
12:23:44 <johnthetubaguy> although we have time
12:24:18 <johnthetubaguy> edleafe: can we focus on this today, with a view to merge on Monday?
12:24:24 <johnthetubaguy> edleafe: does that seem possible?
12:24:31 <sdague> I'm not sure I feel like I have a good handle on the where all the pieces stand
12:24:47 <edleafe> johnthetubaguy: I'm focused only on this right now
12:24:58 <johnthetubaguy> edleafe: OK, cool, lets do this
12:25:14 <johnthetubaguy> edleafe: I vote for a working series, we can squash stuff later if that makes sense
12:25:16 <edleafe> sdague: welcome to the club! :)
12:25:22 <johnthetubaguy> OK...
12:25:41 <edleafe> johnthetubaguy: squashing makes sense
12:26:12 <johnthetubaguy> edleafe: yeah, get all the tests passing, then worry about the best way to merge, I think thats probably the way to go here
12:26:34 <johnthetubaguy> OK, so how do we work out where we are at?
12:26:44 <edleafe> I'll work on getting all the tests passing for https://review.openstack.org/#/c/193725/
12:26:46 <johnthetubaguy> I am not around for this meeting next week, sadly
12:26:48 <edleafe> it's pretty close
12:26:54 <johnthetubaguy> edleafe: OK
12:27:00 <sdague> ok, so I guess a bit more information is in https://etherpad.openstack.org/p/YVR-nova-liberty-summit-action-items
12:27:03 <johnthetubaguy> I am thinking about the big etherpad right now
12:27:30 <johnthetubaguy> sdague: it should really all be in here: https://etherpad.openstack.org/p/liberty-nova-priorities-tracking but its not
12:27:36 <johnthetubaguy> well the patches I mean
12:28:04 <sdague> #info Microversion support for python nova client - only patch listed merge
12:28:15 <johnthetubaguy> OK, so I don't think we have the right folks here to work out where we go
12:28:25 <johnthetubaguy> sdague: ah, there was a part 2 patch, not sure if that merged
12:28:30 <sdague> #info Restructure API tree to remove v3 and other confusing things - holding on ed getting working patch
12:29:05 <sdague> #info Microversion bump guidelines - Nova devref merged
12:29:20 <sdague> is there anything else we really need on microversion bump guidelines?
12:29:42 <johnthetubaguy> I think we got the key bits done, we can add more examples when its obvious what we should add
12:30:12 <sdague> yeh, it looks like the other items in there are AP-WG ones
12:30:35 <sdague> #info Remainging policy moving to API layer - patches up for review, status needed on how far to go
12:30:47 <sdague> #info Middleware to relax jsonschema validation on v2.0 - patches up for review
12:30:53 <johnthetubaguy> the API extension deprecation and remove, I guess thats a little blocked behind the v3 restructure
12:31:05 <sdague> johnthetubaguy: honestly, not entirely
12:31:12 <sdague> we can fix it on the glass
12:31:38 <johnthetubaguy> OK, that would be good
12:31:56 <sdague> when is L3?
12:32:02 * johnthetubaguy checks
12:32:22 <johnthetubaguy> september 1st
12:32:24 <johnthetubaguy> ish
12:32:29 <johnthetubaguy> https://wiki.openstack.org/wiki/Nova/Liberty_Release_Schedule
12:32:39 <sdague> because I'm only working 4 days next week, then out for 8 days (vacation and linuxcon) so trying to figure out how to keep things moving
12:32:55 <johnthetubaguy> yeah, I am 3 days next week, but back after that
12:33:03 <sdague> #info drop extensions - no progress
12:33:14 <sdague> #info Change default paste pipeline to use v2.1 for v2.0 - no progress
12:33:17 <johnthetubaguy> so I guess we need to tidy up the patches that need review etherpad
12:33:40 <johnthetubaguy> #info deprecate v2_legacy - no progress
12:33:44 <sdague> yeh, how I wish we had better tools to keep an eye on stuff like this :)
12:33:51 <sdague> but, anyway
12:33:54 <johnthetubaguy> +1
12:33:56 <johnthetubaguy> but yeah
12:34:14 <johnthetubaguy> so we could just create a blueprint for each one of these
12:34:32 <sdague> yeh, lets do that out of band though.
12:34:37 <johnthetubaguy> yup
12:34:47 <sdague> Also, I won't be here for the next 2 of these meetings, flying both days
12:34:49 <eliqiao1> #info python-novaclient microverversion got +2 already, need 1 more +2 https://review.openstack.org/#/q/status:open+project:openstack/python-novaclient+branch:master+topic:bp/api-microversion-support,n,z
12:35:09 <johnthetubaguy> sdague: yeah, I miss the next one, but I am around for the one after that
12:35:43 <sdague> eliqiao1: thanks
12:35:47 <sdague> ok, I just approved those
12:37:20 <sdague> ok, so that's at least a thing
12:37:33 <sdague> #info python microversion client support approved and headed to the gate
12:37:37 <johnthetubaguy> yep, there are some good patches to support microversions following that
12:37:46 <sdague> I approved the console one
12:37:55 <johnthetubaguy> cool
12:37:56 <sdague> the nmi stuff still needs the api to land
12:38:00 <johnthetubaguy> yeah
12:38:35 <sdague> so... I'm kind of confused why nmi is a useful API
12:38:49 <sdague> because, how is one expected to see the crash dump
12:39:07 <johnthetubaguy> I don't remember how that worked in the spec now
12:39:10 <johnthetubaguy> possible the console log?
12:39:26 <sdague> oh, the spec isn't approved either
12:39:40 <johnthetubaguy> hmm, how did we miss that :S
12:40:10 <johnthetubaguy> http://specs.openstack.org/openstack/nova-specs/specs/liberty/approved/inject-nmi.html
12:40:36 <kashyap> sdague: Randomly chiming in, on systemd-enabled systems you can view core dumps easy using `coredumpctl`
12:40:59 <sdague> johnthetubaguy: there's an update to the spec
12:41:08 <sdague> so, honestly, I want to not call this nmi
12:41:20 <johnthetubaguy> ah, OK
12:41:33 <sdague> it should be called crashdump or something
12:41:43 <sdague> and it happens that we do nmi calls for some backends
12:41:50 <sdague> but how to trigger a dump might be different
12:41:59 <sdague> based on OS or hypervisor
12:42:47 <johnthetubaguy> yeah, that makes a lot of sense
12:42:55 <sdague> kashyap: ok, reading the spec I see that it will be stored in the guest filesystem
12:43:05 <sdague> makes a little more sense to me about that
12:44:04 <kashyap> sdague: Afraid, haven't read the spec completely. Will do after lunch.
12:44:13 <sdague> johnthetubaguy: ok, so given the spec is already approved, how do you want me to give that feedback?
12:44:41 <sdague> also, appologies to not having caught any of these API things during the big spec push
12:45:06 <johnthetubaguy> sdague: I guess firstly on the code review, we can generate a spec review to keep it consistent on top of that, I guess?
12:45:46 <johnthetubaguy> my concern is, we kinda merge that today, or in mitaka, based on the current plan
12:46:05 <johnthetubaguy> now, we totally shound't just merge what we have
12:46:15 <johnthetubaguy> just thinking how to express the merge of the better thing
12:46:47 <sdague> yep
12:46:59 <johnthetubaguy> I have a feeling the right thing might be to -2 and say its not quite ready yet
12:47:01 <sdague> ok, works for me
12:47:28 <johnthetubaguy> I would rather that, than merge a bad API we need to rename later
12:47:41 <sdague> yeh
12:47:46 <sdague> ok, I'll do that.
12:47:59 * johnthetubaguy chooses path of least suck
12:48:17 <edleafe> johnthetubaguy: heh
12:48:17 <johnthetubaguy> OK, how are we doing for other things
12:48:34 <johnthetubaguy> I think there are quite a few actions to follow up on
12:49:03 <johnthetubaguy> #action johnthetubaguy to catch up with alex_xu and others in his morning about the current state of API efforts
12:49:09 <johnthetubaguy> so I should do that ^
12:49:10 <sdague> right so how about the following. I'll update the API Agenda in the wiki with the high level items we are tracking that should be on the agenda each time
12:49:23 <johnthetubaguy> sdague: sounds like a top idea
12:49:44 <johnthetubaguy> that should help drive us forward a bit more, good plan
12:49:50 <sdague> yeh
12:50:10 <johnthetubaguy> I will let the know why the agenda change, if I catch them online
12:50:30 <johnthetubaguy> #action sdague to update the agenda for this meeting to cover the key focus areas of the API work
12:50:41 <johnthetubaguy> #topic Open Discussion
12:50:52 <johnthetubaguy> so I am thinking we are about done now?
12:50:57 <sdague> well 2 things
12:51:03 <johnthetubaguy> ah, fire away
12:51:44 <sdague> 1) I talked with annegentle about our need for a new concept guide. I figure that's a thing I'm going to start writing after we ensure all the critical stuff is landed
12:51:50 <sdague> it will live in the nova tree
12:51:57 <sdague> but publish to developer.openstack.org
12:52:05 <johnthetubaguy> ah, OK
12:52:19 <sdague> I'm assuming that will be a thing we can merge patches on during the freeze
12:52:20 <johnthetubaguy> ah, wait, yeah, thats the correct place for it
12:52:29 <johnthetubaguy> sdague: +1 for docs
12:52:56 <sdague> 2) been talking with dolphm and annegentle about service catalog futures
12:52:59 <johnthetubaguy> sdague: oh wait, the translation people might need to hear about that, but I don't think we translated those at the moment
12:53:18 <sdague> I don't think developer.openstack.org is translated, is it?
12:53:29 <johnthetubaguy> sdague: not as far as I know
12:53:44 <sdague> yeh, so I'm going to punt on i18n on it for now
12:53:57 <sdague> anyway, service catalog
12:54:11 <johnthetubaguy> its just the string freeze, and we are adding text, but thats fine if they know not to translate it
12:54:16 <sdague> right
12:54:16 <johnthetubaguy> yeah, service catalog
12:54:43 <johnthetubaguy> so part of this is having a consistent one between all deploys I guess
12:54:59 <sdague> yeh, there are a few things
12:55:14 <sdague> first, all services should use the service catalog to talk to things, and not config vars
12:55:50 <johnthetubaguy> OK, makes sense, but I do wonder if we still get to have a list of API endpoints for glance, etc
12:55:52 <sdague> there is a patch to nova to get glance via service catalog which does not yet exist
12:56:05 <johnthetubaguy> yeah
12:56:30 <sdague> but, I think we also wanted to get rid of {tenant_id} in the Nova API urls
12:56:43 <sdague> because it's known in the token/context
12:56:53 <sdague> so just weird and reduntant in the url
12:57:05 <johnthetubaguy> oh, there was some debate I saw about that on an internal list, I wondered how that came back up
12:57:20 <johnthetubaguy> so we can do that in a microversion, I guess...
12:57:39 <sdague> it's a little more complicated than that, however there is a cross project spec, and I'll update with a detailed plan
12:57:50 <johnthetubaguy> yes, the old stuff is tricky
12:57:57 <johnthetubaguy> OK, I should read that
12:57:57 <sdague> this is all M and N timeframe
12:58:03 <johnthetubaguy> yeah
12:58:16 <johnthetubaguy> its good to get this out in the open pre summit, so sounds like good timing
12:58:18 <sdague> but I'd like to get the spec in shape before Tokyo so we can move forward
12:58:27 <johnthetubaguy> totally
12:58:52 <sdague> the patch for glance off the service catalog should show up this cycle, I'll do that one
12:59:26 <sdague> and that's it fromme
13:00:18 <johnthetubaguy> OK, the bit that worries me is making the list of API endpoints work, although thats partly something we should get away from
13:00:35 <sdague> yeh, I think I have a plan
13:00:41 <johnthetubaguy> so the history there is, when downloading and uploading, its nice not to have a loadbalancer in the way
13:00:49 <johnthetubaguy> at least, thats why I care about it
13:01:07 <johnthetubaguy> although we have starting moving to a redirecting loadbalancer instead
13:01:10 <johnthetubaguy> anyways, sounds good
13:01:16 <johnthetubaguy> I guess we are out of time, so we should stop
13:01:41 <johnthetubaguy> thanks all, some good debate there, thanks sdague for helping kick this into a higher gear
13:01:46 <johnthetubaguy> #endmeeting