#openstack-meeting: nova api

Meeting started by alex_xu at 12:00:09 UTC (full logs).

Meeting summary

  1. Actions from last meeting (alex_xu, 12:02:46)
    1. https://wiki.openstack.org/wiki/Meetings/NovaAPI (alex_xu, 12:03:37)

  2. API infrastructure (alex_xu, 12:04:12)
  3. v2.0 on v2.1 (alex_xu, 12:05:45)
    1. https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/api-relax-validation,n,z (alex_xu, 12:06:08)
    2. 3 of 4 patches merged for API validation relaxation needed for v2.0 on v2.1 (sdague, 12:06:32)
    3. ACTION: sdague to build experimental devstack/tempest job to test v2.0 on v2.1 (sdague, 12:09:22)

  4. policy.json updates to remove admin hard code at the db level (alex_xu, 12:12:53)
    1. https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/nova-api-policy-final-part,n,z (alex_xu, 12:13:11)
    2. 3 patches left to merge before policy.json updates to remove admin hard code at the db level is done (sdague, 12:14:11)

  5. Test collapse of v2.0 and v2.1 (alex_xu, 12:15:38)
    1. https://etherpad.openstack.org/p/nova-low-hanging-fruit (johnthetubaguy, 12:16:56)
    2. https://wiki.openstack.org/wiki/Nova/Mentoring (johnthetubaguy, 12:17:03)
    3. elevated_context cleanup will happen in Mitaka cycle (sdague, 12:17:37)
    4. ACTION: /me create bp for elevated context cleanup and update low-hanging fruit etherpad (alex_xu, 12:19:02)
    5. https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:merge_sample_tests,n,z (alex_xu, 12:19:21)
    6. put merge of v2.0 / v2.1 tests on hold until v3 removal is complete (sdague, 12:22:10)
    7. ACTION: get status from gmann on overall completeness of the v2.0 / v2.1 test collapse (sdague, 12:25:47)

  6. Removal of v3 naming from source tree (alex_xu, 12:27:29)
    1. https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bug/1462901,n,z (alex_xu, 12:28:12)

  7. API Documentation Improvement (alex_xu, 12:36:25)
  8. API futures - specs (alex_xu, 12:40:59)
    1. ACTION: sdague to find gerrit query to pull all API changed specs (sdague, 12:45:09)
    2. https://review.openstack.org/#/dashboard/?title=Nova+API+Spec+Dashboard&foreach=project:openstack/nova-specs&Reviewed+by+me=reviewer:xuhj+is:open+message:apiimpact&Recently+Closed+And+Reviewed+by+me=is:closed+limit:15+message:apiimpact&Recently+Closed=is:closed+reviewer:self+limit:30+message:apiimpact&Open=is:open+message:apiimpact (alex_xu, 12:46:07)
    3. https://review.openstack.org/#/c/198622/2 (alex_xu, 12:48:39)
    4. https://review.openstack.org/#/c/202617/ (alex_xu, 12:52:11)

  9. API futures - patches for approved specs (alex_xu, 12:55:52)
  10. open (alex_xu, 12:56:22)


Meeting ended at 13:02:35 UTC (full logs).

Action items

  1. sdague to build experimental devstack/tempest job to test v2.0 on v2.1
  2. /me create bp for elevated context cleanup and update low-hanging fruit etherpad
  3. get status from gmann on overall completeness of the v2.0 / v2.1 test collapse
  4. sdague to find gerrit query to pull all API changed specs


Action items, by person

  1. sdague
    1. sdague to build experimental devstack/tempest job to test v2.0 on v2.1
    2. sdague to find gerrit query to pull all API changed specs
  2. UNASSIGNED
    1. /me create bp for elevated context cleanup and update low-hanging fruit etherpad
    2. get status from gmann on overall completeness of the v2.0 / v2.1 test collapse


People present (lines said)

  1. sdague (115)
  2. alex_xu (100)
  3. johnthetubaguy (70)
  4. edleafe (17)
  5. claudiub (3)
  6. openstack (3)


Generated by MeetBot 0.1.4.