#openstack-meeting: nova api

Meeting started by alex_xu at 12:00:17 UTC (full logs).

Meeting summary

  1. Actions from last meeting (alex_xu, 12:03:00)
    1. https://github.com/stackforge/gerrit-dash-creator/blob/master/dashboards/nova-api.dash (alex_xu, 12:04:21)
    2. (alex_xu, 12:04:49)
    3. https://review.openstack.org/#/dashboard/?foreach=%28project%3Aopenstack%2Fnova+OR+project%3Aopenstack%2Fpython%252Dnovaclient+OR+project%3Aopenstack%2Fnova%252Dspecs%29+%28%28file%3A%5E.%2Anova%2Fapi.%2A+OR+file%3A%5E.%2Aapi_samples.%2A%29+OR+message%3Aapiimpact%29+status%3Aopen+NOT+owner%3Aself+NOT+label%3AWorkflow%3C%3D%252D1+label%3AVerified%3E%3D1%252cjenkins+NOT+label%3ACode%252DReview%3E%3D% (alex_xu, 12:04:51)

  2. v2.0 on v2.1 (alex_xu, 12:07:39)
    1. https://review.openstack.org/#/c/214085/ (johnthetubaguy, 12:08:11)
    2. https://review.openstack.org/215436 (alex_xu, 12:09:02)
    3. ACTION: alex_xu to create updated validation patch which strips out extra params (sdague, 12:23:07)
    4. ACTION: sdague to address any additional tempest issues (sdague, 12:23:31)

  3. Test collapse of v2.0 and v2.1 (alex_xu, 12:23:56)
    1. https://review.openstack.org/#/c/163718/ , https://review.openstack.org/#/c/207183/ (gmann_, 12:25:11)
    2. ACTION: sdague will sort out our eventual test matrix here (alex_xu, 12:27:20)
    3. https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/test-collapse-v2-and-v21,n,z (gmann_, 12:30:11)

  4. Test collapse of v2.0 and v2.1 (alex_xu, 12:30:19)
  5. Removal of v3 naming from source tree (alex_xu, 12:32:39)
    1. https://review.openstack.org/#/c/214592/ (johnthetubaguy, 12:34:00)

  6. microversions client (alex_xu, 12:44:05)
    1. https://github.com/openstack/python-novaclient/commit/39739158b0cf10a775fd3899e35df7f53b4c9336 (alex_xu, 12:44:07)

  7. API Documentation Improvement (alex_xu, 12:48:15)
    1. https://etherpad.openstack.org/p/nova-v2.1-api-doc (alex_xu, 12:48:25)
    2. https://github.com/elmiko/pecan-swagger somebody work on generate swagger from pecan (alex_xu, 12:53:10)
    3. detailed API doc plan discussion in 2 weeks time (sdague, 12:58:13)

  8. open (alex_xu, 12:58:55)
    1. https://review.openstack.org/#/c/209917/ (alex_xu, 12:59:24)


Meeting ended at 13:01:28 UTC (full logs).

Action items

  1. alex_xu to create updated validation patch which strips out extra params
  2. sdague to address any additional tempest issues
  3. sdague will sort out our eventual test matrix here


Action items, by person

  1. alex_xu
    1. alex_xu to create updated validation patch which strips out extra params
  2. sdague
    1. sdague to address any additional tempest issues
    2. sdague will sort out our eventual test matrix here


People present (lines said)

  1. alex_xu (104)
  2. sdague (92)
  3. johnthetubaguy (88)
  4. gmann_ (54)
  5. edleafe (17)
  6. oomichi (12)
  7. bauzas (6)
  8. Kevin_Zheng_ (4)
  9. openstack (3)
  10. claudiub (1)


Generated by MeetBot 0.1.4.