12:00:23 <alex_xu> #startmeeting nova api
12:00:24 <openstack> Meeting started Tue Sep  1 12:00:23 2015 UTC and is due to finish in 60 minutes.  The chair is alex_xu. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:27 <openstack> The meeting name has been set to 'nova_api'
12:00:37 <alex_xu> Hello, Who is here today
12:01:04 <edleafe> o/
12:01:12 <gmann_> o/
12:01:21 <oomichi> hello :)
12:01:29 <alex_xu> hello everyone :)
12:01:44 <alex_xu> let's run the meeting
12:01:55 <alex_xu> #topic actions from last meeting
12:02:06 <alex_xu> alex_xu to updated validation patch which strips out extra params
12:02:13 * edleafe runs out for a few minutes to send family off for the day
12:02:17 <alex_xu> I have done that, and the patch merged!
12:02:19 <alex_xu> #link https://review.openstack.org/215436
12:02:25 <alex_xu> edleafe: no problem
12:02:32 <oomichi> alex_xu: cool
12:02:39 <alex_xu> sdague to address any additional tempest issues
12:02:52 <oomichi> that seems also done
12:02:54 <alex_xu> this also done
12:02:57 <alex_xu> #link https://review.openstack.org/216784
12:02:59 <gmann_> alex_xu: that was done
12:03:05 <alex_xu> yea
12:03:20 <alex_xu> one more for sdague: sdague will sort out our eventual test matrix here
12:03:46 <alex_xu> sdague: hi, are you around?
12:04:23 <alex_xu> emm...I guess he is busy on gate. there is something trouble with gate
12:04:41 <oomichi> yeah
12:04:42 <alex_xu> let me check with him after meeting
12:04:44 <sdague> alex_xu: yeh, I'm around, but a little touch and go
12:04:59 <alex_xu> sdague: yea, no problem
12:05:07 <sdague> so, yes, we addressed the tempest issue
12:05:45 <alex_xu> sdague: any update about the test? I think the important one is v2 test job
12:05:47 <sdague> the thing I have not done, that I said I would, is an overall test plan here. I started working on it, then the gate wedged up last week, and I've been trying to get it back to low failure rate for freeze
12:06:00 <sdague> so, my feeling is the following
12:06:09 <sdague> we should make v2.1 the default
12:06:14 <sdague> in the test runs
12:06:26 * edleafe returns
12:06:34 <alex_xu> #link https://review.openstack.org/#/c/207183/
12:06:35 <sdague> then have 2 runs that are only on nova, which is v2.0 on v2.0 stack and v2.0 on v2.1 stack
12:06:41 <alex_xu> sdague: i guess this patch ^
12:06:55 <sdague> alex_xu: well, I think that patch is probably not quite right
12:07:09 <gmann_> sdague: +1 for plan.
12:07:25 <alex_xu> sdague: ok
12:07:36 <alex_xu> sdague: any help you need?
12:07:44 <sdague> anyway, I can also write down the plan in detail if someone else can fling patches
12:07:55 <gmann_> sdague: are you planning to do those with catalog type or changing paste.ini from devstack
12:07:57 <sdague> I'll do that on an etherpad as soon as we're done here
12:08:01 <alex_xu> I can work on the patch
12:08:06 <gmann_> sdague: i can help on those
12:08:09 <gmann_> alex_xu: cool
12:08:20 <sdague> gmann_: for v2.1 and v2.0 on v2.1 that should be the way we setup paste directly
12:08:34 <sdague> v2.0 on v2.0 is going to require a paste change in devstack
12:08:48 <gmann_> sdague: yea
12:08:51 <alex_xu> sdague: yea
12:09:01 <sdague> so there will be a devstack logic bit, then setting the compute url in tempest bit
12:10:00 <alex_xu> sdague: ok, so you will write down etherpad? them I and gmann_ will work on it
12:10:03 <sdague> anyway, I'll write up the plan as soon as the meeting is over
12:10:04 <alex_xu> s/them/then
12:10:12 <alex_xu> sdague: thanks!
12:10:18 <gmann_> sdague: alex_xu cool Thanks.
12:10:26 <sdague> #action sdague to write up test plan for v2.x nova, alex_xu and gmann_ will work on patches
12:10:36 <sdague> thanks folks
12:10:57 <alex_xu> sdague: ok, you are typing faster than me...
12:11:01 <alex_xu> sdague: np
12:11:16 <alex_xu> so any more question, then let's move on
12:11:36 <alex_xu> #topic v2.0 on v2.1
12:11:43 <alex_xu> #info The patch for fixing tempest on extra param is merged https://review.openstack.org/216784
12:11:51 <alex_xu> #info The patch for striping the extra params out is merged https://review.openstack.org/#/c/215436/
12:12:02 <alex_xu> #info The patch for using v2.1 only in api-paste.ini is merging https://review.openstack.org/#/c/214085/
12:12:28 <alex_xu> the only left one is about logging warn message when v2 and v3 running
12:12:30 <alex_xu> #link #link https://review.openstack.org/219188
12:12:49 <alex_xu> oomichi: sdague ^ hope you can take a look at after meeting
12:13:01 <oomichi> alex_xu: ok :)
12:13:05 <oomichi> one second
12:13:06 <gmann_> alex_xu: whats about this one - https://review.openstack.org/#/c/217727/
12:13:15 <alex_xu> oomichi: thanks
12:13:16 <gmann_> alex_xu: we need that also
12:13:52 <sdague> alex_xu: will do
12:13:58 <alex_xu> gmann_: thanks, I missed that one
12:14:24 <gmann_> alex_xu: np
12:14:30 <sdague> alex_xu: yeh, we'll need to rerun tests on that
12:14:38 <sdague> because of the ironic dib test fail
12:14:38 <alex_xu> I will check whether the patch need update, as johnthetubaguy is away thoes two days
12:14:41 <edleafe> I can look into that one
12:15:19 <alex_xu> sdague: ok
12:15:23 <alex_xu> edleafe: which one?
12:15:37 <alex_xu> https://review.openstack.org/#/c/217727/ ?
12:15:46 <edleafe> alex_xu: https://review.openstack.org/#/c/217727/
12:15:49 <edleafe> yes
12:15:58 <alex_xu> edleafe: cool, thanks
12:16:14 <alex_xu> edleafe: so let me help on review
12:16:21 <edleafe> alex_xu: ok
12:16:56 <alex_xu> I think that's all for v2 on v2.1, anything more I missed?
12:17:30 <alex_xu> #info https://review.openstack.org/219188 and https://review.openstack.org/#/c/217727/ are last two patches about v2 on v2.1
12:17:47 <alex_xu> ok, looks like no more question
12:17:50 <alex_xu> let's move on
12:17:56 <alex_xu> oops
12:18:09 <alex_xu> #action edleafe will update https://review.openstack.org/#/c/217727/
12:18:11 <alex_xu> edleafe: :)
12:18:20 <edleafe> cool
12:18:35 <alex_xu> #topic v2.1 default on gate
12:18:48 <alex_xu> I think we already talk about this in the beginning
12:18:59 <alex_xu> anything more want to talk about?
12:19:05 <oomichi> one point
12:19:15 <alex_xu> oomichi: yea, please
12:19:32 <oomichi> johnthetubaguy makes legacy v2 comp API as the default.
12:19:47 <oomichi> isn't that enough for us?
12:19:49 <alex_xu> oomichi: yea
12:20:03 <alex_xu> oomichi: no, we should make v2.1 as the default
12:20:19 <oomichi> without legacy mode, right?
12:20:24 <alex_xu> oomichi: yea
12:20:33 <oomichi> ah, I see.
12:20:43 <oomichi> so another question is
12:20:48 <gmann__> alex_xu: oomichi : yea
12:21:05 <oomichi> how to test legacy v2, legacy v2 comp and v2.1 on the gate?
12:21:20 <oomichi> do we need to test all APIs?
12:21:47 <gmann__> oomichi: we can have v2.1 default and separate job for each on v2 and v2 on v21
12:22:11 <oomichi> gmann__: I see, yeah that is reasonable.
12:22:17 <gmann__> oomichi: sdague will write up the plan in detail
12:22:31 <alex_xu> oomichi: yea, we talked it in the beginning of the meeting, Sean will go to write down the detail paln
12:22:40 <oomichi> gmann__: ok, I'd like to see it :)
12:23:11 <oomichi> alex_xu: thanks, my question is solved ;)
12:23:17 <alex_xu> oomichi: np :)
12:23:24 <gmann__> oomichi: thanks
12:23:35 <alex_xu> then let's move on?
12:23:53 <alex_xu> #topic Test collapse of v2.0 and v2.1
12:24:06 <alex_xu> gmann__: I think all the works already done, right?
12:24:15 <gmann__> alex_xu: yea those are done.
12:24:24 <alex_xu> #info all the works of collapse of v2 and v2.1 tests are done, thanks to gmann__ !
12:24:46 <gmann__> alex_xu: we have now single set of sample files. sdague will be much happy :)
12:24:55 <oomichi> gmann__: thanks for the works
12:25:03 <gmann__> oomichi: np
12:25:13 <alex_xu> gmann__: yea, actually everybody happy, thanks for the works :)
12:25:22 <gmann__> alex_xu: yea. np
12:25:28 <alex_xu> so let's move on
12:25:30 <alex_xu> #topic Remove extensions
12:25:36 <alex_xu> #info Deprecated v2.1 extension options patch is merged https://review.openstack.org/214592
12:25:49 <alex_xu> one more patch for deprecated v2 extension option didn't merge yet
12:25:55 <alex_xu> #link https://review.openstack.org/214601
12:26:12 <alex_xu> hope everybody can review it
12:26:23 <alex_xu> oomichi: sdague ^ special you :)
12:26:52 <oomichi> alex_xu: got it o/
12:26:57 <alex_xu> then I think this the parts of remove extension in Liberty
12:27:01 <alex_xu> oomichi: thanks :)
12:27:15 <sdague> alex_xu: :)
12:27:18 <alex_xu> anymore question or missing?
12:27:42 <alex_xu> so let's move on
12:27:46 <alex_xu> #topic Removal of v3 naming from source tree
12:27:54 <alex_xu> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:x3,n,z
12:28:01 <alex_xu> there are two patches
12:28:19 <alex_xu> but those can be merged after freeze, as they are bug fix
12:28:27 <edleafe> alex_xu: johnthetubaguy wants to wait for freeze to merge them
12:28:37 <alex_xu> edleafe: yea
12:28:39 <edleafe> they don't affect logic, but could cause extra rebases
12:28:54 <alex_xu> but I find one thing we should merge before string freeze
12:28:59 <edleafe> so I'm fine waiting
12:29:00 <alex_xu> #link https://review.openstack.org/219188
12:29:06 <gmann__> alex_xu: edleafe : yea that will good
12:29:19 <alex_xu> edleafe: yea, really thanks all the works :)
12:29:27 <edleafe> alex_xu: yes, already reviewed
12:29:33 <alex_xu> edleafe: thanks
12:30:01 <oomichi> alex_xu: can you respin https://review.openstack.org/#/c/214601/ instead of johnthetubaguy?
12:30:12 <oomichi> alex_xu: I found a wrong message on the patch
12:30:32 <oomichi> alex_xu: after the meeting
12:30:39 <alex_xu> oomichi: no problem, thanks!
12:31:09 <alex_xu> oomichi: and this for you https://review.openstack.org/219188, probably one minute review
12:31:44 <oomichi> alex_xu: that was done already ;)
12:31:50 <alex_xu> oomichi: cool!
12:32:00 <alex_xu> ok, let's move on
12:32:03 <alex_xu> #topic API Documentation Improvement
12:32:05 <oomichi> sdague 's turn
12:32:13 <alex_xu> heh :)
12:32:27 <gmann__> oomichi: :)
12:32:47 <alex_xu> so for doc, I guess we didn't have too much update this point
12:33:01 <annegentle> I'm here fwiw
12:33:10 <alex_xu> annegentle: good morning
12:33:16 <annegentle> g'mornin'
12:33:19 <oomichi> annegentle: morning :)
12:33:38 <annegentle> Russell and I met yesterday and yes you do have to have WADL to get the swagger/json output.
12:33:54 <alex_xu> there is plan for swagger poc in summit, but probably we aren't start yet, as this isn't the focus at this point
12:33:54 <annegentle> We're meeting with Monty this afternoon to discuss server setup to display the docs.
12:34:18 <alex_xu> annegentle: why have to? can we jump over the WADL?
12:34:19 <annegentle> Russell and I have a talk Tuesday afternoon about progress so far
12:34:39 <annegentle> alex_xu: if you'd like to go directly to swagger that's fine but the tooling isn't available for nova, unless you write it
12:34:58 <annegentle> alex_xu: looking at it, Russell thinks tempest is the way to get request/responses and errors then add those to the doc
12:35:12 <oomichi> I have a little crazy idea for getting API sample files from tempest.log as the alternative.
12:35:21 <alex_xu> annegentle: yea, I and oomichi gmann__ probably will work on it
12:35:25 <annegentle> oomichi: yeah that's probably along the same idea
12:35:26 <gmann__> annegentle: alex_xu : updating WADL manually needs lot of affort
12:35:35 <annegentle> alex_xu: oomichi gmann__ excellent
12:35:39 <oomichi> we will be able to use it for all projects.
12:35:44 <sdague> annegentle: I thought we were getting away from WADL
12:35:55 <annegentle> gmann__: yeah I'm not advocating for WADL, just letting you know there's no generator other than from WADL
12:35:58 <annegentle> gmann__: that's all
12:35:59 <alex_xu> gmann__: yea, that is why we jump over WADL
12:36:14 <annegentle> oomichi: that's great
12:36:24 <oomichi> annegentle: thanks, I can try prototype based on positive feedback :)
12:36:45 <alex_xu> oomichi: so in the future, we will remove the api sample tests?
12:36:47 <gmann__> annegentle: humm,
12:36:56 <alex_xu> if your idea works
12:36:59 <annegentle> I had an off-list reply to my ML http://lists.openstack.org/pipermail/openstack-dev/2015-August/072546.html
12:37:17 <oomichi> alex_xu: I canot say it at this time
12:37:45 <sdague> anyway, I've not really had enough concentration on this issue atm given some of the other freeze related things
12:37:45 <annegentle> woops can't find it now, but basically looking for ways to baseline and compare swagger files
12:37:47 <oomichi> alex_xu: I am thnking sample files should be maintained on each probject ideally as the first place
12:38:05 <gmann__> oomichi: alex_xu : yea we may need sample files but we can see those based on how tempest thing goes
12:38:52 <annegentle> gmann__: and oomichi: I agree with you to eventually get rid of the generated samples if tempest works out
12:38:58 <alex_xu> gmann__: oomichi ok, let's see what happened
12:39:10 <annegentle> ok
12:39:36 <gmann__> annegentle: yea, that will be much more generic.
12:39:43 <alex_xu> annegentle: thanks for info, let's get back to this after freeze
12:40:04 <annegentle> ok -- thanks for looking for generic solutions
12:40:32 <alex_xu> anything more question, then let's move on?
12:40:55 <alex_xu> #topic API futures - patches for merge
12:41:13 <alex_xu> only one I noticed and the code is good shape
12:41:16 <alex_xu> #link #link https://review.openstack.org/217572
12:41:20 <alex_xu> gmann__: ^ :)
12:41:32 <gmann__> alex_xu: yea
12:41:52 <gmann__> That is bug fix for VIF thing, spec was approved already
12:42:00 <alex_xu> not sure we have enough bandwidth for it, but I give +1, give it my  best bless
12:42:07 <gmann__> oomichi: reviewed. Than ks
12:42:21 <gmann__> alex_xu: yea, just need 1 more +2
12:42:38 <gmann__> sdague: ^^ in your free time
12:42:42 <alex_xu> gmann__: yea, good luck
12:42:49 <oomichi> that's also sdague's turn
12:42:50 <oomichi> yea
12:42:59 <gmann__> and with that one  more - https://review.openstack.org/#/c/198944/
12:43:24 <alex_xu> gmann__: yea, that is important
12:43:25 <gmann__> that is kilo backporting for VIF thing. master one is already megred
12:43:49 <gmann__> master one  - https://review.openstack.org/#/c/198934/
12:44:02 <edleafe> oomichi: I can fix the missing space on https://review.openstack.org/#/c/214601/ and push a new version, if you and sdague are around to re-review it
12:44:05 <gmann__> sdague: oomichi this one too - https://review.openstack.org/#/c/198944/
12:44:39 <oomichi> edleafe: thanks, will re-review it soon after that
12:44:46 <alex_xu> ok, let's jump to open directly
12:44:48 <alex_xu> #topic open
12:45:08 <alex_xu> I started the microversions api-wg guideline again
12:45:10 <alex_xu> #link https://review.openstack.org/187112
12:45:19 <sdague> +A on https://review.openstack.org/#/c/217572
12:45:25 <alex_xu> so hope everyone can take a look at it after freeze
12:45:37 <gmann__> sdague: Thanks
12:45:52 <alex_xu> gmann__: hah, good luck :)
12:46:09 <gmann__> alex_xu: :)
12:46:30 <alex_xu> anymore open? then let's back to review and update patch, then push oomichi and sdague :)
12:46:43 <oomichi> alex_xu: oops, you are trying very difficult topic.. microversion spec ;)
12:46:53 <gmann__> sdague: oomichi : last one for VIF one - https://review.openstack.org/#/c/198944/
12:47:00 <alex_xu> oomichi: yea, thanks to you push part of consistent
12:47:35 <edleafe> oomichi: sdague: others: fixed and pushed https://review.openstack.org/214601
12:47:38 <oomichi> gmann__: that seems different from stable patch way, I guess
12:47:58 <alex_xu> ok... let's back to openstack-nova to work
12:48:01 <alex_xu> thanks all
12:48:03 <alex_xu> #endmeeting