12:04:07 <sdague> #startmeeting nova-api
12:04:07 <openstack> Meeting started Tue Oct  6 12:04:07 2015 UTC and is due to finish in 60 minutes.  The chair is sdague. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:04:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:04:10 <openstack> The meeting name has been set to 'nova_api'
12:04:15 <edleafe> \o
12:04:19 <sdague> hey there, who's here for the nova-api meeting?
12:04:21 <gmann_> o/
12:04:24 <johnthetubaguy> o/
12:04:26 <bauzas> ~o~
12:05:00 <sdague> the agenda for today - https://wiki.openstack.org/wiki/Meetings/NovaAPI
12:05:45 <sdague> #topic action items from last week
12:05:56 <sdague> there were 2 for alex_xu, who is out, and 1 for johnthetubaguy
12:06:07 <sdague> johnthetubaguy take a look at more about doc unification
12:06:14 <sdague> johnthetubaguy: how did that go?
12:06:15 <johnthetubaguy> so I have a bit of update here
12:06:36 <johnthetubaguy> the docs folks seem to have done most of the work for us, which is cool
12:06:37 <johnthetubaguy> https://review.openstack.org/#/c/229546/
12:06:54 <johnthetubaguy> thats the API reference bit, combining the v2.0 and v2.1 and v2.0 extenions
12:07:09 <sdague> nice,
12:07:17 * sdague stars that for later review
12:07:18 <johnthetubaguy> reviews welcome there, I am sure - I suspect there needs to be some work on the checklinks and the other things, to get that finished off though
12:07:27 <johnthetubaguy> so there is also a related bit...
12:07:52 <johnthetubaguy> so we need to the the API concept guide published somewhere, official
12:08:09 <sdague> instead of in the devref
12:08:11 <johnthetubaguy> annegentle has done some heavy lifting there
12:08:12 <johnthetubaguy> https://review.openstack.org/#/c/226253/7
12:08:14 <johnthetubaguy> sdague: yeah
12:08:22 <johnthetubaguy> actually, its the follow on patch
12:08:29 <johnthetubaguy> https://review.openstack.org/#/c/230186/4
12:08:45 <sdague> ok, more things starred to review
12:08:53 <johnthetubaguy> yeah, some progress there
12:09:14 <johnthetubaguy> honestly, would love someone to take that on and keep pushing, its proving tricky with RC2 and spec mountain
12:09:16 <gmann_> we will have concept guide also on api-site ?
12:09:28 <sdague> there needs to be an actual project-config change for publish as well, right?
12:09:39 <johnthetubaguy> gmann_: I think the first step is publish it somewhere good then, link to it
12:09:53 <johnthetubaguy> sdague: yeah, it feels like there is tox work and gate job work to make that all real
12:09:58 <sdague> ok
12:10:11 <johnthetubaguy> not sure how far anne has got with all those
12:10:15 <sdague> let's try to get the content all landed first
12:10:25 <sdague> how about we set that as a goal for next week
12:10:41 <johnthetubaguy> so get the set of TODOs landed, thats a good goal
12:10:59 <johnthetubaguy> the content was with alex_xu so I suspect he will start on that when he gets back
12:11:04 <sdague> #action nova-api team review and land outstanding doc patches for next week - https://review.openstack.org/#/c/230186 https://review.openstack.org/#/c/226253 https://review.openstack.org/#/c/229546/
12:11:21 <gmann_> +1
12:11:25 <sdague> we can check in on it then
12:11:37 <johnthetubaguy> yeah, more help with that would be good
12:11:52 <johnthetubaguy> its can be super parallel, everyone take one TODO and add some details
12:11:55 <gmann_> I can help on those but need to look on those tomorrow
12:12:09 <edleafe> I'll go over those today, too
12:12:18 <johnthetubaguy> converting a big TODO to an intro with smaller TODOs is also cool, in my book
12:12:19 <sdague> johnthetubaguy: where are all the TODOs listed now?
12:12:34 <johnthetubaguy> sdague: its that content patch really, so https://review.openstack.org/#/c/226253/7
12:12:49 <sdague> oh, gotcha, I see that now
12:13:02 <sdague> yep
12:13:11 <johnthetubaguy> there is an etherpad, but I think thats mostly been worked through, I am told
12:13:23 <johnthetubaguy> #link https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking
12:13:26 <sdague> so, from here on out I suggest the concept guide progress is a standing agenda item
12:13:37 <johnthetubaguy> so the patches are on the new etherpad of doom, FWIW ^
12:13:42 <johnthetubaguy> sdague: +1
12:13:54 <sdague> #action sdague to add concept guide progress to standing agenda
12:14:15 <sdague> johnthetubaguy: anything else?
12:14:26 <sdague> #topic Mitaka Planning
12:15:09 <johnthetubaguy> sdague: I am good on the previous stuff
12:15:22 <johnthetubaguy> mitaka wise, I think we agreed docs, docs and more docs
12:15:26 <sdague> I guess, lets get really near term on mitaka planning
12:15:33 <sdague> is there summit actions we need
12:15:53 <sdague> I agree that docs, docs, and more docs should be the focus for the cycle
12:16:18 <gmann_> yea
12:16:32 <sdague> I guess I wonder if we should have an API priorities slot on the nova track, mostly to try to get more people involved in the docs effort
12:16:47 <sdague> johnthetubaguy: how did you imagine the nova track is going to look this time?
12:17:15 <gmann_> saw lot of issues when people submit tempest patches for Nova tests by referring api doc :)
12:17:42 <johnthetubaguy> sdague: so its not fixed in stone yet, I am totally open to what folks think will be useful for the API stuff
12:18:34 <bauzas> johnthetubaguy: I guess you need to discuss about the proposals once it's closed, right?
12:18:47 <johnthetubaguy> bauzas: I am happy to discuss it now
12:18:48 <sdague> johnthetubaguy: I feel like it would be nice to have 1 slot if we could, because it may help getting more folks invovled
12:19:31 <johnthetubaguy> its a possible one, I think its important enough
12:19:44 <sdague> I guess the other thing that probably needs agreement is how to evaluate both the ec2 potential drop, and the v2 on v2.1 bit for operators
12:19:57 <johnthetubaguy> I just worried what folks will get out of it, we could have a backup plan of a hackathon on a few fixes, if we finish early I guess
12:20:17 <sdague> I think with docs, plus those 2 issues to discuss, we probably have a slot
12:20:22 <johnthetubaguy> yes, I think we need to follow up with everett on some of that, I know he was thinking about it
12:20:47 <johnthetubaguy> who is happy to put that proposal together, and drive it?
12:20:53 <sdague> I can do that
12:20:55 <johnthetubaguy> sweet
12:21:03 <sdague> probably late today, or tomorrow morning
12:21:10 <sdague> #action sdague to propose API slot for summit
12:21:25 <johnthetubaguy> sounds good
12:21:36 <johnthetubaguy> gmann_: you mentioned tempest
12:21:46 <sdague> beyond that, I think for mitaka we need to bring back the old standing agenda items about specs with API impact, and API impact reviews to highlight here
12:21:48 <johnthetubaguy> what can we do to help there, is that blocked on better docs?
12:22:04 <johnthetubaguy> sdague: oh good point, its time to bring them back
12:22:20 <sdague> anyone want to sign up for that agenda change?
12:22:27 <gmann_> johnthetubaguy: not blocked, due to doc there were wrong response etc on many times
12:22:39 <johnthetubaguy> I think some focused work on tempest (and in tree functional tests) are well worth it
12:22:40 <gmann_> johnthetubaguy: then people dig into code
12:22:51 <gmann_> after doc improvement i think that should be fine
12:22:57 <sdague> #info we should bring back standing items on specs and patches with APIImpact
12:23:01 <johnthetubaguy> I was hoping the auto-generated API docs might also generate tests, in some way
12:23:17 <johnthetubaguy> sdague: I am tempted to give that action to alex_xu, but thats feels a bit rude!
12:23:41 <sdague> johnthetubaguy: honestly, everyone wants to autogenerate everything. But in reality some hand crafting usually makes sense here.
12:24:26 <sdague> ok, any other mitaka issues before we move to open discussion?
12:24:48 <johnthetubaguy> sdague: true, more just the heavy lifting I guess
12:24:52 <johnthetubaguy> I am good for open now
12:25:12 <gibi> hi!
12:25:12 <gibi> I have a spec up on review about versioning and therefore documenting the notification API of nova. I guess this forum is interested about such an proposal.
12:25:13 <gmann_> sdague: as johnthetubaguy mentioned any planing to move nova API tests from tempest to nova
12:25:21 <gmann_> specially negative tests
12:25:23 <sdague> #topic Open Discussion
12:25:33 <gibi> here is the spec https://review.openstack.org/#/c/224755/
12:25:33 <gibi> and I here is some WIP example code: https://review.openstack.org/#/c/229881/
12:25:35 <sdague> gmann_: so, honestly, I think those are fine to be done.
12:25:58 <sdague> but they are kind of one off, I did a couple as examples last cycle
12:26:13 <gmann_> sdague: yea flavor one
12:26:44 <sdague> gibi: so, this is mostly about the REST API, but I agree that versioned notification api is important as well
12:27:43 <gmann_> sdague: i will check how we can move all negative one and keep adding more negative on nova side itself
12:27:48 <johnthetubaguy> gibi: so the notification API is probably a bit more for the nova general meeting than the API meeting really
12:28:09 <gibi> sdague, johnthetubaguy: OK, I will then raise it there :)
12:28:10 <gmann_> because due to lack of negative tests we face issue while v2.1 comp things
12:29:04 <johnthetubaguy> gibi: that looks like the plan dansmith was recommending, I see he made some good comments there that need working through
12:29:31 <sdague> gmann_: right, so those should be filled in on the nova functional side
12:29:38 <sdague> I don't think they should go in tempest
12:29:43 <johnthetubaguy> +1
12:29:47 <gmann_> yea
12:30:09 <gibi> johnthetubaguy: yes dansmith gave good comments, I just try to gathering more feedback.
12:30:15 <gmann_> so first move ll negative from Tempest to nova and then add more on nova side itself
12:30:17 <johnthetubaguy> gibi: all good
12:30:22 <gmann_> is it fine ?
12:30:47 <johnthetubaguy> so I think we should concentrate on the docs frist
12:30:50 <johnthetubaguy> first
12:31:03 <sdague> gmann_: honestly, I would add more tests to nova first
12:31:14 <sdague> moving from tempest doesn't gain anything really
12:31:16 <gmann_> johnthetubaguy: yea absolutely. after doc thing only
12:31:23 <johnthetubaguy> gmann_: cool
12:31:26 <sdague> adding tests to nova for stuff that's not covered does
12:31:30 <gmann_> sdague: i see, thats also looks good
12:31:37 <johnthetubaguy> sdague: that makes sense, look at proper negative tests in three, then go from there, that makes sense
12:31:47 <sdague> and, in general, adding more tests is always a win
12:31:57 <gmann_> yup
12:32:05 <johnthetubaguy> I think once our coverage goes up, we just drop the tempest tests
12:32:14 <johnthetubaguy> thats does sound better
12:32:54 <sdague> yes
12:33:05 <sdague> ok, anything else from folks?
12:33:48 <johnthetubaguy> I am good, I think
12:33:53 <bauzas> just a comment that I made a proposal
12:33:54 <gmann_> me too
12:34:13 <bauzas> if we have an API slot, we could see if it could be merged
12:34:22 <bauzas> that's about API extensibility re: scheduler hints
12:34:24 <sdague> cool. slightly related, we're planning on service catalog tng cross project session. I've got to update that spec this week
12:34:48 <johnthetubaguy> bauzas: yeah, that makes sense
12:34:53 <sdague> bauzas: honestly, I think we already agreed on that one point, and further changes like that are hard without something like json home
12:35:05 <sdague> which is going to be dubious for the release if we are focussed on docs
12:35:30 <bauzas> sdague: okay, then let's discuss that off-topic, I probably missed some discussion :)
12:35:37 <sdague> yep, no prob
12:35:42 <sdague> ok, anything else from folks?
12:35:46 <johnthetubaguy> so I have a feeling it might be bad enough for v2.1 adoption that its worth covering, but lets see how it goes
12:35:59 <sdague> johnthetubaguy: ok
12:36:35 <edleafe> I'm good
12:36:45 <sdague> alright, thanks folks
12:36:47 <bauzas> +1
12:36:48 <sdague> #endmeeting