#openstack-meeting: nova api

Meeting started by alex_xu at 12:00:09 UTC (full logs).

Meeting summary

  1. actions from last meeting (alex_xu, 12:01:05)
    1. https://etherpad.openstack.org/p/nova-v2.1-api-doc (alex_xu, 12:01:38)
    2. Action: alex_xu create bp and etherpad to track the concept doc work (alex_xu, 12:02:44)
    3. https://blueprints.launchpad.net/nova/+spec/complete-todo-in-api-concept-doc (alex_xu, 12:02:51)
    4. https://blueprints.launchpad.net/nova/+spec/api-sample-tests-with-all-extensions (gmann_, 12:04:53)
    5. https://etherpad.openstack.org/p/mitaka-nova-api (alex_xu, 12:09:34)

  2. Summit API Session (alex_xu, 12:11:06)
    1. https://etherpad.openstack.org/p/mitaka-nova-api (oomichi, 12:14:31)
    2. http://mitakadesignsummit.sched.org/event/10827a8275cb824c9e2a0fd2ee9c4ae1#.ViYwIm48qaw (oomichi, 12:14:43)
    3. ACTION: gmann_ create bp for microversion top bottom and changed testing (alex_xu, 12:16:36)

  3. API Documentation (alex_xu, 12:18:50)
    1.  https://review.openstack.org/233446 (alex_xu, 12:19:46)
    2.  https://review.openstack.org/235092 (alex_xu, 12:20:12)

  4. Remove project_id from URL (alex_xu, 12:34:37)
    1. https://etherpad.openstack.org/p/removing-project-id-in-nova-urls (sdague, 12:36:27)
    2. https://github.com/openstack/nova/blob/81fbb34e2544b26ae72f7eee3841b4024d22896f/nova/api/openstack/wsgi.py#L813-L821 (sdague, 12:38:03)
    3. https://etherpad.openstack.org/p/mitaka-service-catalog-session is the etherpad for service catalog session (sdague, 12:45:35)

  5. API futures - specs (alex_xu, 12:48:34)
    1. https://etherpad.openstack.org/p/mitaka-nova-spec-review-tracking (johnthetubaguy, 12:49:21)
    2. #link https://review.openstack.org/#/c/227274/1 (alex_xu, 12:49:57)
    3. https://review.openstack.org/#/c/209917/ (alex_xu, 12:56:31)

  6. open (alex_xu, 12:59:42)


Meeting ended at 13:00:44 UTC (full logs).

Action items

  1. gmann_ create bp for microversion top bottom and changed testing


Action items, by person

  1. gmann_
    1. gmann_ create bp for microversion top bottom and changed testing


People present (lines said)

  1. alex_xu (109)
  2. sdague (82)
  3. johnthetubaguy (80)
  4. gmann_ (56)
  5. oomichi (41)
  6. annegentle (6)
  7. edleafe (6)
  8. Kevin_Zheng (5)
  9. ccarmack (3)
  10. openstack (3)
  11. jichen (1)


Generated by MeetBot 0.1.4.