#openstack-meeting: nova api

Meeting started by alex_xu at 12:00:05 UTC (full logs).

Meeting summary

  1. actions from last meeting (alex_xu, 12:02:23)
    1. https://blueprints.launchpad.net/nova/+spec/nova-microversion-functional-tests (gmann_, 12:03:56)

  2. API Documentation (alex_xu, 12:08:17)
    1. https://etherpad.openstack.org/p/nova-v2.1-api-doc (alex_xu, 12:08:46)
    2. alex_xu to organize nova doc virtual sprint for 2nd week of Dec (sdague, 12:19:13)
    3. https://etherpad.openstack.org/p/mitaka-nova-swagger (alex_xu, 12:24:11)
    4. https://review.openstack.org/243365 (alex_xu, 12:24:26)
    5. ACTION: alex_xu update the PoC to show more example (alex_xu, 12:26:04)
    6. https://github.com/russell/fairy-slipper (alex_xu, 12:28:18)

  3. Service Catalog (alex_xu, 12:30:59)
    1. https://etherpad.openstack.org/p/removing-project-id-in-nova-urls (alex_xu, 12:32:17)
    2. https://review.openstack.org/#/c/233076/ (sdague, 12:36:05)
    3. ACTION: sdague to circle with mmmpork today on nova patch (sdague, 12:38:06)
    4. ACTION: sdague to circle with mmmpork today on nova patch for optional project_id (sdague, 12:38:18)

  4. Novaclient (alex_xu, 12:39:14)
    1. https://etherpad.openstack.org/p/mitaka-nova-api (alex_xu, 12:42:36)

  5. Testing (alex_xu, 12:44:19)
    1. https://review.openstack.org/#/c/169126/ (alex_xu, 12:44:29)
    2. https://blueprints.launchpad.net/nova/+spec/api-sample-tests-with-all-extensions (alex_xu, 12:46:22)
    3. https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/api-sample-tests-with-all-extensions,n,z (gmann_, 12:47:06)

  6. API Deprecations (alex_xu, 12:51:54)
    1. ACTION: alex_xu contact the doc team about swagger stuff (alex_xu, 12:57:54)


Meeting ended at 13:00:53 UTC (full logs).

Action items

  1. alex_xu update the PoC to show more example
  2. sdague to circle with mmmpork today on nova patch
  3. sdague to circle with mmmpork today on nova patch for optional project_id
  4. alex_xu contact the doc team about swagger stuff


Action items, by person

  1. alex_xu
    1. alex_xu update the PoC to show more example
    2. alex_xu contact the doc team about swagger stuff
  2. sdague
    1. sdague to circle with mmmpork today on nova patch
    2. sdague to circle with mmmpork today on nova patch for optional project_id


People present (lines said)

  1. alex_xu (126)
  2. gmann_ (53)
  3. sdague (52)
  4. johnthetubaguy (6)
  5. tangchen_ (5)
  6. jichen (4)
  7. Kevin_Zheng (4)
  8. openstack (4)
  9. edleafe (2)


Generated by MeetBot 0.1.4.