#openstack-meeting-4: nova api

Meeting started by alex_xu at 13:00:03 UTC (full logs).

Meeting summary

  1. API Priorities (alex_xu, 13:01:40)
    1. ACTION: cdent to update policy over api spec to reflect pre-microversion handling (cdent, 13:14:16)
    2. ACTION: sdague to create wiki page documenting the content checks that should be done for every file (sdague, 13:24:38)
    3. ACTION: sdague to push comments into all inc files saying that they all need to go through this (sdague, 13:25:11)

  2. open (alex_xu, 13:32:25)
    1. https://review.openstack.org/#/c/308026/ (alex_xu, 13:32:43)
    2. https://review.openstack.org/#/c/304958 seems like a straigh up bugfix to me honestly (sdague, 13:45:06)
    3. https://review.openstack.org/#/c/304958/4/nova/api/openstack/wsgi.py (sdague, 13:46:53)
    4. http://specs.openstack.org/openstack/api-wg/guidelines/evaluating_api_changes.html (mriedem, 13:49:00)
    5. http://docs.openstack.org/developer/nova/api_microversion_dev.html#when-do-i-need-a-new-microversion (mriedem, 13:50:47)
    6. https://review.openstack.org/#/c/307186/ (sdague, 13:58:02)


Meeting ended at 13:59:52 UTC (full logs).

Action items

  1. cdent to update policy over api spec to reflect pre-microversion handling
  2. sdague to create wiki page documenting the content checks that should be done for every file
  3. sdague to push comments into all inc files saying that they all need to go through this


Action items, by person

  1. cdent
    1. cdent to update policy over api spec to reflect pre-microversion handling
  2. sdague
    1. sdague to create wiki page documenting the content checks that should be done for every file
    2. sdague to push comments into all inc files saying that they all need to go through this


People present (lines said)

  1. sdague (110)
  2. alex_xu (47)
  3. cdent (36)
  4. johnthetubaguy (23)
  5. gmann_ (20)
  6. mriedem (17)
  7. oomichi_ (8)
  8. jichen (6)
  9. openstack (4)
  10. edleafe (2)


Generated by MeetBot 0.1.4.