12:59:47 <alex_xu> #startmeeting nova api
12:59:48 <openstack> Meeting started Wed Jun  1 12:59:47 2016 UTC and is due to finish in 60 minutes.  The chair is alex_xu. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:59:52 <openstack> The meeting name has been set to 'nova_api'
12:59:58 <alex_xu> hello, who is here today?
13:00:02 <Kevin_Zheng> o/
13:00:04 <jichen> o/
13:00:05 <oomichi_> hi
13:00:42 <sdague> o/
13:00:55 <johnthetubaguy> o/
13:01:04 <cdent> o/
13:01:14 <alex_xu> hello everyone, i think we can start the meeting
13:01:23 <alex_xu> #topic actions from previous meeting
13:01:31 * alex_xu johnthetubaguy feedback the decision on separated tool for policy discovery back to the spec
13:01:43 <alex_xu> this is done, and the spec already updated
13:01:56 <alex_xu> #link https://review.openstack.org/289405
13:02:28 <alex_xu> i think claudio_ is just waiting for more feedback
13:02:45 <sdague> yeh, I need to provide feedback there shortly
13:03:01 <alex_xu> sdague: cool
13:03:36 <alex_xu> i just leave comment about the cmd needn't specify the policy config file.
13:04:16 <alex_xu> but i guess people didn't look at spec yet, so let us discuss in the spec.
13:04:27 * alex_xu sdague to follow up with dhellman to find the right additional reviewers for oslo.policy changes
13:04:30 <sdague> alex_xu: ++
13:04:49 <sdague> alex_xu: dims said he would also look at it
13:04:49 <alex_xu> sdague: spec merged, and patch ready for review in oslo.policy side, right?
13:05:03 <sdague> did the spec merge? I hadn't looked recently
13:05:27 <alex_xu> sdague: yea, merged, and i reviewed the patch today
13:05:30 <alex_xu> #link https://review.openstack.org/#/q/status:open+project:openstack/oslo.policy+branch:master+topic:bp/policy-sample-generation
13:05:46 <sdague> great
13:06:08 * alex_xu johnthetubaguy to update policy docs to remove user_id references to server actions
13:06:15 <alex_xu> johnthetubaguy: i didn't check that
13:07:13 <alex_xu> i guess johnthetubaguy in the lunch
13:07:21 <alex_xu> let me check with him later
13:07:28 * alex_xu johnthetubaguy to reply on bug and ML about the ops issues with user_id
13:07:45 <johnthetubaguy> no he was just a bit distracted
13:07:52 <alex_xu> sdague: i saw some reply from you, we are good at here?
13:08:09 <sdague> we've got a detailed response from Tim Bell
13:08:20 <johnthetubaguy> I haven't made much progress on the docs at all, I am afraid
13:08:22 <alex_xu> johnthetubaguy: nvm, do you need help? i saw the doc link in the ML, i can do that if you are busy
13:08:38 <sdague> which is probably enough to write a spec and just say we are only going to do the minimum to make CERN happy (for now)
13:09:01 <johnthetubaguy> alex_xu: thank you, honestly, thats probably best, took on more than I can do around spec freeze (as usual :()
13:09:02 <sdague> everyone else was given an opportunity to speak up, and didn't in any useful detail
13:09:32 <johnthetubaguy> sdague: yeah, that seems like the best approach for now
13:09:35 <alex_xu> sdague: ok, check the target on Tim mentioned action?
13:09:50 <sdague> #action sdague to write up a spec about limitted (and deprecated) user_id support in policy in nova
13:09:54 <alex_xu> johnthetubaguy: no problem, really a lot of people need help on freeze :)
13:10:21 <alex_xu> sdague: thanks, if you need some coding help, i signed up
13:10:32 <sdague> alex_xu: yeh, that would be great
13:10:44 <sdague> I think we'll just want to be super clear in the spec about what we are going to add
13:11:12 <alex_xu> #action alex_xu to update policy docs to remove user_id references to server actions
13:11:22 <alex_xu> sdague: ok
13:12:26 <alex_xu> ok, that is all actions, so we can move on, if no more questions
13:13:00 <alex_xu> #topic API priorities
13:13:28 <alex_xu> for api-ref, i think we also merged a lot of fix last week
13:13:53 <sdague> yeh, we have a number up for review still
13:14:02 <sdague> http://burndown.dague.org/
13:14:29 <alex_xu> yeh, but i guess we can merge them in next week
13:14:31 <sdague> I also have a review up for a microversion selector (here is the output) https://dague.net/testing/api-ref/
13:15:01 <sdague> mugsie and I have been chatting a bit about UX. Neither of us is completely thrilled by it, but the functionality is mostly there
13:15:05 <cdent> that's a cool idea
13:15:09 <oomichi_> sdague: cool
13:15:10 <Kevin_Zheng> ah  this is cool
13:15:32 <sdague> so... if anyone else has ideas on presentation ... please speak up
13:15:39 <johnthetubaguy> ah, so that changes the samples?
13:15:44 <johnthetubaguy> (eventually)
13:15:59 <johnthetubaguy> and hides the unsupported bits
13:16:09 <sdague> johnthetubaguy: well, the basic theory at this point is anything in a microversion gets a class tag added to it
13:16:20 <sdague> and this does hide / show based on that
13:16:21 <alex_xu> ah, it is cool
13:16:28 <sdague> right now it is hiding / showing parameters
13:16:39 <sdague> and ... the crash dump action
13:16:42 <johnthetubaguy> gotcha, gives us the option to do samples later, if we need
13:17:02 <oomichi_> sdague: how can we know the differences between microversions on the site?
13:17:02 <sdague> though, taking it out of the TOC is not straight forward, so it stays there
13:17:19 <sdague> oomichi_: the default, "All"
13:17:28 <mugsie> sdague: I have a half baked idea for it right now, let me sit on it for now, but I should have something later on today
13:17:50 <sdague> mugsie: cool
13:17:55 <alex_xu> mugsie: cool
13:18:31 <johnthetubaguy> seems like an awesome start to me
13:19:00 <alex_xu> yea, sdague makes api-ref awsome every week :)
13:19:16 <oomichi_> alex_xu: yeah, right :)
13:19:36 <sdague> yeh, I'd like to get something merged and out this week so we can play with things. That will probably include mugsie's structured error codes markup as well
13:20:05 <alex_xu> cool
13:20:07 <sdague> probably it on api-ref
13:20:15 <jichen> cool~
13:20:52 <johnthetubaguy> sdague: I wonder about something like this for the selecting the microversion: https://jqueryui.com/slider/#hotelrooms
13:21:22 <johnthetubaguy> but thats probably overcomplicating it for the moment
13:22:23 <sdague> johnthetubaguy: sure, that would be a thing. selector seemed a little more wonky to me, but we can play with that bit pretty easily given the hide show functions
13:22:37 <johnthetubaguy> yeah
13:23:27 <alex_xu> ok, all of that are cool, i guess we can move on
13:24:04 <alex_xu> for removng legacy v2
13:24:09 <alex_xu> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/remove-legacy-v2-api-code
13:24:22 <alex_xu> oomichi_: we are very close to remove the code!
13:24:34 <oomichi_> alex_xu: yeah, almost done
13:24:47 <sdague> I think my only question on removing legacy v2 code is if we want to be agreed on the user_id policy spec first
13:24:50 <oomichi_> alex_xu: some feedback is gotten, and will finish them today
13:25:10 <alex_xu> oomichi_: cool
13:25:30 <alex_xu> sdague: ok...but already remove a lot of things...
13:25:38 <oomichi_> sdague: yeah, the last one is holded with your -2 for waiting that
13:25:38 <sdague> alex_xu: true
13:25:59 <sdague> I guess we've deleted so much testing, it probably has gotten broken already anyway
13:26:28 <sdague> ok... I'm fine moving forward, lets get things rebased, then give people time to pile up +2s on it
13:26:40 <alex_xu> cool
13:27:27 <alex_xu> for api policy, we already talked about it in the beginning
13:27:50 <alex_xu> anything else we want to talk about at here, otherwise, we will jump to open
13:28:15 <sdague> no, I think jump to open
13:28:24 <alex_xu> #topic open
13:28:42 <sdague> and I'll reask the question to mugsie about mv selector
13:29:01 <sdague> because I'd like to keep the controls in the bootstrap pallet, as it makes it easier to theme
13:29:26 <sdague> and I wonder if a navbar - http://getbootstrap.com/components/#navbar
13:29:34 <sdague> with the drop down would be better
13:29:50 <sdague> and we could integrate in the expand all to that ... maybe
13:30:51 <sdague> anyway, maybe for later
13:31:11 <sdague> on the specs front
13:31:19 <sdague> we should probably get all the pagination specs approved
13:31:35 <alex_xu> sdague: i remember those are merged
13:31:47 <sdague> alex_xu: ok, I hadn't caught up on that yet
13:31:57 <sdague> are there other outstanding specs that people are concerned on?
13:32:04 <johnthetubaguy> +1 that question
13:32:12 <sdague> as we are getting towards the end of the non priority freeze
13:32:34 <johnthetubaguy> deadline is thursday, I believe
13:32:39 <alex_xu> johnthetubaguy: there is one in the agenda, i guess that is yours?
13:32:48 <johnthetubaguy> oh, whoops
13:32:49 <alex_xu> #link https://review.openstack.org/#/c/248248/
13:33:07 <johnthetubaguy> ah, right, I added that
13:33:08 <alex_xu> johnthetubaguy: sorry, a little late...we have full meeting last few weeks...
13:33:26 <johnthetubaguy> so it was an idea about making some small progress towards tasks
13:33:38 <johnthetubaguy> by expanding instance actions a little
13:33:56 <johnthetubaguy> there are a few specs up on the topic
13:34:26 <johnthetubaguy> add finish_time for actions
13:34:31 <johnthetubaguy> so you know its finished
13:34:53 <johnthetubaguy> and add instance actions for the API operations that are missing
13:34:58 <johnthetubaguy> (thats a spearate spec)
13:35:10 <johnthetubaguy> but its a bit late at this point to hope to get those merged
13:35:16 <johnthetubaguy> but if folks have time, that would be interesting
13:35:31 <johnthetubaguy> probably something for next cycle I guess?
13:36:07 <alex_xu> +1 for add instance actiosn for all the api operations
13:36:54 <sdague> yeh, that seems pretty reasonable
13:37:06 <sdague> I have one quibble over ``running``
13:37:12 <sdague> as that implies we know it's still running
13:37:17 <sdague> which... we really don't
13:37:41 <johnthetubaguy> yeah, thats fair enough
13:37:55 <johnthetubaguy> if we could get eyes on those that would be great
13:38:10 <johnthetubaguy> I think its something the OSIC folks could really start to chew on, if we get it approved
13:38:12 <sdague> yeh, I just went through it, and it seems pretty well scoped as an incremental change
13:38:29 <johnthetubaguy> cool, so I can make an effort to update that to fix any nits, etc
13:39:00 <johnthetubaguy> there is also this one: https://review.openstack.org/#/c/256743/
13:39:12 <johnthetubaguy> but thats the expand coverage bit
13:40:11 <johnthetubaguy> there is this one as well, that take on exposing the data in the API: https://review.openstack.org/#/c/300704
13:40:48 <johnthetubaguy> what do you all think we should focus on with that, I am tempted to say that first one?
13:41:49 <sdague> johnthetubaguy: wait... did they do 2 specs?
13:42:11 <johnthetubaguy> there are kinda three specs going on here, it probably got split up a bit too much
13:42:25 <johnthetubaguy> but there is, record in the DB a finish time for an action
13:42:35 <johnthetubaguy> expose if an action is finished or not
13:42:43 <sdague> ok, can we get this all into one?
13:42:47 <johnthetubaguy> and expand instance actions to other ones
13:42:59 <johnthetubaguy> yeah, I can take that action for now ish
13:42:59 <sdague> because I can't really conceptualize these as different parts
13:43:10 <sdague> as they seem all very related
13:43:22 <alex_xu> or separated this https://review.openstack.org/#/c/256743/2/specs/newton/approved/expand-instance-actions-coverage.rst this is pretty easy.
13:43:29 <johnthetubaguy> so I think the expand the actions is a separate one
13:43:34 <johnthetubaguy> yeah, the other two should all be together
13:43:42 <johnthetubaguy> its kinda two steps of the same task
13:44:07 <alex_xu> +1
13:44:35 <johnthetubaguy> OK, so I will try tidy this up, and ping folks that are still around when thats done
13:44:47 <johnthetubaguy> it would be nice to make a bit of head way on that this cycle
13:44:54 <johnthetubaguy> although time is crazy tight now
13:45:42 <oomichi_> yeah, small steps are nice to move forward to task
13:46:10 <alex_xu> yeah
13:47:24 <alex_xu> so anything more for open?
13:47:49 <cdent> to update on the modern microversion stuff, the change in nova merged as 2.27 and here's the review for updating novaclieng: https://review.openstack.org/#/c/323362/  (the functional failure seems unrelated?)
13:47:58 <alex_xu> cdent: cool
13:48:14 <alex_xu> i already added myself as reviewer
13:48:22 <cdent> gret thank you
13:48:23 <johnthetubaguy> cdent: I just merged something that claimed to fix those failures
13:48:35 <cdent> johnthetubaguy: \o/
13:48:36 <johnthetubaguy> well, +Wed
13:49:06 <alex_xu> cdent: np
13:49:13 <johnthetubaguy> cdent: https://review.openstack.org/#/c/321916/
13:50:17 <cdent> i've rebased, we'll see if it makes happy now
13:50:38 <alex_xu> ok, cool, anything more people want to bring up, otherwise, let us free the meeting, back to help on review.
13:50:58 <alex_xu> 3...
13:51:03 <alex_xu> 2..
13:51:04 <sdague> sounds good, thanks alex_xu
13:51:08 <alex_xu> 1.
13:51:11 <alex_xu> sdague: np
13:51:14 <alex_xu> thanks all!
13:51:20 <alex_xu> #endmeeting