13:00:09 <alex_xu> #startmeeting nova api
13:00:10 <openstack> Meeting started Wed Nov  2 13:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is alex_xu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:14 <openstack> The meeting name has been set to 'nova_api'
13:00:20 <alex_xu> who is here today?
13:00:23 <cdent> o/
13:00:28 <Kevin_Zheng> o/
13:00:49 <johnthetubaguy> o/
13:01:19 <alex_xu> ok, let us start the meeting
13:01:28 <alex_xu> #topic update from summit
13:01:51 <alex_xu> johnthetubaguy: the only one priority task for the API is the query parameter validation?
13:02:15 <johnthetubaguy> that sounds about correct
13:02:26 <johnthetubaguy> although there is no separate freeze date this time around
13:02:51 <alex_xu> johnthetubaguy: ok, cool, let us focus on it for this very short release cycle
13:02:51 <gmann__> and proxy API and extension tide up things ?
13:03:21 <gmann__> alex_xu: johnthetubaguy i can help on extension code cleanup if sdague need help on this
13:03:42 <johnthetubaguy> so here is the thing...
13:03:59 <johnthetubaguy> cells v2 is kinda blocked by not having good validation on the filter/sort params for instances
13:04:09 <johnthetubaguy> so thats a good thing to focus on
13:04:24 <johnthetubaguy> we should still make progress on all those other loose ends and tidyups
13:04:34 <gmann__> +1
13:04:42 <johnthetubaguy> including agreeing the capabilities API with API WG
13:04:58 <alex_xu> so for the proxy API, we can continue image-metadata, due to the spec already merged, right?
13:05:48 <johnthetubaguy> #link http://specs.openstack.org/openstack/nova-specs/specs/ocata/approved/deprecate-image-meta-proxy-api.html
13:05:49 <johnthetubaguy> yeah
13:05:56 <alex_xu> ah, cool
13:06:21 <johnthetubaguy> there is also this one: http://specs.openstack.org/openstack/nova-specs/specs/ocata/approved/flavor-root-disk-none.html
13:06:59 <alex_xu> ok, I didn't notice that one
13:07:21 <johnthetubaguy> http://specs.openstack.org/openstack/nova-specs/specs/ocata/approved/detach-boot-volume.html
13:07:30 <johnthetubaguy> so there are some good features lined up there
13:07:49 <johnthetubaguy> generally fixing up the boot from volume situation, I guess
13:08:07 <alex_xu> cool
13:08:18 <johnthetubaguy> so got distracted from summit update...
13:08:28 <gmann__> yea, this seems nice. it will provide more nice management on volume things
13:08:47 <johnthetubaguy> #link https://etherpad.openstack.org/p/ocata-nova-summit-api
13:09:11 <johnthetubaguy> #link https://review.openstack.org/#/c/386555
13:09:12 <johnthetubaguy> we should all review the above capabilities proposal
13:09:18 <alex_xu> johnthetubaguy: for the query parameter validation, we only fix the validation for server list/detail, do we need to add validation for other api which have query parameters
13:09:50 <johnthetubaguy> alex_xu: not for the priority, but I think we should look at all the sort/filter params to start with
13:10:10 <gmann__> alex_xu: johnthetubaguy are we going to do validation for SHOW api also in case some bogus id is mentioned in query URL ?
13:10:26 <alex_xu> johnthetubaguy: i see now, server list/detail is priority, try others if we have time
13:10:26 <gmann__> alex_xu: johnthetubaguy or something can be taken after wards
13:10:30 <johnthetubaguy> thats already done I assume?
13:10:39 <johnthetubaguy> for the instance uuid I mean
13:11:09 <gmann__> seems no, i saw 1 tests in tempest sending special char as id and expecting 404 error
13:11:34 <alex_xu> i'm not sure we should validate that id, if people input bogus id, then API just return not found, that looks like correct
13:11:39 <gmann__> johnthetubaguy: for SHOW server API i think no, we just try to fetch the given id
13:12:03 <gmann__> alex_xu: i was thinking to return 400 and avoid to look into DB
13:12:14 <johnthetubaguy> OK, so I am not sure which bit you mean
13:12:33 <johnthetubaguy> anyways, feels less important that the filter/sort things
13:12:53 <gmann__> like this. /v2.1/server?query id#$@@
13:12:56 <johnthetubaguy> gmann__: I think 404 is fine for an invalid uuid I guess
13:12:58 <gmann__> johnthetubaguy: yea we can talk later
13:13:17 <johnthetubaguy> gmann: oh, thats the server list that we are talking about right?
13:13:25 <johnthetubaguy> thats just a filter
13:13:48 <johnthetubaguy> show is /server/<uuid> in my head
13:13:58 <gmann__> sorry just SHOW yea, server/*&^
13:14:15 <johnthetubaguy> anyways, do we have someone sorting out the specs for all the filter/sort params?
13:15:20 <johnthetubaguy> alex_xu has the base one, I guess
13:15:21 <johnthetubaguy> #link https://review.openstack.org/#/c/388518/
13:15:27 <alex_xu> that needs a separated spec?
13:15:46 <alex_xu> johnthetubaguy: yea
13:15:52 <johnthetubaguy> oh, maybe not, let me check
13:16:25 <johnthetubaguy> ah, so I think we need a spec for the microversion change to the server's API that adds all the parameter validation
13:16:52 <johnthetubaguy> we also need to talk about what we are doing for older microversions, I think
13:17:09 <johnthetubaguy> I think we just ignore things that are not allowed in the new list?
13:17:31 <gmann__> johnthetubaguy: in old microversion ?
13:17:37 <alex_xu> johnthetubaguy: yes, i think that is the first step, and without microversion
13:17:53 <alex_xu> and fix this bug without microversion https://bugs.launchpad.net/nova/+bug/1609039
13:17:54 <openstack> Launchpad bug 1609039 in OpenStack Compute (nova) "Should not be able to sort instances based on joined tables" [High,In progress] - Assigned to Zhenyu Zheng (zhengzhenyu)
13:18:15 <alex_xu> strict the validation won't be the ocata thing I guess?
13:18:20 <johnthetubaguy> yeah, I suppose that could be a bug fix, but I would rather have a spec thats got the details
13:18:36 <alex_xu> johnthetubaguy: ok
13:19:12 <johnthetubaguy> doesn't need to be a long one
13:19:26 <johnthetubaguy> just think its good to agree the direction for the /servers/... changes for the parameter validation
13:19:26 <alex_xu> Kevin_Zheng: are you interesting on that spec ^ ?
13:19:40 <Kevin_Zheng> sure i can try
13:19:53 <alex_xu> johnthetubaguy: yea
13:20:04 <alex_xu> Kevin_Zheng: thanks, free to ping if you need any help
13:20:06 <gmann__> then we need to finalize the new allowed list first?
13:20:24 <Kevin_Zheng> np
13:20:28 <gmann__> or fixing this bug for joined tables filter only
13:20:38 <johnthetubaguy> well, the spec needs to have the list of allowed things really
13:20:55 <johnthetubaguy> I would rather we do it properly, as this is blocking the cells work
13:21:04 <gmann__> yea, +1
13:21:11 <Kevin_Zheng> got it
13:21:46 <alex_xu> yea
13:22:09 <johnthetubaguy> it seems close, but maybe I am being optimistic
13:23:45 <alex_xu> emm...when we have the detail list, then we will know whether we are optimistic
13:23:54 <johnthetubaguy> true :)
13:24:08 <alex_xu> #link https://review.openstack.org/#/c/389003/
13:24:41 <alex_xu> I update the patch, added the unittest and refactor the code. but I guess not hurry, maybe see more detail before merge
13:25:59 <alex_xu> ok, so...anything more we want to bring up?
13:26:16 <johnthetubaguy> I think thats the main bits from the summit
13:26:44 <johnthetubaguy> Parameter validation, capabilities API WG spec, continue loose ends
13:28:06 <alex_xu> a lot of loose ends :)
13:28:19 <gmann__> yea
13:28:39 <alex_xu> yea, the nova API code is huge
13:28:47 <johnthetubaguy> yup yup
13:28:50 <alex_xu> #topic Open
13:29:03 <gmann__> and lot number of APIs :)
13:29:23 <alex_xu> so anything more want to bring up, otherwise let us end the meeting early
13:29:37 <johnthetubaguy> I guess we need to update the etherpad
13:29:39 <johnthetubaguy> #link https://etherpad.openstack.org/p/ocata-nova-priorities-tracking
13:29:52 <johnthetubaguy> add our new focus areas
13:29:55 <alex_xu> #action Kevin_Zheng will bring up the spec about the server list query parameters
13:30:10 <johnthetubaguy> cool
13:30:20 <alex_xu> johnthetubaguy: thanks
13:30:53 <alex_xu> I will update the etherpad
13:32:20 <alex_xu> so anything more?
13:33:04 <johnthetubaguy> I am happy
13:33:12 <alex_xu> 3...
13:33:15 <gmann__> not from my side
13:33:15 <alex_xu> 2..
13:33:19 <alex_xu> 1.
13:33:23 <alex_xu> thanks all!
13:33:25 <alex_xu> #endmeeting