06:00:12 <gmann> #startmeeting nova api
06:00:13 <openstack> Meeting started Wed Jul 18 06:00:12 2018 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
06:00:16 <openstack> The meeting name has been set to 'nova_api'
06:00:23 <gmann> PING List: gmann, alex_xu
06:00:27 <gmann> who all here today ?
06:00:51 <alex_xu> o/
06:01:59 <huanhongda> I am here
06:02:08 <gmann> alex_xu: hogepodge hi
06:02:29 <alex_xu> gmann: hi
06:02:37 <gmann> let's start
06:02:59 <openstackgerrit> fupingxie proposed openstack/nova master: Delete allocations when it is re-allocated  https://review.openstack.org/582899
06:03:05 <gmann> #topic Priorities
06:03:17 <gmann> #link https://etherpad.openstack.org/p/rocky-nova-priorities-tracking
06:03:47 <gmann> L57 in above etherpad
06:03:53 <gmann> 1. Servers Ips non-unique network names
06:04:43 <gmann> i sent mail to Maciej Kucia last week but no response and also no response on patch.
06:04:48 <gmann> anyone knows Maciej Kucia ?
06:05:15 <gmann> otherwise i can plan to push the code update
06:05:47 <gmann> FF is close and we should have code up for review by this week max
06:06:31 <alex_xu> only one week left
06:06:39 <gmann> yeah
06:07:01 <gmann> ok i will update the code for that
06:07:22 <gmann> #action gmann to update code for 1. Servers Ips non-unique network names
06:07:32 <gmann> 2.Abort live migration in queued state:
06:07:56 <gmann> this is almost done
06:07:58 <gmann> #link https://review.openstack.org/#/q/topic:bp/abort-live-migration-in-queued-status+(status:open+OR+status:merged)
06:08:01 <alex_xu> gmann: the main part already merge?
06:08:15 <alex_xu> gmann: for the non-unique network names
06:08:27 <gmann> alex_xu: no, only spec is merged
06:09:07 <alex_xu> gmann: ok, not sure we have enough time get the patch ready and merge
06:09:33 <gmann> alex_xu: i will check how much code is needed
06:09:39 <alex_xu> gmann: cool, thanks
06:10:34 <gmann> on abort live migration
06:11:10 <gmann> Kevin_Zheng: i think nova client changes are left ?
06:11:18 <gmann> after that we can mark this complete
06:11:39 <Kevin_Zheng> gmann yeah, I will work on that today
06:11:47 <gmann> alex_xu: trivial one -https://review.openstack.org/#/c/583212/
06:11:54 <gmann> Kevin_Zheng: thanks
06:12:17 <alex_xu> gmann: will check
06:12:32 <gmann> alex_xu: thanks
06:12:39 <gmann> 3. Complex anti-affinity policies:
06:12:42 <alex_xu> done...super trivial
06:12:50 <gmann> alex_xu: :)
06:13:07 <gmann> anti-affinity one are merged
06:13:19 <gmann> 1 patch left on nova  #link https://review.openstack.org/#/c/583434/
06:13:26 <gmann> and nova client change
06:13:39 <gmann> #link https://review.openstack.org/#/c/578261/
06:13:50 <gmann> same for this, after those 2 patches it can be marked as complete
06:14:54 <gmann> 4. Volume multiattach enhancements:
06:15:19 <openstackgerrit> Zhenyu Zheng proposed openstack/nova master: Wrong href link returned when providing non-existed version in GET version API  https://review.openstack.org/486850
06:15:19 <gmann> this one is no progress and matt mentioned to work on this in coming weeks may be
06:15:28 <gmann> 5. API Extensions merge work
06:15:49 <gmann> #link https://review.openstack.org/#/q/project:openstack/nova+branch:master+topic:bp/api-extensions-merge-rocky
06:15:58 <gmann> update few patches on this.
06:16:13 <gmann> will push all the remaining code by friday
06:16:27 <alex_xu> gmann: how many we left?
06:17:40 <gmann> alex_xu: 3 on server_create and then response one(~9)
06:18:27 <alex_xu> gmann: cool
06:18:40 <alex_xu> gmann: so we left the policy deprecation to the next release?
06:18:50 <alex_xu> sorry, the policy remove
06:19:15 <gmann> alex_xu: yeah, i thought removing in this cycle is little early. what you say?
06:19:43 <alex_xu> gmann: sounds ok for me
06:19:48 <alex_xu> just ensure the plan
06:20:08 <gmann> alex_xu: ok. in Stein early we can remove them
06:20:15 <alex_xu> gmann: yeah, cool
06:20:54 <gmann> 6. Handling a down cell
06:21:28 <gmann> #link https://review.openstack.org/#/q/topic:bp/handling-down-cell+(status:open+OR+status:merged)
06:21:44 <gmann> code is up for review and matt already +2 on few patches
06:21:59 <gmann> i have not looked into that yet.
06:22:43 <gmann> i will target this fro today
06:22:47 <gmann> from
06:23:32 <gmann> that's all on priority things from me
06:23:52 <gmann> anything else to discuss or any priority review
06:24:06 <alex_xu> nothing from me
06:25:03 <gmann> ok let's move next
06:25:07 <gmann> #topic Bug Triage/Discussion
06:25:25 <gmann> #link https://etherpad.openstack.org/p/nova-api-weekly-bug-report
06:25:28 <gmann> weekly report
06:25:40 <gmann> total bugs 69
06:26:01 <gmann> i reviewed i think 4-5 patches of in-progress bugs
06:26:24 <gmann> #link https://review.openstack.org/#/c/582674/1
06:26:36 <gmann> #link https://review.openstack.org/#/c/566143/
06:26:48 <gmann> ^^ these are in good shape
06:27:01 <gmann> and easy one
06:28:27 <gmann> no  new or untriaged bug.
06:29:12 <gmann> we will keep reviewing the in-progress patches and get the number down
06:29:43 <gmann> any bug anyone want to discuss ? otherwise we can move next may be
06:30:38 <alex_xu> I saw Kevin_Zheng updated this one https://review.openstack.org/486850
06:31:07 <gmann> k
06:31:21 <Kevin_Zheng> yeah, trying to clean up my bugs :)
06:32:03 <gmann> so it is stripping the after version part now?
06:34:40 <gmann> anyway let's review on patch
06:35:29 <alex_xu> yea
06:36:03 <gmann> let's move next
06:36:09 <gmann> #topic Open Discussion
06:36:15 <openstackgerrit> Zhenyu Zheng proposed openstack/nova master: Wrong href link returned when providing non-existed version in GET version API  https://review.openstack.org/486850
06:36:42 <gmann> i do not have anything to discuss.
06:36:53 <alex_xu> me too
06:36:57 <gmann> ok
06:37:10 <gmann> let's close early today and back to work.
06:37:18 <gmann> thanks for joining.
06:37:37 <gmann> alex_xu: and happy holiday :) saw your tweet of lucky draw
06:37:43 <gmann> #endmeeting