16:30:44 <tjones> #startmeeting Nova Bug Scrub
16:30:46 <openstack> Meeting started Wed Mar  5 16:30:44 2014 UTC and is due to finish in 60 minutes.  The chair is tjones. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:30:49 <openstack> The meeting name has been set to 'nova_bug_scrub'
16:31:07 <tjones> lets do a quick hello to see who is here
16:31:22 <wendar> o\
16:31:34 <alexpilotti> o/
16:31:42 <jogo> o/
16:31:53 <melwitt1> o/
16:31:55 <jogo> for the next 8 minutes (train)
16:32:09 <johnthetubaguy> o/
16:32:10 <tjones> ok lets start then ;-)
16:32:16 <tjones> #topic triage owners
16:32:23 <claudiub2> o/
16:32:42 <tjones> i didn't get any results from my ML request for owners on #link https://wiki.openstack.org/wiki/Nova/BugTriage
16:33:02 <tjones> we still need console, ec2, scheduler, testing, and nova-manage
16:33:06 <johnthetubaguy> OK, I will take scheduler then
16:33:09 <tjones> any ideas?
16:33:12 <tjones> thanks johnthetubaguy
16:33:20 <tjones> #action make johnthetubaguy the scheduler owner
16:33:52 <tjones> it's not in bad shape from an un-triaged point of view
16:34:04 <johnthetubaguy> jogo: do you fancy testing?
16:34:11 <tjones> ones that are in bad shape are libvirt, networking, and testing ;-)
16:34:30 <melwitt1> you can put me on nova-manage
16:34:48 <tjones> i have kchamart as the owner of libvirt - but have not heard back from him/her
16:34:53 <tjones> thanks melwitt1
16:35:03 <johnthetubaguy> OK… sounds like libvirt could do with extra people on that list
16:35:07 <tjones> #action melwitt to be the owner of nova-manage
16:35:10 <wendar> jogo: I'll help with testing if you want to take it, I just don't want to be primary on two
16:35:21 <tjones> i can put you both ;-)
16:35:26 <jogo> johnthetubaguy: not enough badwidth to do it right
16:35:32 <jogo> bandwidth
16:35:43 <tjones> let me ask one of our CI guys if they have bandwidth
16:35:47 <johnthetubaguy> jogo: no problem, just wanted to check ;-) you see so on top of that stuff
16:36:00 <jogo> I am happy to help out with that but don't wnat to be primary either
16:36:02 <tjones> #action see if someone can help wendar with testing
16:36:07 <wendar> tjones: I started on both this week, but if anyone pops up for either, I'm happy to share
16:36:16 <tjones> thanks wendar
16:36:32 <tjones> so libvirt is really needing help
16:37:02 <tjones> does anyone know if kchamart is still working on it?
16:38:12 <tjones> ok - lets move on to tagging the last 26 unless someone has something they want to discuss?
16:38:34 <johnthetubaguy> tjones: no idea, russellb might be worth asking
16:38:53 <wendar> just a quick question on how to tag feature tickets that are held for now because of feature freeze?
16:38:58 <tjones> #action ask russellb who else can help with libvirt
16:39:35 <tjones> wendar: im assuming the same as always - they would be help up in review if they are part of a BP
16:39:43 <tjones> s/help/held
16:40:01 <tjones> #topic bug tagging
16:40:15 <tjones> #link https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
16:40:37 * jogo gets off train
16:40:49 <tjones> #link https://bugs.launchpad.net/nova/+bug/1279857
16:41:25 <tjones> this is a feature request for guest debug logging
16:41:32 <tjones> so….  compute?
16:41:44 <wendar> sounds good
16:42:06 <johnthetubaguy> +1
16:42:21 <tjones> #link https://bugs.launchpad.net/nova/+bug/1269407
16:42:33 <tjones> network
16:42:57 <wendar> yeah
16:43:06 <tjones> #link https://bugs.launchpad.net/nova/+bug/1271479
16:43:29 <tjones> does this belong to nova or horizon?
16:43:30 <wendar> libvert?
16:43:46 <tjones> oh ok
16:43:54 <melwitt> it sounds like horizon, no?
16:44:09 <melwitt> oh nvm, hard reboot doesn't work apparently
16:44:17 <tjones> it sounds like horzon puts the right metadata but it is not honored
16:44:38 <melwitt> from the cli
16:44:40 <tjones> #link https://bugs.launchpad.net/nova/+bug/1271479
16:44:42 <johnthetubaguy> tjones: but the cli works fine?
16:44:56 <tjones> johnthetubaguy: melwitt  - yes i read it the cli is fone
16:44:57 <tjones> fine
16:45:40 <melwitt> then another comment says cli hard reboot doesn't work
16:46:51 <tjones> right - confusing
16:47:15 <tjones> ok leaving it with libvirt
16:47:40 <tjones> #link https://bugs.launchpad.net/nova/+bug/1280033
16:48:03 <tjones> no idea
16:48:20 <wendar> oslo?
16:48:32 <tjones> i think this is removing it from nova
16:48:40 <tjones> each project is represented here...
16:48:47 <melwitt> yeah all projects need to update dependency
16:48:56 <tjones> yeah
16:49:09 <melwitt> I'm never sure how to tag ones like that
16:49:14 <johnthetubaguy> yeah, doesn't need a tag I guess, unless we have a dependency one, seems silly
16:49:29 <tjones> here is where we need "wat"
16:49:54 <tjones> #action put "wat" back for bugs like https://bugs.launchpad.net/nova/+bug/1280033
16:50:04 <johnthetubaguy> maybe, "other" would be better?
16:50:04 <tjones> and assign to russellb
16:50:06 <tjones> :-D
16:50:18 <wendar> oooh, the dreaded other
16:50:20 <johnthetubaguy> just needs the dependency list updating
16:50:28 <wendar> how about a status other than New?
16:50:38 <johnthetubaguy> we have one, triaged?
16:50:52 <melwitt> triaged is a good idea
16:51:14 <tjones> johnthetubaguy: well it could be we need a bucket for overall nova stuff.  we can triage it but if it is not tagged im worried it will get lost
16:51:27 <tjones> we have a TON of untagged bugs that are not New
16:51:38 <wendar> I'd tag it with oslo, just because it's the kind of thing I'd do when working on other oslo stuff.
16:51:48 <tjones> 370 to be precise
16:51:58 <tjones> ok will do
16:52:00 <melwitt> theoretically selecting all "triaged" should give a list of things we know how to fix that just need to get done
16:52:00 <johnthetubaguy> tjones: true, maybe other makes sense then?
16:53:06 <tjones> well it sounds like wendar will take care of it if i put it in oslo ;-)
16:53:21 <wendar> true :)
16:53:41 <tjones> getting close to time - so moving to #link https://bugs.launchpad.net/nova/+bug/1280389
16:54:25 <wendar> network?
16:54:28 <tjones> yeah
16:54:47 <tjones> #link https://bugs.launchpad.net/nova/+bug/1281087
16:54:50 <tjones> migration bug
16:55:07 <melwitt> compute?
16:55:33 <tjones> yeah #link https://bugs.launchpad.net/nova/+bug/1281969
16:55:43 <melwitt> the possible dupe in the comment is tagged libvirt fwiw
16:56:04 <tjones> #action look at the dup comment in https://bugs.launchpad.net/nova/+bug/1281087
16:56:28 <tjones> this one https://bugs.launchpad.net/nova/+bug/1281969 looks like an infra issue
16:57:02 <melwitt> I'd say api probably
16:57:34 <johnthetubaguy> needs more info I feel
16:57:41 <johnthetubaguy> need nova logs for the error
16:58:09 <tjones> ok added that comment
16:58:14 <melwitt> nova returning 500 to tempest, could be compute too
16:58:49 <tjones> once we get more info we can triage it better.
16:59:12 <tjones> or i can put both?
16:59:25 <tjones> never mind - they can't do anything without the nova logs
16:59:34 <tjones> almost out of time.
16:59:38 <wendar> does that get an Incomplete?
16:59:42 <tjones> should i change this to 8am-9am?
16:59:47 <tjones> wendar: good idea
16:59:56 <tjones> start it 1/2 hour earlier?
17:00:05 <melwitt> yeah, can ask the reporter for additional info then mark incomplete until they reply
17:00:23 <wendar> 1/2 hour earlier is fine for me
17:00:27 <wendar> so is running 1/2 hour longer
17:00:29 <johnthetubaguy> I can't make half an hour earlier I am afraid, at least, probably not
17:00:35 <tjones> i have another meeting now
17:00:37 <johnthetubaguy> but I can just join late
17:01:07 <tjones> cause things are just going to heat up for the next couple of weeks
17:01:18 <tjones> we will need to start focusing on movement of critical bugs for rc
17:01:26 <tjones> not just tagging
17:01:29 <wendar> yeah
17:02:12 <wendar> 10 minutes per day might be more effective for a couple weeks than 1 hour per week
17:02:17 <wendar> but, difficult to coordinate
17:02:27 <tjones> interesting...
17:02:27 <wendar> (and definitely not sustainable beyond a couple weeks anyway)
17:02:43 <tjones> that is a really good idea
17:02:53 <wendar> could be just focused on RC
17:03:02 <tjones> yes
17:03:30 <tjones> only up unitl rc ;-)
17:03:42 <wendar> yeah
17:04:15 <johnthetubaguy> but the thing we need to spot it the big bloopers, so probably need to get the tag owners to pull their finger out with priority setting right?
17:04:41 <tjones> johnthetubaguy: yes that is critcal (which is why i wanted owners so badly)
17:05:05 <johnthetubaguy> :)
17:06:32 <tjones> let me think about how this will work and i'll drop an email to the ML
17:07:01 <wendar> good idea
17:07:07 <tjones> and i'll continue tagging the obvious ones.  i gotta run to my next meeting.  thanks for the help!
17:07:10 <tjones> #endmeeting