10:00:17 <markus_z> #startmeeting nova-bugs-team
10:00:18 <openstack> Meeting started Tue May 10 10:00:17 2016 UTC and is due to finish in 60 minutes.  The chair is markus_z. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:00:21 <openstack> The meeting name has been set to 'nova_bugs_team'
10:00:39 <markus_z> hey ho, anyone around?
10:01:00 <andrearosa> o/
10:01:16 <markus_z> hi andrearosa
10:01:24 <markus_z> let's wait for another minute
10:01:32 <andrearosa> ok
10:02:04 <markus_z> #info 33 new bugs which need triage: https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
10:02:16 <markus_z> #info 914 open bugs overall
10:02:51 * kashyap waves
10:03:18 <markus_z> well, ok, it looks like the folks from huawei won't come
10:03:34 <andrearosa> is it a good time for them?
10:03:57 <markus_z> I offered an earlier time slot but didn't get a response.
10:04:30 <markus_z> #action markus_z move the timeslot 2 hours earlier
10:04:46 <markus_z> andrearosa: Do you like to skim new bugs for the next days?
10:05:01 <andrearosa> I have a question, while we are triaging a bug do we need to assign the bug to ourselves?
10:05:10 <markus_z> andrearosa: no
10:05:31 <markus_z> The assignee of a bug report should provide a patch for review in Gerrit
10:05:54 <andrearosa> what about commit my self for the next week? this one is pretty busy. I can try to help you next mon and tue
10:05:57 <andrearosa> how that sounds?
10:06:19 <markus_z> andrearosa: next week is great too
10:06:27 <kashyap> andrearosa: Yeah, no need to assign the bug to yourself, unless of course you're providing the fix :-)
10:06:30 <markus_z> I'm not a lot in the office this week
10:06:49 <markus_z> #action markus_z tag the currently open untagged bugs reports
10:07:25 <markus_z> kashyap: What's does your schedule say? Can you take a look at libvirt bugs this week?
10:07:35 <markus_z> Currenty 6 new libvirt tagged bug reports
10:07:41 <andrearosa> markus_z: kashyap ok I was thinking that it might be that 2 ppl can do the same job ...but it seems that is more a wish than the reality :)
10:07:42 <kashyap> markus_z: Hey
10:08:15 <kashyap> markus_z: Sure, I can look at the libvirt bugs.
10:08:23 <markus_z> andrearosa: Do you mean 2 or more people doing bug triage at the same time?
10:08:28 <andrearosa> yeap
10:08:35 <markus_z> kashyap: thanks!
10:08:48 <markus_z> andrearosa: It's still possible, just talk to each other in #openstack-nova
10:08:55 <kashyap> markus_z: Currently working on the Liberty version of https://review.openstack.org/#/c/314012/3
10:08:55 <andrearosa> good point
10:09:32 <andrearosa> even if you don't know that someone else is looking at the same bug. But it doesn't seem the case here so nevermind
10:10:01 <markus_z> kashyap: yeah, I tried to figure out the issue in the unit test but didn't find it
10:10:03 <kashyap> andrearosa: Heh, yeah -- it's common that two or more heads work on finding the root cause, and arriving at a fix.
10:10:20 <markus_z> kashyap: The next day I checked the patch was approved for master
10:10:47 <kashyap> markus_z: Yeah, Dan Smith / Matt Riedemann are more familiar with that area -- so they got through them quickly
10:10:58 <kashyap> markus_z: And last time I checked you still have only 24 hours
10:11:17 <markus_z> andrearosa: Would you add your name here for the next week please? https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty
10:11:33 <markus_z> kashyap: yeah, I try to bend time by pure will power, but wasn't successful yet :(
10:11:36 <andrearosa> markus_z: will do
10:11:39 <markus_z> thanks
10:11:45 <kashyap> markus_z: :-) Nah, you're doing good
10:12:06 <markus_z> Any open questions by anyone? Otherwise I would close the meeting.
10:12:15 <kashyap> markus_z: I'm just trying to reduce massive context-switching lately.  So, a week on Nova, next on lower-layer Virt, or something like that
10:12:22 <kashyap> Nothing at the moment from me
10:12:38 <markus_z> kashyap: Ah, yes, very good approach. Context switches kill a lot of time for me too.
10:12:43 <andrearosa> markus_z: we should think of closing
10:12:46 <andrearosa> very old bugs
10:12:54 <andrearosa> I remeber we had a kind of discussion on ML
10:13:25 <kashyap> andrearosa: Yeah, the point of agreement was that: if the bugs are reported for releases that EOLed, then it's fair game to close them asking to "Please retry on current stable or master"
10:13:33 <markus_z> right, I didn't hear voices against closing old things.
10:13:43 <kashyap> FWIW, that's what we do in Fedora distribution -- which has a 6-month life cycle too
10:13:59 <andrearosa> kashyap: it sounds like a good approach
10:14:00 <markus_z> #link potentially expired bug reports: http://45.55.105.55:8082/bugs-dashboard.html#tabExpired
10:14:33 <markus_z> A lot of them are old wishlist items
10:14:46 <kashyap> andrearosa: Put another way Once N+2 is released, 'N' goes End-of-Life.  And, all bugs (that are not solved) reported against 'N' are closed, with a request to re-test them on N+2, and re-open it if the issue persists.
10:14:55 <markus_z> I signed up to close them case-by-case but didn't make much progress in the last week
10:15:30 <andrearosa> markus_z: case by case seems an endless job, I'd go for a more drastic way
10:15:46 <andrearosa> that is my opinion and I am not very familiar with the official process here
10:15:53 <andrearosa> so I could be compeltely wrong
10:16:14 <kashyap> andrearosa: Markus has some LP scripts
10:16:28 * kashyap needs to step out now; see ya later
10:16:58 <markus_z> yeah, it's easy to automate, but I couldn't convice myself to do this as a bulk operation (with this much of open items)
10:17:03 <markus_z> kashyap: see you
10:17:11 <andrearosa> kashyap: bye
10:17:42 <markus_z> I'm targeting the time after the non-priority-feature freeze for a general cleanup of old bug reports
10:18:00 <andrearosa> ok
10:18:47 <markus_z> #action markus_z announce LP cleanup after R-14 (non-priority-feature freeze)
10:19:16 <markus_z> That's the time slot where some people should have more time, after their features got merged or not.
10:19:58 <andrearosa> yeap
10:19:59 <markus_z> ok, other open items or things you like to discuss?
10:20:05 <andrearosa> nope
10:20:22 <markus_z> ok, closing in 3...
10:20:30 <andrearosa> ok bye
10:20:52 <markus_z> thanks for your time, next meeting next Tuesday at 18:00 UTC
10:20:56 <markus_z> #endmeeting