09:59:30 <markus_z> #startmeeting nova-bugs-team
09:59:30 <openstack> Meeting started Tue May 24 09:59:30 2016 UTC and is due to finish in 60 minutes.  The chair is markus_z. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:59:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:59:33 <openstack> The meeting name has been set to 'nova_bugs_team'
09:59:47 <macsz> \o
09:59:48 <lyarwood_> \o
09:59:53 <takashin_> \o
09:59:54 <markus_z> o/
10:00:09 <markus_z> Hello everyone, thanks for participating!
10:00:21 <markus_z> First a few infos
10:00:25 <andrearosa> hi
10:00:35 <markus_z> #info old wishlist reports are closed, exceptions for reports tagged with "ops".
10:00:45 <markus_z> #info Old bug reports will be expired in week R-13: http://lists.openstack.org/pipermail/openstack-dev/2016-May/095654.html
10:01:04 <markus_z> #link Bug stats now live and updated every hour at http://45.55.105.55:8082/bugs-stats.html
10:01:11 <markus_z> #info stats: 831 open bug reports
10:01:15 <markus_z> #info stats: 29 untriaged "new" bug reports
10:01:24 <markus_z> #info This early meeting will be moved to 2 hours earlier to reach out more folks in Asia: https://review.openstack.org/320337
10:02:10 <markus_z> We have a lot new bug reports.
10:02:24 <markus_z> raj_singh tagged them all (thanks for that)
10:02:44 <markus_z> but we need to check if they are valid or invalid
10:03:06 <markus_z> #link new bugs: https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
10:03:28 <markus_z> If anyone wants to help here, every effort counts
10:03:36 <andrearosa> markus_z: that's one of my point I'd like to ask you today after my exoperience last week
10:03:48 <andrearosa> to set valid/invalid
10:04:02 <andrearosa> do we need to manage to reproduce the issue and prove it?
10:04:23 <andrearosa> or do we have a kind of rule of thumb?
10:04:37 <andrearosa> soemtimes it's im[possible to reproduce an issue
10:04:46 <andrearosa> and most of the time it takes hours to do that
10:04:50 <andrearosa> so that is going to kill us
10:04:55 <andrearosa> do you see my point?
10:05:23 <andrearosa> is it enough to have a look at the code and say, yes it iseems you are right let mark this as valid
10:05:29 <andrearosa> or do we need to be more strict?
10:05:53 <markus_z> yeah, I'm seeing what you mean
10:06:43 <markus_z> My rule of thumb is, if you can make a somewhat educated guess, use it, cite your sources (github code, ML discussions, ...)
10:07:07 <markus_z> There is not strict rule to prove it.
10:07:24 <markus_z> You've seen that the effort to do it would be too huge
10:08:19 <markus_z> I tend to have local Devstack VMs (1x liberty, 1x mitaka, 1x master) which I can start when I need to check something on a full system.
10:08:23 <andrearosa> yes probably we should try to put this effort on the reporter's shoulders
10:08:51 <andrearosa> and use the Invalid axe if the info in the ticket are not clear or if there is not a valid way to eproduce it
10:09:02 <andrearosa> but I do not want to get ppl angry with us
10:09:08 <markus_z> yes, absolutely. If there is information necessary or steps to reproduce are missing, it's absolutely fair to ask for them and put the bug report to "incomplete".
10:10:17 <andrearosa> ok
10:10:32 <markus_z> finding a middle ground isn't easy, true. When you are in doubt with a specific bug report, just ping me in #openstack-nova and we'll discuss it.
10:11:21 <markus_z> #info we have the "needs-attention" tag, which I'm subscribed to. Use it when you're unclear which path to choose.
10:11:49 <andrearosa> yes i do not want to abuse the use of that tag
10:12:32 <markus_z> fair. Anything else you want to share from your experience from last week?
10:12:44 <andrearosa> yes is it now a good time?
10:12:47 <andrearosa> to ask?
10:12:58 <markus_z> yep, free for all right now :)
10:13:03 <andrearosa> cool
10:13:51 <andrearosa> when a bug it is already assigned I was just tagging it assuming that the reporter is working on it and it is a valid one. If it is not valid prbably that will be spotted during the reivew of the patch. is it correct?
10:14:23 <markus_z> correct
10:14:58 <andrearosa> you already asnwer this, but when it is not reproducible what the best status to close it? Invalid or Incomplete?
10:15:59 <markus_z> "Incomplete" is an open state, the report is not closed.
10:16:18 <markus_z> I'd chose this one to give others and the reporter the chance to provide more information.
10:16:44 <markus_z> incomplete bug reports get closed (with invalid) 30 days after it was changed to "incomplete"
10:17:07 <andrearosa> ok cool
10:17:22 <markus_z> oh, wait, I used "won't fix" for them
10:17:51 <markus_z> because it's not "invalid", we just don't find a way to fix/verify it.
10:18:22 <andrearosa> ok so mark it as incomplete after 30 days they go to won't fix. it sounds reasonable to me
10:18:27 <markus_z> Would it help if I write up a "status X means Y" doc thing?
10:18:57 <andrearosa> just few sentences to expalin how to treat those cases
10:19:00 <macsz> +1 :)
10:19:07 <markus_z> yep, "new" -> "incomplete" -> 30 days over -> "won't fix"
10:19:30 <andrearosa> last questiopn
10:19:41 <markus_z> #action markus_z write some FAQ for bug handling and status transitions
10:20:33 <andrearosa> how do we treat the dependencies? I have an open bug which was assigned to me but to get it fixed I need to wait to a new API in Cinder (i think the bug is the 1547142). I put a comment but the bug is still open even if itt is actually stuck
10:20:49 <kashyap> markus_z: Closed with a reasonable comment :-)
10:21:01 <kashyap> "Incomplete bugs" I mean.
10:21:11 <kashyap> (Sorry, I jumped in randomly.)
10:21:11 <markus_z> kashyap: cool, thanks! :)
10:21:36 * markus_z reads bug 1547142
10:21:37 <openstack> bug 1547142 in OpenStack Compute (nova) "A shelved_offload VM's volumes are still attached to a host" [Undecided,In progress] https://launchpad.net/bugs/1547142
10:22:07 <andrearosa> yeap that one
10:23:14 <markus_z> You left a comment, that's already good enough IMO. You could also make an "affects project cinder" to make the dependency more clear.
10:23:27 <markus_z> But I think the comment is sufficient.
10:23:35 <andrearosa> ok
10:23:56 <macsz> maybe we can add a tag waiting for external?
10:25:27 <markus_z> I'd rather not, to be honest. Sometimes it's just simply reading the comments, so cite your sources when you make comments :)
10:26:12 <markus_z> And use commit IDs when linking code.
10:26:30 <markus_z> Anymore open questions?
10:26:51 <andrearosa> nope, thanks for your help
10:26:54 <macsz> one related to new time proposal
10:26:58 <markus_z> #help bug skimming for next week is needed, volunteers?
10:27:09 <markus_z> sure, go ahead
10:27:15 <macsz> Maybe we can move it another 2 hours earlier? Current proposal is middle of the night in US - 3 AM. It would be easier to attend at 1 AM
10:28:01 <markus_z> This meeting has alternating time slots. Next week is the US friendly time slot at 1800 UTC.
10:28:29 <macsz> so this proposal is for one time slot only?
10:28:36 <markus_z> yes
10:29:00 <macsz> ok
10:29:06 <markus_z> This week Europe/Asia (the changed time proposal), next week is US (time slot unchanged)
10:30:18 <macsz> no more questions :)
10:30:20 <andrearosa> sorry I have one more
10:30:23 <andrearosa> question
10:30:25 <markus_z> sure
10:30:36 <andrearosa> who can change the Importance of the bug?
10:30:56 <tonyb> any member of the nova-bugs team
10:31:05 <tonyb> (which is an open group)
10:31:09 <markus_z> #link https://launchpad.net/~nova-bugs
10:31:36 <markus_z> just join and you're free to set the importance
10:31:43 <andrearosa> ok
10:32:52 <markus_z> Anyone want to volunteer for next weeks bug skimming? It's a great way to learn things about Nova and I'm available for questions too.
10:33:17 <markus_z> #link https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty
10:33:40 <andrearosa> I can commit few hours again next week, not sure when precisely
10:34:02 <markus_z> That would be great, thanks a lot!
10:34:18 <andrearosa> ok, np
10:34:47 <markus_z> I've seen we have some "docimpact" bug reports, they should be easy to handle
10:34:51 <markus_z> #link DocImpact => bug report in nova: http://lists.openstack.org/pipermail/openstack-dev/2016-March/088382.html
10:35:30 <markus_z> It's usually poking the authors of the patches and ask what manuals they think should be updated
10:35:57 <markus_z> After that, reroute it to the manuals team with a comment what needs to be documented.
10:36:23 <andrearosa> is it not the relnote enough
10:36:26 <andrearosa> to get the doc team
10:36:30 <andrearosa> all the info they need?
10:36:36 <tonyb> Or create a devref review
10:36:59 <andrearosa> mmh maybe the relnote is too short
10:37:01 <tonyb> andrearosa: Yeah the idea is the triage close to the code and then escalate to the docs team as require
10:37:15 <markus_z> ^ what tonyb said
10:37:38 <andrearosa> gothca
10:37:50 <andrearosa> gotcha even
10:37:56 <markus_z> :)
10:38:38 <markus_z> As I said at the beginning, would be great if anyone here would grab one of the (older) "new" bugs and check them.
10:39:04 <markus_z> mriedem is on vacation AFAIK and he closed a lot lately, so we don't have that right now.
10:39:31 <tonyb> tsck tsck he shouldn't be closing bugs wheil on vacation
10:39:56 <markus_z> OK, anything else? Open questions?
10:40:54 <markus_z> tonyb: Hm, poor wording from my side, he closed a lot before his vacation. Right now he's chilling I guess :)
10:41:09 <macsz> :D
10:41:27 <tonyb> markus_z: Ahh OK
10:41:34 <markus_z> Closing in 3 ...
10:42:00 <markus_z> Thanks for your time! Next meeting is on next Tuesday at 18:00 UTC
10:42:06 <andrearosa> bye
10:42:08 <markus_z> #endmeeting