18:00:10 <markus_z> #startmeeting nova-bugs-team
18:00:11 <openstack> Meeting started Tue Aug  9 18:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is markus_z. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:15 <openstack> The meeting name has been set to 'nova_bugs_team'
18:01:27 * markus_z waits a little
18:02:03 <markus_z> let's start
18:02:06 <markus_z> #topic info round
18:02:14 <markus_z> #info overall 657 open bug reports
18:02:19 <markus_z> #info 37 untriaged bug reports
18:02:44 <markus_z> #info a lot of stale in progress bug reports http://45.55.105.55:8082/bugs-dashboard.html#tabInProgressStale
18:03:08 <markus_z> #action markus_z cleanup some of the stale in progress reports: http://45.55.105.55:8082/bugs-dashboard.html#tabInProgressStale
18:03:40 <auggy> o/
18:03:46 <markus_z> #info ~3 weeks left until N-3 milestone
18:03:51 <markus_z> hey auggy
18:04:10 <markus_z> #topic last action items
18:04:16 <auggy> hey markus_z! i've been here but forgot to raise my hand haha
18:04:35 <markus_z> no worries :)
18:05:14 <markus_z> #info https://bugs.launchpad.net/nova/+bug/1605742 could be resolved
18:05:14 <openstack> Launchpad bug 1605742 in openstack-ansible "Paramiko 2.0 is incompatible with Mitaka" [Critical,Fix committed] - Assigned to Jesse Pretorius (jesse-pretorius)
18:05:33 <markus_z> #info https://bugs.launchpad.net/nova/+bug/1605804 gets solved with https://review.openstack.org/#/c/352344/
18:05:34 <openstack> Launchpad bug 1605804 in OpenStack Compute (nova) "Instance creation sometimes fails after host aggregate deletion" [Low,In progress] - Assigned to Markus Zoeller (markus_z) (mzoeller)
18:06:02 <markus_z> #info the "review pipeline idea" didn't find enough attention. A conclusion is at http://lists.openstack.org/pipermail/openstack-dev/2016-August/100628.html
18:06:49 <markus_z> #info I'm search a new timeslot for the "early meeting" http://lists.openstack.org/pipermail/openstack-dev/2016-August/100613.html
18:07:07 <markus_z> That was basically last weeks action items
18:07:35 <markus_z> #topic specific bugs to discuss
18:07:55 <markus_z> I thought it could make sense to discuss some bug reports here
18:08:10 <markus_z> https://bugs.launchpad.net/nova/+bug/1610069
18:08:10 <openstack> Launchpad bug 1610069 in OpenStack Compute (nova) "there is no detach interface api policy in nova " [High,Triaged]
18:08:31 <markus_z> alaski explained to me that the policy is now on the API level only
18:08:50 <markus_z> If you missed it, this is now purely in python code, the "policy.json" file is empty.
18:09:20 <markus_z> policy checks are done with "context.can($policy)"
18:09:34 <auggy> oh cool, that's all been implemented now
18:10:03 <markus_z> I'm bringing this up here in case something similar to the bug reports above comes up in the future.
18:10:24 <auggy> good to know!
18:10:42 <markus_z> here's the thing in code: http://git.openstack.org/cgit/openstack/nova/tree/nova/api/openstack/compute/attach_interfaces.py#n147
18:11:43 <markus_z> The bug above is basically an all-or-nothing situation where you either can or cannot attach AND detach. There is no granularity. alaski is going to push a patch for that.
18:11:58 <auggy> ok that makes sense
18:12:12 <auggy> you can do both or neither but not one or the other
18:12:18 <markus_z> right
18:12:45 <markus_z> the policy for "detach-interface" got overlooked back then
18:13:39 <markus_z> Another bug I wanted to discuss is: https://bugs.launchpad.net/nova/+bug/1610393
18:13:39 <openstack> Launchpad bug 1610393 in OpenStack Compute (nova) "Unexpected API Error: unexpected keyword argument 'prompt'" [Undecided,New]
18:14:25 <markus_z> auggy: I had the hope that you could give me a little insight about the "api.openstack.extension"
18:14:44 <auggy> hrm, i'm not really sure, let me look at the bug
18:15:09 <markus_z> At the bottom of the stacktrace is "nova.api.openstack.extensions TypeError: __init__() got an unexpected keyword argument 'prompt'"
18:15:26 <markus_z> I hadn't enough time to wrap my head around this
18:15:42 <auggy> yeah i am looking at that
18:15:51 <auggy> i can take a look today and see if i can get more information
18:16:07 <auggy> i thought extenstions were deprecated?? but maybe not?? i'm not sure, so many things going on
18:16:14 <auggy> it might be extensions/plugins somewhere else were deprecated
18:17:07 <markus_z> yeah, that's what I remember too, and I wanted to understand what the extensions thing is.
18:17:26 <markus_z> Maybe we can chat this week in #nova and I post a summary at the next meeting
18:17:31 <auggy> hrm yeah i'm not sure, or not remembering right now
18:17:38 <auggy> sure
18:18:11 <markus_z> If everything fails I'll ask alex_xu or sdague
18:18:35 <markus_z> #topic open round
18:19:10 <markus_z> uh oh, macsz does the bug skimming this week, I totally forgot that
18:19:16 <markus_z> https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty
18:19:20 <markus_z> cool beans
18:19:40 <macsz> yup, reassigned myself for this week as well
18:19:52 <markus_z> awesome, thanks a lot!
18:20:12 <auggy> oh cool!
18:20:31 <markus_z> I fired all shells I had, anyone from you wants to discuss a topic?
18:20:39 <auggy> markus_z: i think for that bug you'd linked about the api extensions, we need more info from the reporter anyways, like what version they are running
18:21:44 <markus_z> yeah, would be great. I have an ongoing discussion with oomichi about the log message which could confuse people: https://review.openstack.org/#/c/335146/
18:22:53 <auggy> that's good because that's our #1 issue when people are reporting these errors
18:23:08 <markus_z> I'm not even sure which information else is needed for the api.extension bug, I don't understand that area enough.
18:24:09 <markus_z> macsz: Anything you want to add for today's meeting?
18:24:51 <macsz> nope, im cool
18:24:54 <auggy> it looks like it's related to keystone
18:25:15 <macsz> will start bug triage tomorrow, today im occupied with other stuff
18:26:00 <markus_z> cool cool
18:26:34 <markus_z> auggy: yeah, at first I thought it is the keystoneauth load issue where one option got renamed
18:26:51 <auggy> hrm yeah, well i can't try to reproduce it until i know what they are running
18:27:00 <auggy> sometimes people have custom setups and post these problems
18:27:07 <auggy> like, through another tool
18:27:13 <markus_z> I mean that one: https://review.openstack.org/#/c/344371/
18:27:28 <auggy> oh right yeah
18:27:38 <auggy> yeah it's just hard to really investigate it without knowing how they are running Openstack
18:28:02 <markus_z> true, I'll follow up on that one
18:28:03 <auggy> i put a request to the reporter for more info and updated the status
18:28:24 <markus_z> ah, cool, you're faster than me :)
18:28:54 <auggy> i noticed we have a couple of unskimmed bugs that were last updated in april
18:29:24 <auggy> https://bugs.launchpad.net/nova/+bug/1570107
18:29:24 <openstack> Launchpad bug 1570107 in OpenStack Compute (nova) "block device mapping : booting up attached volumes with no boot index when multiple bootable volumes are used" [Undecided,New]
18:30:03 <auggy> https://bugs.launchpad.net/nova/+bug/1573875
18:30:04 <openstack> Launchpad bug 1573875 in OpenStack Compute (nova) "The same ceph rbd device is used by multiple instances" [Undecided,New]
18:30:42 <markus_z> I'm not sure who looks at volume related issues after ndipanov left
18:30:51 <markus_z> I never found anyone for ceph related things...
18:31:18 <auggy> ah ok, we should bring that up at the next meeting
18:31:22 <markus_z> There are a few sriov issues, I think moshele does a meeting for that topic, I'm asking around
18:31:33 <auggy> yeah there's a subteam for that
18:31:50 <markus_z> #action markus_z Poke SRIOV subteam wrt bugs
18:31:50 <auggy> we can tag those as "needs-attention" right?
18:32:17 <markus_z> auggy: yeah, which basically means I poke folks (when I find time)
18:32:20 <auggy> haha
18:32:30 <auggy> ok well feel free to delegate if you don't have time
18:32:43 <auggy> i will look at some of those old bugs that have been sitting around still in "new" state
18:32:54 <auggy> and see if i can determine anything new about them or try to reproduce any
18:33:30 <auggy> i had some luck using devstack-gate, although i never got multinode to work in the environment i was trying to get it to work in
18:33:39 <auggy> so i can repro environments that aren't multi-node
18:34:48 <markus_z> #action markus_z push (more) devstack local.conf examples like https://review.openstack.org/#/c/305967/
18:35:37 <markus_z> what's the purpose of devstack-gate again?
18:35:57 <auggy> it spins up devstack instances to run tests on, basically
18:36:40 <markus_z> ah, I have to look at that
18:36:53 <auggy> the idea is if you have a test that's failing in the gate and you can't reproduce it locally, you can try to reproduce the gate environment and rerun the tests that the gate is running
18:37:09 <auggy> it's pretty handy
18:37:27 <markus_z> sounds nice
18:37:40 <auggy> since it runs on clean vm's if there are any system dependencies, it's supposed to handle installing tehm
18:37:41 <auggy> them
18:37:47 <auggy> so you shouldn't have to configure ceph for instance
18:38:02 <auggy> you should just have to run that job via devstack-gate and it should do all the setup
18:38:14 <auggy> it can be a little tricky
18:39:50 <markus_z> Hm, I should definitely look at it
18:40:19 <auggy> yeah let me know if you have questions, the instructions are somewhat incomplete and i need to post some updates
18:40:46 <markus_z> So, well, I would wrap it up for today. Once again, we have enough bugs to work on.
18:41:30 <auggy> alright
18:41:36 <auggy> thanks markus_z
18:41:42 <markus_z> I'm also up for suggestions how this meeting can be more productive/efficient. The agenda isn't written in stone. Just ping me if you have ideas.
18:41:57 <markus_z> Thanks for your time and effort, see you in #nova
18:42:01 <markus_z> closing in 3...
18:42:11 <markus_z> #endmeeting