22:00:12 <alaski> #startmeeting nova_cells
22:00:13 <openstack> Meeting started Wed Jan  7 22:00:12 2015 UTC and is due to finish in 60 minutes.  The chair is alaski. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:18 <openstack> The meeting name has been set to 'nova_cells'
22:00:34 <alaski> Anybody here for the cells meeting?
22:00:38 <bauzas> \o aloha
22:00:39 <belmoreira> hi
22:01:03 <alaski> hi
22:01:08 <melwitt> o/
22:01:24 <alaski> cool, let's get started
22:01:44 <alaski> I will admit up front that I'm a bit disorganized after the break
22:01:50 <alaski> still catching up on a lot of stuff
22:01:53 <bauzas> eh
22:02:01 <melwitt> join the club :P
22:02:04 <belmoreira> :)
22:02:05 <alaski> :)
22:02:09 <alaski> #topic testing
22:02:39 <alaski> so it appears that we're up to about 70 failures on the cells job now
22:03:00 <alaski> it was at around 40 before the break
22:03:06 <bauzas> ergh
22:03:13 <alaski> I'm not sure what tests are failing now yet
22:03:35 <alaski> it's possible that we'll just want to skip them
22:03:42 * edleafe arriving late
22:04:02 <alaski> but this does make me want to get this job voting asap
22:04:24 <alaski> #link https://etherpad.openstack.org/p/nova-cells-testing
22:04:32 <alaski> so as always, any help here is appreciated
22:04:36 <bauzas> can we maybe provide a non-voting job first ?
22:04:52 <bauzas> because atm, it's only experimental pipeline right ?
22:04:52 <alaski> bauzas: we have one, but it is in experimental
22:04:57 <alaski> right
22:05:15 <alaski> moving that to the check queue might be a good step
22:05:18 <bauzas> alaski: yeah, that's why I thought we should maybe put a non-voting in the check pipeline
22:05:42 <bauzas> alaski: in there, just skip the failing ones
22:05:46 <alaski> I like that
22:05:59 <bauzas> alaski: and leave the full testing in experimental
22:06:14 <bauzas> alaski: so at least we would make sure we wouldn't regress
22:06:25 <alaski> yeah
22:06:47 <alaski> bauzas: would you like to look into that?
22:06:55 <bauzas> alaski: sure
22:07:07 <alaski> cool
22:07:26 <bauzas> alaski: just lemme find how to get 25 hours for a day but I'm fine eh ;)
22:07:29 <alaski> #action bauzas look into getting a cells tempest job into check pipeline
22:07:40 <alaski> bauzas: heh.  I'm happy to help with that too
22:07:58 <bauzas> alaski: lol, I guess we all are kinda busy
22:08:10 <alaski> anything else on testing?
22:08:11 <bauzas> that's life, go ahead
22:08:37 <alaski> #topic table analysis
22:08:57 <alaski> I was supposed to put up a review to get the uncontroversial tables into the devref
22:09:08 <alaski> I have not
22:09:10 <bauzas> lol
22:09:31 <alaski> but I will propose that tomorrow
22:10:07 <belmoreira> well... is not really the tables that are controversial
22:10:36 <belmoreira> there are questions like the scheduler, aggregates, nova-network that we need to discuss
22:11:03 <alaski> agreed
22:11:36 <belmoreira> maybe having a meeting to discuss these points would be a good start
22:11:44 <alaski> I think it will be helpful to have some things that are more concrete so we have a common understanding
22:11:59 <alaski> but we definitely need to discuss those larger topics soon
22:12:00 <bauzas> belmoreira: +1
22:12:57 <alaski> should we plan to devote these meetings to a particular topic each week for a bit?
22:13:36 <bauzas> we could discuss that during midcycle but I'm not sure that everyone can attend
22:13:40 <belmoreira> alaski: I think is a good idea
22:14:01 <belmoreira> bauzas: I will not be in the midcycle
22:14:15 <bauzas> belmoreira: ack
22:14:32 <alaski> belmoreira: okay.  we'll pick a topic to focus on each week
22:14:44 <bauzas> belmoreira: we did something last midcycle about a remote participation for the sched, maybe we could do this too ?
22:15:22 <belmoreira> bauzas: that would be great
22:16:05 <alaski> Everyone okay with starting with scheduling next week?
22:16:15 <bauzas> +1
22:16:19 <belmoreira> alaski: +1
22:16:36 <edleafe> +1
22:16:47 <alaski> cool
22:17:16 <alaski> #action alaski clear out next weeks agenda to discuss scheduling
22:17:33 <alaski> which leads nicely into the next topic
22:17:40 <alaski> #topic cells scheduling
22:17:59 <alaski> mainly I want to point out https://review.openstack.org/#/c/141486/
22:18:37 <alaski> I am going to update it as soon as I can, and we can use that to work towards next weeks discussion
22:18:53 <bauzas> cool
22:19:03 <belmoreira> great
22:19:30 <alaski> #topic open discussion
22:19:50 <alaski> Anyone have anything to discuss?
22:20:33 <bauzas> alaski: now that the first BP has been merged, do you plan to provide the change also ?
22:20:39 <bauzas> I mean soon
22:21:05 <bauzas> and by soon, I mean k2
22:21:08 <alaski> I would like to work on those soon, but I haven't written any code yet
22:21:20 <bauzas> alaski: ok
22:21:40 <alaski> and I'm happy to share if others are interested in getting involved
22:21:41 <bauzas> alaski: also, I won't explain to a core that you will need to ask for an exception for all the missing specs :)
22:22:14 <alaski> bauzas: :)
22:22:28 <alaski> I'm not sure that I want an exception for them honestly
22:22:40 <alaski> I don't want to rush things here
22:22:48 <alaski> but I also don't want work to get held up
22:22:59 <bauzas> alaski: yeah makes sense
22:23:04 <alaski> so I'm considering looking at a feature branch to use for prototyping
22:23:16 <alaski> but I don't know what all is involved with that
22:23:31 <bauzas> alaski: warning, big question : do you plan a stackforge fork ?
22:23:55 <alaski> I am not planning a fork
22:24:22 <bauzas> alaski: oh by branching you mean a Gerrit change
22:24:23 <belmoreira> the second BP is also approved
22:24:26 <bauzas> series
22:24:57 <alaski> bauzas: that would be one way, but I think we can actually have a separate branch to merge to
22:24:57 <bauzas> by branching, I was thinking about git branch...
22:25:05 <alaski> bauzas: right
22:25:10 <bauzas> alaski: orly?
22:25:26 <alaski> bauzas: I don't know any details, but I've heard it discussed before
22:25:34 <alaski> I want to get some details before proposing anything
22:25:34 * bauzas needs to think about the bribe amount
22:26:22 <bauzas> well, I was stupidely thinking that branches were duties for the Project Manager
22:26:42 <bauzas> hence the stackforge iterations
22:26:52 <alaski> this only matters though if we finish the two approved blueprints with plenty of time left in the cycle
22:26:56 <bauzas> hence Gantt and all the other tiny ugly projects
22:27:04 <bauzas> right
22:27:32 <bauzas> k, sounds a good approach then, to be discussed later then
22:27:58 <alaski> cool.  let's get some code merged first :)
22:28:02 <belmoreira> alaski: about getting involved in the implementation I'm interested. Or at least I can point someone.
22:28:18 <alaski> belmoreira: excellent
22:28:19 <belmoreira> alaski: let's discuss later
22:28:31 <alaski> belmoreira: sounds good
22:29:03 <alaski> anything else for open discussion?
22:29:42 <bauzas> crickets
22:29:44 <alaski> closing up early then
22:29:49 <alaski> Thanks everyone!
22:29:57 <alaski> #endmeeting