21:00:05 <alaski> #startmeeting nova_cells
21:00:06 <openstack> Meeting started Wed Apr  1 21:00:05 2015 UTC and is due to finish in 60 minutes.  The chair is alaski. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:09 <openstack> The meeting name has been set to 'nova_cells'
21:00:16 <alaski> anyone around?
21:00:22 <melwitt> o/
21:00:24 * tonyb is
21:00:27 <bauzas> \o
21:00:40 <alaski> sweet
21:00:47 <alaski> #topic Tempest testing
21:01:02 <alaski> https://review.openstack.org/#/c/168294/ and https://review.openstack.org/#/c/166396/
21:01:28 <alaski> it sounds like everything is mostly there, but jenkins is being grumpy atm
21:01:33 <bauzas> yeah, I hitted the Jenkins dependency merge issue...
21:01:35 <alaski> so we can't see test results
21:02:03 <alaski> bauzas: are there any workarounds for that?
21:02:14 <bauzas> alaski: none I've heard of
21:02:20 <bauzas> only recheck
21:02:23 <alaski> ok
21:02:24 <melwitt> I also have this patch up for the object service transient failures https://review.openstack.org/#/c/168121/ after chatting with mtreinish in irc
21:02:47 <alaski> melwitt: nice
21:02:50 * dansmith strolls in after getting disconnected from his proxy
21:03:00 <bauzas> alaski: so I will bug the other cores by tomorrow once Jenkins is happy
21:03:01 <alaski> #link https://review.openstack.org/#/c/168121/
21:03:40 <alaski> bauzas: sounds good.  I did -1 a patch with a question
21:03:51 <bauzas> alaski: orly ?
21:04:06 <alaski> https://review.openstack.org/#/c/169400/
21:04:30 <bauzas> oh, I see
21:04:44 <bauzas> well, I'll answer your questions
21:04:58 <alaski> cool
21:05:01 <bauzas> about the context stuff, I was thinking it was overcomplicating what we needed
21:05:12 <bauzas> but fair point for the tests
21:05:36 <bauzas> (because the context has to be passed to the Response object)
21:05:42 <alaski> right
21:05:49 <melwitt> but isn't he right that object.save() wouldn't work right with a None, None context?
21:06:22 <melwitt> for example
21:06:36 <bauzas> melwitt: well, the context is only passed if we need to backport the object
21:06:41 <bauzas> erm
21:06:56 <bauzas> I mean the context is only *needed if we have to bakcport the object
21:07:22 <alaski> bauzas: it passes it to the obj_from_primitive()
21:08:06 <bauzas> mmmm
21:08:07 <alaski> it will work fine here because the object isn't saved later, but could cause confusion later
21:08:22 <alaski> but we can debate it on the review
21:08:23 <bauzas> yeah you are probably right on that point
21:08:34 <melwitt> I'm thinking of a scenario of someone receiving the Response containing objects, and if they made a change and then did a save()
21:08:36 <bauzas> that's not impacting, but confusing
21:09:16 <alaski> melwitt: right.  that would either fail, or potentially save with wrong project_id info
21:09:25 <alaski> and/or user_id
21:09:45 <bauzas> ok, I have homework then :)
21:09:59 <alaski> anything else on our march towards green?
21:10:12 <alaski> thanks for all the work on this bauzas and melwitt
21:10:24 <bauzas> np
21:10:35 <alaski> #topic Specs
21:10:47 <alaski> I started splitting up the scheduling spec
21:10:51 <bauzas> \o/
21:11:01 <alaski> https://review.openstack.org/#/c/141486/4
21:11:02 <tonyb> :)
21:11:06 <alaski> https://review.openstack.org/#/c/169901/
21:11:07 <bauzas> we had a question about AZs on the ML
21:11:20 <bauzas> I gently pushed back the answer to that spec :)
21:12:01 <alaski> cool
21:12:12 <alaski> what I have up right now addresses the simple case
21:12:33 <alaski> but we do need to figure out azs/aggregates/whatever as well
21:13:14 <alaski> I'll try to dig up the list of db tables we weren't sure about and perhaps we can walk through them one by one during the meetings
21:13:24 <bauzas> sure thing
21:13:24 <alaski> or on a spec
21:13:41 <bauzas> perhaps going over the existing filters
21:13:54 <tonyb> alaski: I'd saya in a meetign and then document that by linking to the IRC log.
21:13:55 <bauzas> ie. server groups, AZs, aggs and instances
21:14:04 <tonyb> it'll be higher bandwidth that way
21:14:07 <alaski> bauzas: that could work too
21:14:15 <alaski> tonyb: +1
21:14:29 <bauzas> alaski: for that point, I would love to see operators interest
21:14:40 <bauzas> I could bug belmiro, I'm on the same TZ
21:15:06 <alaski> #action alaski find the list of scheduler features to work into cells, or get a list of filters
21:15:14 <alaski> bauzas: cool
21:15:15 <tonyb> I'm sure if we asked Tim Bell he'd come along hes' kinda invested in the outcome :)
21:15:33 <bauzas> belmiro works with Tim :)
21:15:38 <alaski> I can pull in VW and maybe a couple of others
21:15:43 <tonyb> bauzas: Ahh okay my bad
21:15:51 <bauzas> at CERN in Geneva, kinda 2h drive from my place :)
21:16:37 <bauzas> alaski: by thinking about it, aggs were not available for cells v1 right ?
21:16:51 <alaski> besides scheduler things, what other specs are people expecting to see for L?
21:17:03 <bauzas> alaski: about the action you took, I can help you for sure
21:17:10 <alaski> bauzas: right, there was some work but it wasn't finished afaik
21:17:41 <bauzas> alaski: ping me when you want to work on this, we could just do a quick review of what the scheduler is doing in terms of placement and overcommitment
21:17:49 <alaski> bauzas: sounds good, thanks
21:18:49 <alaski> any other specs we should discuss or think about proposing?
21:19:44 <tonyb> alaski: Personally I think the scheduler is it.
21:19:59 <tonyb> alaski: it's big enough that it's going to take most of L to get right
21:20:26 <alaski> tonyb: fair point
21:20:47 <alaski> I would love to see us able to boot an instance in L, and I think the scheduler is the big missing piece
21:21:02 <tonyb> alaski: Clearly there will be testing etc but that's not spec work.
21:21:05 <bauzas> tonyb: in particular as we're fast moving stuff in the vanilla scheduler too...
21:21:18 <tonyb> alaski: +1
21:21:30 <tonyb> bauzas: Yeah, can we pay you to slow down :P
21:21:57 <bauzas> my bribe rate is quite high
21:22:22 <tonyb> bauzas: phooey I was looking to get rid of the stray EUR I have after Paris ;P
21:22:47 <bauzas> anyway, I'm just thinking about how the ResourceTracker is working, and was thinking about scaling that out with cells
21:23:06 <bauzas> I would say it's doable, but the claims stuff sounds a bit risky
21:23:28 <bauzas> but let's leave the details up to the specs and POcs
21:23:59 <melwitt> this might be a dumb question, but is the db stuff nailed down already, that means already specced and just needs implementation, and speccing scheduler in L?
21:24:15 <bauzas> alaski: one last point, I should resume work on the RequestSpec object by early L1
21:24:19 <alaski> melwitt: not all of it
21:24:39 <alaski> melwitt: the db is in place, but we'll be adding more to it
21:24:44 <bauzas> yeah
21:24:59 <alaski> bauzas: okay.  that'll tie into one of the specs that's up
21:25:33 <bauzas> alaski: yeah, I thought you would be interested in knowing the status when I looked at your spec series :)
21:25:45 <alaski> melwitt: and what's going to get added isn't fully specced yet
21:27:15 <melwitt> alaski: okay, thanks. that helps me get a picture of how the road looks
21:27:35 <alaski> I'm starting to think that I want to get a lot of lightweight specs up with some plans, but with the understanding that they're not all for L
21:28:05 <alaski> lots of work to do
21:28:09 <alaski> anything else on specs?
21:28:52 <alaski> #topic Open Discussion
21:29:41 <bauzas> well, nothing but the Vancouver summit maybe ?
21:30:15 <alaski> anything in particular?
21:30:59 <bauzas> well, nothing really important, but I saw a point about fixing objectification for Cells V1
21:31:07 <alaski> oh?
21:31:38 <alaski> I do have https://review.openstack.org/#/c/79741/ up
21:31:40 <bauzas> wrt to the pain in the ass that's messaging returning objects, I would tend to say yes, but is it worth doing it?
21:32:22 <bauzas> alaski: well, I think that at least we need the Response patch fix to be landed at least
21:32:41 <bauzas> because if not, any objects will be returned as dicts
21:32:48 <alaski> yeah, given the pervasiveness of objects I think cells v1 should be updated to work with them
21:33:06 <tonyb> alaski: +1
21:33:07 <alaski> we're hitting more and more pain by not supporting them
21:33:24 <bauzas> okay, let's attempt this then
21:33:35 <tonyb> the code is going to be around for a while so it still needs life support
21:33:42 <bauzas> let's land the above series by Kilo and we'll target to objectify by L
21:34:16 <bauzas> tonyb: well, the main problem is that objects are not cell-aware
21:34:17 <tonyb> bauzas: which series are we tryign to lind in Kilo?
21:34:39 <bauzas> tonyb: https://review.openstack.org/#/c/169901/
21:34:44 <melwitt> yeah, I still have that object-ify patch where I hit the instance.save() cycle that I will work with again once the current series lands
21:34:52 <bauzas> tonyb: so we hacked a bit for returning objects
21:35:06 <alaski> I think you meant https://review.openstack.org/#/c/168294/3 :)
21:35:20 <tonyb> bauzas: okay FWIW that's in my to review list for today
21:35:59 <bauzas> alaski: eh, joker :)
21:36:36 <bauzas> oops
21:36:37 <bauzas> http://dictionnaire.reverso.net/francais-anglais/joker
21:36:42 <bauzas> wildcard I mean
21:37:30 <alaski> heh, joker has meaning as well
21:38:02 <alaski> okay, so there's still some cells v1 work ahead in L as well
21:38:03 * bauzas writes down a new word in his personal dictionary
21:38:39 <alaski> does anyone want to write up a spec for that, like a declaration of intent?
21:38:55 <bauzas> alaski: right, but we should state that we only plan to work on reducing the tech debt
21:39:02 <bauzas> alaski: fair point
21:39:28 <bauzas> alaski: I don't honestly think it deserves a spec but more an intent document
21:39:49 <alaski> sure.  it's similar to the objects work in that, but we've used specs for it
21:40:00 <bauzas> oh ok
21:40:29 <bauzas> yeah, that sounds a good thing to do
21:41:08 <tonyb> alaski: I'm happy to do it but it would be middle of my todo list, probably early May at this point
21:41:20 <tonyb> (so after Kilo lands but before the summit)
21:41:34 <tonyb> alaski: if that timeline works then you can # action me
21:41:59 <bauzas> I would at least propose to amend the Cells V2 manifesto
21:42:10 <bauzas> that should not be hard work
21:42:14 <alaski> tonyb: okay.  I'll assign you as I'm not sure of my timeline for it, but if I get to it I'll let you know
21:43:07 <alaski> #action tonyb Propose a declaration of intent L spec for objects/cells
21:43:51 <alaski> bauzas: amend it with the objects work?
21:44:42 <bauzas> alaski: amend by saying that we continue to work on Cells v1 meanwhile, but only by reducing the tech debt, not providing any new feature nor removing experimental state
21:45:05 <alaski> bauzas: gotcha. I'm +1 on that
21:45:22 <bauzas> ok, I can put a draft for it
21:45:49 <alaski> cool
21:46:16 <alaski> anything else?
21:46:54 <alaski> we'll let bauzas get back to his show then
21:47:05 <alaski> thanks all!
21:47:05 <bauzas> s/his/her
21:47:13 <alaski> heh
21:47:20 <bauzas> by 'her', meaning that I share TV
21:47:30 <alaski> #endmeeting