21:00:19 <alaski> #startmeeting nova_cells
21:00:20 <openstack> Meeting started Wed Aug 10 21:00:19 2016 UTC and is due to finish in 60 minutes.  The chair is alaski. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:23 <openstack> The meeting name has been set to 'nova_cells'
21:00:44 <melwitt> o/
21:01:18 <alaski> mriedem confirmed the meeting time and then doesn't show up. that guy
21:01:22 <dansmith> o7
21:01:27 <melwitt> haha
21:01:38 <alaski> well let's forge ahead quickly
21:01:42 <alaski> #topic testing
21:01:44 <mriedem> o/
21:02:10 <alaski> dansmith: any updates on grenade land?
21:02:31 <dansmith> alaski: oh, we were supposed to talk about that.. I've been mostly consumed with devstack-tempest-neutron stuff
21:02:59 <dansmith> alaski: that's coming to a close today hopefully, so lets chat tomorrow morning and make sure I know what I said I was going to do
21:03:03 <dansmith> because it wasn't clear to me from the etherpad
21:03:14 <alaski> sounds good.
21:03:21 <dansmith> also,
21:03:36 <dansmith> there are 600 things in the check queue right now, and getting runs is like a 24 hour affair,
21:03:44 <dansmith> so getting anything tested with grenade is likely to be "fun"
21:03:47 <alaski> yeah...
21:04:45 <alaski> just getting a rough sketch in place would be useful though. we can continue pushing on it after freeze if necessary to get it in order
21:05:00 <dansmith> yeah, well, let's do that tomorrow
21:05:10 <alaski> roger
21:05:16 <alaski> #topic Open reviews
21:05:41 <alaski> I'm only aware of a few things that still need eyes
21:05:50 <alaski> melwitt has a patch series on instance groups
21:06:06 <alaski> https://review.openstack.org/330995
21:06:29 <alaski> I have https://review.openstack.org/263927 for using the buildrequest in an instance show request
21:06:38 <alaski> I'm currently working on the followup for listing instances
21:06:49 <alaski> which involves replicating db sorting and filtering in python :(
21:07:08 <mriedem> ok i was waiting for https://review.openstack.org/#/c/263927/ to be rebased
21:07:13 <mriedem> so i'll star that one
21:07:49 <melwitt> I pushed https://review.openstack.org/#/c/326906/ last night for the rpc transport move from RequestContext and caching
21:07:50 <mriedem> so feel free to bug me for reviews
21:07:53 <alaski> melwitt also has https://review.openstack.org/#/c/326906/ on mq switching
21:08:04 <melwitt> oh, darn it sorry
21:08:12 <alaski> nope, I was too slow
21:08:33 <alaski> that's all I'm aware of that's ready for review
21:09:09 <alaski> well, and https://review.openstack.org/#/c/322311 which is a devstack change
21:09:24 <alaski> #topic Open discussion
21:09:41 <dansmith> I demand to know what animal cellsv2 is
21:09:42 <melwitt> there are some cell0 things I see in the priorities etherpad but I wasn't sure what the status on those is right now
21:09:59 <melwitt> or are those not for newton perhaps
21:10:10 <alaski> dansmith: that requires an ML post and a long discussion
21:10:22 <dansmith> alaski: or a secret discussion, so I understand
21:11:05 <alaski> true
21:11:19 <mriedem> it would be a mushroom
21:11:27 <mriedem> because they spread
21:11:36 <alaski> melwitt: those are good candidates for N, but need someone to pick them up since doffm is locked away these days
21:11:53 <dansmith> maybe doffm-in-handcuffs can be our mascot?
21:12:05 <mriedem> #help need help with cell0 patches
21:12:17 <mriedem> #action dansmith and alaski to talk about grenade plan
21:12:42 <alaski> #chair mriedem
21:12:43 <openstack> Current chairs: alaski mriedem
21:12:49 <mriedem> oh snap
21:13:00 <mriedem> #help need help with cell0 patches
21:13:03 <mriedem> #action dansmith and alaski to talk about grenade plan
21:13:07 <mriedem> is that how that works?
21:13:17 <alaski> *shrugs*
21:13:21 <mriedem> :)
21:13:46 <melwitt> something I realized while I was working on mq switching yesterday is that there is need for an up call from a cell for the consoleauth api. but, since that's on the road to being deprecated, I'm not sure if we might be able to punt on it
21:14:27 <alaski> that would be nice if so
21:14:34 <alaski> what is it calling up for?
21:14:38 <melwitt> IIUC, we don't store the transport url for the api cell in the database and we would need to for up calls
21:14:50 <melwitt> console token auth stuff
21:15:23 <alaski> is that assuming the auth service is at the API level?
21:15:28 <melwitt> it is
21:15:49 <melwitt> nova-consoleauth
21:16:11 <alaski> okay. we should sync with PaulMurray. he was working on something so that the console service could live in a cell
21:16:19 <melwitt> there is also nova-console which is a xen-specific thing but I couldn't find much about it and don't find any handling of it in cells v1
21:16:35 <melwitt> a-ha, okay
21:17:02 <melwitt> I saw his bp and notes from the midcycle about deprecating consoleauth service and storing tokens in the nova db
21:17:32 <melwitt> and auth would be a db query from what I understand
21:17:54 <alaski> yeah. we discussed which db that should be in and landed on the cell db
21:18:17 <alaski> and he was working on, or added, a change so that console queries include the instance uuid so they can be directed to a cell
21:18:36 <alaski> API queries
21:20:20 <alaski> just so everyone is aware I'm going to propose cutting back the meetings to bi-weekly after the freeze
21:20:26 <alaski> as we've done in the past
21:20:44 <alaski> honestly we may not even need it that often
21:21:01 <alaski> unless we want to argue about mascots
21:21:09 <alaski> anyone have a topic?
21:21:50 <alaski> cool
21:21:51 <dansmith> mascots?
21:21:52 <alaski> thanks all!
21:21:56 <dansmith> oh, fine
21:22:07 <alaski> I can hold off
21:22:20 <alaski> I know you really want to discuss it
21:22:27 <mriedem> there is nothing to discuss
21:22:29 <mriedem> it's done
21:22:33 <alaski> :)
21:22:35 <alaski> #endmeeting