17:00:06 <alaski> #startmeeting nova_cells
17:00:06 <openstack> Meeting started Wed Sep 28 17:00:06 2016 UTC and is due to finish in 60 minutes.  The chair is alaski. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:10 <openstack> The meeting name has been set to 'nova_cells'
17:00:17 <mriedem> o/
17:00:21 <dansmith> ohai
17:00:23 <melwitt> o/
17:00:29 <alaski> welcome back from the long break
17:00:47 <alaski> there's nothing on the agenda today so let's jump to open discussion
17:00:52 <alaski> #topic Open Discussion
17:01:11 <alaski> it is time to think about specs and summit discussions
17:01:44 <alaski> I have a few I plan to propose, scheduling interaction, and searchlight integration
17:01:58 <alaski> anyone have something they're thinking about?
17:02:18 <alaski> I should clarify, I mean specs here
17:02:27 <dansmith> I don't, but searchlight is a thing we need to discuss for sure
17:02:36 <dansmith> s/discuss/figure out/
17:02:46 <alaski> yeah. it's the big unknown for this cycle I think
17:03:08 <alaski> everything else seems pretty well understood
17:03:15 <dansmith> we also need to talk about the minimum number of things we need to do in order to have two cells, even if sorting in python makes it not super realistic
17:03:16 <melwitt> alaski: do you think a spec is needed for the move quota commits to the api? as I write that, I think the answer is probably yes
17:03:27 <alaski> melwitt: yeah, I think so
17:04:17 <alaski> dansmith: yeah. maybe I'll start an etherpad on that with what I think is left and everyone can jump in
17:04:24 <dansmith> cool
17:04:38 <alaski> #action alaski start an etherpad of remaining items to get to two cells
17:05:03 * melwitt is tempted to suggest mitosis
17:05:27 <alaski> lol. that should have been the nova-manage command
17:05:41 <melwitt> hahaha
17:05:47 <dansmith> we could have a lot of fun with some of those commands
17:06:14 <dansmith> like, could we take two deployments and make them into a single one with two cells? nova-manage meiosis?
17:06:41 <melwitt> now we're talking
17:06:58 <dansmith> you'll need a ph.d in biology to run nova-cells! and a good sense of humor
17:06:59 <alaski> I'm onboard
17:07:48 <alaski> well, once we see what's in the etherpad we can determine what specs are missing
17:08:44 <alaski> for summit there's not a lot of new high level ground to cover, but we can dive into specifics on things
17:08:56 <alaski> mriedem: is it only one time slot this time around?
17:09:08 <alaski> that's what it looked like on the tentative schedule
17:09:53 <melwitt> I noticed we have only 2 days for nova (including the friday meetup) this time instead of the usual 3 days
17:09:53 <alaski> also, melwitt demanded that I give her some time to talk about quotas and I capitulated
17:10:08 <mriedem> alaski: we haven't decided slots yet
17:10:27 <mriedem> need to talk about that at some point this week, but now it's already wed...
17:10:37 <mriedem> i think we're going to be fine on slots, maybe too many
17:10:46 <alaski> mriedem: okay. I think one slot may be fine
17:11:19 <alaski> but we can make use of two if they're available
17:12:10 <melwitt> hah. not a long time to talk about quotas, just a sanity check to run it by people (committing quotas immediately in the api) to find out if I'm missing anything there
17:12:15 <alaski> melwitt is going to talk about quota changes, I want to discuss searchlight, and there will be other things to get into
17:13:57 <alaski> so one other thing I wanted to drop on everyone in this meeting https://review.openstack.org/#/c/369634/
17:14:10 <alaski> just a quick PoC of having computes self register to a cell
17:14:42 <alaski> It's lower priority than a lot of other things, but I'd love to have a solution there
17:15:00 <melwitt> cool
17:15:12 <alaski> so it's something I would like to discuss this cycle, but probably not at summit
17:15:35 <alaski> that's all I've got for today
17:15:38 <alaski> anyone have a topic?
17:15:52 <mriedem> we need that bug fix in for rc2
17:15:57 <mriedem> https://review.openstack.org/#/c/378636/
17:15:59 <alaski> oh right
17:16:12 <alaski> getting it for rc2 would be great
17:16:20 <alaski> we need it in Newton some way or the other
17:16:38 <mriedem> i was good with the change, just had the nits
17:16:47 <alaski> cool. I think I've addressed those now
17:16:53 <melwitt> didn't know about that one. will look
17:17:21 <alaski> melwitt: someone pinged me last night to say that I had broken reschedules
17:17:50 <mriedem> it was baby lucas
17:18:03 <mriedem> he's gifted
17:18:12 <alaski> he pinged me to tell me his teeth still haven't come in
17:18:19 <melwitt> lol
17:18:28 <mriedem> but just so you know, they hurt like a mfer
17:18:35 <alaski> yep
17:18:43 * dansmith is so over this conversation
17:19:04 <alaski> heh
17:19:09 <alaski> I think we're done here
17:19:11 <alaski> thanks all
17:19:13 <alaski> #endmeeting