14:00:35 <PaulMurray> #startmeeting Nova Live Migration
14:00:39 <openstack> Meeting started Tue Dec  8 14:00:35 2015 UTC and is due to finish in 60 minutes.  The chair is PaulMurray. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:43 <openstack> The meeting name has been set to 'nova_live_migration'
14:00:48 <eliqiao> o/
14:00:50 <davidgiluk> o/
14:00:51 <jlanoux> o/
14:00:52 <andrearosa> hello
14:00:54 <PaulMurray> Who is here?
14:00:54 <alex_xu> o/
14:00:55 <paul-carlton2> o/
14:01:16 <PaulMurray> Just wait a minute as usual
14:01:36 <mdbooth> o/
14:02:36 <PaulMurray> ok - lets start
14:02:48 <PaulMurray> The agenda is here: https://wiki.openstack.org/wiki/Meetings/NovaLiveMigration
14:02:59 <PaulMurray> #link Specs status
14:03:11 <PaulMurray> We have passed the deadline
14:03:21 <PaulMurray> and we have eight merged as I count
14:03:33 <alex_xu> yeah~ \o/
14:03:34 <PaulMurray> See bottom of https://etherpad.openstack.org/p/mitaka-live-migration
14:03:36 <PaulMurray> for a list
14:03:56 <PaulMurray> Well done to everyone who got something in
14:04:15 <PaulMurray> Now a reminder that we are soon going to be half way through the cycle
14:04:32 <PaulMurray> so lets get the code done
14:05:00 <PaulMurray> #link CI status
14:05:10 <PaulMurray> I don't think I see anyone here for CI
14:05:19 <PaulMurray> jlanoux, unless you know anything?
14:05:37 * alex_xu added item to spec status, looks like missed
14:05:44 <jlanoux> PaulMurray: Nope, didn't hear anything from Timofey
14:06:11 <PaulMurray> ok - the experimenta job is there, so do feel free to use 'check experimental'
14:06:15 <PaulMurray> on patches to run it
14:06:33 <PaulMurray> #topic Bugs
14:06:56 * PaulMurray just realised he was using link instead of topic...
14:07:22 <PaulMurray> I wondered if there is something we can do to organise bug work
14:07:28 <PaulMurray> (or should be doing)
14:07:52 <PaulMurray> eliqiao, your name was mentioned to me as someone who is involved in bugs - is that right?
14:08:10 <eliqiao> PaulMurray: yes
14:08:29 <eliqiao> PaulMurray: previously, I have some bugs assigned.
14:08:56 <PaulMurray> are you involved in the collaboration between intel and rackspace on this?
14:09:23 <eliqiao> PaulMurray: yes, most of the bug tracked are in a google sheet
14:09:49 <eliqiao> link is in the bottom of our live-migration etherpad
14:10:13 <PaulMurray> https://docs.google.com/spreadsheets/d/19MFatOpjePS4JtkVHXCh6Qa8XUf6T2t0Igy1PucZ3Zk/edit#gid=2127877307
14:10:19 <PaulMurray> that one ^^ ?
14:10:23 <eliqiao> yes
14:10:40 <eliqiao> I haven't review for some time
14:10:55 <PaulMurray> is there anything we can do to help?
14:11:44 <eliqiao> PaulMurray: not sure, I will review them tomorrow and update the list to see if we can do something
14:12:11 <PaulMurray> I wondered if there is something like a trivial bug list we could start on our etherpad
14:12:28 <PaulMurray> Maybe we can talk about it later
14:13:00 <eliqiao> some are 'dead' bug, in status incompelete.
14:13:17 <eliqiao> we could do a cleanup
14:13:21 <johnthetubaguy> just wondering if we can get the bug status into launchpad?
14:14:06 <johnthetubaguy> I see we have quite a few, and some seem related to blueprints we have approved: https://bugs.launchpad.net/nova/+bugs?field.tag=live-migration
14:14:38 <johnthetubaguy> I am sure markus_z would be happy to see some movement on those :)
14:14:39 <PaulMurray> eliqiao, how up to date is your spreadsheet?
14:15:12 <eliqiao> PaulMurray: I have Status last checked coluem in the list
14:15:33 <eliqiao> from Mar to Aug
14:15:43 <PaulMurray> I see
14:15:44 <alex_xu> +1 for updae to launchpad
14:15:59 <eliqiao> johnthetubaguy: sure, we can update it to lanuchpad, this is a public doc.
14:17:00 <PaulMurray> The bugs are lined from our meeting page at this url: https://bugs.launchpad.net/nova/+bugs?field.tag=live-migration+
14:17:14 <PaulMurray> Same for untriaged bugs
14:17:39 <PaulMurray> it would be good if we could get some momentum around keeping it up to date and getting through them
14:17:50 <PaulMurray> Maybe we could have a session on that
14:18:11 <PaulMurray> I know there are a few people around who would be able to take some on
14:18:20 <eliqiao> +1, it would be a good start on live-mgraiton bug fixing.
14:19:02 <PaulMurray> If you guys have been organising them already it would be great to get your help with getting it all up to date
14:19:42 <johnthetubaguy> yeah, lets keep this in launchpad if we can
14:19:53 <PaulMurray> eliqiao, If its ok with you I'll get in touch later and we can sort it out
14:19:55 <johnthetubaguy> its not awesome, but everyone knows where it is
14:20:10 <eliqiao> PaulMurray: sure, okay
14:20:35 <PaulMurray> #action PaulMurray to talk to eliqiao about updating bugs
14:20:58 <PaulMurray> #topic Open reviews
14:21:13 <PaulMurray> So now specs are done the main focus is reviews
14:21:22 <PaulMurray> https://review.openstack.org/#/c/227278/
14:21:43 <PaulMurray> Anyone here can comment on this one ^^
14:22:08 <johnthetubaguy> seeing the good list of patches here:
14:22:10 <johnthetubaguy> #link https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking
14:22:56 <PaulMurray> i know the authors are not here....
14:23:13 <PaulMurray> But I wanted to bring that series up
14:23:30 <PaulMurray> The next I wanted to highlight was ndipanov's series
14:23:36 <johnthetubaguy> so in terms of priority are you happy with what the blueprints have got right now?
14:23:50 <PaulMurray> https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bug/1417667,n,z
14:24:03 <PaulMurray> johnthetubaguy, yes
14:24:06 <johnthetubaguy> I made that series above high priority, as it seems one of the most important ones
14:24:07 <johnthetubaguy> cools
14:24:18 <PaulMurray> johnthetubaguy, most of the blueprints have code yet to be done
14:24:26 <johnthetubaguy> PaulMurray: agreed
14:24:35 <PaulMurray> so I wanted to encourage people to get reviews done on the code that is sitting there
14:24:43 <PaulMurray> and hopefully get it out the way
14:25:27 <PaulMurray> ndipanov's series above has a few trivial patches with lots of reviews and one non-trivial one with almost no reviews
14:26:06 <PaulMurray> So if anyone has time please do have a go at it. We can move it on to core reviewers when someone has had a look
14:26:39 <PaulMurray> This next one was added to the agenda today:
14:26:52 <PaulMurray> https://review.openstack.org/#/c/215483/ - Set migration status to 'error' on live-migration failure
14:26:55 <ankit> Hi PaulMurray, ndipanov: My colleague "Rajesh Tailor" had requested to review https://review.openstack.org/#/c/215483/ earlier
14:27:02 <ankit> Could you please revisit it and add your opinion on the patch ^
14:27:32 <PaulMurray> ankit, I had a look at it today and talked briefly to ndipanov who also commented
14:27:56 <PaulMurray> his feeling was that the security fix it is related to was not very well done
14:28:26 <PaulMurray> so he does like the idea of more code relying on it
14:29:07 <ankit> PaulMurray: Could you please add your concerns on the patch
14:29:18 <PaulMurray> I think that issue needs to be addressed - maybe dansmith or alaski could comment too
14:29:35 <PaulMurray> I will add that comment and lets see if we can get a wider
14:29:42 <ankit> PaulMurray: Thanks
14:29:50 <PaulMurray> review from people who are familiar with the previous patch
14:30:08 <PaulMurray> Is there anything else anyone wants to bring up
14:30:21 <alex_xu> PaulMurray: yea, I added one
14:30:41 <PaulMurray> alex_xu, do you have a link?
14:30:44 <alex_xu> just bring some discussion from api meeting to here, I think it's good for people to know at here
14:30:56 <alex_xu> #link http://specs.openstack.org/openstack/nova-specs/specs/mitaka/approved/live-migration-progress-report.html
14:31:35 <alex_xu> it's thanks to johnthetubaguy point it out. same as the pause/abort instance, we only add new thing to /servers/{id}/migrations, not the /migrations one
14:32:08 <alex_xu> And there is agreement on the api meeting for updating this spec, to add new field to severs' subresource migrations
14:32:41 <paul-carlton2> but the new fields would still be added to migrations data model?
14:33:08 <alex_xu> paul-carlton2: yes, but we can filter it out for /migrations
14:33:30 <paul-carlton2> otherwise the GET /servers/{id}/migrations would need to do sync call to compute
14:33:33 <paul-carlton2> good
14:34:00 <eliqiao> alex_xu what the command line for python-novalcient to call GET /servers/{id}/migrations ?
14:34:06 <eliqiao> new CLI?
14:34:22 <alex_xu> eliqiao: good point
14:34:42 <johnthetubaguy> yeah, there will have to be a new CLI I suspect
14:34:43 <alex_xu> eliqiao: maybe servers-migration?
14:34:47 <johnthetubaguy> yeah
14:35:15 <eliqiao> servers-migration ? not server-migration ?
14:35:55 <alex_xu> eliqiao: emm...maybe server-migrations, I will put that detail in the spec
14:36:12 <eliqiao> alex_xu: get you. thanks
14:36:35 <PaulMurray> alex_xu, you also mentioned API docs in IRC the other day
14:36:36 <alex_xu> anyway I will take care that spec updated, and flush out all the detail.
14:36:45 <PaulMurray> alex_xu, do you need anything?
14:36:46 <paul-carlton2> migration is better, the plan is for it only to return active migrations which should only be one of
14:37:22 <alex_xu> PaulMurray: yes, thanks, today and tomorrow is api doc sprint
14:37:26 <eliqiao> actually, I am worry about the data in table migrations , won't that be lots of query data?
14:37:42 <alex_xu> appreciate people can help on our api doc, and there is etherpad https://etherpad.openstack.org/p/nova-v2.1-api-doc to track the tasks
14:37:52 <mdbooth> eliqiao: Explain. What is your specific concern?
14:37:57 <johnthetubaguy> yeah, lets get that in the spec revision
14:37:58 <johnthetubaguy> PS the revision doesn't require an exception or anything messy like that, we can just merge that
14:38:28 <eliqiao> okay, :)
14:39:17 <PaulMurray> alex_xu, what's the format for the docs sprint - just pick something off the list etherpad ?
14:39:55 <alex_xu> PaulMurray: yeh, we have two API docs need updated, one is API concept doc, it is under the https://github.com/openstack/nova/tree/master/api-guide/source
14:40:13 <PaulMurray> #link https://etherpad.openstack.org/p/nova-v2.1-api-doc - docs sprint etherpad
14:40:16 <alex_xu> people can find 'TODO' in those doc, and fre to take it.
14:40:32 <alex_xu> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/complete-todo-in-api-concept-doc,n,z
14:40:48 <alex_xu> and check this link, if there is one already done by others
14:41:10 <alex_xu> another doc is api-ref, the tasks of api-ref already listed in the etherpad
14:41:24 <PaulMurray> #help anyone free for live migration stuff in docs sprint see above links
14:41:40 <alex_xu> also just free to check any part of doc, if you found something old and incorrect, then fix it!
14:41:50 <alex_xu> PaulMurray: thanks!
14:41:58 <PaulMurray> alex_xu, ok - not sure how many people are around, but I will take a look
14:42:07 <alex_xu> PaulMurray: pretty thanks
14:42:17 * PaulMurray has xmas lunch most of tomorrow
14:42:19 <alex_xu> free to contact me if you have any question on doc sprint
14:42:43 <PaulMurray> I think we are done - any last minute quesitons?
14:43:16 <eliqiao> PaulMurray: have a question on how to bring attention to review live-migration bp patches
14:43:46 <eliqiao> PaulMurray: shall we add patch link to etherpad and call for others to do review?
14:43:49 <alex_xu> eliqiao: put in https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking
14:43:54 <PaulMurray> there is a review tracking page
14:43:58 <PaulMurray> ^^ that's it
14:44:19 <eliqiao> PaulMurray: alex_xu thank you
14:44:21 <PaulMurray> Put links on the list under live migration on that page
14:44:36 <PaulMurray> There is a subteam section and a core section
14:44:57 <PaulMurray> the idea is subteam reviews first so we don't both cores with simple fixes
14:45:06 <PaulMurray> then it gets moved up to cores
14:45:16 <eliqiao> just pull under section "Live-Migration" , right ?
14:45:28 <PaulMurray> yes
14:45:42 <PaulMurray> I try to keep an eye on them and do some house keeping
14:45:42 <eliqiao> PaulMurray: get it . thanks :-)
14:45:55 <PaulMurray> eliqiao, thanks
14:46:19 <PaulMurray> ok - I think we are done now
14:46:27 <PaulMurray> Thank you all for coming
14:46:31 <PaulMurray> #endmeeting