14:02:16 <PaulMurray> #startmeeting Nova Live Migration
14:02:17 <openstack> Meeting started Tue Dec 15 14:02:16 2015 UTC and is due to finish in 60 minutes.  The chair is PaulMurray. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:18 <PaulMurray> hm, nothing happened
14:02:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:22 <openstack> The meeting name has been set to 'nova_live_migration'
14:02:27 <andrearosa> hi
14:02:31 <openstack> PaulMurray: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
14:02:53 <eliqiao> hehe....
14:02:58 <andrearosa> PaulMurray: the first command worked
14:03:00 <PaulMurray> ok - seems it started but I didn't see the messages
14:03:01 <mdbooth> Somebody's going to have a lot of static and the end of their meeting
14:03:07 <mdbooth> Ah
14:03:08 * alex_xu lurks
14:03:13 <mdbooth> o/
14:03:23 <eliqiao> o/
14:03:25 <PaulMurray> ok - who's here
14:03:26 <tdurakov> o/
14:03:29 <shaohe_feng> o/
14:03:31 <jlanoux> o/
14:03:35 * PaulMurray pretends nothing happened
14:04:17 <davidgiluk> o/
14:04:34 <PaulMurray> As usual the agenda is here: https://wiki.openstack.org/wiki/Meetings/NovaLiveMigration
14:04:47 <PaulMurray> #topic Next meeting
14:05:03 <PaulMurray> We are coming up to the holiday period
14:05:05 * toan lurks
14:05:16 <PaulMurray> I am going to be away for the next two weeks
14:05:25 <PaulMurray> Does anyone want a meeting in that time?
14:05:34 <andrearosa> I won't be around
14:05:56 * mdbooth will also not be around
14:06:13 <PaulMurray> I will send an email on the ML but I will assume there is no need for a meeting in the
14:06:31 <PaulMurray> next two weeks unless someone responds to the email with a great desire to host one
14:06:39 <andrearosa> FWIW nova-meeting has been canceled for the next two weeks
14:06:48 * kashyap lurks
14:07:05 <PaulMurray> #info There will be an email on ML to see if anyone needs a meeting in next two weeks
14:07:09 <pkoniszewski> o/
14:07:16 <andrearosa> as we are a sub-team of nova team I do not expect many ppl will be up for meetings
14:07:19 <PaulMurray> #topic Specs status
14:07:28 <PaulMurray> strangely we still have a spec status
14:07:45 <PaulMurray> #link this needs reviews: http://specs.openstack.org/openstack/nova-specs/specs/mitaka/approved/live-migration-progress-report.html
14:08:01 <alex_xu> PaulMurray: that is old agenda I guess
14:08:20 <alex_xu> but yes, that patch didn't merge yet
14:08:25 <alex_xu> #link https://review.openstack.org/#/c/255122/
14:08:26 <PaulMurray> actually this is the review
14:08:40 <PaulMurray> yes - well done alex_xu ^^
14:09:10 <PaulMurray> #topic CI status
14:09:19 <PaulMurray> Anything to add for CI ?
14:09:21 <eliqiao> the patch seems good
14:09:21 <alex_xu> PaulMurray: thanks
14:09:25 <tdurakov> hi
14:09:31 <PaulMurray> hi tdurakov
14:09:33 <eliqiao> can we get it merged before vacation?
14:09:33 <tdurakov> managed to start ceph cluster
14:09:41 <PaulMurray> \o/
14:10:02 <tdurakov> now working on setting properly config for nova/cinder/etc
14:10:21 <tdurakov> will be finished this week, hope
14:10:25 <PaulMurray> good job tdurakov
14:10:40 <PaulMurray> please do pester people if you need reviews done
14:10:45 <tdurakov> sure
14:10:59 <PaulMurray> I'm sure we can find appropriate cores for this stuff too
14:11:03 <tdurakov> again, feel free to run check experimental
14:11:24 <PaulMurray> I haven't seen it fail yet, have you?
14:11:30 <tdurakov> PaulMurray, well, it seems clear, but need time to clean up
14:11:41 <tdurakov> existing job works well
14:11:45 <tdurakov> no failures
14:11:53 <tdurakov> cleanup needed for ceph
14:11:59 <tdurakov> so working on it
14:12:45 <PaulMurray> tdurakov, do you have ceph configured as a backend for other services ?
14:12:51 <tdurakov> yep
14:12:55 <tdurakov> for glance
14:12:59 <tdurakov> and cinder
14:13:39 <tdurakov> and nova of course
14:13:41 <tdurakov> :)
14:14:06 <PaulMurray> I'm glad to see this still making progress every week
14:14:37 <PaulMurray> #info CI has ceph working and backing cinder and glance
14:14:49 <PaulMurray> moving on
14:14:59 <PaulMurray> #topic Bugs
14:15:14 <PaulMurray> mikal is starting to prepare for a bug triage day
14:15:36 <PaulMurray> he did want to do it this week, but I haven't seen any more on that yet
14:15:40 <PaulMurray> he sent out this email
14:15:41 <kashyap> PaulMurray: Probably he should co-ordinate with our bug czar - Markus
14:15:52 <PaulMurray> http://lists.openstack.org/pipermail/openstack-operators/2015-December/009193.html
14:16:09 <PaulMurray> I think markus is in on it
14:16:28 <PaulMurray> I have talked to him before
14:17:35 <PaulMurray> I will come back to this after new year if nothing happens before then
14:17:36 <kashyap> Okay
14:18:01 <PaulMurray> next
14:18:14 <PaulMurray> #topic Open reviews
14:18:30 <PaulMurray> Does anyone have anything they want to bring up
14:19:00 <pkoniszewski> I do
14:19:06 <PaulMurray> pkoniszewski, go ahead
14:19:28 <pkoniszewski> first of all - every review will be appreciate there - https://review.openstack.org/#/c/252506/3 - so we can get block live migration with non-shared storage attached
14:20:41 <pkoniszewski> and I have implementation for "Pause VM during LM" almost ready, early review will be very appreciated as I'm not that much fimiliar with nova - starting from here https://review.openstack.org/#/c/257270/2
14:20:59 <pkoniszewski> this will also HP help to step in and implement cancel and query live migration
14:21:21 <PaulMurray> I have those first three for migration with non-shared storage as the top three on https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking
14:21:44 <PaulMurray> In case anyone didn't realise the rule is we get to put 3 reviews at a time forward for core review
14:21:54 <PaulMurray> and right now its those three
14:22:17 <PaulMurray> so please help to get them done - and I'll poke a core or two if they don't get attention
14:23:13 <PaulMurray> I have also noticed that the other reviews in the subteam list have not had much attention recently
14:23:26 <PaulMurray> they lack updates and reviews
14:23:33 <PaulMurray> so please do help out there if you can
14:23:46 <PaulMurray> If the list looks wrong or has something missing you can change it
14:24:10 <johnthetubaguy> just to echo the request, the more good non-cores we have doing great reviews, the more likely something is going to merge
14:25:08 <PaulMurray> I'm going to add one last topic now
14:25:12 <johnthetubaguy> reviews are low right now, from cores and non-cores, I am assuming partly due to holidays
14:25:31 <PaulMurray> #topic other business
14:25:51 <PaulMurray> This is to make sure people realise where we are
14:26:10 <PaulMurray> the next couple of weeks will be holiday for a lot of people
14:26:26 <PaulMurray> when we get back after new year there will be three weeks to the mid cycle
14:26:38 <PaulMurray> and slightly less than that to mitaka-2 I think
14:27:01 <PaulMurray> So we effectively have less than one month to the next milestone
14:27:27 <PaulMurray> and then we will be looking towards the end of this cycle
14:27:39 <PaulMurray> So please get as much done as possible as soon as possible
14:28:15 <PaulMurray> Anything else for today?
14:28:42 <eliqiao> PaulMurray: I have question on bugs
14:28:50 <PaulMurray> eliqiao, go for it
14:29:22 <eliqiao> #link https://etherpad.openstack.org/p/mitaka-nova-live-migration-bugs I see some are marked as Triaged and others Untriaged
14:29:43 <eliqiao> PaulMurray: I meant if we can help to anything
14:30:37 <PaulMurray> eliqiao, that is a very good question
14:30:44 <eliqiao> PaulMurray: as we talked on mail, shaohe_feng and me would like to help on bug triaged stull, my question is where/how can we start?
14:31:12 <eliqiao> and how to define a bug of Triaged?
14:31:28 <PaulMurray> eliqiao, I was expecting mikal to say something but I expect he is still waiting for a response from his operators email
14:31:53 <PaulMurray> I'm not sure exactly what he was going to do with that page, but he does intend to use it for the triage day
14:31:56 <johnthetubaguy> I think triaged means its understood, and there is a note on the bug of how to fix it
14:32:16 <johnthetubaguy> its defined by markus_z somewhere, but its roughly that, I think
14:32:35 <johnthetubaguy> I suspect lots of the bugs will be fixed by the blueprints we have in process
14:32:36 <eliqiao> johnthetubaguy: oh, yeah, totally get you! :)
14:32:55 <johnthetubaguy> or at least, the bugs need re-checking after the blueprints land
14:33:45 <shaohe_feng> johnthetubaguy:  how do we difine which bugs need bp?
14:33:47 <eliqiao> also some bugs are marked as incompelete, so how to go with these? (no update from the repoter)
14:34:31 <PaulMurray> At least one of the bugs marked untriaged on the etherpad is in progress on launchpad - I will ask mikal to send out clarification and what his plan is
14:35:06 <johnthetubaguy> shaohe_feng: I was more meaning the reverse here, these bugs are fixed by blueprints we have targeted for mitaka
14:35:41 <eliqiao> PaulMurray: That would be great, Thx. please let us know if we can help on it.
14:35:55 <shaohe_feng> johnthetubaguy: got it.
14:35:59 <PaulMurray> eliqiao, you definitely can help
14:36:08 <johnthetubaguy> shaohe_feng: if a bug touches the API, it needs a spec, if a bug fix requires significant re-work or changes in existing behaviour, its best done as a blueprint, but thats a different discussion, lets take that offline
14:36:20 <eliqiao> PaulMurray: yeah, I'd like to ,just have no idea how to start :)
14:36:55 <PaulMurray> do feel free to go over the bugs on this list: https://bugs.launchpad.net/nova/+bugs?field.tag=live-migration+
14:36:58 <shaohe_feng> incompelete for a long time, such as  half years,  neams it is not active, how should we take action on it?
14:37:14 <PaulMurray> and see if there is anything that needs amending, comments etc.
14:37:41 <PaulMurray> you can make comments on mikal s etherpad too
14:38:12 <eliqiao> okay, get it.
14:38:33 <PaulMurray> eliqiao, and feel free to pick any up if you want to as well
14:39:15 <PaulMurray> #action PaulMurray to ask mikal for clarification on bug triage day
14:39:38 <PaulMurray> Anything else for today ?
14:40:24 <PaulMurray> Everyone have a happy holiday and I see you next year
14:40:32 <PaulMurray> thanks for coming
14:40:39 <PaulMurray> #endmeeting