14:00:13 <tdurakov> #startmeeting Nova Live Migration
14:00:14 <openstack> Meeting started Tue Feb 16 14:00:13 2016 UTC and is due to finish in 60 minutes.  The chair is tdurakov. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'nova_live_migration'
14:00:21 <tdurakov> hi everyone
14:00:24 <pkoniszewski> o/
14:00:30 <andrearosa> hi
14:00:34 <jlanoux> hi
14:01:06 <davidgiluk> o/
14:01:17 <tdurakov> #topic priority-reviews
14:01:27 <tdurakov> let's walk over reviews
14:01:46 <eliqiao> o/
14:02:15 <tdurakov> - report live migration progress
14:03:06 <tdurakov> there are several patches on review
14:04:32 <tdurakov> as decision for writing to database was made on previous meeting, any blockers?
14:05:56 * eliqiao am i still on line?
14:06:09 <tdurakov> yep
14:06:27 <tdurakov> seems we have nothing on this series, let's move on then
14:06:40 <tdurakov> - Making the live-migration API friendly
14:07:08 <tdurakov> eliqiao, could you provide update for that?
14:07:09 * eliqiao sorry, was still on vacation, in hotel's network.
14:07:26 <eliqiao> yep, I updated the meeting pages.
14:07:35 <eliqiao> #link https://wiki.openstack.org/wiki/Meetings/NovaLiveMigration
14:08:34 <eliqiao> xen driver #link https://review.openstack.org/#/c/254101/20 pending on john's reply
14:09:13 <tdurakov> eliqiao, ok acked
14:09:14 <eliqiao> libvirt driver #link https://review.openstack.org/#/c/275585/2 has +2 from alex_xu but I need to rebase it.
14:09:46 <tdurakov> #action ask johnthetubaguy to review https://review.openstack.org/#/c/254101/20  again
14:09:49 <eliqiao> johnthetubaguy does like https://review.openstack.org/#/c/254102/26 return any from live-migration,  I will update patch
14:09:56 <eliqiao> tdurakov: thx for the notes.
14:10:17 <tdurakov> ok, let's move on
14:10:28 <tdurakov> abort-live-migration
14:10:32 <eliqiao> but i have a question on if we need to bump compute rpc version. will try to ping dansmith
14:10:33 <andrearosa> that's mine
14:11:19 <andrearosa> I got some review I need to squash two patches in a single one, unfortunately I was wroking on an internal blocker for the last 3 days, hopefully from
14:11:26 <andrearosa> tomorrow I should be able to work again on that patch
14:11:37 <tdurakov> andrearosa, do you need any help for this?
14:11:51 <andrearosa> tdurakov: at the moment I am fine I am not too far
14:11:54 <andrearosa> from having it ready
14:12:05 <tdurakov> #action review patches for abort-live-migration once they are updated
14:12:14 <andrearosa> in case I'll ping on IRC
14:12:18 <andrearosa> if I need help
14:12:32 <andrearosa> that patch it very similar to the pause-live-migration
14:12:42 <andrearosa> so I hope the review it will be not so hard
14:13:05 <andrearosa> as I am trying  to follow what pawel did for the pause-live-migration
14:13:27 <tdurakov> acked
14:14:17 <tdurakov> - block migration of instances with attached volumes is finally merged
14:14:26 <tdurakov> pkoniszewski, (y)
14:14:37 <pkoniszewski> thats true
14:14:55 <tdurakov> what about block-migration for config-drive?
14:14:55 <pkoniszewski> i still need to add reno
14:15:04 <pkoniszewski> well, its blocked, can't find solution
14:15:15 <eliqiao> pkoniszewski: congrats
14:15:26 <pkoniszewski> probably won't make it in Mitaka
14:15:49 <tdurakov> pkoniszewski, what is the blocker for that?
14:15:51 <pkoniszewski> the problem is that we can't transfer config drive because libvirt/qemu does not have privilages to write to read-only device
14:16:27 <pkoniszewski> and we can't skip cd-rom because it won't be transferred at all
14:16:29 <pkoniszewski> and LM won
14:16:35 <pkoniszewski> and LM won't be transparent anymore
14:16:38 * eliqiao congrats for "block migration of instances with attached volumes"
14:16:42 <pkoniszewski> it can break the VM after reboot
14:16:50 <pkoniszewski> so, no solution atm
14:16:53 * eliqiao sorry for late...
14:17:15 <tdurakov> pkoniszewski, acked, thanks for update
14:18:23 <tdurakov> any other bp to be discussed?
14:18:46 <pkoniszewski> i think that get/list migrations is worth mentioning
14:19:01 <tdurakov> pkoniszewski, link please
14:19:16 <pkoniszewski> https://review.openstack.org/#/c/258771/
14:19:57 <tdurakov> pkoniszewski, well, actually I've acked about this bp first
14:20:06 <pkoniszewski> oh, sorry
14:20:23 <tdurakov> np, what do you want to discuss?
14:21:02 <tdurakov> pkoniszewski, ^
14:21:18 <eliqiao> shao
14:21:22 <pkoniszewski> just an update - so there is a thread on a ML whether we allow to retrieve instance by db index, once it is solved I think this patch will be in a good standing
14:21:55 <pkoniszewski> I still have some concerns around changes without bumping microversion in https://review.openstack.org/#/c/258771/14/nova/objects/migration.py
14:22:36 <pkoniszewski> thats it, thanks! :)
14:23:50 <tdurakov> pkoniszewski, have you discussed micro versions with andreykurilin?
14:24:10 <eliqiao> pkoniszewski: I think that require a object version bump since it is a remote call
14:24:14 <pkoniszewski> tdurakov: yes, I did, he explained me how it works in novaclient
14:24:37 <eliqiao> pkoniszewski: do you mean REST micro version?
14:24:51 <pkoniszewski> eliqiao: MigrationList object
14:25:15 <tdurakov> ah
14:25:42 <eliqiao> pkoniszewski: I remember that I have asked for dansmith , he told that a change of remote method may need to bump object version.
14:26:25 <tdurakov> it looks like that micro version should be bumped there, need to check it more carefully
14:26:59 <tdurakov> #action check version bump for https://review.openstack.org/#/c/258771/14/nova/objects/migration.py
14:27:25 <tdurakov> anything else?
14:27:38 <pkoniszewski> that's all for me
14:28:26 <tdurakov> if we finished with bps let's move on to bugs
14:28:53 <tdurakov> #topic bugs
14:29:06 <tdurakov> let me start
14:29:23 <tdurakov> found one strange thing with live-migration reporting
14:30:36 <tdurakov> https://review.openstack.org/#/c/279398/ - in several cases libvirt doesn't report any update for live-migration, faced with this problem while block-migrating relatively big instance
14:31:58 <tdurakov> have anyone faced with this problem?
14:32:47 <pkoniszewski> haven't played with this yet (and big instances)
14:33:41 <tdurakov> migration was aborted by timeout, but I saw data was transferred over network. continue working on this.
14:33:43 <eliqiao> tdurakov: how to define 'big instance' ?
14:34:10 <tdurakov> eliqiao, flavor type
14:35:06 <tdurakov> so in my case migration and reporting for example works for tiny but not work for small
14:35:35 <pkoniszewski> i will give it a shot
14:35:46 <tdurakov> I'll file bug for it, so it will be possible to aggregate info
14:36:11 <tdurakov> let's move for the next bug
14:36:34 <eliqiao> tdurakov: yes, I know that you are talking about flavor, but I don't get what is big m1.large /m1.xlarge?
14:36:57 <eliqiao> good to file bug, thanks
14:37:43 <tdurakov> eliqiao, well, it's depends on underlying hosts capacity, I've provide example ^
14:38:11 <eliqiao> tdurakov: cool, thanks :)
14:38:15 <tdurakov> #action tdurakov to file a bug for live-migration reporting
14:38:47 <tdurakov> what about this patch series? libvirt: Acquire TCP ports for console during live migration
14:39:54 <tdurakov> I'd rather say more reviews needed here
14:41:06 <tdurakov> #action to review: Acquire TCP ports for console during live migration patches
14:42:35 <tdurakov> pkoniszewski, what about this https://review.openstack.org/#/c/235994
14:42:47 <eliqiao> #link https://review.openstack.org/#/c/215102/ for Acquire TCP ports for console during live migration patches
14:43:05 <pkoniszewski> so i updated it according to johnthetubaguy suggestion
14:43:41 <pkoniszewski> it had +2 already, so it waits for reviews
14:44:02 <eliqiao> yeah, also looks good to alex_xu on previous patch set.
14:45:43 <tdurakov> kk
14:46:37 <tdurakov> Any updates for this? https://review.openstack.org/#/c/243105
14:47:15 <tdurakov> seems pretty accurate
14:47:58 <tdurakov> eliqiao, https://review.openstack.org/#/c/171310 - what about this one
14:49:17 <tdurakov> eliqiao, you probably be interested in https://review.openstack.org/#/c/280653/ - the idea is to remove _live_migration_cleanup_flags from compute
14:51:51 <tdurakov> so, any other bugs to be discussed?
14:53:03 <tdurakov> #topic open discussion
14:53:59 <tdurakov> who has submitted talks for austin design summit for live-migration?
14:54:13 <pkoniszewski> I did, with PaulMurray and andrearosa
14:54:58 <pkoniszewski> i g2g, sorry guys, need to drop right now
14:55:00 <pkoniszewski> thanks and bye
14:55:07 <tdurakov> cool, bye
14:56:02 <tdurakov> anything else to be discussed?
14:57:01 <tdurakov> ok, thanks to everyone then.
14:57:26 <andrearosa> bye
14:57:39 <tdurakov> #endmeeting