14:00:00 <PaulMurray> #startmeeting Nova Live Migration
14:00:01 <openstack> Meeting started Tue Apr 19 14:00:00 2016 UTC and is due to finish in 60 minutes.  The chair is PaulMurray. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <openstack> The meeting name has been set to 'nova_live_migration'
14:00:14 <mdbooth> o/
14:00:15 <tdurakov> o/
14:00:17 <PaulMurray> Hi all
14:00:21 <paul-carlton1> o/
14:00:27 <scheuran> hi
14:00:30 <andrearosa> hi
14:00:51 <PaulMurray> I managed to start exactly on time today !
14:01:00 <PaulMurray> lets wait on minute for later comers
14:01:01 <tdurakov> (y)
14:01:18 <PaulMurray> in the meantime - agenda here: https://wiki.openstack.org/wiki/Meetings/NovaLiveMigration
14:01:19 <luis5tb_> hi
14:01:58 <PaulMurray> #topic Summit sessions
14:02:20 <PaulMurray> #link Nova Live Migration session:
14:02:20 <PaulMurray> https://www.openstack.org/summit/austin-2016/summit-schedule/events/9095?goback=1
14:02:42 <PaulMurray> I don't know why that came out on two lines
14:03:22 <PaulMurray> can't remember how to undo
14:03:25 <PaulMurray> #undo
14:03:26 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x92e2b10>
14:03:44 <PaulMurray> #link Nova Live Migration session: https://www.openstack.org/summit/austin-2016/summit-schedule/events/9095?goback=1
14:03:54 <PaulMurray> anyway - we have one session
14:04:09 <PaulMurray> there are also two unconference sessions
14:04:11 <davidgiluk> o/
14:04:18 <PaulMurray> and the contributor meetup on friday
14:04:39 <PaulMurray> So we can spread anything we want to talk about over those if needed
14:05:05 <PaulMurray> What should we give priority to in the Live Migration session ?
14:05:29 <tdurakov> PaulMurray: I think it's worth to add storage pool specs to etherpad too? Or there will be no changes with it?
14:06:14 <paul-carlton1> It will change, I'll get to it soon
14:06:48 <mdbooth> We should focus on controversy.
14:07:03 <mdbooth> e.g. post-copy
14:07:05 <luis5tb_> are you going to discuss about how to include post-copy?
14:07:29 <PaulMurray> we could do that
14:07:31 <paul-carlton1> I plan to update both storage pools spec and use storage pools to do cold migrate to build on what mdbooth is doing to tidy up imagebackend etc
14:07:45 <luis5tb_> I will not attend the summit, but pkoniszenwski will and he will try to show the pros and cons of the approaches we've been discussing
14:09:04 <PaulMurray> I didn't see any more dicussion on the ML
14:09:16 <PaulMurray> So are we still with the options posted there originally
14:09:17 <PaulMurray> ?
14:09:20 <tdurakov> I think it's important to decide on summit will we expose all new features over api or not
14:09:41 <paul-carlton1> Post-Copy should be enabled via config setting, if enabled then it should be set in manual mode so monitor thread can activate it using API call as deemed appropriate
14:09:47 <tdurakov> it will affect ops and it would be good to ask them
14:10:13 <PaulMurray> Lets do that in advance - has anyone put a post on the ops ML?
14:10:20 * kashyap joins late
14:10:42 <PaulMurray> I think the possition in nova is we cannot expose virt features in API
14:10:44 <tdurakov> +1 for ops ml, to get feedback before summit
14:11:15 <PaulMurray> We can only expose "properties" of VMs
14:11:18 <andrearosa> +1 for not exposing driver specific flags via API
14:11:21 <PaulMurray> at an abstract level
14:11:45 <andrearosa> we did remove the disk_over_commit even because it was a driver specific thing
14:11:47 <davidgiluk> andrearosa: Not necessarily driver specific
14:12:24 <tdurakov> well, here is spec from paul-carlton1 which tries to expose this things wrapping them in abstractions
14:12:34 <tdurakov> so, there are options imho
14:12:54 <tdurakov> I'd ask ops anyway
14:13:10 <PaulMurray> who wants to do an ops ML post ?
14:13:19 <tdurakov> I could
14:13:49 <PaulMurray> #action tdurakov to post question to ops ML on live migration API for post-copy etc.
14:13:57 <PaulMurray> thanks
14:14:14 <PaulMurray> If we do this topic in the session it will eat up time, but its a good one
14:14:22 <PaulMurray> anything else that should be there ?
14:15:12 <PaulMurray> will the post-copy topic also cover auto-converge
14:15:18 <PaulMurray> i.e. will it be general ?
14:15:28 <tdurakov> I'd say yes
14:15:33 <tdurakov> not only post-copy
14:16:14 <paul-carlton1> Again it should be able to be turned on or of in config
14:16:53 <PaulMurray> paul-carlton1, there was some debate about adding config options - so I guess this all comes together
14:17:16 <paul-carlton1> if on then the live migration monitir thread can set the initial throttling and increment to control when it gets used and how aggresively
14:17:51 <tdurakov> paul-carlton1: your spec claims to expose it tbh
14:18:02 <tdurakov> with abstraction layer, but to expose
14:18:28 <paul-carlton1> PaulMurray, agreed too many config options are bad but need to give operators option to turn these things off if they want
14:18:42 <PaulMurray> yep
14:19:04 <PaulMurray> so we'll bring this all together then
14:19:17 <paul-carlton1> tdurakov, my thinking is that live mig should be told how are to try and work out what it needs to do based on what is availble
14:19:45 * mdbooth would like to discuss some less fully formed ideas, such as improving shared storage detection and a move to Tasks
14:20:18 <tdurakov> paul-carlton1: yes, but where to store such conf? on computes on controllers? There still room for options
14:20:23 <tdurakov> mdbooth: +1
14:20:25 <mdbooth> tdurakov: You've been doing work relating to both of the above, right?
14:20:38 <tdurakov> yes
14:21:04 <tdurakov> there are several patches on review with poc and spec, there 2 more to be done
14:21:08 <mdbooth> That's the kind of road-mappy type stuff which we want people to generally understand and be on board with
14:21:44 * mriedem was totally in the wrong channel
14:21:57 <PaulMurray> mdbooth, tdurakov how much time do you think that would need ?
14:22:16 <tdurakov> mdbooth: true, I will not be on Austin Summit, but alaski will be, so he could provide some details i believe
14:22:41 <mdbooth> tdurakov: Ah, that sucks. I've noted that I'd really like to do that, but not in great detail.
14:22:53 <mriedem> PaulMurray: might want a different etherpad for the summit session since i currently have https://etherpad.openstack.org/p/newton-nova-live-migration linked into it
14:23:05 <mriedem> which is more detailed than you probably want for a session
14:23:33 <PaulMurray> mriedem, yes, and the notes on the sessions details page are likely to be inaccurate
14:23:36 <mdbooth> tdurakov: If you email me a canonical list of patches I could potentially bone up and advocate for you if you'd like.
14:23:38 <PaulMurray> by this discussion
14:23:46 <tdurakov> mdbooth: sure
14:23:57 <PaulMurray> mriedem, I can reorganise the etherpad
14:24:05 <tdurakov> well, I could start ml for that
14:24:12 <PaulMurray> mriedem, Its a place holder for now
14:24:12 <mdbooth> tdurakov: Sure thing
14:24:30 <mdbooth> tdurakov: Pretty sure I'll have read most of them at some point anyway
14:25:11 <mriedem> PaulMurray: maybe off topic, but is the subteam tracking this? https://blueprints.launchpad.net/nova/+spec/migration-state-machine
14:25:26 <mriedem> the owner was asking for it to be re-approved for newton, it'll probably come up in the thursday nova meeting
14:26:04 <PaulMurray> mriedem, we were tracking that in mitaka
14:26:25 <PaulMurray> mriedem, its not on the list in thenewton etherpad
14:26:41 <mdbooth> I recall having looked at it a while back and approving of the concept at least
14:27:50 <PaulMurray> mriedem, it was not approved for mitaka, only discussed - so needs proper review
14:27:59 <PaulMurray> bac to topic
14:28:16 <PaulMurray> We have two items for the main session:
14:28:32 <PaulMurray> how to expose post-copy etc
14:28:51 <PaulMurray> and shared storage detection
14:29:06 <PaulMurray> That is plenty for one session
14:29:15 <PaulMurray> And may over spill
14:29:36 <PaulMurray> there are topics in the neutron/nova session that cover live migration
14:29:51 <PaulMurray> - possibly cinder too (mutli attach)
14:30:17 <PaulMurray> mdbooth, do you need to do anything on storage pools ?
14:30:29 <PaulMurray> or is that just spec review now
14:30:43 <mdbooth> PaulMurray: I'm hoping there's nothing controversial in there other than the churn in that specific code.
14:30:56 <PaulMurray> ok
14:30:58 <mdbooth> So I'll likely advocate for it generally
14:31:34 <PaulMurray> We also need a plan for CI - but that can be covered on the friday session
14:31:51 <PaulMurray> anything else should go into the unconference sessions
14:31:57 <luis5tb_> PaulMurray: will it be possible to follow the session online? or get access to some session minutes if not?
14:32:17 <PaulMurray> luis5tb_, I think the best hope will be etherpads
14:32:24 <PaulMurray> I don't think there is anything live
14:32:29 <luis5tb_> ok, thanks!
14:33:37 <PaulMurray> Note: I will be presenting (along with pkoniszewski and andrearosa at the same time as the weds unconference, so I will see if we can get preference for thrus if there
14:33:46 <PaulMurray> are topics on the unconference list
14:34:03 <PaulMurray> our talk will be live migration in mitaka
14:34:07 <PaulMurray> BTW
14:35:00 <PaulMurray> #action PaulMurray sort out agenda
14:35:36 <PaulMurray> #undo
14:35:37 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x9a91890>
14:35:46 <PaulMurray> #action PaulMurray sort out agenda for summit session
14:36:08 <PaulMurray> #topic Specs
14:36:21 <PaulMurray> Very little review on the specs at the moment
14:36:31 <PaulMurray> anything anyone wants to bring up ?
14:37:08 <tdurakov> about specs?
14:37:41 <PaulMurray> tdurakov, yep - there are about 10 on the etherpad with very little review
14:38:12 <tdurakov> action- review specs?
14:38:28 <PaulMurray> yes please - especially with the summit next week
14:38:53 <PaulMurray> #action sub-team to review specs on https://etherpad.openstack.org/p/newton-nova-priorities-tracking
14:39:16 <tdurakov> PaulMurray: what the difference between Unapproved Specs and Work Items in etherpad?
14:40:16 <PaulMurray> tdurakov, the unapproved specs should really be what is up for review in the priorities-tracking page
14:40:36 <tdurakov> acked
14:40:41 <PaulMurray> in mitaka I ended up with a list of specs approaved and specs not approved at the bottom of the sub-team etherpad
14:40:57 <PaulMurray> just to remember what should be done and what is not going to be done in this cycle
14:41:18 <PaulMurray> the list of work items built up with notes all through the cycle
14:41:32 <PaulMurray> I reorganised it at the summit to reflect the priority for the cycle
14:41:42 <PaulMurray> decided at the time
14:42:32 <PaulMurray> For now we should go by the priorities tracking link above
14:43:26 <PaulMurray> anything else to discuss ?
14:44:10 <PaulMurray> No meeting next week due to summit
14:44:30 <PaulMurray> If you are there, say hello - especially if I haven't met you before
14:44:34 <PaulMurray> :)
14:44:43 <PaulMurray> thanks for coming
14:44:52 <PaulMurray> #endmeeting