14:00:16 <PaulMurray> #startmeeting Nova Live Migration
14:00:17 <openstack> Meeting started Tue May 24 14:00:16 2016 UTC and is due to finish in 60 minutes. The chair is PaulMurray. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:21 <openstack> The meeting name has been set to 'nova_live_migration'
14:00:22 * kashyap waves
14:00:24 <mdbooth> o/
14:00:26 <eliqiao> o/
14:00:26 <diana_clarke> o/
14:00:29 <andrearosa> hi
14:00:30 <PaulMurray> hi all
14:00:44 <tangchen_> hi
14:00:44 <abhishekk> o/
14:01:02 <PaulMurray> Agenda: https://wiki.openstack.org/wiki/Meetings/NovaLiveMigration
14:01:25 <tdurakov> hi
14:01:33 <PaulMurray> #topic CI
14:01:42 * PaulMurray straight in today
14:01:58 <PaulMurray> we had a couple of actions on CI from last week
14:02:08 <PaulMurray> kashyap to follow up with clarkb about experimental job running xenial fix (presumed cpu model)
14:02:12 <kashyap> PaulMurray: One was one me...
14:02:18 <kashyap> PaulMurray: https://review.openstack.org/#/q/topic:systemctrl
14:02:34 <kashyap> Specifically this should get merged - https://review.openstack.org/#/c/319819/
14:02:53 <kashyap> But both the patches in that topic need to go in...
14:03:05 <kashyap> Reviews appreciated
14:03:12 <tdurakov> kashyap: is it really helps to restart
14:03:34 <kashyap> Then, we've got a dummy Nova change that depends on the above -- https://review.openstack.org/#/c/319934/1
14:03:39 <tdurakov> I've tested locally and there is still issues with gate64 model
14:04:04 <kashyap> tdurakov: From testing by clarkb and sdague -- yes, an explicit 'restart' seem to bring in the CPU model
14:04:31 <kashyap> tdurakov: What kind of issues you're seeing locally?
14:04:42 <PaulMurray> #link this should get merged to help cpu model fix - https://review.openstack.org/#/c/319819/
14:04:57 <kashyap> tdurakov: Admittedly, I see the opposite effect of what both, Clark and Sean said: https://kashyapc.fedorapeople.org/behavior-of-systemctl-and-service-with-libvirt-bin-on-Xenial.txt
14:05:05 <tdurakov> kashyap: actually the same, the only diff is that i'm using service, not systemctl, is it critical?
14:05:53 <tdurakov> oh, ok
14:06:15 <kashyap> But I went ahead and made the change as the evidence from two people stacked against me -- and I'm not a regular Ubuntu user either.
14:06:29 <kashyap> So, I want to see what the CI reports with the above two changes, then we can take it from there.
14:06:38 <sdague> tdurakov: it's still not passing last time I looked, so it is going to require someone to investigate further
14:07:05 <PaulMurray> #undo
14:07:06 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xa7e1390>
14:07:40 <tdurakov> sdague, what do you mean by not passing?
14:07:58 <sdague> https://review.openstack.org/#/c/319934/1
14:08:05 <sdague> the experimental change is still not working
14:08:24 <tdurakov> https://www.irccloud.com/pastebin/iWNE3Qc9/gate64
14:08:37 <tdurakov> but still got the same issue
14:09:02 <tdurakov> so I looks like it's not enough just to restart libvirt
14:09:13 <tdurakov> s/i/it
14:09:25 <kashyap> tdurakov: Clark confirmed that it surely worked for him
14:09:44 <sdague> kashyap: well it's not working in code
14:10:04 <tdurakov> could we discuss it just after meeting in #openstack-nova?
14:10:14 <PaulMurray> Good idea
14:10:22 <PaulMurray> sounds like this needs more digging
14:10:26 <tdurakov> +
14:10:31 <kashyap> sdague: The dummy change failed because there were trivial bugs in the DevStack change. Let's see if it suceeds, otherwise, needs more investigation.
14:10:34 <kashyap> PaulMurray: Sure.
14:10:40 <PaulMurray> thanks for following up
14:10:47 <PaulMurray> moving on
14:11:03 <PaulMurray> next: mriedem to change an existing job to use raw instead of qcow2
14:11:08 <PaulMurray> he's not here
14:11:17 <PaulMurray> and I expect he had no time to do anything
14:11:36 <mdbooth> PaulMurray: The sky's not falling and I'll ping him in the week if it becomes necessary.
14:11:54 <PaulMurray> Does anyone else have an update for CI ?
14:12:34 <PaulMurray> #topic Libvirt Storage Pools
14:12:49 <PaulMurray> Any updates here ?
14:12:52 <PaulMurray> mdbooth, paul-carlton
14:13:03 <PaulMurray> diana_clarke, ?
14:13:30 <mdbooth> So, *all* the prepatches are in iirc!
14:13:39 <diana_clarke> I put 3 of the 5 backends up for review last week, and then went on vacation, so not much news from me ;)
14:14:05 <PaulMurray> good
14:14:22 * mdbooth is still addressing feedback, so no movement on the bdm stuff, yet
14:14:30 <PaulMurray> lets move on then
14:14:39 <PaulMurray> #topic Specs
14:14:40 <diana_clarke> I hope to finish the remaining backends this week, plus start using the new methods in the driver.
14:14:50 <PaulMurray> We are coming up to non-priority spec freeze
14:14:57 <PaulMurray> on June 2nd
14:15:05 <PaulMurray> https://wiki.openstack.org/wiki/Nova/Newton_Release_Schedule
14:15:31 <PaulMurray> The review trackin gpage is here:
14:15:32 <PaulMurray> https://etherpad.openstack.org/p/newton-nova-priorities-tracking
14:16:06 <PaulMurray> actually, mdbooth your patches should be on there
14:16:16 <PaulMurray> but I guess you're getting reviews anyway
14:16:34 <mdbooth> PaulMurray: Yep. Will ensure they all go up there after this meeting.
14:16:58 <PaulMurray> I will move some of those specs up to the next section
14:17:11 <PaulMurray> there are several specs that need approval this week
14:17:33 <PaulMurray> these are close I think:
14:17:35 <PaulMurray> https://review.openstack.org/#/c/306561
14:17:47 <PaulMurray> auto complete ^^
14:18:02 <PaulMurray> https://review.openstack.org/#/c/307131 - live migration of rescued
14:18:34 <PaulMurray> Any otheres need a mention or discussion?
14:18:50 <tangchen_> Hi, I have a BP about migration state machine that needs some help. https://blueprints.launchpad.net/nova/+spec/migration-state-machine
14:19:19 <tangchen_> I proposed it in mitaka, but I didn't have enough time to finish it.
14:19:54 <tangchen_> I'd like you guys help to review it, and approve it if possible. :)
14:19:56 <PaulMurray> tangchen_, is there a current spec link
14:20:28 <tangchen_> No, sorry. In mitaka, we agreed that it needs no spec.
14:20:35 <tangchen_> It changes no API.
14:20:51 <tangchen_> Just use a state machine to replace the current strings.
14:21:07 <PaulMurray> tangchen_, ok - I missed that
14:21:09 <tangchen_> I can write a spec if necessary.
14:21:16 <PaulMurray> so its just the patches on the spec ?
14:21:23 <PaulMurray> ...sorry on the bp
14:21:37 <tangchen_> yes
14:21:46 <PaulMurray> https://review.openstack.org/#/q/topic:bp/migration-state-machine,n,z
14:21:50 <tdurakov> 2 spec from me: https://review.openstack.org/#/c/292271/ - orchestration to conductor, https://review.openstack.org/#/c/320416/ - instance action to conductor, and checks before live-migration in background
14:22:24 <PaulMurray> The all have -2 from johnthetubaguy
14:22:34 <PaulMurray> that needs lifting or no one will look
14:22:55 <PaulMurray> Try pinging him in openstack-nova
14:23:03 <tangchen_> yes. John told me that it is better to raise it up in a meeting.
14:23:06 <PaulMurray> and put on the spec review tracking page
14:23:13 <tangchen_> I have talked with him.
14:23:28 <PaulMurray> tangchen_, did he mean here or in the nova meeting ?
14:24:10 <tangchen_> I asked the same question, and he said live-migrate meeting will be a good idea.
14:24:19 <tangchen_> So I came here. :)
14:24:25 <PaulMurray> ha
14:24:47 <PaulMurray> ok - I'll take a look and talk to him and you about it later
14:25:12 <tangchen_> I think he asked me to discuss with you that if using the automaton is a good idea. :)
14:25:14 <PaulMurray> I'm not up on it at the moment - unless anyone else has any comments
14:25:45 <tangchen_> OK, thank you very much. But it is late in my time zone. I have to get off.
14:25:49 <PaulMurray> I thought there was general agreement that it was a good idea
14:26:00 <tangchen_> Please leave a message on the patch or the BP.
14:26:14 <PaulMurray> tdurakov, does it clash with what you are looking at ?
14:26:16 <tangchen_> OK, thx. :)
14:26:34 <PaulMurray> i.e. the two specs you linked above?
14:26:56 <PaulMurray> Remove compute-compute communication in live-migration
14:26:59 <PaulMurray> ^^
14:27:06 <PaulMurray> https://review.openstack.org/#/c/292271/
14:27:08 <tdurakov> PaulMurray: yes it is
14:27:36 <PaulMurray> why does it clash, I would expect it to be complementary ?
14:28:27 <tdurakov> PaulMurray: wait, are you talking about state machines?
14:28:41 <PaulMurray> yes
14:29:00 <PaulMurray> https://review.openstack.org/#/c/241476/ - Implement state machine for live-migration
14:29:02 <tdurakov> PaulMurray: let me check state machine spec first, will leave comment
14:29:30 <PaulMurray> ok
14:29:33 <tangchen_> tdurakov: Thank you very much. :)
14:29:44 <tangchen_> And Paul, thx too. :)
14:30:30 <tdurakov> folks, could you take a look on the specs I've mentioned above
14:30:32 <PaulMurray> #action PaulMurray follow up on status for https://blueprints.launchpad.net/nova/+spec/migration-state-machine (needs no spec)
14:30:57 <PaulMurray> Any more specs ?
14:31:26 <PaulMurray> We only have until Thursday next week to get approval
14:31:55 <PaulMurray> moving on....
14:31:59 <PaulMurray> #topic Review request
14:32:06 <PaulMurray> I think we spilled into this already
14:32:09 <PaulMurray> anything else here ?
14:32:23 <PaulMurray> on patches in general
14:32:38 <eliqiao> I got 2 patches
14:32:41 <abhishekk> hi, need review on this https://review.openstack.org/#/c/215483/ (Set migration status to 'error' on live-migration failure)
14:32:47 <eliqiao> PaulMurray: https://review.openstack.org/#/c/310707/ libvirt: Prevent block live migration with tunnelled flag
14:33:40 <eliqiao> PaulMurray: this is a regression bug in mitaka, pkoniszewski help to tested alread.
14:33:56 <PaulMurray> abhishekk, I said I would follow up on that one but I decided not to be pushy yet
14:34:03 <PaulMurray> I will follow up on it now
14:34:28 <abhishekk> PaulMurray: thank you and sorry for making noise
14:35:18 <johnthetubaguy> PaulMurray: I can remove the -2, just ping the -2 on IRC once the blueprint is approved, in the usual way
14:35:43 <johnthetubaguy> PaulMurray: ah, this is the one from tangchen_, the blueprint needs approving first
14:35:45 <PaulMurray> johnthetubaguy, who is going to approve ?
14:36:24 <johnthetubaguy> do we all like the direction thats taking, as a live-migrate subteam?
14:37:08 <PaulMurray> We are going to take a look at the code
14:37:15 <PaulMurray> everyone has got rusty on it
14:37:59 <PaulMurray> johnthetubaguy, it seems we decided it would not need a spec - is that ok ?
14:38:28 <johnthetubaguy> not sure
14:38:33 <PaulMurray> johnthetubaguy, I have an action to catch up with you later
14:38:41 <PaulMurray> about it
14:38:41 <johnthetubaguy> the problem is actually getting people to understand it, and agree we like the direction
14:38:49 <johnthetubaguy> it feels like we need more than the blueprint to do that
14:39:01 <PaulMurray> yes, that's why I wondered about a spec
14:39:12 <johnthetubaguy> for me, I think a spec is likely to be quicker
14:39:18 <johnthetubaguy> as odd as that sounds
14:39:38 <johnthetubaguy> but I am willing to try the blueprint only approach, if we can agree the direction
14:40:02 <johnthetubaguy> anyways, happy to catch up after the meeting, with the interested folks
14:41:12 <PaulMurray> tangchen_, do you think you could resurect the old spec quickly ?
14:41:30 <PaulMurray> It would be a useful place to add comments - we may decide we don't need it
14:43:01 <tdurakov> PaulMurray: +1 for spec
14:43:35 <tdurakov> i've walked quickly over patches, I think it would be useful to read kind of doc
14:43:41 <PaulMurray> tangchen_, johnthetubaguy my thought is we could review look at the spec and try to decide what we want to do in the next few days ?
14:44:16 <PaulMurray> I'm particularly interested in what happens if/when we decide to change the state machine
14:45:07 <PaulMurray> looks like we lost tangchen_
14:45:13 <PaulMurray> I'll follow up
14:45:21 <johnthetubaguy> cool
14:45:25 <PaulMurray> #topic Open Discussion
14:45:27 <johnthetubaguy> yeah, lets follow up later
14:45:35 <johnthetubaguy> so I wanted to rase the auto converge spec
14:45:44 <johnthetubaguy> https://review.openstack.org/#/c/306561/18
14:45:48 <PaulMurray> go ahead
14:45:48 <johnthetubaguy> I really like where its going
14:45:56 <johnthetubaguy> but I got confused about a contractition
14:46:13 <johnthetubaguy> I think you have the auto API to force post copy at any point of the migration (probably after the current memory copy completes?), and if not, we wait till the memory sync is not improving things by 10%?
14:46:17 <johnthetubaguy> does that sound correct?
14:46:49 <PaulMurray> just gave paul-carlton a poke
14:46:54 <PaulMurray> :)
14:47:19 <PaulMurray> I think that's right johnthetubaguy
14:47:25 <johnthetubaguy> OK, cool
14:47:35 <johnthetubaguy> if its just a typo thing, I am basically +2 on the approach
14:47:45 <johnthetubaguy> not a fan of config options changing what an API does
14:47:53 <PaulMurray> the force flag in live-migrate made it agressive about the switch
14:47:57 <johnthetubaguy> but I am much less of a fan of exposing implementation details vai the API
14:48:03 <paul-carlton2> I'll check the spec, what I meant was that it would automatically switch if less than 10% progress after first cycle
14:48:14 <johnthetubaguy> so the force flag got deleted
14:48:27 <johnthetubaguy> paul-carlton2: cool
14:48:36 <paul-carlton2> but the operator could use force-complete to make it switch at any time
14:48:48 <johnthetubaguy> yeah, that sounds good
14:49:05 <PaulMurray> paul-carlton2, so the foce flag in ive-migrate is definitely dropped then ?
14:49:12 <paul-carlton2> except that if they try to force the switch too early, i.e. before a complete memory copy cycle we defer it
14:49:19 <paul-carlton2> Yep
14:49:44 <paul-carlton2> I don't see it having enough value to be worth having at this stage
14:50:01 <paul-carlton2> We can add it later if we find a need
14:50:02 <PaulMurray> I'm good with that
14:50:20 <PaulMurray> johnthetubaguy, do you know if danpb is about at all ?
14:50:28 <PaulMurray> we haven't seen him in a while
14:50:33 <PaulMurray> mdbooth, ^^ ?
14:50:46 <tangchen_> PaulMurray, johnthetubaguy: Hi, I'm here. I can submit a spec for it. :)
14:50:53 <mdbooth> PaulMurray: He's definitely away for a few days at least
14:50:53 <tangchen_> Will do it tomorrow.
14:50:55 <PaulMurray> tangchen_, thanks
14:50:59 <mdbooth> Don't know exactly how long
14:51:01 <tangchen_> :)
14:51:05 <paul-carlton2> I'll mail him and dlist to solicit comments/approaval
14:51:33 <mdbooth> paul-carlton2: He's on holiday, so don't expect a quick reply
14:51:48 <paul-carlton2> mdbooth, ack
14:52:20 <PaulMurray> mdbooth, do you know when he is back a work ?
14:52:32 <PaulMurray> like next week ?
14:52:32 <mdbooth> PaulMurray: Unfortunately not, no
14:52:37 <PaulMurray> ok
14:52:44 <mdbooth> I expect so, but really don't know
14:53:17 <PaulMurray> Is there anything else to finish with ?
14:53:56 <PaulMurray> ...then we're done for this week.
14:54:02 <PaulMurray> thanks for coming
14:54:09 <PaulMurray> #endmeeting