14:00:25 <tdurakov> #startmeeting Nova Live Migration
14:00:26 <openstack> Meeting started Tue Aug 30 14:00:25 2016 UTC and is due to finish in 60 minutes.  The chair is tdurakov. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:29 <openstack> The meeting name has been set to 'nova_live_migration'
14:00:50 <tdurakov> hello everyone, agenda for the meeting: https://wiki.openstack.org/wiki/Meetings/NovaLiveMigration
14:00:55 <pkoniszewski> o/
14:01:04 <luis5tb> o/
14:01:12 <mdbooth> o/
14:01:25 <tdurakov> let's wait a minute and then start
14:02:32 <tdurakov> so
14:03:15 <tdurakov> #topic newton-3 feature freeze
14:03:47 <tdurakov> do we have any patches except imagebackend, that requires attention and need review?
14:04:19 <tdurakov> imagebackend is the next topic)
14:04:35 * kashyap waves
14:05:17 <tdurakov> as I understand no, let's move on then
14:05:20 <johnthetubaguy> there was a stuck one the other day, let me take a quick peak
14:05:32 <tdurakov> johnthetubaguy: sure
14:05:45 <johnthetubaguy> oh, that is the imagecache one
14:05:55 <johnthetubaguy> carry on... :)
14:06:24 <tdurakov> #topic image backend
14:06:36 <tdurakov> mdbooth: anything except review request?
14:07:01 <mdbooth> So I don't think this is going to get there
14:07:05 <mdbooth> Just reviews
14:07:27 <mdbooth> johnthetubaguy: Which is the imagecache one?
14:07:42 <mdbooth> Is that the 1 with -1 from jay and +2 from somebody else?
14:07:48 <tdurakov> #action anyone to review imagebackend topic
14:08:00 <tdurakov> s/everyone
14:08:15 <mdbooth> It's really core review it needs at this point, tbh
14:08:25 <johnthetubaguy> I think the problem is we need that conflict resolving
14:08:35 <mdbooth> johnthetubaguy: Got a link?
14:08:45 <johnthetubaguy> https://review.openstack.org/#/c/334956
14:08:50 <johnthetubaguy> I mean the -1 from jay
14:08:59 <mdbooth> Ah, right.
14:09:08 <mdbooth> TBH, that mini-series isn't that important.
14:09:25 <johnthetubaguy> I think I pinged some image cache folks to take a peak, but they have not had chance
14:09:27 <mdbooth> I think it's correct, but I haven't made a fuss about it because it's not a dependency of anything.
14:09:37 <johnthetubaguy> ah, so maybe I am just getting distracted from the meat by that bit
14:09:54 <mdbooth> It was just a cleanup I did because I had my head in that code for other reasons and noticed that it was pretty obtuse.
14:09:58 <mdbooth> And I fixed it.
14:10:29 <tdurakov> mdbooth: tried to review this one: https://review.openstack.org/#/c/335966/16 tbh it's pretty complicated, tend to agree with dansmith about nested mocks
14:10:54 <mdbooth> Oh, I missed his comments.
14:11:02 <mdbooth> I actually wish he'd left a -1 :/
14:12:42 <tdurakov> mdbooth: also  related to your work https://review.openstack.org/#/c/355415/
14:13:39 <tdurakov> I haven't asked Jens Rosenboom yet why he decided to leave this patch, as for me it's ok, and I think it could be merged before your refactoring
14:13:41 <mdbooth> I've already reviewed that. I was +1 iirc.
14:14:00 <mdbooth> Right. The refactor was the reason I was less fussed than mriedem, I think.
14:14:11 <mdbooth> But it's backportable.
14:14:28 <tdurakov> I'l ask Jens first, and if he don't mind update commit message
14:16:07 <tdurakov> ok, anything else?
14:16:27 <mriedem> so on https://review.openstack.org/#/c/355415/
14:16:33 <mriedem> is anyone going to update it?
14:16:49 <mriedem> tdurakov: are you going to add a unit test?
14:17:04 <tdurakov> mriedem: yes
14:17:10 <mriedem> ok
14:17:19 <tdurakov> let's move on
14:17:24 <tdurakov> #topic CI
14:17:56 <tdurakov> live-migration job is pretty stable
14:17:59 <tdurakov> but
14:18:18 <tdurakov> I've spend some time trying to recheck/gather stats for nfs too
14:18:20 <tdurakov> https://review.openstack.org/#/c/329466/
14:18:57 <tdurakov> so it looks like it's become unstable when nfs is enabled
14:19:22 <tdurakov> at the same time it's not reproducible on my local env
14:20:08 <tdurakov> I want to spend more time on that, or maybe consider enable ceph first
14:20:43 <mriedem> tdurakov: is it failing in any new way?
14:20:49 <mriedem> we could check just that change in logstash
14:21:00 <mriedem> i would agree with probably doing ceph before NFS
14:21:08 <mriedem> we don't test NFS anywhere else in upstream CI
14:21:11 <tdurakov> mriedem: yes, something new
14:21:33 <tdurakov> mriedem: acked, will try to do that
14:22:32 <tdurakov> let's move on
14:22:48 <tdurakov> #topic networking
14:23:13 <tdurakov> any updates on post-copy issues
14:23:47 <kashyap> tdurakov: Is there a specific bug you're referring to?
14:25:03 <kashyap> I think this - https://bugs.launchpad.net/bugs/1605016
14:25:03 <openstack> Launchpad bug 1605016 in OpenStack Compute (nova) "Post copy live migration interrupts network connectivity" [High,In progress]
14:25:04 <tdurakov> kashyap:
14:25:04 <tdurakov> https://bugs.launchpad.net/nova/+bugs?field.searchtext=post+copy&search=Search&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.assignee=&field.bug_reporter=&field.
14:25:04 <tdurakov> omit_dupes=on&field.has_patch=&field.has_no_package=
14:25:09 <tdurakov> ops
14:25:15 <tdurakov> https://bugs.launchpad.net/nova/+bug/1605016
14:25:25 <tdurakov> yeah, this one
14:26:03 <tdurakov> moved it to confirmed, as there is no assignee
14:27:21 <kashyap> tdurakov: Dave Gilbert mentioned that Luis (not sure of last name) was working on something (a spec) to address it?
14:27:26 <johnthetubaguy> hmm, I thought someone was working on that at one point
14:27:45 <johnthetubaguy> ah, I see they got unassigned
14:27:49 <luis5tb> I worked on the post-copy patch, but not on the fix
14:28:05 <johnthetubaguy> there is a wider thing in Neutron, tracking both port bindings (source and destination)
14:28:11 <johnthetubaguy> but we could fix it sooner
14:28:16 <luis5tb> I see it said it is in progress, did someone else started working on it?
14:28:34 <johnthetubaguy> comments say they have stopped working on it
14:28:52 <tdurakov> luis5tb: I've status already
14:29:12 <johnthetubaguy> I think its all about when we updating the port binding to point at the destination host, we do that today in post-live-migrate, we could do that sooner for post copy, to reduce the downtime
14:29:31 <johnthetubaguy> the proper fix is further away (tracking both source and destination port bindings)
14:30:00 <johnthetubaguy> I am hoping to get OSIC folks to help work on the nova bits for that next cycle, at least potentially
14:30:24 <johnthetubaguy> I added notes on a potential quick fix in the bug
14:31:23 <tdurakov> johnthetubaguy: thank you
14:31:59 <tdurakov> any update on setup_network_on_hosts for neutron api?
14:33:43 <tdurakov> so, let's move on
14:33:54 <tdurakov> #topic open discussion
14:34:30 <johnthetubaguy> there were comments on that patch
14:34:37 <johnthetubaguy> I don't remember seeing if there were resolved now
14:35:45 <johnthetubaguy> ah, it seems https://review.openstack.org/#/c/275073/ is ready to review again
14:37:05 <tdurakov> yep, reviews are welcome
14:37:13 <tdurakov> anything else?
14:37:59 <tdurakov> thanks everyone
14:38:04 <tdurakov> #endmeeting