14:00:36 <tdurakov> #startmeeting Nova Live Migration
14:00:37 <openstack> Meeting started Tue Jan 31 14:00:36 2017 UTC and is due to finish in 60 minutes.  The chair is tdurakov. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:40 <openstack> The meeting name has been set to 'nova_live_migration'
14:00:47 <tdurakov> hello everyone
14:00:56 <davidgiluk> o/
14:00:59 <armstrong> Hello
14:01:09 <tdurakov> agenda https://wiki.openstack.org/wiki/Meetings/NovaLiveMigration
14:01:20 <armstrong> am new here
14:02:05 <tdurakov> so, let's start
14:02:09 <tdurakov> #topic ci
14:02:17 <pkoniszewski> o/
14:02:17 * kashyap waves
14:02:47 <siva_krishnan> o/
14:02:49 <tdurakov> update on serial console activity: hook is good, tempest patch requires additional updates
14:03:12 <tdurakov> I expect markus_z will update it soon
14:03:38 <tdurakov> grenade, seems to start failing again
14:03:38 * johnthetubaguy lurks to see what is release critical and needs urgent review
14:04:09 <tdurakov> johnthetubaguy: https://review.openstack.org/#/c/347471/
14:04:49 <tdurakov> according to mriedem's thread(see agenda) job start skipping live-migration tests, due to tempest misconfig
14:05:10 <tdurakov> are there any volunteers to work on this problem?
14:06:06 <tdurakov> also, clarkb left comment with details of back_and_forth testing(seems to be easy one)
14:06:36 <pkoniszewski> yeah, i saw this
14:06:55 <pkoniszewski> but i might not find time to work on this in upcoming weeks
14:07:17 <tdurakov> I'm going to write status update in ml this week...
14:07:28 <tdurakov> will find anyone to fix this
14:07:46 <tdurakov> #action tdurakov to find volunteers
14:08:08 <siva_krishnan> tdurakov:  i will try to work on it
14:08:18 <tdurakov> siva_krishnan: sold!:)
14:08:36 <tdurakov> thanks, https://review.openstack.org/#/c/382456/ - see comment
14:08:40 <pkoniszewski> siva_krishnan: if you need any help just ping me on IRC
14:08:59 <tdurakov> anything else on ci?
14:09:17 <tdurakov> next then
14:09:30 <siva_krishnan> pkoniszewski: sure
14:09:34 <tdurakov> #topic bugs
14:10:02 <tdurakov> first, haven't seen any *new* bugs, been filed recently
14:10:27 <pkoniszewski> siva_krishnan: i'm based in UTC+1 (3 PM right now here), usually stay at work till 5 PM
14:11:04 <tdurakov> so, claims
14:11:14 <tdurakov> https://review.openstack.org/#/c/244489/
14:12:02 <tdurakov> johnthetubaguy: review very-very welcome
14:13:04 <tdurakov> pkoniszewski: am I missed smth on https://review.openstack.org/#/c/244489/58/nova/compute/manager.py@5676 ?
14:13:35 <pkoniszewski> i'm gonna push new change soon
14:13:41 <pkoniszewski> but i didn't touch this piece of code
14:13:57 <pkoniszewski> we should focus on passing migration over RPC rather than hardening this
14:14:11 <pkoniszewski> this patch will never be perfect...
14:15:21 <pkoniszewski> i'm focused on fixing mdbooth concerns, as the issue that he found in live migration rollback is critical
14:15:44 <tdurakov> pkoniszewski: agree on that, but, what if we start passing at least migrate_data object?
14:16:01 <tdurakov> shouldn't be a big change
14:16:34 <tdurakov> at least I'd like to see this change merged within one release
14:16:43 <pkoniszewski> its more code to this already very complicated change
14:17:51 <johnthetubaguy> is it worth passing the extra data around first, then adding the claims in a patch on top, would that make it easier to get in?
14:18:16 <pkoniszewski> i'd say that it will postpone this 1.5 years old patch even more
14:18:21 <tdurakov> johnthetubaguy: it would, but this change is ps-58
14:18:22 <pkoniszewski> and this bit is not critical
14:18:25 <tdurakov> pkoniszewski: ++
14:18:41 <pkoniszewski> it's something we might want fix some time in the future
14:19:20 <tdurakov> pkoniszewski: I'm ok  then to address mdbooth comments first, then merge this one, and after that polish it
14:19:35 <tdurakov> johnthetubaguy: what do you think?
14:19:45 * mdbooth was ok with it otherwise except for the race I misread.
14:20:01 <pkoniszewski> mdbooth: but the rollback is broken as you pointed it out
14:20:06 <mdbooth> pkoniszewski: Yeah.
14:20:15 <pkoniszewski> mdbooth: this is what i'm trying to fix currently
14:20:17 <mdbooth> I found 2 problems, and one of them wasn't a problem.
14:20:23 <johnthetubaguy> breaking rollback sounds bad
14:20:26 <tdurakov> since rollback is cast, right?
14:20:33 <pkoniszewski> mdbooth: yeah, misundestood you, your right
14:20:46 <pkoniszewski> not because it is a cast
14:21:12 <pkoniszewski> but it calls save within context manager
14:21:25 <tdurakov> ah, that one, ok
14:21:32 <tdurakov> to many ps...
14:21:34 <pkoniszewski> mutated_migration_context context manager
14:21:36 <tdurakov> s/too
14:22:23 <tdurakov> so, let's wrap this up, fixing this up, then merge, then polish, agree?
14:23:12 <pkoniszewski> i'd prefer this way
14:23:22 <tdurakov> johnthetubaguy: ^
14:25:02 <armstrong> I have a question: Does openstack fully supports parallel (concurrent) live migration of VMs ?
14:25:10 <tdurakov> let's move on, I think johnthetubaguy will express opinion on review anyway
14:25:43 <tdurakov> armstrong: it supports
14:25:57 <tdurakov> any other bugs/fixes?
14:26:29 <tdurakov> next
14:26:58 <tdurakov> #topic Pike specs
14:27:04 <johnthetubaguy> tdurakov: yeah, I need more context on that one, everything I read through it my head explodes, sadly
14:27:16 <johnthetubaguy> s/everything/every time/
14:27:23 <tdurakov> johnthetubaguy: np, just review:-p
14:27:58 * pkoniszewski going offline
14:28:01 <pkoniszewski> thanks for the meeting!
14:28:05 <tdurakov> bb
14:28:14 <armstrong> I will like to fullt involve
14:28:33 <armstrong> fully*
14:30:04 <tdurakov> I'd like to ask everyone  to review not only l-m related specs, but all migration specs for pike, e.g. cold-migration abort or cold-migration with target hosts, since it will help to align migrations in nova
14:30:06 <armstrong> tdurakov: where can I start contributing?
14:30:15 <tdurakov> and make them consistent
14:30:30 <tdurakov> #topic open discussions
14:31:24 <tdurakov> armstrong: take a look at bugs: https://bugs.launchpad.net/nova/+bugs?field.tag=live-migration+
14:31:38 <armstrong> ok thanks
14:31:40 <tdurakov> also contribution to ci and test coverage is very welcome
14:31:51 <tdurakov> e.g. tempest
14:32:07 <tdurakov> + review of the l-m related patches
14:32:20 <tdurakov> do we have any open topics?
14:33:27 <tdurakov> ok
14:33:31 <tdurakov> thanks for coming
14:33:35 <tdurakov> #endmeeting