14:00:33 <tdurakov> #startmeeting Nova Live Migration
14:00:35 <openstack> Meeting started Tue Mar 28 14:00:33 2017 UTC and is due to finish in 60 minutes.  The chair is tdurakov. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:38 <openstack> The meeting name has been set to 'nova_live_migration'
14:01:19 <tdurakov> #link agenda https://wiki.openstack.org/wiki/Meetings/NovaLiveMigration
14:01:31 <tdurakov> #topic bugs
14:02:47 <tdurakov> there is a new bug filed
14:02:54 <davidgiluk> o/
14:03:12 <tdurakov> #link https://bugs.launchpad.net/nova/+bug/1672597
14:03:12 <openstack> Launchpad bug 1672597 in OpenStack Compute (nova) "[live migration] The instance directory on the destination host is not clean up" [Undecided,Incomplete]
14:03:45 <tdurakov> according to bug desciption ceph based storage in case of failure doesn't clean up destination node
14:04:19 <tdurakov> I've asked question to bug reporter to clarify release version
14:04:32 <tdurakov> once got response - will work on that
14:05:15 <raj_singh> o/
14:05:18 <tdurakov> siva_krishnan left a comment on the https://bugs.launchpad.net/nova/+bug/1671379 - so waiting for the results
14:05:18 <openstack> Launchpad bug 1671379 in OpenStack Compute (nova) "The first VM of one network in one compute node cannot send RARP packets during KVM's live-migration in a neutron ML2 hierachical port binding environment whose second mechanism driver was configured as the existing OVS driver "openvswitch"" [Undecided,New]
14:05:32 <tdurakov> this is for the new bugs.
14:05:46 <tdurakov> any other new?
14:07:41 <tdurakov> for the existing ones, I've wrote to pkoniszewski on the claims fix
14:07:56 <tdurakov> so will address comments and resubmit patch-set
14:08:33 <tdurakov> #action to review https://review.openstack.org/#/c/434870/
14:08:47 <tdurakov> anything I missed?
14:09:34 <siva_krishnan> tudurakov sorry late for the meeting
14:10:14 <tdurakov> siva_krishnan: no problem, I saw your comment on the bug, we've discussed yesterday, thank you
14:10:28 <tdurakov> let's wait for the response on that first
14:10:34 <tdurakov> moving on
14:10:40 <tdurakov> #topic pike specs
14:11:20 <tdurakov> config part for completion timeout is waiting for +2 as for me
14:11:47 <tdurakov> raj_singh: https://review.openstack.org/#/c/442809/ - I've +1 this one
14:11:55 <tdurakov> but left a comment inline
14:12:06 <tdurakov> could you please take a look
14:12:21 <raj_singh> tdurakov: I just saw that, will reply on the patch
14:12:44 <tdurakov> I'm just interested if you did some benchmarking or it's kind of intuitive guess
14:13:08 <tdurakov> overall all 3 specs looks good
14:13:27 <tdurakov> anything on implementation?
14:13:52 <raj_singh> yea I have a backlog spec for that, my goal is to gather data around LM to have proper values for config options
14:14:14 <tdurakov> ++
14:14:26 <raj_singh> rescue implementation is in progress, while other 2 I will kick off soon
14:14:38 <tdurakov> cool
14:15:14 <tdurakov> once ready fill free to ping or add to review them
14:15:22 <tdurakov> s/feel
14:15:55 <raj_singh> alright
14:17:00 <tdurakov> going next
14:17:03 <tdurakov> #topic CI
14:17:25 <tdurakov> I sam markus_z's patches for serial console were updated
14:17:30 <tdurakov> please review them
14:17:53 <tdurakov> #link https://review.openstack.org/#/c/346815/
14:19:20 <tdurakov> do you have updates?
14:19:41 <raj_singh> tdurakov: Do you update Nova review etherpad once things are ready to be reviewed by core team?
14:20:03 <tdurakov> raj_singh: good question, need to update it
14:20:24 <raj_singh> yea I was wondering if my specs can be on that list now
14:20:33 <tdurakov> raj_singh: yep
14:20:37 <raj_singh> it got +1's from John and you
14:20:54 <raj_singh> and siva_krishnan
14:21:11 <raj_singh> tdurakov: thx
14:21:56 <tdurakov> ok
14:22:05 <tdurakov> #topic open discussion
14:22:24 * davidgiluk is just working on some qemu patches to allow the RARP/ARP section to be longer/configurable
14:22:50 <tdurakov> davidgiluk: do you have a patch on gerrit?
14:23:10 <davidgiluk> tdurakov: No, not posted yet, and anyway these are QEMU patches so they'll go to qemu-devel
14:23:32 <davidgiluk> but they may be useful to those who have sluggish network switchovers
14:23:50 <tdurakov> davidgiluk: I think it would be useful anyway to take a look
14:23:56 <tdurakov> talking about the underlay
14:24:01 <davidgiluk> nod
14:24:19 <tdurakov> don't you know, are there any activity to expose more information on jobinfo?
14:24:33 <tdurakov> e.g. disk copy progress during block-migration?
14:25:14 <davidgiluk> tdurakov: Is this using the older qemu block migration or the new drive-mirror/copy stuff over nbd ?
14:25:33 <tdurakov> nbd I expect
14:25:49 * davidgiluk will ask
14:26:05 <tdurakov> anyway, afair there are no info about the progress in libvirt job info
14:26:22 <tdurakov> so, block migration is threated as a no progress for while
14:26:30 <tdurakov> until disk copy is finished
14:26:30 <kashyap> Yes, much thanks to davidgiluk for helping me debug with the RARP / ARP stuff
14:26:48 <kashyap> tdurakov: Which one is this that you're talking about?  Sorry, I wasn't paying full attention
14:26:49 <davidgiluk> tdurakov: OK, I'll figure out if we've got that info anywhere
14:27:23 <tdurakov> kashyap: I'm talking about more details exposure on the live-migration job info
14:27:25 <kashyap> You can actually verify by looking at libvirt debug logs what _kind_ of migration is being used -- old-style "migrate" or the NBD-based on
14:29:11 <kashyap> tdurakov: The existing libvirt API to monitor job progress isn't sufficient?   (`virsh blockjob --info VM`)
14:29:27 <kashyap> But yeah, we can hash out the details on #openstack-nova
14:30:01 <kashyap> And let the rest of the discussion proceed here
14:30:30 * tdurakov trying to find out link
14:30:37 <tdurakov> are there  any other open questions?
14:31:28 <siva_krishnan> tudurakov, we do log these info while monitoring live migration right ?
14:32:04 <tdurakov> siva_krishnan: yes
14:34:01 <tdurakov> if there noting else
14:34:06 <tdurakov> let's finish the meeting
14:34:12 <tdurakov> thanks for joining
14:34:15 <tdurakov> #endmeeting